Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: [Opgelost] VPN-server opgezet maar werkt half  (gelezen 1776 keer)

Offline PH-MJS

  • Lid
  • Steunpunt: Nee
[Opgelost] VPN-server opgezet maar werkt half
« Gepost op: 2011/01/11, 15:26:00 »
Ha fantastische community,

Na lang zoeken op dit forum en internet doe ik toch een beroep op jullie kennis.

Ik heb op Ubuntu 10.10 Server pptpd geïnstalleerd. Vervolgens via Webmin een user aangemaakt en de adressenreeks, die mag worden uitgedeeld aan clients, ingesteld.
Heb het nu voor elkaar dat ik nu met de VPN-server kan verbinden.

Het probleem is dat er alleen communicatie mogelijk is met de VPN-server en kan dus verder niet het netwerk op. De VPN-server heeft volledige toegang tot alles, dus dat is het probleem niet.
Als ik met een client connect krijg ik een IP-adres uit de ingestelde reeks, maar krijg geen gateway mee.

Enig idee wat het probleem is? Heb ik nog wat over het hoofd gezien?

Alvast bedankt voor het meedenken!!

Gr,
PH-MJS
« Laatst bewerkt op: 2011/01/17, 21:51:50 door PH-MJS »

Offline FratzBC

  • Lid
    • zomg.eu
  • Steunpunt: Nee
Re: VPN-server opgezet maar werkt half
« Reactie #1 Gepost op: 2011/01/12, 11:14:19 »
Citaat
Het probleem is dat er alleen communicatie mogelijk is met de VPN-server en kan dus verder niet het netwerk op. De VPN-server heeft volledige toegang tot alles, dus dat is het probleem niet.
Als ik met een client connect krijg ik een IP-adres uit de ingestelde reeks, maar krijg geen gateway mee.

Bedoel je dat je het netwerk niet op kan vanaf de VPN-server? of kan je na het verbinden met de VPN-server niet meer op je eigen netwerk?

En wat voor OS / client gebruik je?

Offline ruujan

  • Lid
  • Steunpunt: Nee
Re: VPN-server opgezet maar werkt half
« Reactie #2 Gepost op: 2011/01/12, 13:13:15 »
Is er ook een route terug vanaf de andere machines op je LAN terug naar de VPN-client. Of is je VPV-server default gateway voor die machines?

Offline Dooitze de Jong

  • Lid
    • dooitze
    • Dooitze de Jong
  • Steunpunt: Nee
Re: VPN-server opgezet maar werkt half
« Reactie #3 Gepost op: 2011/01/12, 14:30:18 »
Door het VPN heen kun je een ssh server draaien waarmee je een socks proxy aan kunt maken en dus alsnog op het netwerk kunt komen
Linux User : 491909
Ubuntu User: 2928
Word geen 100 % Offtopic-spammer, maar help ook eens anderen!
[size=10]Soms plaats ik berichten met mijn pda, dus er kunnen spellingsfouten in zitten[/size]

Offline PH-MJS

  • Lid
  • Steunpunt: Nee
Re: VPN-server opgezet maar werkt half
« Reactie #4 Gepost op: 2011/01/12, 16:27:36 »
@FratzBC
Als ik op de VPN-server inlog, dan is er alleen nog maar communicatie mogelijk van en naar mijn VPN-server en niet met de rest van het netwerk.
Clients: Zowel Ubuntu als Windows XP en 7

@ruujan
Er is een gateway (router) 192.168.2.1 en mijn VPN-server zit op 192.168.2.222. De VPN-server is dus niet de default gateway op de server.

@Iedereen
Bedankt voor jullie meedenken en antwoorden!

Offline ruujan

  • Lid
  • Steunpunt: Nee
Re: VPN-server opgezet maar werkt half
« Reactie #5 Gepost op: 2011/01/13, 21:23:56 »

@ruujan
Er is een gateway (router) 192.168.2.1 en mijn VPN-server zit op 192.168.2.222. De VPN-server is dus niet de default gateway op de server.



Hmm, even doorvragen. Je client, zit die in hetzelfde subnet als je server of heeft-ie een nummer uit een ander netwerk? Ik ken die pptp-VPN niet, maar bij mijn eigen VPN's met OpenVPN is er altijd een apart subnet voor de clients. In jouw geval betekent dat dus dat je client niet in 192.168.2.0/24 zit, maar bijvoorbeeld in 192.168.3.0/24. In dat geval moet je op de andere hosts dus aangeven dat een pakketje voor de VPN-client niet via de default gateway moet maar via de VPN-server.

Je kunt dit op twee manieren doen. Ten eerste kun je natuurlijk op elke host apart een extra route aanmaken die ervoor zorgt dat pakketjes wel via de gateway worden gerouteerd.  Maar je kunt ook op je gateway, meestal een adsl-modem of zo, een extra statische route aanmaken. Op het moment dat een er een pakketje voor je VPN-client dan vanuit het lokale net wordt verstuurd, dan stuurt de router het door naar je VPN-gateway en verstuurt bovendien een ICMP route redirect pakket naar de host die het pakket verstuurd heeft. Die host voegt deze route vervolgens toe aan zijn dynamische routes en een volgend pakket wordt direct naar de VPN-gateway gestuurd.


Overigens moet je op je VPN-server ook ip-forwarding aanzettenmet  echo 1 > /proc/sys/net/ipv4/ip_forward in de terminal.
« Laatst bewerkt op: 2011/01/13, 21:27:00 door ruujan »

Offline PH-MJS

  • Lid
  • Steunpunt: Nee
Re: VPN-server opgezet maar werkt half
« Reactie #6 Gepost op: 2011/01/17, 20:25:04 »
Ha Ruujan,

Bedankt voor je antwoord en dat je wilt meedenken.
Als ik echo 1 > /proc/sys/net/ipv4/ip_forward uitvoer krijg ik toegang geweigerd. Ook met een sudo is dat het geval.
Hoe krijg ik dit alsnog voor elkaar?
Tevens ben ik ook naar OpenVPN aan het kijken en ziet er mooi uit!

Gr,
PH-MJS

EDIT
Heb het voor elkaar!!!
Het was inderdaad de IP-forwarding en heb dit nu via sysctl.conf veranderd.
Ontzettend bedankt voor het duwtje in de goede richting!
« Laatst bewerkt op: 2011/01/17, 21:51:34 door PH-MJS »