Nieuws:

We zijn er weer.

Na lange tijd van afwezigheid zijn we er weer  :laugh:
We hebben alle wachtwoorden gereset, je oude wachtwoord werkt niet meer.Je moet via het "wachtwoord vergeten"-linkje je wachtwoord resetten. Je krijgt hiervoor een mailtje op het adres dat je bij ons geregistreerd hebt.

De komende tijd zijn we nog druk bezig om de rest van de site op te bouwen, dus het kan zijn dat sommige onderdelen (tijdelijk) niet werken.

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Tutorial: Crossover (Normaal of Games) in plaats van WINE (legaal & gratis)  (gelezen 6348 keer)

Offline peter5

  • Lid
  • Steunpunt: Nee
Tutorial: Crossover (Normaal of Games) in plaats van WINE (legaal & gratis)

Niveau: gevorderd

Inleiding
Veel linuxgebruikers zullen wel gehoord hebben van WINE, het programma dat Windows-toepassingen inlaad in Linux.
Crossover is een betaalde versie van WINE, maar is, in tegendeel van WINE, grondig getest bij elke release. Wine geeft vaak Beta-versies uit een test niet altijd alle Windows programma's uit hun App-database, wat crossover wel doet & garandeerd dat alles in hun database werkt.

Dat waren genoeg redenen voor mij om Crossover te gebruiken i.p.v Wine.
Crossover is niet gratis, zoals ik al eerder zei, maar het is wel gebasseerd op Wine. << En hier zit de truuk. Wine is opensource, wat betekend dat Crossover hun source ook moet uitgeven!

Voordat je verder gaat
Backup je Wine-map als je al wine hebt geinstalleerd! Om een backup te maken, kun je het beste in de terminal doen:
cp -r ~/.wine ~/backup.wine

Normaalgesproken past de compilatie, of het verwijderen van wine niet je wine-configuratie aan. Maar je kan het  beste het zekere voor het onzekere nemen ;)

Broncode downloaden
Je mag kiezen welke je wil, de gewone versie of de Games versie, de laatste is speciaal gebouwd om veel games te draaien. Als je geen gamer bent, of gewoon Word of zo draait, neem je de normale: CrossOver Sources
Sla de download ergens op in je home map, bijvoorbeeld de Downloads map.

Zorg er wel voor dat alle Wine versies van je computer af zijn: In de terminal: sudo apt-get remove wine1.0 OF sudo apt-get remove wine1.3

Voorbereiding compilatie
Om de juiste pakketten te downloaden, voeg de bron van WineHQ in bronnenlijst toe: sudo add-apt-repository ppa:ubuntu-wine/ppa
Update je lijst door "sudo apt-get update" te draaien.

We hebben een source, en geen binair programma, die moeten we dus nog maken. Voordat we dat kunnen doen moeten we de afhankelijkheden hebben, dus typ in de terminal: sudo apt-get build-dep wine1.3

In de tussentijd pakken we onze gedownloade sources uit. Ga in je verkenner naar de map waar je Crossover sources staan en druk op je rechtermuisknop op de sources en klik op "Hier uitpakken"
Als het installeren van de afhankelijkheden en het uitpakken voltooid zijn, heb je er een nieuwe map bij met de naam crossover-sources-9.2.0 (mag afwijken).

Compileren
Nu gaan we verder met het compileren, houd het venster open van je terminal, typ er "cd " (zonder aanhalingstekens, let op de spatie aan het eind) en sleep de map crossover-sources-9.2.0 naar je terminal. Als het goed is, is het pad nu automatisch al ingevuld (ik vind die feature goddelijk!)
Druk op enter.

We zitten nu in de map van Crossover!

We moeten eerst nog even de gepatchte Freetype bibliotheek van Crossover installeren:
Typ "cd freetype" en vervolg met enter
Typ "./configure" en vervolg met enter en wachten tot 'ie klaar is.
Typ nu "make". Als dat klaar is, typ "sudo make install"

Nu de Wine, waar we dit allemaal voor doen:
Typ "cd ../wine" en vervolg met enter
Typ "./configure --without-xml" en vervolg met enter en wachten tot 'ie klaar is.
Als er "configure: Finished.  Do 'make' to compile Wine." staat is het goed, anders is er iets fout gegaan.
Typ nu "make depend" voor het maken van de afhankelijkheden.
Typ nu "make". Dit gaat heel lang duren, ongeveer een uur. Dus laat de hond uit, pak wat te eten of iets dergelijks ;)
Als het klaar is beloond het zich wel dus het is het wachten zeker waard! (uit ervaring)

De compilatie is gelukt als er "Wine build complete." staat.
Typ nu "sudo make install" om de installatie te voltooien!

Tot slot
Gefeliciteerd! Als alles goed is, heb je nu een gratis versie van CrossOver! Het enige wat mist, is de gesloten-source grafische interface van Crossover. Maar de wine versies zijn identiek.

Je kan een windowsprogramma laden door in je terminal te typen: "wineloader naamvanprogramma.exe"

Tips
Aangeraden: Als je al eerder Wine had, zullen de programma's niet meer laden. Om dit wel te kunnen, voer dit uit in de terminal: sudo mv /usr/local/bin/wineloader /usr/local/bin/wine
Je kan dan een windows programma laden door in je terminal te typen: "wine naamvanprogramma.exe"
Deze tip is ook handig als je een interface bij Wine gebruikt, zoals PlayOnLinux.

Om te zien welke programma's er zo ie zo draaien op crossover, kan je op deze site kijken: http://www.codeweavers.com/compatibility/.

Getest op: Ubuntu 10.10, met de laatste updates.

Wijzigingen
[12:30]: Foutje dat de repository van wine niet toegevoegd was
[13:52]: Nieuwe tip toegevoegd.
[14:44]: Meer uitleg over het starten van Windows-programma's
« Laatst bewerkt op: 2010/12/31, 14:49:31 door peter5 »
Ubuntu 10.04 voor homeserver en werk pc - iPhone - iPad Wifi 16GB - Packard Bell Dot S met Ubuntu 10.10.

Ubuntu Center! Mijn interpretatie van iTunes (open source, wordt nog aan gewerkt): https://bitbucket.org/peterwilli/ubuntu-center

Offline TopGear

  • Forumteam
  • Steunpunt: Nee
Bij mij gaat het al snel fout:
peter@peter-kastje:~$ sudo apt-get build-dep wine1.3
[sudo] password for peter:
Pakketlijsten worden ingelezen... Klaar
Boom van vereisten wordt opgebouwd       
De status informatie wordt gelezen... Klaar
E: Kan geen bronpakket vinden voor wine1.3

Daarna gaat ./configure ook al fout:
peter@peter-kastje:~/Downloads/crossover-games-sources-9.2.0/freetype$ ./configure

FreeType build system -- automatic system detection

The following settings are used:

  platform                    unix
  compiler                    cc
  configuration directory     ./builds/unix
  configuration rules         ./builds/unix/unix.mk

If this does not correspond to your system or settings please remove the file
`config.mk' from this directory then read the INSTALL file for help.

Otherwise, simply type `make' again to build the library,
or `make refdoc' to build the API reference (the latter needs python).

Generating modules list in ./objs/ftmodule.h...
* module: truetype  (Windows/Mac font files with extension *.ttf or *.ttc)
* module: cff       (OpenType fonts with extension *.otf)
* module: pfr       (PFR/TrueDoc font files with extension *.pfr)
* module: type42    (Type 42 font files with no known extension)
* module: winfnt    (Windows bitmap fonts with extension *.fnt or *.fon)
* module: pcf       (pcf bitmap fonts)
* module: bdf       (bdf bitmap fonts)
* module: sfnt      (helper module for TrueType & OpenType formats)
* module: autofit   (automatic hinting module)
* module: pshinter  (Postscript hinter module)
* module: raster    (monochrome bitmap renderer)
* module: smooth    (anti-aliased bitmap renderer)
* module: smooth    (anti-aliased bitmap renderer for LCDs)
* module: smooth    (anti-aliased bitmap renderer for vertical LCDs)
* module: psaux     (Postscript Type 1 & Type 2 helper module)
* module: psnames   (Postscript & Unicode Glyph name handling)
done.
cd builds/unix; ./configure
checking build system type... x86_64-unknown-linux-gnu
checking host system type... x86_64-unknown-linux-gnu
host is x86_64-unknown-linux-gnu
checking for gcc... gcc -m32
checking for C compiler default output file name...
configure: error: in `/home/peter/Downloads/crossover-games-sources-9.2.0/freetype/builds/unix':
configure: error: C compiler cannot create executables
See `config.log' for more details.
make: *** [setup] Fout 77

Waar gaat het hier fout?

Offline peter5

  • Lid
  • Steunpunt: Nee
Bij mij gaat het al snel fout:
peter@peter-kastje:~$ sudo apt-get build-dep wine1.3
[sudo] password for peter:
Pakketlijsten worden ingelezen... Klaar
Boom van vereisten wordt opgebouwd       
De status informatie wordt gelezen... Klaar
E: Kan geen bronpakket vinden voor wine1.3

Daarna gaat ./configure ook al fout:
peter@peter-kastje:~/Downloads/crossover-games-sources-9.2.0/freetype$ ./configure

FreeType build system -- automatic system detection

The following settings are used:

  platform                    unix
  compiler                    cc
  configuration directory     ./builds/unix
  configuration rules         ./builds/unix/unix.mk

If this does not correspond to your system or settings please remove the file
`config.mk' from this directory then read the INSTALL file for help.

Otherwise, simply type `make' again to build the library,
or `make refdoc' to build the API reference (the latter needs python).

Generating modules list in ./objs/ftmodule.h...
* module: truetype  (Windows/Mac font files with extension *.ttf or *.ttc)
* module: cff       (OpenType fonts with extension *.otf)
* module: pfr       (PFR/TrueDoc font files with extension *.pfr)
* module: type42    (Type 42 font files with no known extension)
* module: winfnt    (Windows bitmap fonts with extension *.fnt or *.fon)
* module: pcf       (pcf bitmap fonts)
* module: bdf       (bdf bitmap fonts)
* module: sfnt      (helper module for TrueType & OpenType formats)
* module: autofit   (automatic hinting module)
* module: pshinter  (Postscript hinter module)
* module: raster    (monochrome bitmap renderer)
* module: smooth    (anti-aliased bitmap renderer)
* module: smooth    (anti-aliased bitmap renderer for LCDs)
* module: smooth    (anti-aliased bitmap renderer for vertical LCDs)
* module: psaux     (Postscript Type 1 & Type 2 helper module)
* module: psnames   (Postscript & Unicode Glyph name handling)
done.
cd builds/unix; ./configure
checking build system type... x86_64-unknown-linux-gnu
checking host system type... x86_64-unknown-linux-gnu
host is x86_64-unknown-linux-gnu
checking for gcc... gcc -m32
checking for C compiler default output file name...
configure: error: in `/home/peter/Downloads/crossover-games-sources-9.2.0/freetype/builds/unix':
configure: error: C compiler cannot create executables
See `config.log' for more details.
make: *** [setup] Fout 77

Waar gaat het hier fout?
Aan de errors te zien, ligt het aan mijn computer. Ik heb de WineHQ repositiory. Ik zal de tutorial aanpassen. Sorry voor en ongemak en bedankt voor het melden! Gelukig nieuwjaar ;)

Gezien je console kan je nu gewoon sudo add-apt-repository ppa:ubuntu-wine/ppa en sudo apt-get update draaien. Daarna weer "sudo apt-get build-dep wine1.3"
Als het goed is kun je dan weer verder :)
« Laatst bewerkt op: 2010/12/31, 12:33:31 door peter5 »
Ubuntu 10.04 voor homeserver en werk pc - iPhone - iPad Wifi 16GB - Packard Bell Dot S met Ubuntu 10.10.

Ubuntu Center! Mijn interpretatie van iTunes (open source, wordt nog aan gewerkt): https://bitbucket.org/peterwilli/ubuntu-center

Offline TopGear

  • Forumteam
  • Steunpunt: Nee
Ik zal het eens proberen.
En jij natuurlijk ook een goed nieuwjaar :D (leuk, naamgenoot :))

Jeej, de boel is geïnstalleerd :D Het is gelukt :D
Maar ik heb dus geen GUI... Wat moek nu doen dan? Om een iets te installeren?
« Laatst bewerkt op: 2010/12/31, 13:43:50 door TopGear »

Offline peter5

  • Lid
  • Steunpunt: Nee
Ik zal het eens proberen.
En jij natuurlijk ook een goed nieuwjaar :D (leuk, naamgenoot :))

Jeej, de boel is geïnstalleerd :D Het is gelukt :D
Maar ik heb dus geen GUI... Wat moek nu doen dan? Om een iets te installeren?
Fijn om te horen dat het nu wel gelukt is :D
Je kan een programma installeren door in je terminal "wineloader naamvanprogramma.exe" te draaien.
Deze zal dan gewoon grafisch draaien.

In veel tutorials word windeloader als "wine" gezien, dus je kan het beste eenmalig "sudo mv /usr/local/bin/wineloader /usr/local/bin/wine" doen, zodat je  "wine naamvanprogramma.exe" kan gebruiken. Dit is niet nodig, maar ik kan het wel aanraden.

Om te zien welke programma's er zo ie zo draaien op crossover, kan je op deze site kijken: http://www.codeweavers.com/compatibility/.
Ubuntu 10.04 voor homeserver en werk pc - iPhone - iPad Wifi 16GB - Packard Bell Dot S met Ubuntu 10.10.

Ubuntu Center! Mijn interpretatie van iTunes (open source, wordt nog aan gewerkt): https://bitbucket.org/peterwilli/ubuntu-center

Offline BaukeP

  • Lid
  • Steunpunt: Nee
Hallo,

Ik heb crossover een tijd geleden geïnstalleerd (en betaald) en er draaien inderdaad meer progr op. En net het progje wat ik moet gebruiken draait niet op wine, wel in Crossover. Dus is deze tutorial een uitkomst. Maar ik krijg het volgende:

┌── bauke@LTop zaterdag, 1 januari 2011 12:21:34 op Ubuntu 10.04.1 LTS
└─> [~] $ sudo apt-get build-dep wine1.3
[sudo] password for bauke:
Pakketlijsten worden ingelezen... Klaar
Boom van vereisten wordt opgebouwd       
De status informatie wordt gelezen... Klaar
De volgende pakketten hebben niet-voldane vereisten:
  libgstreamer-plugins-base0.10-dev: Vereisten: libglib2.0-dev maar het zal niet geïnstalleerd worden
  libgstreamer0.10-dev: Vereisten: libglib2.0-dev maar het zal niet geïnstalleerd worden
E: Bouwvereisten voor wine1.3 konden niet voldaan worden.

┌── bauke@LTop zaterdag, 1 januari 2011 12:21:47 op Ubuntu 10.04.1 LTS
└─> [~] $ sudo apt-get install libglib2.0-dev
Pakketlijsten worden ingelezen... Klaar
Boom van vereisten wordt opgebouwd       
De status informatie wordt gelezen... Klaar
Sommige pakketten konden niet geïnstalleerd worden. Dit kan betekenen dat u
een onmogelijke situatie gevraagd hebt of dat u de 'unstable'-distributie
gebruikt en sommige benodigde pakketten nog vastzitten in 'incoming'.
De volgende informatie helpt u mogelijk verder:

De volgende pakketten hebben niet-voldane vereisten:
  libglib2.0-dev: Vereisten: libglib2.0-0 (= 2.24.1-0ubuntu1) maar 2.25.11-3ubuntu1~10.04~ricotz1 zal geïnstalleerd worden
E: Niet-werkende pakketten:

Wat doe ik hieraan?

Alvast bedankt en uiteraard nog een heel goed 2011!

Bauke

Offline peter5

  • Lid
  • Steunpunt: Nee
Hallo,

Ik heb crossover een tijd geleden geïnstalleerd (en betaald) en er draaien inderdaad meer progr op. En net het progje wat ik moet gebruiken draait niet op wine, wel in Crossover. Dus is deze tutorial een uitkomst. Maar ik krijg het volgende:

┌── bauke@LTop zaterdag, 1 januari 2011 12:21:34 op Ubuntu 10.04.1 LTS
└─> [~] $ sudo apt-get build-dep wine1.3
[sudo] password for bauke:
Pakketlijsten worden ingelezen... Klaar
Boom van vereisten wordt opgebouwd       
De status informatie wordt gelezen... Klaar
De volgende pakketten hebben niet-voldane vereisten:
  libgstreamer-plugins-base0.10-dev: Vereisten: libglib2.0-dev maar het zal niet geïnstalleerd worden
  libgstreamer0.10-dev: Vereisten: libglib2.0-dev maar het zal niet geïnstalleerd worden
E: Bouwvereisten voor wine1.3 konden niet voldaan worden.

┌── bauke@LTop zaterdag, 1 januari 2011 12:21:47 op Ubuntu 10.04.1 LTS
└─> [~] $ sudo apt-get install libglib2.0-dev
Pakketlijsten worden ingelezen... Klaar
Boom van vereisten wordt opgebouwd       
De status informatie wordt gelezen... Klaar
Sommige pakketten konden niet geïnstalleerd worden. Dit kan betekenen dat u
een onmogelijke situatie gevraagd hebt of dat u de 'unstable'-distributie
gebruikt en sommige benodigde pakketten nog vastzitten in 'incoming'.
De volgende informatie helpt u mogelijk verder:

De volgende pakketten hebben niet-voldane vereisten:
  libglib2.0-dev: Vereisten: libglib2.0-0 (= 2.24.1-0ubuntu1) maar 2.25.11-3ubuntu1~10.04~ricotz1 zal geïnstalleerd worden
E: Niet-werkende pakketten:

Wat doe ik hieraan?

Alvast bedankt en uiteraard nog een heel goed 2011!

Bauke
Hallo Bauke,

Ik zie dat u Ubuntu 10.04 heeft en die heb ik nog niet getest, al twijfel ik of dat versieverschil heel veel uitmaakt. Kun je je inhoud van /etc/apt/sources.list geven?

Ik zal zelf ook Ubuntu 10.04 testen vanmiddag.

U ook een fijn 2011!
Ubuntu 10.04 voor homeserver en werk pc - iPhone - iPad Wifi 16GB - Packard Bell Dot S met Ubuntu 10.10.

Ubuntu Center! Mijn interpretatie van iTunes (open source, wordt nog aan gewerkt): https://bitbucket.org/peterwilli/ubuntu-center

Offline Nunslaughter

  • Lid
    • timovwb
  • Steunpunt: Nee
Het ligt niet aan 10.04, maar aan de pakketjes uit de ricotz PPA. Deze heeft heel nieuwe pakketten van cruciale systeemonderdelen voor het testen van Gnome-shell.
Hij wil namelijk versie 2.24.1-0ubuntu1 van libglib installeren, maar in de pakketbronnen staat nu 2.25.11-3ubuntu1~10.04~ricotz1 om te installeren, daarom dat hij een foutmelding geeft.

Ik zou alle pakketjes van die PPA downgraden naar de originele versies, die PPA verwijderen en Gnome-shell via jhbuild installeren.

Offline BaukeP

  • Lid
  • Steunpunt: Nee
Uiteraard!
┌── bauke@LTop zaterdag, 1 januari 2011 12:54:37 op Ubuntu 10.04.1 LTS
└─> [~] $ cat /etc/apt/sources.list
deb-src http://archive.ubuntu.com/ubuntu lucid main restricted #Added by software-properties
deb http://nl.archive.ubuntu.com/ubuntu/ lucid main restricted
deb-src http://nl.archive.ubuntu.com/ubuntu/ lucid restricted main multiverse universe #Added by software-properties
deb http://nl.archive.ubuntu.com/ubuntu/ lucid-updates main restricted
deb-src http://nl.archive.ubuntu.com/ubuntu/ lucid-updates restricted main multiverse universe #Added by software-properties
deb http://nl.archive.ubuntu.com/ubuntu/ lucid universe
deb http://nl.archive.ubuntu.com/ubuntu/ lucid-updates universe

deb http://nl.archive.ubuntu.com/ubuntu/ lucid multiverse
deb http://nl.archive.ubuntu.com/ubuntu/ lucid-updates multiverse

# deb http://nl.archive.ubuntu.com/ubuntu/ lucid-backports main restricted universe multiverse
# deb-src http://nl.archive.ubuntu.com/ubuntu/ lucid-backports main restricted universe multiverse

deb http://archive.canonical.com/ubuntu lucid partner
deb-src http://archive.canonical.com/ubuntu lucid partner

deb http://security.ubuntu.com/ubuntu lucid-security main restricted
deb-src http://security.ubuntu.com/ubuntu lucid-security restricted main multiverse universe #Added by software-properties
deb http://security.ubuntu.com/ubuntu lucid-security universe
deb http://security.ubuntu.com/ubuntu lucid-security multiverse
deb http://www.ftd4linux.nl/releases/ubuntu lucid main #openFTD
# deb http://archive.getdeb.net/ubuntu lucid-getdeb games #GetDeb


@nunslaughter:

Ik heb inderdaad de ricotz ppa een keer gebruikt om de nieuwe gnome-shell te proberen. Was niet goed genoeg en heb de ppa weer verwijderd.
Hoe grade ik dat spul nu down? (Allemaal nieuwe spelling anno 2011 ;))

Bauke

Offline Nunslaughter

  • Lid
    • timovwb
  • Steunpunt: Nee
Ik weet niet of dit gaat werken, maar ga eens naar Synaptic en kies linksonder voor "Oorsprong". Zoek in de lijst naar de ricotz PPA en voor elk pakketje dat geinstalleerd is, klikt ge in het menu op Pakket=>Versie forceren... en kies daar de originele Ubuntu versie.

Offline BaukeP

  • Lid
  • Steunpunt: Nee
@nunslaughter:

Dat kan, maar dan wil ie bijna alles verwijderen wat ik heb. Geschat zo'n 150 pakketten.

Bauke

Edit: Of is het daarna een kwestie van gebroken pakk. repareren?

Offline Nunslaughter

  • Lid
    • timovwb
  • Steunpunt: Nee
Geen idee eigenlijk, ik heb nooit eerder pakketjes uit een externe repository moeten downgraden, misschien iemand anders?
Ik zou in ieder geval niet doorgaan met de actie, die 150 pakketten zullen (belangrijke) pakketten zijn die glib, gconf, etc als dependency hebben.

Offline BaukeP

  • Lid
  • Steunpunt: Nee
Ben ik weer!

Om toekomstige problemen met ppa's te voorkomen heb ik Ubu 10.04.1 maar opnieuw geïnstalleerd. Alles draait weer, alleen een java-prog loopt ineens een stuk langzamer. Maar daar komen we wel achter.

Het wine probleem is echter nog niet weg. De ricotz-melding wel gelukkig. Zal straks de output van de verschillende commando's posten.

Bauke

Offline BaukeP

  • Lid
  • Steunpunt: Nee
De beloofde output:
┌── bauke@LTop dinsdag, 4 januari 2011 20:08:01 op Ubuntu 10.04.1 LTS
└─> [~] $ sudo apt-get build-dep wine1.3
[sudo] password for bauke:
Pakketlijsten worden ingelezen... Klaar
Boom van vereisten wordt opgebouwd       
De status informatie wordt gelezen... Klaar
E: Kan geen bronpakket vinden voor wine1.3

┌── bauke@LTop dinsdag, 4 januari 2011 20:09:01 op Ubuntu 10.04.1 LTS
└─> [~] $ cd /mnt/Data/Downloads/Linux/Crossover/crossover-sources-9.2.0/

┌── bauke@LTop dinsdag, 4 januari 2011 20:10:12 op Ubuntu 10.04.1 LTS
└─> [/mnt/Data/Downloads/Linux/Crossover/crossover-sources-9.2.0] $ ls -l
totaal 20
drwxr-xr-x  3 bauke bauke 4096 2010-10-19 17:49 cxgui/
drwxr-xr-x  9 bauke bauke 4096 2011-01-02 16:00 freetype/
drwxr-xr-x  4 bauke bauke 4096 2010-10-19 17:48 loki/
drwxr-xr-x  9 bauke bauke 4096 2010-10-19 17:48 samba/
drwxr-xr-x 11 bauke bauke 4096 2010-10-19 17:49 wine/

┌── bauke@LTop dinsdag, 4 januari 2011 20:10:18 op Ubuntu 10.04.1 LTS
└─> [/mnt/Data/Downloads/Linux/Crossover/crossover-sources-9.2.0] $ cd freetype/

┌── bauke@LTop dinsdag, 4 januari 2011 20:10:37 op Ubuntu 10.04.1 LTS
└─> [/mnt/Data/Downloads/Linux/Crossover/crossover-sources-9.2.0/freetype] $ ./configure

FreeType build system -- automatic system detection

The following settings are used:

  platform                    unix
  compiler                    cc
  configuration directory     ./builds/unix
  configuration rules         ./builds/unix/unix.mk

If this does not correspond to your system or settings please remove the file
`config.mk' from this directory then read the INSTALL file for help.

Otherwise, simply type `make' again to build the library,
or `make refdoc' to build the API reference (the latter needs python).

cd builds/unix; ./configure
checking build system type... x86_64-unknown-linux-gnu
checking host system type... x86_64-unknown-linux-gnu
host is x86_64-unknown-linux-gnu
checking for gcc... gcc -m32
checking for C compiler default output file name...
configure: error: in `/mnt/Data/Downloads/Linux/Crossover/crossover-sources-9.2.0/freetype/builds/unix':
configure: error: C compiler cannot create executables
See `config.log' for more details.
make: *** [setup] Fout 77

┌── bauke@LTop dinsdag, 4 januari 2011 20:10:50 op Ubuntu 10.04.1 LTS
└─> [/mnt/Data/Downloads/Linux/Crossover/crossover-sources-9.2.0/freetype] $

Naar aanleiding van bovenstaande meldingen heb ik nog even gekeken of build-essential was geïnstalleerd. Ja dus.

Kan iemand hier iets mee?

Groetjes, Bauke

Offline Vistaus

  • Webteam
    • vistaus
  • Steunpunt: Nee
Als je even ppa-purge installeert, dan ben je er voor de volgende keer vanaf; gewoon met ppa-purge de ppa voorgoed verwijderen en dan worden alle pakketten netjes teruggezet naar de standaardversie :)

Offline BaukeP

  • Lid
  • Steunpunt: Nee
Bedankt voor de tip! Maar in synaptic staat ie niet. Waar vind ik ppa-purge?

Bauke

Offline Vistaus

  • Webteam
    • vistaus
  • Steunpunt: Nee
Ik weet niet wat jij gebruikt, maar sinds 10.10 staat ie erin :)
http://www.webupd8.org/2010/08/ppa-purge-added-to-official-ubuntu-1010.html

Offline peter5

  • Lid
  • Steunpunt: Nee
Wow ik ben blij dat ik mensen hiermee geholpen heb! :D Was het toch niet voor niks (was een week schrijfwerk)
Wanneer ik nog wat tijd heb zal ik kijken of ik de tutorial kan uitbreiden met screenshots.
Ubuntu 10.04 voor homeserver en werk pc - iPhone - iPad Wifi 16GB - Packard Bell Dot S met Ubuntu 10.10.

Ubuntu Center! Mijn interpretatie van iTunes (open source, wordt nog aan gewerkt): https://bitbucket.org/peterwilli/ubuntu-center

Offline BaukeP

  • Lid
  • Steunpunt: Nee
Waar het Topgear blijkbaar wel lukte (zie eerdere post) blijf ik de volgende melding krijgen:

┌── bauke@LTop vrijdag, 7 januari 2011 21:37:22 op Ubuntu 10.04.1 LTS
└─> [~] $ sudo apt-get build-dep wine1.3
Pakketlijsten worden ingelezen... Klaar
Boom van vereisten wordt opgebouwd       
De status informatie wordt gelezen... Klaar
E: Kan geen bronpakket vinden voor wine1.3

Wat doe ik hieraan?

@Vistaus: ppa-purge gevonden. Ik  werk trouwens met 10.04.1 LTS

Bauke
« Laatst bewerkt op: 2011/01/07, 21:40:30 door BaukeP »

Offline socialdefect

  • Lid
    • socialdefect
    • Socialdefect's Blog
  • Steunpunt: Nee
Bedankt voor deze HOWTO!! had er nog nooit bij stilgestaan dat de basis van Crossover wel helemaal open source is.. Als ik deze week nog wat tijd heb en in Debian kom zal ik eens kijken of ik er een Deb van kan bouwen, of hangt er geen GPL aan??