Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: [niet opgelost wel afgesloten] Nvidia drivers installeren  (gelezen 1258 keer)

Offline baboom

  • Lid
  • Steunpunt: Nee
[niet opgelost wel afgesloten] Nvidia drivers installeren
« Gepost op: 2010/12/30, 20:26:55 »
Hallo,

ik heb een asus laptop voorzien van ubuntu 10.04 lts,
het enige probleem zijn de drivers die ubuntu aanbied voor de videokaart.

de videokaart is een nvidia gforce310m cuda 1 GB,
de drivers die ubuntu aanbied via Systeem>Beheer>Stuurprogammas, zorgen ervoor dat het scherm na het opstarten volledig zwart blijft

op internet zijn er bergen topics te vinden over dit onderwerp, maar een echte oplossing ben ik nog niet tegengekomen,
(dit heeft voornamelijk te maken met mijn gebrek aan " ubuntukennis"   ;) )

1 van de manieren die zou moeten werken is volgens mij de volgende;
de driver downloaden bij nvidia ;
(http://www.nvidia.com/object/linux-display-amd64-260.19.29-driver.html)

en vervolgens in de terminal: sudo ./nvidiadriver.run
de uitkomst hiervan is:
        NVIDIA Accelerated Graphics Driver for Linux-x86_64 (260.19.29)

ERROR: You appear to be running an X server; please exit X before            
         installing.  For further details, please see the section INSTALLING  
         THE NVIDIA DRIVER in the README available on the Linux driver        
         download page at www.nvidia.com.


                                       OK  


 NVIDIA Software Installer for Unix/Linux                      www.nvidia.com


als ik deze melding wegklik krijg ik de volgende boodschap:

 ERROR: Installation has failed.  Please see the file
         '/var/log/nvidia-installer.log' for details.  You may find            
         suggestions on fixing installation problems in the README available  
         on the Linux driver download page at www.nvidia.com.



hieronder dus de uitkomst van dat log bestand:

nvidia-installer log file '/var/log/nvidia-installer.log'
creation time: Thu Dec 30 20:21:17 2010
installer version: 260.19.29

PATH:
/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/X11R6/bin

option status:
  license pre-accepted               : false
  update                             : false
  force update                       : false
  expert                             : false
  uninstall                          : false
  driver info                        : false
  precompiled interfaces             : true
  no ncurses color                   : false
  query latest version               : false
  no questions                       : false
  silent                             : false
  no recursion                       : false
  no backup                          : false
  kernel module only                 : false
  sanity                             : false
  add this kernel                    : false
  no runlevel check                  : false
  no network                         : false
  no ABI note                        : false
  no RPMs                            : false
  no kernel module                   : false
  force SELinux                      : default
  no X server check                  : false
  no cc version check                : false
  run distro scripts                 : true
  no nouveau check                   : false
  run nvidia-xconfig                 : false
  sigwinch work around               : true
  force tls                          : (not specified)
  force compat32 tls                 : (not specified)
  X install prefix                   : (not specified)
  X library install path             : (not specified)
  X module install path              : (not specified)
  OpenGL install prefix              : (not specified)
  OpenGL install libdir              : (not specified)
  compat32 install chroot            : (not specified)
  compat32 install prefix            : (not specified)
  compat32 install libdir            : (not specified)
  utility install prefix             : (not specified)
  utility install libdir             : (not specified)
  installer prefix                   : (not specified)
  doc install prefix                 : (not specified)
  kernel name                        : (not specified)
  kernel include path                : (not specified)
  kernel source path                 : (not specified)
  kernel output path                 : (not specified)
  kernel install path                : (not specified)
  precompiled kernel interfaces path : (not specified)
  precompiled kernel interfaces url  : (not specified)
  proc mount point                   : /proc
  ui                                 : (not specified)
  tmpdir                             : /tmp
  ftp mirror                         : ftp://download.nvidia.com
  RPM file list                      : (not specified)
  selinux chcon type                 : (not specified)

Using: nvidia-installer ncurses user interface
-> The file '/tmp/.X0-lock' exists and appears to contain the process ID '1165'
   of a runnning X server.
ERROR: You appear to be running an X server; please exit X before installing.
       For further details, please see the section INSTALLING THE NVIDIA DRIVER
       in the README available on the Linux driver download page at
       www.nvidia.com.


ik heb al op internet rondgekeken maar kan zo gauw even niet vinden wat hier de oplossing voor zou moeten zijn.
wel ben ik erachter dat het een " bekend"  probleem is.
ook het readme bestand waar in de foutmelding over gesproken word kan ik nergens terugvinden

ik weet dat het af te raden is om zelf drivers te gaan downloaden, maar zoals ik al zei; als ik de aangeboden drivers installeer heb ik alleen zwart beeld.

de laptop in kwestie is een:
asus x52j
intel core i5
nvidia geforce 310m
« Laatst bewerkt op: 2011/01/06, 20:00:47 door baboom »
Asus X52J,                                        Acer Aspire 3610
Nvidia Gforce M310 :(                         Celeron M 1500 Mhz
Intel core i5                                      80 Gb HD
Ubuntu 10.04 LTS/Win7 Ultimate           Mint 10

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
Re: Nvidia drivers installeren
« Reactie #1 Gepost op: 2010/12/30, 21:26:22 »
Je kan beter deze PPA toevoegen voor nieuwere drivers van Nvidia: https://launchpad.net/~ubuntu-x-swat/+archive/x-updates

Maar ik vraag me af of dat wel gaat werken, want het is onduidelijk waardoor het probleem precies veroorzaakt wordt.
Ik kan op internet namelijk helemaal geen bergen topics vinden over jouw probleem...
Gaat het om een verse installatie van 10.04? Heb je het ook met de live cd?
Wat gebeurt er wanneer je een extern scherm aansluit op je laptop?

Offline baboom

  • Lid
  • Steunpunt: Nee
Re: Nvidia drivers installeren
« Reactie #2 Gepost op: 2010/12/30, 22:14:55 »
het  gaat idd om een verse installatie van 10.04.

hier een voorbeeldje van iemand met hetzelfde probleem:
http://ubuntuforums.org/showthread.php?t=309787
 
maar als ik CTR+ALT+F1 indruk gebeurd er niet , behalve dan wat gekleurde pixels links en rechts

wat betreft dat externe scherm, ik nu even niet de mogelijkheid om dat te testen

dat PPA is nieuw voor me , ik zal eens kijken wat ik daar mee kan




edit: het is uiteindelijk toch gelukt middels de link in mijn eerdere bericht !

uiteindelijk toch in virtual console kunnen komen, en daar kon ik de drivers installeren.
na een reboot , alleen even X herstarten et voila
« Laatst bewerkt op: 2010/12/30, 22:44:22 door baboom »
Asus X52J,                                        Acer Aspire 3610
Nvidia Gforce M310 :(                         Celeron M 1500 Mhz
Intel core i5                                      80 Gb HD
Ubuntu 10.04 LTS/Win7 Ultimate           Mint 10

Offline baboom

  • Lid
  • Steunpunt: Nee
Re: Nvidia drivers installeren
« Reactie #3 Gepost op: 2010/12/31, 09:39:36 »
hmzzz jammer, iets te vroeg gejuichd.

ik krijg bij het opstarten nu de melding dat er word opgestart in veilige modus, mogelijk moet ik mijn cfg, bestand bijwerken om dit te verhelpen.
 daarna krijg ik de keuze:

*opstarten in veilige grafische modus
*grafische omgeving opnieuw instellen
* de fout oplossen
*de opdrachtregel aanmelden
* x herstarten

het enige waar ik eigenlijk iets mee kan is X herstarten, dan start de laptop op,
volgens mij in veilige modus.

als ik vervolgend in ubuntu ga naar Sysyeem>Voorkeuren>Nvidia Xserver settings , krijg ik de volgende melding:
You do not appear to be using the NVIDIA X driver.  Please edit your X configuration file (just run `nvidia-xconfig` as root), and restart the X server.

de oplossing die geboden word lijkt niet te werken , want als ik dus idd in de terminal :  sudo nvidia-config intik ,
krijg ik wel keurig de volgende melding:
asus@asus-laptop:~$ sudo nvidia-xconfig

Using X configuration file: "/etc/X11/xorg.conf".
Backed up file '/etc/X11/xorg.conf' as '/etc/X11/xorg.conf.backup'
New X configuration file written to '/etc/X11/xorg.conf'


maar bij het opstarten van de Nvidia Xserver settings krijg ik weer de meldind :
You do not appear to be using the NVIDIA X driver.  Please edit your X configuration file (just run `nvidia-xconfig` as root), and restart the X server.

het aanmaken van het cfg bestand lijkt te lukken, alleen ziet ubuntu hem niet meer nadat hij hem heeft aangemaakt ?
 
edit:

oke ik geef het op, het probleem zit dus in optimus, een optie welke niet ondersteund word in linux:
http://www.nvnews.net/vbulletin/showthread.php?t=144750
 >:( >:( >:(
het is dus een kwestie van wachten tot iemand er een oplossing voor vind, of tot nvidia  een beetje mee gaat werken.
of geen nvidia meer gebruiken, maar kiezen voor ATI.
ik denk dat ik maar voor de laatste optie ga, dat word dus terug naar de winkel...., erg jammer aangezien in altijd erg blij was met mijn nvidia producten  :-[


« Laatst bewerkt op: 2011/01/01, 10:50:14 door baboom »
Asus X52J,                                        Acer Aspire 3610
Nvidia Gforce M310 :(                         Celeron M 1500 Mhz
Intel core i5                                      80 Gb HD
Ubuntu 10.04 LTS/Win7 Ultimate           Mint 10