Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: opengl freeze met planet pinguin racer, sreen saver en andere apps.  (gelezen 1012 keer)

Clemens

  • Gast
Hallo,

al een tijdje heb ik last van het vastlopen van planet pinguin racer en andere programma's.

Ik heb een ATI rage 9000, heb een tijdje planet pinguin racer kunnen spelen zonder problemen. Ubuntu 5.06 (of 5.10) maar niet met 6.06.

Met glxinfo krijgt ik
clemens@home-desktop:~$ glxinfo
name of display: :0.0
display: :0  screen: 0
direct rendering: Yes
server glx vendor string: SGI
server glx version string: 1.2
Met glxhead krijg ik
clemens@home-desktop:~$ glxheads
glxheads: exercise multiple GLX connections (any key = exit)
Usage:
  glxheads xdisplayname ...
Example:
  glxheads :0 mars:0 venus:1
Name: :0
  Display:     0x805e008
  Window:      0x2a00002
  Context:     0x8066fe8
  GL_VERSION:  1.3 Mesa 6.4.1
  GL_VENDOR:   Tungsten Graphics, Inc.
  GL_RENDERER: Mesa DRI R200 20041207 AGP 1x TCL
clemens@home-desktop:~$
De screen saver en planet pinguin racer freezen na een tijdje.
- CapsLock werkt NIET meer
- Numlock werkt WEL
- Remote desktop werkt WEL
- sudo kill -9 'xorg-pid' werkt niet????

Ik weet niet wat ik ter analyse moet doen.

Het probleem is natuurlijk behoorlijk irritant. Oplossing is een remote shutdown -r nowSuggesties voor analyse zijn welkom. En natuurlijk oplossingen ;-)

Offline Kiwinote

  • Lid
    • Launchpad
  • Steunpunt: Nee
opengl freeze met planet pinguin racer, sreen saver en andere apps.
« Reactie #1 Gepost op: 2007/01/07, 18:08:24 »
Misschien dat je je xserver opnieuw kan configureren: sudo dpkg-reconfigure xserver-xorg

Clemens

  • Gast
opengl freeze met planet pinguin racer, sreen saver en andere apps.
« Reactie #2 Gepost op: 2007/01/08, 15:54:06 »
Citaat van: Kiwinote
Misschien dat je je xserver opnieuw kan configureren: sudo dpkg-reconfigure xserver-xorg
Bedankt voor je reactie

Toch eerst een paar vragen ...
- wat zou dit me opleveren?
- weet je ook waar / in welke logfiles ik eventuele meldingen zou kunnen vinden over dit 'vastlopen'?

Het kostte me aardig wat moeite om de refresh-rates goed te krijgen dus ben ik wat huiverig om X te herconfigureren. Als een backup van '/etc/X11/xorg.conf' voldoende is is er natuurlijk geen risico.

Het frusterende is dat ik niet begrijp waarom het freezen na een tijdje gebeurt en niet meteen of na 3 minuten spelen oid. Een foute lib lijkt dan ook niet de oorzaak ... hoe controleer je dat?

Offline Tukcedo

  • Lid
    • http://www.tukcedo.nl
  • Steunpunt: Nee
opengl freeze met planet pinguin racer, sreen saver en andere apps.
« Reactie #3 Gepost op: 2007/01/08, 16:18:45 »
Er moet ergens een bestand zijn, iets van xerrors. Ik las laatst hier ergens ook wat over. Dit is het bestand waar de X server zijn log schrijft en zo kun je misschien zien wat er gebeurde op 't moment dat-ie vastliep.

Toch zit het probleem in de aansturing van je grafische kaart door X. Als het onder vorige versies wel werkte dan geeft dat aan dat er iets in de X Server is veranderd. Heb je de "oude" xorg.conf nog? Gebruikte je wellicht toen andere instellingen voor die kaart?
Tukcedo Services - Unix en Linux Consultants
http://www.tukcedo.nl

blubber

  • Gast
opengl freeze met planet pinguin racer, sreen saver en andere apps.
« Reactie #4 Gepost op: 2007/01/08, 16:43:33 »
Je zou deze tests even uit kunnen voeren om na te gaan of ie het zou moeten doen.
http://wiki.cchtml.com/index.php/Verifying
En volgens mij zou
lsmod | grep fglrxuit moeten wijzen of de juiste module wel geladen is. Als je bevindingen negatief zijn, post dan je xorg.conf eens.

Clemens

  • Gast
opengl freeze met planet pinguin racer, sreen saver en andere apps.
« Reactie #5 Gepost op: 2007/01/08, 17:16:41 »
Citaat van: blubber
Je zou deze tests even uit kunnen voeren om na te gaan of ie het zou moeten doen.
http://wiki.cchtml.com/index.php/Verifying
Via bovenstaande site en
fglrxinfo
clemens@home-desktop:/boot/grub$ fglrxinfo
display: :0.0  screen: 0
OpenGL vendor string: Tungsten Graphics, Inc.
OpenGL renderer string: Mesa DRI R200 20041207 AGP 1x TCL
OpenGL version string: 1.3 Mesa 6.4.1
krijg ik 'goede' output. Alleen ... is dit ATI of MESA.

fgl_glxgears # is fout
fgl_glxgears -fbo # is minder fout: witte vlakken
Wat ik dus nu niet meer snap ... ik heb de ATI zooi gedeinstalleerd. De nieuwste driver ondersteund namelijk alleen vanaf RAGE 96(?)00 en niet vanaf RAGE 9000 en die heb ik. MESA lijkt voldoende te performen.

Ik wil gewoon MESA. Waarom heb ik dan toch ATI software op mijn systeem?

Is glewinfo

---------------------------
    GLEW Extension Info
---------------------------

GLEW version 1.3.1
Reporting capabilities of display :0.0, visual 0x27
Running on a Mesa DRI R200 20041207 AGP 1x TCL from Tungsten Graphics, Inc.
OpenGL version 1.3 Mesa 6.4.1 is supported
...
de hint dat mijn systeem 'gewoon' fout is ingesteld.

???Heeft automatix op 5.10 ook ATI geinstalleerd en deed daarom Planet Pinguin Racer het???

Hoe kan ik erachter komen waar fglrxinfo vandaan komt, uit welk pakket?
(paniek alom ;()
Ik ga xorg.conf na vlooien en synaptic ;(

Bedankt voor het meedenken.

Clemens

  • Gast
opengl freeze met planet pinguin racer, sreen saver en andere apps.
« Reactie #6 Gepost op: 2007/01/08, 17:30:41 »
Citaat van: tukcedo
Er moet ergens een bestand zijn, iets van xerrors. Ik las laatst hier ergens ook wat over. Dit is het bestand waar de X server zijn log schrijft en zo kun je misschien zien wat er gebeurde op 't moment dat-ie vastliep.
Met
sudo find / 2>/dev/null | grep -i xerrorvind ik alleen het bestand /usr/share/X11/XErrorDB. Dit lijkt een lookup tabel voor meldingen.

Citaat van: tukcedo
Toch zit het probleem in de aansturing van je grafische kaart door X. Als het onder vorige versies wel werkte dan geeft dat aan dat er iets in de X Server is veranderd. Heb je de "oude" xorg.conf nog? Gebruikte je wellicht toen andere instellingen voor die kaart?
Er zijn vele wijzigingen geweest.
- 5.05 -> 5.10 -> 6.06
- xorg update
- ATI driver (voor RAGE 96(?)00+) + kernel 686
- refresh van xorg.conf

De logging van X less /var/log/Xorg.0.loglaat inderdaad iets zien wat ik niet had verwacht. Er staat een ATI driver in ... als alternative device. Oeps.

OK ... dan toch maar eerst xorg.conf schonen ... grrr ... val ik door de mand :(

Bedankt ... en wacht maar even met reageren ... hopelijk vind ik het nu ... en zo ja (en nee) laat ik het weten.