Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Ubuntu vergeet z' n driver telkens!  (gelezen 970 keer)

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
Ubuntu vergeet z' n driver telkens!
« Gepost op: 2007/01/06, 17:28:43 »
Met alsaconf heb ik een ouwe soundblaster geluidskaart met ISA-aansluiting, weer aan de praat gekregen in Xubuntu 6.06.1.

Dankzij Dennis' alsapakketje! Gewoon sudo alsaconf, vragenriedeltje volgen en de rest volgt vanzelf. Driver geïnstalleerd en geconfigureerd.

Prima geluid! Maar..... telkens als ik de computer herstart, dan is Xubuntu 6.06.1  z' n driver weer helemaal kwijt! Om weer geluid te krijgen, moet ik dan sudo alsaconf opnieuw uitvoeren.

Op het Engelstalige forum heeft iemand met hetzelfde probleem, een oplossing gepost. http://www.ubuntuforums.org/showthread.php?t=331758&highlight=alsaconf
 Het gaat om bijdrage 3 en 4 in dit draadje.

Alleen kan ik er geen soep van koken. Het veronderstelt teveel technische kennis. Wie kan me in duidelijke, stap voor stap aanwijzingen zeggen hoe ik zijn oplossing kan uitvoeren?

Groet, Pjotr.

Offline kennywest

  • Lid
    • http://kennywest.blogspot.com
  • Steunpunt: Nee
Ubuntu vergeet z' n driver telkens!
« Reactie #1 Gepost op: 2007/01/06, 20:08:12 »
Als je sudo alsactl --help doet, krijg je dit:
Usage: alsactl command

Available options:
  -h,--help       this help
  -f,--file #     configuration file (default /var/lib/alsa/asound.state or /etc/asound.names)
  -F,--force      try to restore the matching controls as much as possible
  -d,--debug      debug mode
  -v,--version    print version of this program

Available commands:
  store  save current driver setup for one or each soundcards
                  to configuration file
  restore load current driver setup for one or each soundcards
                  from configuration file
  power [card #] [state]
                  get/set power state for one or each soundcards
De truc die de poster uithaalt is de volgende:
- via alsactl store gaat ie de settings opslaan in een bestand
- via alsactl restore gaat ie de settings uit dat bestand terugzetten
Het laatste commando heeft de poster in een script geplaatst zodat dit wordt uitgevoerd bij het opstarten van het systeem. Laat ons eerst eens proberen of het uitvoeren van store/restore (handmatig dan) werkt voor u.

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
Ubuntu vergeet z' n driver telkens!
« Reactie #2 Gepost op: 2007/01/06, 20:55:56 »
OK, Kenny, ik snap 't. Bedankt. Maar helaas: nog geen resultaat!

Wat heb ik gedaan:
- asound.state en asound.names aangemaakt met alsactl
- beide bestanden gekopieerd naar /home/gebruiker
- alsactl restore /home/gebruiker/asound.state
melding: alsactl: load_state:1250: Cannot find soundcard '/home/gebruiker/asound.state'...
- alsactl restore /home/gebruiker/asound.names
melding: alsactl: load_state:1250: Cannot find soundcard '/home/willem/asound.names'...

Het gekke is verder: bij het uitvoeren van sudo alsaconf, wat dus tijdelijk een geslaagde installatie van de geluidskaart veroorzaakt, zegt alsaconf op het einde van de vragenriedel, dat hij /etc/modprobe.d/sound zal wijzigen. Maar als ik naderhand dat bestand inzie, dan is het leeg.

De inhoud van asound.names is overigens:
ctl {
alsactl1 {
name hw:0
comment 'Physical Device - Sound Blaster 16 at 0x220, irq 5, dma 1&3'
}
}
pcm {
alsactl1 {
name default:0
comment 'Abstract Device - Default Device (Duplex)'
}
alsactl2 {
name plug:default:0
comment 'Abstract Device With Conversions - Default Device (Duplex)'
}
alsactl3 {
name 'hw:0,0'
comment 'Physical Device - DSP v4.16 (Duplex)'
}
alsactl4 {
name 'plughw:0,0'
comment 'Physical Device With Conversions - DSP v4.16 (Duplex)'
}
}
rawmidi {
alsactl1 {
name default
comment 'Abstract Device - Default Device (Duplex)'
}
alsactl2 {
name 'hw:0,0'
comment 'Physical Device - Sound Blaster 16 MIDI (Duplex)'
}
alsactl3 {
name virtual
comment 'Virtual Device - Sequencer (Duplex)'
}
alsactl4 {
name 'virtual:MERGE=0'
comment 'Virtual Device - Sequencer (No Merge) (Duplex)'
}
}
timer {
alsactl1 {
name 'hw:CLASS=1,SCLASS=0,CARD=-1,DEV=0,SUBDEV=0'
comment 'Physical Device - system timer'
}
}
seq {
alsactl1 {
name default
comment 'Default Device - Sequencer (Duplex)'
}
alsactl2 {
name hw
comment 'Physical Device - Sequencer (Duplex)'
}
}
Groet, Pjotr.

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
Ubuntu vergeet z' n driver telkens!
« Reactie #3 Gepost op: 2007/01/06, 22:32:43 »
Uiteindelijk heb ik via Google een goede oplossing kunnen vinden. Alsaconf is maar een tijdelijke (sessiegebonden) oplossing, blijkt het. Althans voor mij. Het heeft veel te maken met het lege sound bestand.

Definitief opgelost heb ik het zo: in terminal:
sudo mousepad /etc/modules

daarna de volgende regel toegevoegd aan dat tekstbestandje:
snd-sb16Opslaan en sluiten

Daarna in terminal:
sudo mousepad /etc/modprobe.d/sound

daarna de volgende regel in dat tekstbestandje gezet: options snd-sb16 isapnp=0 port=0x220 irq=5 dma8=1 dma16=5daarna in terminal:
sudo update-modules

daarna in terminal:
sudo reboot

Klaar!

Groet, Pjotr.

Offline eendje

  • Lid
  • Steunpunt: Nee
Ubuntu vergeet z' n driver telkens!
« Reactie #4 Gepost op: 2007/01/06, 23:07:04 »
@pjotr123

moet het aanroepn van het commando niet als volgt:


alsactl -f /home/gebruiker/asound.state restore card_naam

of

alsactl -f /home/gebruiker/asound.state restore card_id
Een dag niets geleerd is een dag niet geleefd!
Ik blog dus ik besta!
__________________________________________________________
Een vraag? Heb je al eens gekeken op: http://wiki.ubuntu-nl.org/FAQ?

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
Ubuntu vergeet z' n driver telkens!
« Reactie #5 Gepost op: 2007/01/06, 23:25:46 »
Citaat van: eendje
@pjotr123
moet het aanroepn van het commando niet als volgt:

alsactl -f /home/gebruiker/asound.state restore card_naam

of

alsactl -f /home/gebruiker/asound.state restore card_id
Zou goed kunnen, eendje. Maar ik heb het nu anders opgelost, en goed=goed!

Ik heb er al genoeg tijd in gestoken..... Enfin, het geeft ook voldoening, om me ergens als een pitbull in vast te bijten en het op te lossen!

Groet, Pjotr.

Offline Marcel S

  • Lid
  • Steunpunt: Nee
Ubuntu vergeet z' n driver telkens!
« Reactie #6 Gepost op: 2007/01/07, 16:16:14 »
Wat ik altijd deed was:

alsaconf > alsamixer (om alles in te stellen, staat nl. uit) > alsactl store

Vooral alsamixer is belangrijk om de volumes te activeren en in te stellen.

gr. Marcel
Ubuntu-user 12429
Nexus Psile White | Jetway J9F2-Extreme Mini-ITX - i945GM - DVI – HDMI | Intel Core 2 Duo Mobile T7200 2.00GHz 667MHz 4MB | OCZ DDR2 PC2-5400 Gold GX XTC Dual Channel 1GB | Western digital Caviar GP 500 GB | Samsung SyncMaster 710v | HP Photosmart 2575 | QNAP - TS110 (NAS)