Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: [OPGELOST] Transmission + SAMBA  (gelezen 2425 keer)

Offline nforcer

  • Lid
  • Steunpunt: Nee
[OPGELOST] Transmission + SAMBA
« Gepost op: 2010/12/25, 23:51:29 »
Hallo iedereen!

Ik heb vandaag 10.04 Server geïnstalleerd met daarbij Transmission en SAMBA. Samba volgens deze tutorial: https://help.ubuntu.com/10.04/serverguide/C/samba-fileserver.html. Nu kan ik vanaf iedere Windows PC in het netwerk netjes op het gedeelde mapje komen zonder wachtwoord ofzo. Ik kan daar een mapje/bestand aanmaken en verwijderen. Dit werkt dus tot zover uitstekend.

Hierna heb ik Transmission geïnstalleerd via de bekende apt-get install transmission-daemon. Ik heb mijn download en incomplete folder neergezet in het mapje die ik met Samba heb gedeeld. Transmission kon niets downloaden, er kwam bij de download te staan "access denied". Op zich wel logisch want ik had de mapjes "download" en "incomplete" aangemaakt via Samba vanaf mijn Windows-computer. Ik heb het probleem opgelost door mijn Samba-share, de "download" en "incomplete" mapjes te chmodden met sudo chmod o+w /pad/naar/share en ook o+r en o+x.
Transmission kan nu downloaden maar de bestanden die aangemaakt worden kan ik niet verwijderen. Ook niet als ik de torrents uit Transmission heb gegooid (dus ze zijn niet in gebruik).

Blijkbaar neemt Transmission ownership van de bestanden? Ik moet inloggen via SSH en via de command line de bestanden/mappen verwijderen die gedownload zijn.

Weet iemand hoe ik Ubuntu zover kan krijgen zodat ik gedownloade mappen via de Samba share kan verwijderen? :rolleyes:
« Laatst bewerkt op: 2010/12/28, 19:54:53 door nforcer »

Offline jan11000

  • Lid
  • Steunpunt: Nee
Re: Transmission + SAMBA
« Reactie #1 Gepost op: 2010/12/26, 01:19:56 »
In de samba config file staat onderaan de map die je shared. Iets daarboven staat een voorbeeld, met directories en files, om de eigennaar te wijzigen in de share, dit kun je dus bij je eigen share erbij zetten, dan worden alle files die jij in je share zet veranderd naar deze waarde dus bij 775 of zo.

# File creation mask is set to 0700 for security reasons. If you want to
# create files with group=rw permissions, set next parameter to 0775.
;   create mask = 0700

# Directory creation mask is set to 0700 for security reasons. If you want to
# create dirs. with group=rw permissions, set next parameter to 0775.
;   directory mask = 0700

Dus dit erbij zetten:(onderaan de file staat je share).
create mask = 0775
directory mask = 0775
« Laatst bewerkt op: 2010/12/26, 10:03:48 door jan11000 »

Offline nforcer

  • Lid
  • Steunpunt: Nee
Re: Transmission + SAMBA
« Reactie #2 Gepost op: 2010/12/27, 00:44:35 »
Helaas, dit helpt ook niet  ???

Offline jan11000

  • Lid
  • Steunpunt: Nee
Re: Transmission + SAMBA
« Reactie #3 Gepost op: 2010/12/27, 01:00:44 »
Op mijn server(desktop ubuntu) had ik dat de server geen files kon deleten in de samba map.
Wel kon ik vanaf een ubuntu pc(andere pc) files verwijderen en erbij zetten.
Dmv create mask = 0775, directory mask = 0775, kan nu ook de server alles doen, terwijl de niet server als eigennaar staat vermeld bij de files. De eigennaar is een samba user op de server, dus deze user is niet ingelogt/opgestart.

Kijk eens bij user en groups.

De samba share map, heb ik als eigennaar de andere pc(dus de gewone pc user), dus de server is geen eigennaar van de samba share.
« Laatst bewerkt op: 2010/12/27, 01:08:14 door jan11000 »

Offline nforcer

  • Lid
  • Steunpunt: Nee
Re: Transmission + SAMBA
« Reactie #4 Gepost op: 2010/12/27, 01:33:35 »
Ik heb nog wat zitten frutten met het systeem. Via de SAMBA tutorial die ik gevolgd heb staat:

sudo mkdir -p /srv/samba/share
sudo chown nobody.nogroup /srv/samba/share/

Maar om Transmission te laten schrijven in het Samba mapje moeten er mappen aangemaakt worden (incomplete en complete) waar Transmission eigenaar van is. Als ik iets (dat gedownload is) probeer te verwijderen via Samba kan dat niet. Maar als ik "nogroup" dan eigenaar maak van bijvoorbeeld het mapje complete, kan ik wel alles verwijderen. Ik gebruik dan het volgende commando:

sudo chgrp -R nogroup <mapnaam>
Kan ik dan niet die nogroup toevoegen aan Transmission ofzo??


Offline nforcer

  • Lid
  • Steunpunt: Nee
Re: Transmission + SAMBA
« Reactie #6 Gepost op: 2010/12/28, 19:54:21 »
Bedankt. In één van die linkjes stond dat ik umask op 0 moest zetten. Het werkt nu!