Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: boot probleem  (gelezen 2849 keer)

Offline tangski

  • Lid
  • Steunpunt: Nee
boot probleem
« Gepost op: 2010/12/24, 10:20:30 »
Hallo,

Ik heb enkele maanden geleden ubuntu 10.04 geïnstalleerd binnen de windows 7 omgeving. Bij de opstart kon ik dan kiezen of ik in Windows of in Linux opstartte. Dit werkte probleemloos.

Ik heb nu een tijdje niet meer met Linux gewerkt omdat ik steeds windows programma's nodig had. Toen ik vandaag wilde opstarten in Linux ging dit niet meer. Als ik aanduid om in Linux op te starten kom ik telkens terug op het keuzescherm waar ik kan aanduiden in welke os ik wil opstarten. Iemand een idee?

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
Re: boot probleem
« Reactie #1 Gepost op: 2010/12/24, 11:15:24 »
Hallo,

Ik heb enkele maanden geleden ubuntu 10.04 geïnstalleerd binnen de windows 7 omgeving. Bij de opstart kon ik dan kiezen of ik in Windows of in Linux opstartte. Dit werkte probleemloos.

Ik heb nu een tijdje niet meer met Linux gewerkt omdat ik steeds windows programma's nodig had. Toen ik vandaag wilde opstarten in Linux ging dit niet meer. Als ik aanduid om in Linux op te starten kom ik telkens terug op het keuzescherm waar ik kan aanduiden in welke os ik wil opstarten. Iemand een idee?

Dan heb je een Wubi-installatie van Ubuntu gedaan.... Die is sowieso niet ideaal.

Verwijder Wubi eens (vanuit Windows, via Configuratiescherm - Software installeren/verwijderen). En doe daarna eens een technisch betere, gewone installatie, waarbij Ubuntu een eigen partitie krijgt naast Windows: https://sites.google.com/site/computertip/installeren

Offline tangski

  • Lid
  • Steunpunt: Nee
Re: boot probleem
« Reactie #2 Gepost op: 2010/12/24, 12:21:56 »
Ik heb ook al aan een herinstallatie gedacht. Maar dan verlies ik waarschijnlijk alle bestanden die onder linux staan, niet?

Offline heir4c

  • Lid
  • Steunpunt: Nee
Re: boot probleem
« Reactie #3 Gepost op: 2010/12/26, 19:13:51 »
Die kan je normaal gezien redden door met de LiveCD op te starten en dan die bestanden eerst naar een externe schijf te backuppen.
Via de LiveCD moet je die kunnen zien.

Backup ook al je andere zaken onder windows voor alle zekerheid.

Offline Jan E.

  • Lid
  • Steunpunt: Nee
Re: boot probleem
« Reactie #4 Gepost op: 2010/12/27, 09:42:53 »
Die kan je normaal gezien redden door met de LiveCD op te starten en dan die bestanden eerst naar een externe schijf te backuppen.
Via de LiveCD moet je die kunnen zien.

Backup ook al je andere zaken onder windows voor alle zekerheid.
NEE... Dit gaat niet zo werken, omdat het een Wubi-installatie is...... Als je dan opstart vanaf de LiveCD, kan je wellicht wel op de Windows-partitie, maar daar zul je de Ubuntu-installatie aantreffen als één gigantisch bestand. Waar je vervolgens niet veel mee kan......

Ik vrees dat TS inderdaad de bestanden die hij onder Ubuntu heeft staan, vanwege de ongelukkige keuze voor de Wubi-install, kwijt is.....
Misschien moet dat toch eens ergens wat uitgebreider beschreven worden, dat die Wubi eigenlijk ongeschikt is als permanente installatie. Wubi is uitgebreid proberen, uitgebreider en comfortabeler dan vanaf de CD, maar meer ook niet.


Samsung NP300E7A
Ubuntu 14.04

Offline heir4c

  • Lid
  • Steunpunt: Nee
Re: boot probleem
« Reactie #5 Gepost op: 2010/12/27, 11:01:37 »
Oh... Nou, weer iets dat ik weet.
Heb geen ervaring met wubi maar ik dacht dus dat de persoonlijke bestanden wel te vinden zouden zijn.

Offline jolo

  • Lid
  • Steunpunt: Nee
Re: boot probleem
« Reactie #6 Gepost op: 2010/12/27, 11:27:46 »
Ik vrees dat TS inderdaad de bestanden die hij onder Ubuntu heeft staan, vanwege de ongelukkige keuze voor de Wubi-install, kwijt is
Ik zie dit los van de Ubuntu installatie keuze. Kans op data verlies heb je namelijk altijd. Een harddisk kan tenslotte ook plotseling de geest geven.

Wat de TS nog wel zou kunnen proberen staat op Ubuntu Wiki WubiGuide Cannot boot into Ubuntu.

Ikzelf heb ook nog even een kleine test gedaan op één van mijn oude test PC's. Namelijk de Dual P3 PC uit mijn onderschrift. De wubi installatie van Ubuntu 10.04.1 loopt goed, zodat deze na de eerste reboot wordt voltooid. Echter na de volgende reboot selecterend Ubuntu, eindigde deze in een busybox melding. Omdat die PC een SATA en PATA harddisk heeft, blijkt in GRUB de Ubuntu keuze te verwijzen naar de verkeerde harddisk. Blijkbaar verwisseld de wubi installatie die twee harddisk met elkaar. En dit terwijl een echte installatie van Ubuntu op de harddisk, wel de juiste gegevens in GRUB plaatst.
Hoofd PC september 2011 Asus P8Z68-V Pro i7 2600K 8 GB RAM GT730 Ubuntu 14.04
PC 2007 Asus P5B E6600 2GB RAM 8800GTS  
Notebook 2008 Lenovo ThinkPad R61i 8932GMG 2,5 GB RAM
Test pc's AthlonXP 1700+ PC 1,5 GB RAM nVidia 7600GS en Dual P3 1000 MHz 1 GB RAM X1650Pro

Offline tangski

  • Lid
  • Steunpunt: Nee
Re: boot probleem
« Reactie #7 Gepost op: 2010/12/30, 09:27:22 »
Misschien is dit de reden van het probleem: Onder de map

C:\ubuntu\disks\boot\grub

staan geen bestanden.

Offline jolo

  • Lid
  • Steunpunt: Nee
Re: boot probleem
« Reactie #8 Gepost op: 2010/12/30, 12:47:52 »
C:\ubuntu\disks\boot\grub staan geen bestanden.
Ik denk niet dat dit de reden is, dat je wubi installatie niet meer werk. Want op die Dual P3 PC waarop ik in Windows XP als test Ubuntu 10.04.1 via wubi geïnstalleerd had, heb ik ook geen bestanden in C:\ubuntu\disks\boot\grub staan. Je zou de bestanden kunnen vergelijken, met die van mij. Dit doe je door achter de Opdrachtprompt via CD te gaan naar de c:\ubuntu map, gevolgd door het commando attrib /s /d
Microsoft Windows XP [Version 5.1.2600]
(C) Copyright 1985-2001 Microsoft Corp.

C:\Documents and Settings\Jolo>cd \ubuntu

C:\ubuntu>attrib /s /d
           C:\ubuntu\disks\boot\grub
           C:\ubuntu\disks\boot
A          C:\ubuntu\disks\root.disk
A          C:\ubuntu\disks\swap.disk
A          C:\ubuntu\install\.fuse_hidden0000000400000001
A          C:\ubuntu\winboot\wubildr
A          C:\ubuntu\winboot\wubildr.cfg
A          C:\ubuntu\winboot\wubildr.mbr
A          C:\ubuntu\cls
           C:\ubuntu\disks
           C:\ubuntu\install
A  SH      C:\ubuntu\Thumbs.db
A          C:\ubuntu\Ubuntu.ico
A          C:\ubuntu\uninstall-wubi.exe
           C:\ubuntu\winboot

C:\ubuntu>
Dit commando toont alle (verborgen) bestanden en lege mappen. Bij mij start die wubi installatie gewoon nog op. Had je intussen die Ubuntu Wiki WubiGuide hyperlink uit mijn vorig bericht al kunnen checken? Dus die chkdsk /r in Windows op de C: schijf.  
Hoofd PC september 2011 Asus P8Z68-V Pro i7 2600K 8 GB RAM GT730 Ubuntu 14.04
PC 2007 Asus P5B E6600 2GB RAM 8800GTS  
Notebook 2008 Lenovo ThinkPad R61i 8932GMG 2,5 GB RAM
Test pc's AthlonXP 1700+ PC 1,5 GB RAM nVidia 7600GS en Dual P3 1000 MHz 1 GB RAM X1650Pro

Offline tangski

  • Lid
  • Steunpunt: Nee
Re: boot probleem
« Reactie #9 Gepost op: 2011/01/02, 09:56:51 »
Ik heb het chkdisk /r uitgevoerd, maar Ubuntu wil nog steeds niet booten.
Ik heb de map C:\ubuntu\cls niet staan. Zou daar het probleem kunnen liggen?

Offline jolo

  • Lid
  • Steunpunt: Nee
Re: boot probleem
« Reactie #10 Gepost op: 2011/01/02, 16:02:25 »
Ik heb de map C:\ubuntu\cls niet staan. Zou daar het probleem kunnen liggen?
Ik heb dit even nagekeken. Het is een tekst bestand met dezelfde tekst, als ik had gepost in de Code van mijn vorig bericht. Dat bestand hoeft daar niet te staan.
Ik heb het chkdisk /r uitgevoerd, maar Ubuntu wil nog steeds niet booten.
Maar heb je kunnen zien of die commando iets repareerde? 

Je zou nog het volgende kunnen controleren. Als het goed is staat er onderaan in de c:\boot.ini
  C:\wubildr.mbr = "Ubuntu" Check of deze daar daadwerkelijk staat. Zo zit dit er bij mij uit in C:\
26-12-2010  21:38            88.242 wubildr

26-12-2010  21:38             8.192 wubildr.mbr
Want als het goed werkt, zou er na de keuze voor Ubuntu, het Ubuntu GRUB menu behoren te verschijnen.
Hoofd PC september 2011 Asus P8Z68-V Pro i7 2600K 8 GB RAM GT730 Ubuntu 14.04
PC 2007 Asus P5B E6600 2GB RAM 8800GTS  
Notebook 2008 Lenovo ThinkPad R61i 8932GMG 2,5 GB RAM
Test pc's AthlonXP 1700+ PC 1,5 GB RAM nVidia 7600GS en Dual P3 1000 MHz 1 GB RAM X1650Pro

Offline tangski

  • Lid
  • Steunpunt: Nee
Re: boot probleem
« Reactie #11 Gepost op: 2011/01/02, 17:35:28 »
Hallo,

Met welk programma kan ik een .mbr bestand openen?

Offline jolo

  • Lid
  • Steunpunt: Nee
Re: boot probleem
« Reactie #12 Gepost op: 2011/01/02, 20:00:55 »
Waarom zou je een .mbr bestand willen openen? Je zou deze thread nog kunnen checken Can't boot in Ubuntu, after installation. Je bent dan weliswaar je Ubuntu entry niet kwijt. Wellicht staat er toch iets bruikbaars in deze How To Restore the Wubi Ubuntu Bootloader.
Hoofd PC september 2011 Asus P8Z68-V Pro i7 2600K 8 GB RAM GT730 Ubuntu 14.04
PC 2007 Asus P5B E6600 2GB RAM 8800GTS  
Notebook 2008 Lenovo ThinkPad R61i 8932GMG 2,5 GB RAM
Test pc's AthlonXP 1700+ PC 1,5 GB RAM nVidia 7600GS en Dual P3 1000 MHz 1 GB RAM X1650Pro

Offline tangski

  • Lid
  • Steunpunt: Nee
Re: boot probleem
« Reactie #13 Gepost op: 2011/01/03, 11:19:31 »
Wellicht staat er toch iets bruikbaars in deze How To Restore the Wubi Ubuntu Bootloader.

Ik had er goede hoop in dat dit mijn probleem zou kunnen oplossen, maar het was een njet. Toen ik voor wubi koos in het opstartscherm kwam er een melding dat windows niet kon opstarten. Mijn pc raadde mij aan om de windows cd te gebruiken. Ik heb dit niet gedaan en gewoon weer met windows 7 proberen op te starten en dat lukte.