Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: [opgelost] upgrade mysql mislukt  (gelezen 651 keer)

Offline jobo

  • Lid
  • Steunpunt: Nee
[opgelost] upgrade mysql mislukt
« Gepost op: 2010/12/18, 17:16:47 »
Beste mensen ik heb een probleem.

Heb een servertje draaien ubuntu server 9.04.
Nu wilde ik updaten, want mijn mysql client was niet gelijk met mysql server wat mijn applicatie wel vereist.
enfin, ik dus van alles geprobeert, maar het gaat fout.

Ik heb nu al zoveel geprobeert dat ik niet eens meer weet wat ik wel en niet geprobeert heb eigenlijk, maar het lijkt erop dat mysql server niet geheel geinstaleerd meer is.

als ik dan ook apt-get install mysql-server doe, krijg ik de volgende foutmelding.

1
Reading package lists... Done
Building dependency tree
Reading state information... Done
mysql-server is already the newest version.
You might want to run `apt-get -f install' to correct these:
The following packages have unmet dependencies:
  mysql-server: Depends: mysql-server-5.1 but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

okay, dus vrolijk apt-get -f install gedaan, krijg ik de volgende melding.

2
The following extra packages will be installed:
  mysql-server-5.1
Suggested packages:
  tinyca
The following NEW packages will be installed:
  mysql-server-5.1
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
3 not fully installed or removed.
Need to get 0B/7,273kB of archives.
After this operation, 16.5MB of additional disk space will be used.
Do you want to continue [Y/n]? Y


dus doen zou je zeggen, maar dan krijg ik deze melding.

3
Preconfiguring packages ...
dpkg: regarding .../mysql-server-5.1_5.1.37-1ubuntu5.5_amd64.deb containing mysql-server-5.1:
 mysql-server-5.1 conflicts with mysql-server (<< 5.1.54-0.dotdeb.0)
  mysql-server (version 5.1.37-1ubuntu5.5) is present and unpacked but not configured.
dpkg: error processing /var/cache/apt/archives/mysql-server-5.1_5.1.37-1ubuntu5.5_amd64.deb (--unpack):
 conflicting packages - not installing mysql-server-5.1
Errors were encountered while processing:
 /var/cache/apt/archives/mysql-server-5.1_5.1.37-1ubuntu5.5_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

heb dus in /var/cache/apt/archives/ dus al de nodige mysql installs verwijderd, en ook clean gedaan van apt-get.
maar niets helpt, ook alt-get upgrade na een apt-get clean

dan krijg ik wederom:
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run `apt-get -f install' to correct these.
The following packages have unmet dependencies:
  mysql-server: Depends: mysql-server-5.1 but it is not installed
E: Unmet dependencies. Try using -f.

maar krijg dan wderom dezelfde melding als bi codeblock 3 dus.

ben nu ten einde raad, want mijn mysql doet het nu dus niet meer, en alt-get remove mysql-server werkt dus niet, dan zegt hij dat hij verwijderd maar dan na install krijg ik weer die foutmeldig.

iemand een idee?
« Laatst bewerkt op: 2010/12/19, 15:59:22 door jobo »

Offline rja

  • Lid
  • Steunpunt: Nee
Re: upgrade mysql mislukt
« Reactie #1 Gepost op: 2010/12/19, 13:07:39 »
Hoe ziet je sources.list er uit in /etc/apt

Offline jobo

  • Lid
  • Steunpunt: Nee
Re: upgrade mysql mislukt
« Reactie #2 Gepost op: 2010/12/19, 15:59:07 »
ja dat was inderdaad mijn probleem, ik had ooit een repro toegevoegd en weer eruitgehaald was een dev repro.
die veroorzaakt dus het probleem.

Dus repro toegevoegd, toen alles verwijderd, toen opnieuw geinstaleerd, werkte toen wel, maar moest nog wel in my.cnf nog even aangeven waar de mysql.sock moest staan want dat was ook niet lekker.

alles werkt dus weer.

gr.