Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Vreemd Mplayer ondertitel probleem  (gelezen 429 keer)

Cronos

  • Gast
Vreemd Mplayer ondertitel probleem
« Gepost op: 2010/12/18, 10:40:22 »
Hallo,

Ik heb een heel vreemd probleem met Mplayer waar ik al een tijdje een oplossing voor probeer te vinden, maar het lukt me niet. Ik heb van alles afgegoogled en het internationale Ubuntu forum afgezocht en dit probleem daar ook gepost, maar helaas niets. Misschien dat het iemand hier een oplossing heeft?

Ik heb de SVN versie van Mplayer geinstalleerd met daarbij de laatste versie van Smplayer op 10.04 Lucid Lynx, met VDPAU hardwareversnelling (mijn PC heeft een Nvidia 9600GT kaart, 4450e dual core processor, met 4GB ram), en het spelen van HD films en series gaat vrij goed. Maar het probleem is wanneer ik gewone standaard niet-HD films wil afspelen van mijn harde schijf.

Ik start Smplayer op, selecteer de optie 'DVD vanuit map', en selecteer dan de video_ts map van de film. Dan begint de film te spelen, maar zodra de eerste ondertitels in beeld komen, slaat het beeld op zwart. Meteen als die ondertitel weg is, heb ik weer een paar seconden gewoon beeld, maar zodra de volgende ondertitel in beeld komt, gaat het beeld weer op zwart. En zo gaat het de hele film door. Om het probleem nog vreemder te maken, dit gebeurt met sommige films, niet alle. :| Het is echt de ene film wel, en de andere niet. Ik heb overigens geen probleem met de ondertitels van HD films en series, maar dat komt denk ik omdat daar vaak losse .srt ondertitels bijzitten.

Ik heb al van allerlei settings geprobeerd te veranderen in zowel Mplayer als Smplayer, maar dat helpt helaas niets. Ik heb VDPAU uitgezet, OpenGL geprobeerd, X11, etc. Maakte ook niets uit. Toen dacht ik dat het misschien aan de films zelf lag, iets met slechte encoding of zo. Maar als ik diezelfde films in VLC afspeel, doen ze het wel gewoon, geen enkel zwart scherm. Helaas is het voortaan afspelen via VLC ook geen optie. Ik heb een twinview setup, met mijn PC en mijn Panasonic TV. En als ik daarop VLC met een film afspeel, is er behoorlijke screen tearing, iets waar ik weer geen last van heb met Smplayer. Maar ja, als die weer moeilijk gaat lopen doen met het afspelen van films (de ene wel goed, en de andere dus helaas niet), dan schiet het ook niet echt op. Ik hoop dat misschien iemand hier een suggestie of oplossing heeft. Alvast bedankt. :)