Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Geluid door speakers en hoofdtelefoon  (gelezen 3167 keer)

Offline Bekos

  • Lid
  • Steunpunt: Nee
Geluid door speakers en hoofdtelefoon
« Gepost op: 2010/12/15, 22:07:44 »
Dag iedereen,

Ik heb onlangs Ubuntu 10.04 geïnstalleerd. In het algemeen werkt alles zeer goed maar er is wel 1 probleem: wanneer ik mijn hoofdtelefoon insteek, komt het geluid door de speakers en de hoofdtelefoon tegelijk. Ik heb al naar een oplossing gezocht op het web maar dit heeft niets opgelost. Ik ben echter vrij nieuw in het linux-wereldje waardoor ik natuurlijk ook een fout kan hebben gemaakt bij het uitvoeren van de aangegeven oplossingen. Daarom heb ik toch een topic geopend voor mijn probleem.

De oplossingen die ik al geprobeerd heb:
  • Gewoon kijken bij de standaard geluidsinstellingen: hier is mijn hoofdtelefoon niet te zien en dus kon ik hier ook niets aanpassen.
  • De geluidsinstellingen wijzigen door alsamixer op te starten via de terminal: ook hier zag ik geen melding van mijn hoofdtelefoon. Ik heb dan maar wat met de balkjes gespeeld maar ook dit bood dus geen oplossing.
  • Via synaptic linux-backports-modules-alsa-lucid-generic geïnstalleerd: dit maakte het probleem alleen maar erger. Ik kreeg toen namelijk helemaal niets meer te horen via de hoofdtelefoon.
  • http://ubuntuforums.org/showthread.php?t=1043568&page=14  (de eerste oplossing op de pagina): dit bood geen oplossing maar het was ook al iets moeilijker dan de vorige oplossingen. Ik sluit niet uit dat ik een fout heb gemaakt toen ik dit probeerde.
  • http://forum.ubuntu-nl.org/hardware-en-drivers/geluid-speelt-tegelijk-via-speakers-en-hoofdtelefoon/ (de oplossing van mrGee) : Ik heb een aantal zaken aan dit bestand toegevoegd maar ik weet niet of ik de juiste regels heb toegevoegd.

Ten slotte nog mijn systeem: Asus K52J

Ik hoop dat jullie me kunnen helpen.

Bij voorbaat dank,

Bekos
 

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Re: Geluid door speakers en hoofdtelefoon
« Reactie #1 Gepost op: 2010/12/15, 22:30:17 »
Welke geluidskaart/chip heb je daar inzitten? Open een terminal(onder Hulpmiddelen) en type daarin lspci  (de eerste letter is een kleine L) en geef een ENTER. Kan je je de uitkomst hier plaatsen?
In der Beschränkung zeigt sich der Meister.

Offline Bekos

  • Lid
  • Steunpunt: Nee
Re: Geluid door speakers en hoofdtelefoon
« Reactie #2 Gepost op: 2010/12/15, 22:50:14 »
Dit is de output:
00:00.0 Host bridge: Intel Corporation Core Processor DRAM Controller (rev 18)
00:01.0 PCI bridge: Intel Corporation Core Processor PCI Express x16 Root Port (rev 18)
00:02.0 VGA compatible controller: Intel Corporation Core Processor Integrated Graphics Controller (rev 18)
00:16.0 Communication controller: Intel Corporation 5 Series/3400 Series Chipset HECI Controller (rev 06)
00:1a.0 USB Controller: Intel Corporation 5 Series/3400 Series Chipset USB2 Enhanced Host Controller (rev 06)
00:1b.0 Audio device: Intel Corporation 5 Series/3400 Series Chipset High Definition Audio (rev 06)
00:1c.0 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 1 (rev 06)
00:1c.1 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 2 (rev 06)
00:1c.5 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 6 (rev 06)
00:1d.0 USB Controller: Intel Corporation 5 Series/3400 Series Chipset USB2 Enhanced Host Controller (rev 06)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev a6)
00:1f.0 ISA bridge: Intel Corporation Mobile 5 Series Chipset LPC Interface Controller (rev 06)
00:1f.2 SATA controller: Intel Corporation 5 Series/3400 Series Chipset 4 port SATA AHCI Controller (rev 06)
00:1f.6 Signal processing controller: Intel Corporation 5 Series/3400 Series Chipset Thermal Subsystem (rev 06)
01:00.0 VGA compatible controller: nVidia Corporation Device 0a70 (rev a2)
03:00.0 Network controller: Atheros Communications Inc. AR9285 Wireless Network Adapter (PCI-Express) (rev 01)
04:00.0 System peripheral: JMicron Technology Corp. SD/MMC Host Controller (rev 80)
04:00.2 SD Host controller: JMicron Technology Corp. Standard SD Host Controller (rev 80)
04:00.3 System peripheral: JMicron Technology Corp. MS Host Controller (rev 80)
04:00.4 System peripheral: JMicron Technology Corp. xD Host Controller (rev 80)
04:00.5 Ethernet controller: JMicron Technology Corp. JMC250 PCI Express Gigabit Ethernet Controller (rev 03)
ff:00.0 Host bridge: Intel Corporation Core Processor QuickPath Architecture Generic Non-core Registers (rev 05)
ff:00.1 Host bridge: Intel Corporation Core Processor QuickPath Architecture System Address Decoder (rev 05)
ff:02.0 Host bridge: Intel Corporation Core Processor QPI Link 0 (rev 05)
ff:02.1 Host bridge: Intel Corporation Core Processor QPI Physical 0 (rev 05)
ff:02.2 Host bridge: Intel Corporation Core Processor Reserved (rev 05)
ff:02.3 Host bridge: Intel Corporation Core Processor Reserved (rev 05)

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Re: Geluid door speakers en hoofdtelefoon
« Reactie #3 Gepost op: 2010/12/15, 23:18:37 »
Oke, open weer een terminal en type daarin sudo gedit /etc/modprobe.d/alsa-base.conf en geef een ENTER, hierna moet je het wachtwoord ingeven, hiervan zie je niets, geen sterretjes, bolletjes, o.i.d., gewoon blind typen en geef een ENTER. Nu opent alsa-base.conf en kan je dit bestand bewerken. Kijk of je regels ziet die beginnen met options, hiervoor zet je een #, daarmee schakel je ze uit. Zet onder die regels deze regel,
options snd-hda-intel model=auto  sla het bestand op en start de computer opnieuw op. Kan je de inhoud van het gewijzigde bestand hier plaatsen?
En werkt dit voor je?
In der Beschränkung zeigt sich der Meister.

Offline Bekos

  • Lid
  • Steunpunt: Nee
Re: Geluid door speakers en hoofdtelefoon
« Reactie #4 Gepost op: 2010/12/15, 23:30:16 »
Alvast bedankt voor de hulp!

Het aangepaste bestand is:

# autoloader aliases
install sound-slot-0 /sbin/modprobe snd-card-0
install sound-slot-1 /sbin/modprobe snd-card-1
install sound-slot-2 /sbin/modprobe snd-card-2
install sound-slot-3 /sbin/modprobe snd-card-3
install sound-slot-4 /sbin/modprobe snd-card-4
install sound-slot-5 /sbin/modprobe snd-card-5
install sound-slot-6 /sbin/modprobe snd-card-6
install sound-slot-7 /sbin/modprobe snd-card-7

# Cause optional modules to be loaded above generic modules
install snd /sbin/modprobe --ignore-install snd $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-ioctl32 ; /sbin/modprobe --quiet --use-blacklist snd-seq ; }
#
# Workaround at bug #499695 (reverted in Ubuntu see LP #319505)
install snd-pcm /sbin/modprobe --ignore-install snd-pcm $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-pcm-oss ; : ; }
install snd-mixer /sbin/modprobe --ignore-install snd-mixer $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-mixer-oss ; : ; }
install snd-seq /sbin/modprobe --ignore-install snd-seq $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq-midi ; /sbin/modprobe --quiet --use-blacklist snd-seq-oss ; : ; }
#
install snd-rawmidi /sbin/modprobe --ignore-install snd-rawmidi $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq-midi ; : ; }
# Cause optional modules to be loaded above sound card driver modules
install snd-emu10k1 /sbin/modprobe --ignore-install snd-emu10k1 $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-emu10k1-synth ; }
install snd-via82xx /sbin/modprobe --ignore-install snd-via82xx $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq ; }

# Load saa7134-alsa instead of saa7134 (which gets dragged in by it anyway)
install saa7134 /sbin/modprobe --ignore-install saa7134 $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist saa7134-alsa ; : ; }
# Prevent abnormal drivers from grabbing index 0
#options bt87x index=-2
#options cx88_alsa index=-2
#options saa7134-alsa index=-2
#options snd-atiixp-modem index=-2
#options snd-intel8x0m index=-2
#options snd-via82xx-modem index=-2
#options snd-usb-audio index=-2
#options snd-usb-us122l index=-2
#options snd-usb-usx2y index=-2
#options snd-usb-caiaq index=-2
# Ubuntu #62691, enable MPU for snd-cmipci
#options snd-cmipci mpu_port=0x330 fm_port=0x388
# Keep snd-pcsp from being loaded as first soundcard
#options snd-pcsp index=-2
options snd-hda-intel model=auto

Dit heeft mijn probleem echter niet opgelost.


Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Re: Geluid door speakers en hoofdtelefoon
« Reactie #5 Gepost op: 2010/12/15, 23:50:26 »
We zijn nog niet helemaal klaar, open weer een terminal en type daar in sudo apt-get install gnome-alsamixer  Je kan natuurlijk de mixer via Synaptic of het Ubuntu Software Centrum. Na de installatie terug te vinden onder Audio en Video. Open de gnome-alsamixer en kijk of op de tab de juiste geluidskaart wordt aangegeven. Kijk ook of onder de Headphone en andere schakelaars staan, staat er een vinkje voor Headphones?
Staat de schakelaar erbij? Zo niet klik op Bewerken>Eigenschappen geluidskaart> En vink Headphones aan. Lukt het nu en staat je geluidskaart op de tab?
In der Beschränkung zeigt sich der Meister.

Offline Bekos

  • Lid
  • Steunpunt: Nee
Re: Geluid door speakers en hoofdtelefoon
« Reactie #6 Gepost op: 2010/12/16, 00:05:39 »
Ik heb een screenshot gemaakt van het resultaat van de alsamixer. Ik zie mijn headset er precies niet tussen staan.

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Re: Geluid door speakers en hoofdtelefoon
« Reactie #7 Gepost op: 2010/12/16, 00:39:33 »
Verander de regel die je toegevoegd hebt in options snd-hda-intel model=3stack-dig
Nog een vraagje, heb je de 32 bit of de 64 bit Ubuntu geïnstalleerd?
« Laatst bewerkt op: 2010/12/16, 00:41:05 door Gijsbert »
In der Beschränkung zeigt sich der Meister.

Offline Bekos

  • Lid
  • Steunpunt: Nee
Re: Geluid door speakers en hoofdtelefoon
« Reactie #8 Gepost op: 2010/12/16, 00:45:22 »
Ook bij deze nieuwe regel blijft het probleem behouden.

Ik heb de 32 bit versie geïnstalleerd.

Offline Cumulus007

  • Lid
  • Steunpunt: Nee
Re: Geluid door speakers en hoofdtelefoon
« Reactie #9 Gepost op: 2010/12/16, 23:29:30 »
Open Geluidsvoorkeuren. Ga naar tabblad Uitvoer. Selecteer als Connector de "Analog Headphones". Druk nu op Ctrl+Alt+T. Typ alsamixer, druk op enter. navigeer met de pijltoetsen naar het item "Front". Druk op pijltoets omhoog totdat dit 100% is. Druk op q. Nu moet je hoofdtelefoon goed werken.

Offline Bekos

  • Lid
  • Steunpunt: Nee
Re: Geluid door speakers en hoofdtelefoon
« Reactie #10 Gepost op: 2010/12/17, 00:20:53 »
Alvast bedankt voor de hulp.

Ik kan "Analog headphones" echter niet als output selecteren (zie bijlage).

Offline Cumulus007

  • Lid
  • Steunpunt: Nee
Re: Geluid door speakers en hoofdtelefoon
« Reactie #11 Gepost op: 2010/12/17, 18:30:43 »

Offline Bekos

  • Lid
  • Steunpunt: Nee
Re: Geluid door speakers en hoofdtelefoon
« Reactie #12 Gepost op: 2010/12/17, 21:30:40 »
Dat heeft mijn probleem opgelost!
Hartelijk bedankt!

Bekos

Offline Cumulus007

  • Lid
  • Steunpunt: Nee
Re: Geluid door speakers en hoofdtelefoon
« Reactie #13 Gepost op: 2010/12/17, 23:40:14 »
Dat heeft mijn probleem opgelost!
Hartelijk bedankt!

Bekos
Mooi om te horen, graag gedaan!