Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Booten met ACPI=OFF  (gelezen 2108 keer)

Offline Jelle

  • Lid
  • Steunpunt: Nee
Booten met ACPI=OFF
« Gepost op: 2007/01/04, 21:09:08 »
Hallo,

Ik wilde m'n pa de live cd 'ns laten zien z'n acer aspire 1690 met ATI driver en breedbeeld, maar dat eindigt met een zwart scherm.

Even gezocht op Linux en Acer Aspire en wat blijkt:

IMPORTANT: When first booting you have to use "acpi=off" as kernel command line i.e. in your lilo.conf or GRUB menu. Else the screen stays black.

Mijn vraag:

Hoe moet dat?

Online Ron

  • Forumteam
    • r0n
    • Dwarsligger
  • Steunpunt: Ja
Booten met ACPI=OFF
« Reactie #1 Gepost op: 2007/01/04, 21:26:06 »
Bij het opstarten, kan je opties meegeven, daar moet je het intikkenacpi=offdan gewoon enter geven om te booten.

Succes,
Ron
OpenStandaard evangelist, OpenSource promotor, OpenData liefhebber.
Xubuntu gebruiker en voorstander (XFCE).
In Nederland bekend als een dwarsligger.

Offline Jelle

  • Lid
  • Steunpunt: Nee
Booten met ACPI=OFF
« Reactie #2 Gepost op: 2007/01/05, 09:33:44 »
Ron, je bedoelt in dat scherm waarin 1 lange regel staat en waar ik quiet al uit had verwijderd?
Kan ik daar gewoon ONDER typen, of moet dat ACHTER de regel?

(ik zou het ook gewoon kunnen proberen, maar ik ben nu niet meer in de buurt van de betreffende laptop. Ik bereid me daarom liever even goed voor.)

Offline Tukcedo

  • Lid
    • http://www.tukcedo.nl
  • Steunpunt: Nee
Booten met ACPI=OFF
« Reactie #3 Gepost op: 2007/01/05, 16:37:00 »
Hoi Jelle, ben ik weer. Je kunt dit ook in het bestand grub.conf opnemen. Nou wil dat bestand nog wel es onder verschillende namen voorkomen, dus je kunt het best doen:

sudo locate grub.conf

Zou iets van /boot/grub/grub.conf moeten zijn, maar het bestand kan ook menu.lst heten.

Zoek even op de string "acpi=off" in de volgende pagina voor een voorbeeldje:

http://www.physics.wustl.edu/~alford/thinkpad/T23_FC2.html
Tukcedo Services - Unix en Linux Consultants
http://www.tukcedo.nl

Offline Samuel Rave

  • Lid
    • http://www.familie-rave.de/
  • Steunpunt: Nee
Booten met ACPI=OFF
« Reactie #4 Gepost op: 2007/01/05, 16:52:13 »
Citaat van: tukcedo
Hoi Jelle, ben ik weer. Je kunt dit ook in het bestand grub.conf opnemen. Nou wil dat bestand nog wel es onder verschillende namen voorkomen, dus je kunt het best doen:

sudo locate grub.conf

Zou iets van /boot/grub/grub.conf moeten zijn, maar het bestand kan ook menu.lst heten.

Zoek even op de string "acpi=off" in de volgende pagina voor een voorbeeldje:

http://www.physics.wustl.edu/~alford/thinkpad/T23_FC2.html
Beste tukcedo, lijkt me dan natuurlijk wel handig wanneer hij zowiezo helemaal kan opstarten...

De regel waar hij en ron het over hebben wordt meegegeven in het bootmenu van de CD-Rom

Online Ron

  • Forumteam
    • r0n
    • Dwarsligger
  • Steunpunt: Ja
Booten met ACPI=OFF
« Reactie #5 Gepost op: 2007/01/05, 17:02:21 »
Sorry dat ik niet duidelijker ben, maar ik heb alleen maar alternate cd's bij de hand ......

Ron
OpenStandaard evangelist, OpenSource promotor, OpenData liefhebber.
Xubuntu gebruiker en voorstander (XFCE).
In Nederland bekend als een dwarsligger.

Offline Tukcedo

  • Lid
    • http://www.tukcedo.nl
  • Steunpunt: Nee
Booten met ACPI=OFF
« Reactie #6 Gepost op: 2007/01/07, 11:38:57 »
En ik dacht dat-ie al van de HD aan het booten was ... ander heeft CORVUS_CORAX uiteraard helemaal gelijk.
Tukcedo Services - Unix en Linux Consultants
http://www.tukcedo.nl

Offline Jelle

  • Lid
  • Steunpunt: Nee
Booten met ACPI=OFF
« Reactie #7 Gepost op: 2007/01/12, 10:36:26 »
Ik heb de live cd nu een aantal keren gedraaid met acpi=off met en zonder spaties en altijd weer een zwart scherm. Uit de Post van Azalin (live cd Edgy zwart scherm) maak ik op dat de live cd gewoon niet KAN werken, omdat X niet met de ATI kaart overweg kan.

De enige weg lijkt dan te zijn om vanaf de alternate cd gewoon te installeren en dan via de terminal de juiste ATI driver installeren.

Ik hoop wel dat dit probleem nog wordt opgelost, want die live cd is nu juist een prachtige manier om Ubuntu/Linux te promoten. Installeren en dan in een terminal omgeving allerlei settings aanpassen zal bij mijn pa (en vele andere "onbekeerden" ) alleen maar de indruk versterken dat je wel haast een computerprogrammeur moet zijn of worden om over te stappen op Linux. Dat was nu net de indruk die ik had willen wegnemen.

Offline Samuel Rave

  • Lid
    • http://www.familie-rave.de/
  • Steunpunt: Nee
Booten met ACPI=OFF
« Reactie #8 Gepost op: 2007/01/16, 23:57:46 »
Waneer krijg je het zwarte scherm na het usplash-boot-scherm of ervoor?
(zwart scherm met de letters ubuntu en logo daaronder een oranje laadbalk = in edgy, in dapper weer een beetje anders namelijk met tekst van wat het aan het inladen is) Dus wanneer je dat scherm, beschreven tussen haakjes, wel ziet, kun je alsnog de dektop-CD wel aan de praat krijgen.

Namelijk wanneer het faalt om X te starten, krijg je normaal een commandprompt en daarin kun je gewoon draaiende vanaf CD invoeren:
sudo dpkg-reconfigure xserver-xorg.

Offline Jelle

  • Lid
  • Steunpunt: Nee
Booten met ACPI=OFF
« Reactie #9 Gepost op: 2007/01/18, 08:22:39 »
Wanneer m'n pa d'r nog trek in heeft kunnen we dat allicht eens proberen. Voor zover ik me herinner kregen we meestal een helemaal zwart scherm, dus zonder prompt, maar ik kan er hoe dan ook nog wel een keer een poging tegenaan gooien. Lukt het niet, dan brand ik de alternate cd van Dapper en dan installeren we die nog wel eens.

Het usplash scherm verschijnt overigens wel gewoon, maar vlak voordat het balkje helemaal vol is komt er een rare streep dwars over het scherm, dan gaat 'ie op zwart en laadt de cd nog een hele tijd door. Vervolgens hoor je de begintune van Ubuntu, dan laadt de cd weer een hele tijd door en dan wordt het stil........

Offline Dave

  • Lid
  • Steunpunt: Nee
Booten met ACPI=OFF
« Reactie #10 Gepost op: 2007/01/18, 09:42:03 »
dat ubuntu dan zelf niet naar een standaard driver grijpt bij die zeer veel voorkomende kaarten is me een raadsel.

Offline Jelle

  • Lid
  • Steunpunt: Nee
Booten met ACPI=OFF
« Reactie #11 Gepost op: 2007/01/19, 11:20:21 »
Het wordt steeds erger, de alternate cd (Dapper) wil ook al niet installeren. Ik heb vooraf de integriteit van de cd getest en die was OK, maar tijdens het installeren krijg ik toch ineens de melding dat een of meer .deb-jes niet kunnen worden geïnstalleerd. Is het toeval dat deze debjes beginnen met een X ?

Gewoon doorzetten leidt tot een debootstrap melding of error (ik heb de betreffende laptop niet bij de hand, want hij is niet van mij). Uiteindelijk is er dus geen afgeronde installatie.

Ik zal de cd ook 'ns op m'n eigen pc installeren. Kijken of dat ook fout gaat. Ik hoop het wel, want dan ligt het gelukkig aan de cd. Wanneer het niet aan de cd ligt, dan vrees ik dat deze computer (en de gebruiker) gewoon bij het vertrouwde XP moeten blijven.

Voorlopig heb ik maar niet meer zo'n grote mond over hoe geweldig Ubuntu wel niet is. Na 3 middagen prutsen heeft m'n pa er in ieder geval geen hoge pet meer van op, en dat kan ik hem geeneens kwalijk nemen.

edit:

HET IS GELUKT!!!

En het was nog eenvoudig ook. De alternate cd was inderdaad stuk. Een nieuwe iso opgehaald (Edgy) en gebakt met Gnomebaker. Ubuntu geïnstalleerd. Bij opstarten werkte X uiteraard niet, vanwege de ATI kaart. Een externe monitor werkte overigens wel. Het probleem zit 'em dus blijkbaar in de combinatie van de ATI kaart en het laptop beeldscherm.

Vervolgens de monitor er weer afgehaald, opgestart in recovery mode. dpkg-reconfigure xserver-xorg gedaan en daar de driver op VESA gezet.

Dat was alles. Starten met acpi=off is niet eens nodig. Blijkbaar wordt dat al getackeld door de hardwareherkinning van Ubuntu (volgens de linux-laptops site was het met debian op deze laptop namelijk wel nodig)

Ik vermoed overigens (nog niet getest) dat standby e.d. pas zal werken na het installeren van een nieuwe DSTD. Op mijn eigen laptop (Medion) werkt het nl. ook niet en daar staat in het opstartlog na ACPI  iets van "DSTD not found".

Voorlopig ben ik weer blij met Ubuntu. Bijna helemaal blij. Echt  blij wordt ik pas als Ubuntu prijsgeeft waarom het steeds vastloopt (op mijn PC, hopelijk niet op deze, want die is van m'n pa en als die met vastlopers gaat geconfronteerd worden, dan is het uit met Ubuntu en terug naar XP) Nieuwsgierig waar ik het over heb? Zie mijn topic VASTLOPERS IN NAUTILUS.