Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Bestanden krijgen verkeerde rechten bij het kopiëren van bureaublad naar server  (gelezen 1852 keer)

Offline Vermeulenova

  • Lid
  • Steunpunt: Nee
Ik heb op onze server een aantal mappen en gebruikers aangemaakt, 2 gebruikers heb ik maar even als voorbeeld genomen.
Gebruiker Management mag eigenlijk in alle mappen komen (management, studio, magazijn, plotter, NewBase-CG)
Gebruiker Studio mag dat ook, met uitzondering van de map management (studio, magazijn, plotter, NewBase-CG)
Gebruiker “Management”
/werkmap/
chgrp management Management
chown management Management
chmod -R 770 Management

[Lokale Gebruikers]
Primaire groep: management
Secundaire groep: studio, magazijn, plotter, NewBase-CG

Gebruiker “Studio”
/werkmap/
chgrp studio 1-Orders
chown studio 1-Orders
chmod -R 770 1-Orders

[Lokale Gebruikers]
Primaire groep: studio
Secundaire groep: magazijn, plotter, NewBase-CG

Het probleem is als volgt:
Als ik ben ingelogd als gebruiker management, en gooi een bestand vanaf mijn bureaublad en een map in de map van gebruiker studio, dan kan studio niets met het bestand doen.
Het bestand is dan chgrp management, chown management, chmod 660
Terwijl het chgrp studio, chown management, chmod 770 had moeten zijn.
Maar de map daarop tegen is wel chgrp studio, chown management, chmod 770

Ik begrijp niet helemaal waarom dit zo is, moet ik op de werkstations ook die gebruikers aan maken?

Offline Buzzin

  • Lid
  • Steunpunt: Nee
Nee, dat heeft niet zoveel nut.
Je bent op die server ingelogt als Management, dat, en niets anders, bepaald welke user er aan een nieuw bestand word gegeven.

Je kunt de map zelf wel het GUID bit geven, hierdoor word bij nieuwe bestanden automatisch de groep gezet.
Een chmod 2770 zou dan moeten doen. (en als ik me niet vergis kan het ook met chmod g+s <map naam> )
Waarom de rechten niet goed staan....dat ligt meestal aan het masker van die map....maar hoe dat ook alweer werkt weet ik niet meer uit m'n hoofd.
Football: A battle between two teams of mindless thugs over scraps of coloured cloth. Usually accompanied by the spectacle of 22 overpaid primadonnas kicking a ball on a field.
DebianDevuan, KDE & OperaVivaldi addict, RedHat Engineer

Offline wowo

  • Lid
  • Steunpunt: Nee
Sorry voor het hacken van dit topic, maar ik ben ook erg benieuwd wat hiervan de oorzaak is.

Ik was er al op aan het wachten totdat dit probleem vanzelf voorbij zou komen, want ik heb er zelf als ik op een bepaalde pc werk ook last van dat de rechten 644 opeens veranderen naar 600.
Doordat dat gebeurt worden die bestanden niet meer herkent bij het scannen en moet ik aldus de rechten weer eerst handmatig aanpassen.

Ik werk met een server en heeft dat soms te maken met bepaalde zaken die je in fstab moet regelen?

Nb 1) ik werk op de desbetreffende pc's met dezelfde eigenaar (1000). nb 2) ik werk met nfs.
Desktop Ubuntu 16.04 LTS

Offline Buzzin

  • Lid
  • Steunpunt: Nee
Het spontaan veranderen van filerechten is iets anders als het verkeerd aanmaken van filerechten.
Een probleem tegelijk graag :) (ze zijn al moeilijk genoeg zonder elkaar, maar beide moeten opgelost worden natuurlijk)

Voor het spontaan veranderen: welke taken worden er door cron allemaal uitgevoerd, en waar staat de map op het fs?
Wat voor een server is het? Is de map waar je in schrijft als prive gemarkeerd, want dan zou het logisch zijn dat hij de bestanden naar 600 zet.
Football: A battle between two teams of mindless thugs over scraps of coloured cloth. Usually accompanied by the spectacle of 22 overpaid primadonnas kicking a ball on a field.
DebianDevuan, KDE & OperaVivaldi addict, RedHat Engineer

Offline wowo

  • Lid
  • Steunpunt: Nee
Het spontaan veranderen van filerechten is iets anders als het verkeerd aanmaken van filerechten.
Een probleem tegelijk graag :) (ze zijn al moeilijk genoeg zonder elkaar, maar beide moeten opgelost worden natuurlijk)

Voor het spontaan veranderen: welke taken worden er door cron allemaal uitgevoerd, en waar staat de map op het fs?
Wat voor een server is het? Is de map waar je in schrijft als prive gemarkeerd, want dan zou het logisch zijn dat hij de bestanden naar 600 zet.
Alvast bedankt voor het antwoord, maar voor de overzichtelijkheid ga ik inderdaad binnenkort een apart topic starten. Ik kan er echter wel mee leven en zal ook eerst zelf wat onderzoek doen. Nogmaals excuses voor het verstoren van dit topic.
Desktop Ubuntu 16.04 LTS

Offline Vermeulenova

  • Lid
  • Steunpunt: Nee
chmod -R 6770 [naam van de map] is volgens mij de truc, ik heb een aantal mappen 6770 gegeven, en morgen gaan we het meemaken ;)
Buzzin, bedankt voor je uitleg.

http://www.linuxdocs.nl/wiki/index.php/Chmod

Offline jan11000

  • Lid
  • Steunpunt: Nee
Indien je samba gebruikt, dan zie de smb.config file.
Onderaan staat je gedeelde map.
Iets daarboven staat een voorbeeld van directory en files, en hoe je de eigennaar wijzigd

# File creation mask is set to 0700 for security reasons. If you want to
# create files with group=rw permissions, set next parameter to 0775.
;   create mask = 0700

# Directory creation mask is set to 0700 for security reasons. If you want to
# create dirs. with group=rw permissions, set next parameter to 0775.
;   directory mask = 0700

Bovenstaande moet je dus bij je samba share toevoegen.
create mask = 0700
directory mask = 0700
Of natuurlijk 0775

Nu worden nieuwe files bruikbaar voor iedereen.

Offline rja

  • Lid
  • Steunpunt: Nee
Als het niet via samba gaat.

Zou je naar umask kunnen kijken.

http://www.cyberciti.biz/tips/understanding-linux-unix-umask-value-usage.html


Offline Vermeulenova

  • Lid
  • Steunpunt: Nee
Onze server draait met Netatalk, we hebben geen Windows rommel in ons netwerk :evil:
Wij hebben lang met Samba gedraaid, maar Netatalk draait sneller en is simpeler.
Ook hebben we Avahi daemon  draaien, zodat Ubuntu ook aan bonjour doet, en de Apple's denken dat ze aan een Xserve hangen.
Nu wil ik Appletalk ook nog aan de gang krijgen, zodat ik oudere apparatuur kan gebruiken, Apple heeft namelijk in Snow Leopard Appletalk er uit gesloopt.

Offline jan11000

  • Lid
  • Steunpunt: Nee
Misschien staat hier iets in, gaat over bsd, maar misschien de /etc/netatalk/AppleVolumes.system en /etc/netatalk/rc.atalk.
http://onlamp.com/pub/a/bsd/2000/11/14/OpenBSD.html

http://www.kremalicious.com/2008/06/ubuntu-as-mac-file-server-and-time-machine-volume/

Offline Vermeulenova

  • Lid
  • Steunpunt: Nee
Bedankt voor de links, deze ga ik even rustig door nemen.
De laatste link kende ik al, hierdoor ben ik op het idee gekomen om de server als Xserve te laten gedragen, alleen dit is een redelijke tijd geleden en ik kon deze site niet meer vinden.
Ik heb er gelijk een bladwijzer van gemaakt, goeie HowTo.