Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: FlightGear,  (gelezen 2954 keer)

Albe

  • Gast
FlightGear,
« Gepost op: 2007/01/02, 22:07:50 »
Goede avond en een gelukkig Nieuwjaar!

Ik heb FlightGear binnengehaald, samen met wat nodig is om deze normaal te doen werken doch het scherm met Flightgear gaat even open, opladen van vliegtuigen en afbeeldingen enz doch dan sluit het venster en krijg ik deze mededeling op mijn terminalvenster ;

alain@alain-penty:~$ fgfs
freeglut (fgfs): Unable to create direct context rendering for window 'FlightGear'
This may hurt performance.
opening file: /usr/share/games/FlightGear/Navaids/carrier_nav.dat
/usr/share/games/FlightGear/Navaids/TACAN_freq.dat
fgfs: indirect_vertex_array.c:1359: __indirect_glTexCoordPointer: Assertion `a != ((void *)0)' failed.
Geannuleerd
alain@alain-penty:~$

Een idée? Kan het iets te maken hebben met het feit dat ik de NVidia driver niet gebruik? (ik durf die niet installeren, heb vroeger nog probleem mee gehad, na herstarten geen beeld meer, iets met x-config meen ik mij te herinneren en ik had dat daar helemaal verknoeid...

Mijn systeem; Ubuntu Dapper Gnome 6.06 met 512 MB geheugen en plaats zat op de HD.

Thanks!

Albe

  • Gast
FlightGear,
« Reactie #1 Gepost op: 2007/01/02, 22:11:18 »
sorry, verkeerde forum
Herposten in software en configuratie

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
FlightGear,
« Reactie #2 Gepost op: 2007/01/02, 22:12:14 »
Toch maar ff die nvidia driver weer installeren! Gewoon met Synaptic. De prestaties van je videokaart worden een stuk beter.

na installatie via Synaptic:
- in terminal: sudo dpkg-reconfigure xserver-xorg

In de vragenriedel als enige eigen keuze, kiezen voor de driver "nvidia" i.p.v. de voorgeselecteerde "nv". verder geen enkele eigen keuze maken, dus op het einde gewoon meefietsen met advanced en de voorgestelde advanced-waarden. Dat geeft de beste resultaten, gek genoeg.

- Daarna in terminal: sudo reboot

Groet, Pjotr.

Albe

  • Gast
FlightGear,
« Reactie #3 Gepost op: 2007/01/02, 22:17:53 »
Citaat van: pjotr123
Toch maar ff die nvidia driver weer installeren!

Groet, Pjotr.
Waaaaw, dat was inderdaad supersnel :-)

OK ik ga het toch proberen en laat wel iets weten, morgenavond waarschijnlijk.

Bedankt!

Albe

  • Gast
FlightGear,
« Reactie #4 Gepost op: 2007/01/02, 22:53:51 »
Citaat van: pjotr123
na installatie via Synaptic:
- in terminal: sudo dpkg-reconfigure xserver-xorg

In de vragenriedel als enige eigen keuze, kiezen voor de driver "nvidia" i.p.v. de voorgeselecteerde "nv". verder geen enkele eigen keuze maken, dus op het einde gewoon meefietsen met advanced en de voorgestelde advanced-waarden. Dat geeft de beste resultaten, gek genoeg.

- Daarna in terminal: sudo reboot

Groet, Pjotr.
Had ik het niet gedacht...het is weer van hetzelfde, donker scherm en het booten gaat zelfs niet tot mijn login of pasw.
In herstelmode ben ik terug  die reconfigure gaan doen maar het blijft hetzelfde, x-server wordt zelfs uitgeschakeld (melding)
Hier ben ik dus verloren en vorige keer ben ik Ubuntu gaan herinstalleren.
Ik hoop dat dit nu niet meer nodig is?

Nu ga ik slapen, morgen zware dag ;-)

Slaapwel en tot morgenavond

(Gepost in Win :-(  )

Offline eendje

  • Lid
  • Steunpunt: Nee
FlightGear,
« Reactie #5 Gepost op: 2007/01/02, 23:14:18 »
Bij installeren van nvidia driver onderstaande howto gebruiken...

https://help.ubuntu.com/community/BinaryDriverHowto/Nvidia

Misschien ben je de restricted spullen vergeten...
Een dag niets geleerd is een dag niet geleefd!
Ik blog dus ik besta!
__________________________________________________________
Een vraag? Heb je al eens gekeken op: http://wiki.ubuntu-nl.org/FAQ?

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
FlightGear,
« Reactie #6 Gepost op: 2007/01/02, 23:33:13 »
Citaat van: Alb
Had ik het niet gedacht...het is weer van hetzelfde, donker scherm en het booten gaat zelfs niet tot mijn login of pasw.
In herstelmode ben ik terug  die reconfigure gaan doen maar het blijft hetzelfde, x-server wordt zelfs uitgeschakeld (melding)
Hier ben ik dus verloren en vorige keer ben ik Ubuntu gaan herinstalleren.
Ik hoop dat dit nu niet meer nodig is?

Nu ga ik slapen, morgen zware dag ;-)

Slaapwel en tot morgenavond

(Gepost in Win :-(  )
Jammer. Je kunt natuurlijk altijd weer terugvallen op de oude driver "nv", in de vragenriedel van sudo dpkg-reconfigure xserver-xorg
Dan ben je weer terug in je oude situatie.

Maar ik hoop toch, dat het gaat werken met "nvidia".

Groet, Pjotr.

Albe

  • Gast
FlightGear,
« Reactie #7 Gepost op: 2007/01/03, 21:43:06 »
Citaat van: eendje
Bij installeren van nvidia driver onderstaande howto gebruiken...

https://help.ubuntu.com/community/BinaryDriverHowto/Nvidia

Misschien ben je de restricted spullen vergeten...
Nee, ik heb de restricted spullen, anders had ik die nvidia niet kunnen installeren :-)

Ondanks die help howto krijg ik het niet meer in orde. Zie mijn antwoord aan Pjotr, dadelijk.

Albe

  • Gast
FlightGear,
« Reactie #8 Gepost op: 2007/01/03, 22:28:40 »
Het gaat gewoon niet, gewoon nog enkele keren die config herhaald, met nv en met nvidia, geen resultaat, donker scherm vlak voor het moment waar ik mijn login en pasw moet invoeren.

Het is de tweede maal dat ik dit voorheb in een maand of zes tijd, vorige keer was het formatteren... nu?
Heel de how to voor nvidia gevolgd.

Offline eendje

  • Lid
  • Steunpunt: Nee
FlightGear,
« Reactie #9 Gepost op: 2007/01/03, 22:39:51 »
Maar het heeft dus wel gewerkt?

Probeer, om te kijen of het überhaupt werk, i.p.v. van "nv" nog een keer "vesa".
Een dag niets geleerd is een dag niet geleefd!
Ik blog dus ik besta!
__________________________________________________________
Een vraag? Heb je al eens gekeken op: http://wiki.ubuntu-nl.org/FAQ?

Albe

  • Gast
FlightGear,
« Reactie #10 Gepost op: 2007/01/03, 22:41:18 »
Citaat van: eendje
Maar het heeft dus wel gewerkt?

Probeer, om te kijen of het überhaupt werk, i.p.v. van "nv" nog een keer "vesa".
ga ik direct rebooten in nunux en proberen, tot zo ;-)

Albe

  • Gast
FlightGear,
« Reactie #11 Gepost op: 2007/01/03, 22:49:50 »
Citaat van: eendje
Maar het heeft dus wel gewerkt?

Probeer, om te kijen of het überhaupt werk, i.p.v. van "nv" nog een keer "vesa".
Voil

Offline eendje

  • Lid
  • Steunpunt: Nee
FlightGear,
« Reactie #12 Gepost op: 2007/01/03, 23:05:31 »
Ik vraag me af of je wel een nvidia kaart hebt. Of er is iets goed fout met de nv driver bij jouw...  Plak de inhoud van onderstaand commando een sop dit forum (uitvoeren in terminal venster):

lspci
Een dag niets geleerd is een dag niet geleefd!
Ik blog dus ik besta!
__________________________________________________________
Een vraag? Heb je al eens gekeken op: http://wiki.ubuntu-nl.org/FAQ?

Albe

  • Gast
FlightGear,
« Reactie #13 Gepost op: 2007/01/03, 23:14:52 »
Citaat van: eendje
Ik vraag me af of je wel een nvidia kaart hebt. Of er is iets goed fout met de nv driver bij jouw...  Plak de inhoud van onderstaand commando een sop dit forum (uitvoeren in terminal venster):

lspci
Het is in orde!

Omdat ik er net aan uit kon dat het met vesa ging ben ik, nu vanuit een terminal venster, terug gaan configureren en je gelooft het misschien niet, de laatste keer had ik Vesa ingevoerd en nu bij de automatische keuze stond die vanzelf op "nv"! Ik ben dus verder gegaan zonder iets te veranderen, terug opgestart en alles duidelijk en nvidia in gebruik :-)

Het is dus in orde en ik heb je procedure opgeschreven voor later indien nodig.

Van harte bedankt beide voor de moeite :-)

Hier het gevraagde :

alain@alain-penty:~$ lspci
0000:00:00.0 Host bridge: Intel Corporation 82845 845 (Brookdale) Chipset Host Bridge (rev 04)
0000:00:01.0 PCI bridge: Intel Corporation 82845 845 (Brookdale) Chipset AGP Bridge (rev 04)
0000:00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev 05)
0000:00:1f.0 ISA bridge: Intel Corporation 82801BA ISA Bridge (LPC) (rev 05)
0000:00:1f.1 IDE interface: Intel Corporation 82801BA IDE U100 (rev 05)
0000:00:1f.2 USB Controller: Intel Corporation 82801BA/BAM USB (Hub #1) (rev 05)0000:00:1f.3 SMBus: Intel Corporation 82801BA/BAM SMBus (rev 05)
0000:00:1f.4 USB Controller: Intel Corporation 82801BA/BAM USB (Hub #2) (rev 05)0000:01:00.0 VGA compatible controller: nVidia Corporation NV17 [GeForce4 MX 460] (rev a3)
0000:02:02.0 FireWire (IEEE 1394): VIA Technologies, Inc. IEEE 1394 Host Controller (rev 46)
0000:02:03.0 Communication controller: Ambient Technologies Inc HaM controllerless modem (rev 02)
0000:02:06.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)
0000:02:07.0 Multimedia audio controller: C-Media Electronics Inc CM8738 (rev 10)
alain@alain-penty:~$

Het is duidekijk een nvidia kaart MX460

Albe

  • Gast
FlightGear,
« Reactie #14 Gepost op: 2007/01/03, 23:44:59 »
Als ik nu FlightGear opstart krijg ik dit :

alain@alain-penty:~$ fgfs
freeglut (fgfs): OpenGL GLX extension not supported by display ':0.0'
alain@alain-penty:~$

Toch iets te maken met dat ik "nv" heb ingesteld?
Met nvidia nog eens geprobeerd maar die werkt dus niet.

Offline eendje

  • Lid
  • Steunpunt: Nee
FlightGear,
« Reactie #15 Gepost op: 2007/01/03, 23:50:56 »
0000:01:00.0 VGA compatible controller: nVidia Corporation NV17 [GeForce4 MX 460] (rev a3)

Aha, wel een echte Nvidia grafische kaart :) Met de nv module heb je echter nog steeds geen hardware versnelling, dus als nog durft om het opnieuw te installeren dan ehh... :D

Gek... jouw kaart zou gewoon moeten met de nvidia driver... (ik heb even gecheckt of de legacy driver nodig hebt, maar jouw kaart wordt ondersteund door de driver die je hebt geïnstalleerd. Kun je even het volgende controleren... Type in  het terminal vernster het volgende commando in:

uname -r

vergelijk die versie met versie van de restricted modules die je hebt gïnstalleerd. DIe versie moet exact het zelfde zijn.

als ik het commando uitvoer krijg ik:

2.6.15-27-k7

ik heb via Synaptic de modules:

linux-restricted-modules-2.6.15-27-k7
linux-restricted-modules-k7

geïnstalleerd.

ALs die versies met elkaar kloppen zou het in theorie allemaal moeten werken...
Een dag niets geleerd is een dag niet geleefd!
Ik blog dus ik besta!
__________________________________________________________
Een vraag? Heb je al eens gekeken op: http://wiki.ubuntu-nl.org/FAQ?

Albe

  • Gast
FlightGear,
« Reactie #16 Gepost op: 2007/01/04, 10:28:53 »
Citaat van: eendje
0000:01:00.0 VGA compatible controller: nVidia Corporation NV17 [GeForce4 MX 460] (rev a3)



2.6.15-27-k7

ik heb via Synaptic de modules:

linux-restricted-modules-2.6.15-27-k7
linux-restricted-modules-k7

geïnstalleerd.

ALs die versies met elkaar kloppen zou het in theorie allemaal moeten werken...
Hier : alain@alain-penty:~$ uname -r
2.6.15-27-386
alain@alain-penty:~$

Jij hebt een AMD waarschijnlijk ?

Albe

  • Gast
FlightGear,
« Reactie #17 Gepost op: 2007/01/04, 10:41:15 »
Non-free Linux 2.6.15 modules on 386
This package provides restricted modules for Linux version 2.6.15 on
386.
Currently the following modules are included:
 - madwifi (Atheros)
Het is dus wel de goede die er steekt, dacht ik :-)

- fglrx (ATI)
 - nvidia
 - fcdsl, fcdsl2, fcdslsl, fcdslslusb, fcdslusb, fcdslusb2, fcdslusba,
   fcpci, fcpcmcia, fcpcmcia_cs, fcusb, fxusb (AVM ISDN)
 - ltmodem (Winmodem)

These modules are "restricted" because they are not available under a
completely Free licence.

Albe

  • Gast
FlightGear,
« Reactie #18 Gepost op: 2007/01/04, 11:05:09 »
Voil

Offline eendje

  • Lid
  • Steunpunt: Nee
FlightGear,
« Reactie #19 Gepost op: 2007/01/04, 20:43:57 »
Mooi dat het werkt!!! Wel apart dat  inde lijst van Nvidia staat dat je de gewone driver kunt gebruiken, maar dat niet werkt. Nou, in ieder geval weer een treden klant, dat is het belangrijkste :)
Een dag niets geleerd is een dag niet geleefd!
Ik blog dus ik besta!
__________________________________________________________
Een vraag? Heb je al eens gekeken op: http://wiki.ubuntu-nl.org/FAQ?

Albe

  • Gast
FlightGear,
« Reactie #20 Gepost op: 2007/01/04, 21:01:56 »
Citaat van: eendje
Mooi dat het werkt!!! Wel apart dat  inde lijst van Nvidia staat dat je de gewone driver kunt gebruiken, maar dat niet werkt. Nou, in ieder geval weer een treden klant, dat is het belangrijkste :)
Vooral, weeral iets bijgeleerd, hoofdzakelijk dankzij jullie toffe hulp :-)
Nog bedankt!
Vroeger ging ik formatteren maar dat stadion ben ik blijkbaar voorbij ;-)