Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Nvidia-current zorgt dat het inloggen op zwart gaat  (gelezen 1279 keer)

Offline jurgenh

  • Lid
  • Steunpunt: Nee
Nvidia-current zorgt dat het inloggen op zwart gaat
« Gepost op: 2010/11/10, 19:22:11 »
Hallo.

Ik ben nu alweer een tijd aan het knoeien met mijn nvidia driver.
Onder Lucid werkte het prima maar nu draai ik met maverick .

Zonder de driver werkt alles goed alleen geen mooie 3d effecten.
Zodra Nvidia geintalleerd is start Kubuntu gewoon op totdat ik bij het inlogscherm kom.
Daar stopt het verhaal.... gewoon een commandline inlogscherm.
Ik kan dan wel handmatig inloggen en als ik lang wacht 3 á 4 minuten logt hij ook vanzelf in.

Even wat gegevens:
Maverick 64 bit
videokaart GeForce 8500 GT
Nvidia-current 260.19.12 (dus een nieuwere dan in de standaard repositories)

Ik heb me al suf gelezen op engelse fora maar ik kom er niet uit.
Volgens Nvidia zou de bug (driver werkte niet goed met de nieuwe xorg 1.9) gefixed zijn in de nieuwe drivers..

Ik hoop dat er onder jullie iemand is die mij kan helpen.

Groetjes,
Jurgen

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Re: Nvidia-current zorgt dat het inloggen op zwart gaat
« Reactie #1 Gepost op: 2010/11/10, 20:03:25 »
In der Beschränkung zeigt sich der Meister.

Offline jurgenh

  • Lid
  • Steunpunt: Nee
Re: Nvidia-current zorgt dat het inloggen op zwart gaat
« Reactie #2 Gepost op: 2010/11/10, 21:58:44 »
Hoi Gijsbert.

Bedankt voor je antwoord.
Ik heb inderdaad de 64b versie te pakken.
Ik heb net de alllllller nieuwste geinstalleerd (260.19.21) maar daarmee heb ik het zelfde probleem.

 :|

Ik vraag me af of ik wel goed aan het zoeken ben hoor.
Misschien trickerd de nvidia driver wel iets anders wat voor de problemen zorgt.
Als iemand log bestanden wil zien dan hoor ik het wel (wel even vertellen hoe of wat).
« Laatst bewerkt op: 2010/11/10, 22:41:05 door jurgenh »

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Re: Nvidia-current zorgt dat het inloggen op zwart gaat
« Reactie #3 Gepost op: 2010/11/10, 23:00:04 »
Ik kan er verder weinig zinnigs over zeggen. Ik heb zelf een Nvidia 7600GS met de current driver op 64 bit. Bij mij werkt het verder goed.
Waarschijnlijk is het toch de combinatie van jouw grafische kaart driver en de Xorg. Het enigste wat ik nu kan doen is verder zoeken op het internet.
Misschien dat in de tussentijd iemand anders wat weet.


P.S.
Kijk hier eens naar, misschien bij jou ook van toepassing:
http://nourlinux.wordpress.com/2010/04/04/how-to-get-plymouth-working-with-proprietary-nvidia-drivers/
« Laatst bewerkt op: 2010/11/10, 23:09:08 door Gijsbert »
In der Beschränkung zeigt sich der Meister.

Offline jurgenh

  • Lid
  • Steunpunt: Nee
Re: Nvidia-current zorgt dat het inloggen op zwart gaat
« Reactie #4 Gepost op: 2010/11/11, 08:45:01 »
Hallo Gijsbert.

Het Plymouth gebeuren heb ik geprobeerd maar zonder succes.
Onder Lucid kreeg ik met deze howto wel weer een knap opstartscherm (resolutie) maar onder Maverick lukt dat niet eens.
Als Nvidia niet geïnstalleerd is ziet alles er wel goed uit (behalve de 3d effecten dan).

Offline kamelot

  • Lid
  • Steunpunt: Nee
Re: Nvidia-current zorgt dat het inloggen op zwart gaat
« Reactie #5 Gepost op: 2010/11/11, 09:06:08 »
Mmm klinkt beetje het zelfde als bij mij alleen dan met ati drivers die ik zelf heb geinstalleerd.
Bij mij werkte het meestal om de xorg te verwijderen en dan via de ati drivers een nieuw xorg aan te.maken.

sudo cp /etc/X11/xorg.conf /etc/X11/xorg.conf.bak

Voor backup

sudo rm /etc/X11/xorg.conf

Voor verwijderen

Hou er erg in dat het kan zijn dat hij pas de driver gaat gebruiken zodra je een nieuw xorg heb
« Laatst bewerkt op: 2010/11/11, 09:08:38 door kamelot »
Humankind cannot gain anything without first giving something in return.
To obtain, something of equal value must be lost

Offline jurgenh

  • Lid
  • Steunpunt: Nee
Re: Nvidia-current zorgt dat het inloggen op zwart gaat
« Reactie #6 Gepost op: 2010/11/11, 09:18:01 »
Hey Kamelot.

Bedankt voor je reactie.
Deze heb ik ook geprobeerd maar het maakte niet veel uit.
Ik zal mijn xorg.conf als bijlage mee sturen misschien dat iemand er wat mee kan.
Ik heb overigens de nvidia-current weer naar 260.19.12 terug gezet.

Groetjes,
Jurgen

Offline jurgenh

  • Lid
  • Steunpunt: Nee
Re: Nvidia-current zorgt dat het inloggen op zwart gaat
« Reactie #7 Gepost op: 2011/06/13, 10:41:18 »
Goed ik ben nu een hele periode verder.
Onder kubuntu 10.04.0 had ik geen last maar nu draai ik onder 10.04.2 en is het probleem terug.
Alles start goed en snel op maar zodra ik Nvidia-current installeer wordt de opstart tijd zomaar 3 á 4 minuten.
Ik ben nu zover dat ik er achter ben gekomen dat het conflict tussen de nvidia driver en mijn tvkaart zit.

Ik voeg een txt bestandje van dmesg | less bij en daarin is te zien dat er errors voorkomen vanaf regel 891.

Mijn tv kaart: Haupauge HVR-1120
Nvidia-current: 270.29

Ik hoop dat iemand me hier mee kan helpen

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Re: Nvidia-current zorgt dat het inloggen op zwart gaat
« Reactie #8 Gepost op: 2011/06/13, 12:39:48 »
De fouten betreffen de tv-kaart, er wordt gezocht naar een firmware update. Is het mogelijk om je tv-kaart tijdelijk uit de computer? En hierna eens opnieuw opstart en kijkt of de computer nu wel goed opstart.
En dit is de nieuwste gesloten Nvidia driver voor jouw kaart. http://www.nvidia.com/object/linux-display-amd64-270.41.19-driver.html

    * Fixed a bug in the VDPAU presentation queue that could cause 1 second hangs when transitioning from blit-based display to overlay- based display. This would most commonly happen when disabling a compositing manager.
    * Fixed a bug that could cause crashes when capturing SDI video.
    * Fixed a corner-case in which the OpenGL driver could leak resources in applications utilizing fork().
    * Addressed a Linux kernel interface compatibility problem that could lead to ioremap() errors and, potentially, functional and/or stability problems.
    * Fixed a bug that caused SLI initialization to fail on some Intel based systems.
    * Fixed a bug that caused SLI initialization to fail when using recent Linux kernels, such as 2.6.38.

In der Beschränkung zeigt sich der Meister.

Online jolo

  • Lid
  • Steunpunt: Nee
Re: Nvidia-current zorgt dat het inloggen op zwart gaat
« Reactie #9 Gepost op: 2011/06/13, 13:29:15 »
Onder kubuntu 10.04.0 had ik geen last maar nu draai ik onder 10.04.2 en is het probleem terug.
Alleen is je dmesg output zo te zien van Natty Narwhal. Daarin is via de repositories nVidia versie 270.41.06 te installeren. Dat scheelt dus niet zo heel erg veel, met die van de nVidia website. Voor je tv-kaart zou je deze hyperlink kunnen checken http://linuxtv.org/wiki/index.php/Hauppauge_WinTV-HVR-1120

Overigens zit er nu ook weer niet zo heel erg veel verschil tussen Kubuntu 10.04.0 en -10.04.2. In mijn hoofd PC draait gewoon Ubuntu 10.04.2 met een nVidia videokaart, en een oude analoge Hauppauge tv-kaart. De nVidia drivers had ik gewoon geïnstalleerd via de gebruikelijke Systeem > Beheer > Stuurprogramma's.
Hoofd PC januari 2018 HP Compaq Elite 8300 SFF Windows 10 & Linux Mint 18.3 Cinnamon
PC 2011 Asus P8Z68-V Pro i7 2600K 8 GB RAM GT730 Xubuntu 18.04 & Ubuntu 18.04  
PC 2007 Asus P5B E6600 2GB RAM 8800GTS  
Notebook 2008 Lenovo ThinkPad R61i 8932GMG 2,5 GB RAM

Offline jurgenh

  • Lid
  • Steunpunt: Nee
Re: Nvidia-current zorgt dat het inloggen op zwart gaat
« Reactie #10 Gepost op: 2011/06/13, 20:28:47 »
Hallo Gijsbert en Jolo.

Bedankt voor jullie antwoorden.

Als ik de tv-kaart eruit haal start alles inderdaad gewoon goed en snel op.

De nieuwste versie van Nvidia heb ik al uitgeprobeerd.
Ik vermoed dat kde ook een rol speelt. In lucid 10.04.0 had ik kde 4.4 (en dat ging goed).
Toe ging ik naar Maverick (kde 4.5) en dat werkte ook niet goed.
Natty het zelfde verhaal.
Nu draai ik dus weer Lucid omdat ik dacht dat dat goed was.
Echter draait ik nu 10.04.2 en daar krijg ik kde 4.5 bij.

Hoe verloopt het:
10.04.2 met kde 4.5 zonder Nvidia gaat goed.
Dan installeer ik Nvidia (ook via de gebruikelijke Systeem > Beheer > Stuurprogramma's) en tadaah de opstart vertraging is daar.

Ook heb ik nu de nieuwste kernel voor Lucid draaien (2.6.38-8-generic) maar dat maakt ook niet uit.

Het verschil zal hem dus in kde en gnome zitten als bij Jolo de kaart wel goed draait?

Groetjes,
Jurgen