Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: ubuntu ziet hardeschijven niet op sata controller  (gelezen 884 keer)

Offline swestland

  • Lid
  • Steunpunt: Nee
ubuntu ziet hardeschijven niet op sata controller
« Gepost op: 2010/10/29, 15:24:21 »
Ik heb zojuist mijn linux server gemigreerd van Redhat ES naar ubuntu 10.10.
Maar heb nu een probleem met het heractiveren van mijn software RAID 1 array, die ik in redhat altijd gebruikte.

Het probleem is dat ubuntu maar 1 harde schijf ziet en deze ook niet kan benaderen. Kan het zijn dat ubuntu problemen heeft met het aansturen van de promise controller?
Ik gebruik dus de RAID functionaliteit van de controller niet, puur alleen voor de SATA poorten. In redhat werkte dit altijd prima icm mdadm .

Ik heb een Tyan tomcat i915 moederbord met onboard Promise SATA RAID controller

WD Raptor 74gb is rechtstreeks aangesloten op het moederbord. (Gevonden als /dev/sda, werkt verder prima)
2 x WD 500gb aangesloten op de promise sata raid controller. (1 gevonden als /dev/sdb maar niet te mounten. dit moet uiteindelijk dus /dev/md0 worden)

Ik hoop dat iemand mij verder op weg kan helpen want ik kom er even niet meer uit.

De uitvoer van dmesg is als volgt;
[    0.308145] ata_piix 0000:00:1f.2: version 2.13
[    0.308170]   alloc irq_desc for 19 on node -1
[    0.308174]   alloc kstat_irqs on node -1
[    0.308185] ata_piix 0000:00:1f.2: PCI INT B -> GSI 19 (level, low) -> IRQ 19
[    0.308194] ata_piix 0000:00:1f.2: MAP [ P0 P2 IDE IDE ]
[    0.308253] ata_piix 0000:00:1f.2: setting latency timer to 64
[    0.308391] scsi0 : ata_piix
[    0.308546] scsi1 : ata_piix
[    0.310084] ata1: SATA max UDMA/133 cmd 0x1f0 ctl 0x3f6 bmdma 0xf000 irq 14
[    0.310090] ata2: PATA max UDMA/100 cmd 0x170 ctl 0x376 bmdma 0xf008 irq 15
[    0.310597] isapnp: Scanning for PnP cards...
[    0.310814] Fixed MDIO Bus: probed
[    0.310878] PPP generic driver version 2.4.2
[    0.310952] tun: Universal TUN/TAP device driver, 1.6
[    0.310957] tun: (C) 1999-2004 Max Krasnyansky <maxk@qualcomm.com>
[    0.311098] ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver
[    0.311128]   alloc irq_desc for 23 on node -1
[    0.311132]   alloc kstat_irqs on node -1
[    0.311141] ehci_hcd 0000:00:1d.7: PCI INT A -> GSI 23 (level, low) -> IRQ 23
[    0.311163] ehci_hcd 0000:00:1d.7: setting latency timer to 64
[    0.311170] ehci_hcd 0000:00:1d.7: EHCI Host Controller
[    0.311232] ehci_hcd 0000:00:1d.7: new USB bus registered, assigned bus number 1
[    0.315158] ehci_hcd 0000:00:1d.7: cache line size of 64 is not supported
[    0.315185] ehci_hcd 0000:00:1d.7: irq 23, io mem 0xd02c4000
[    0.327920] ehci_hcd 0000:00:1d.7: USB 2.0 started, EHCI 1.00
[    0.328150] hub 1-0:1.0: USB hub found
[    0.328159] hub 1-0:1.0: 8 ports detected
[    0.328307] ohci_hcd: USB 1.1 'Open' Host Controller (OHCI) Driver
[    0.328335] uhci_hcd: USB Universal Host Controller Interface driver

[    0.331412] device-mapper: uevent: version 1.0.3
[    0.351544] input: AT Translated Set 2 keyboard as /devices/platform/i8042/serio0/input/input2
[    0.359897] device-mapper: ioctl: 4.17.0-ioctl (2010-03-05) initialised: dm-devel@redhat.com
[    0.412108] device-mapper: multipath: version 1.1.1 loaded
[    0.412114] device-mapper: multipath round-robin: version 1.0.0 loaded
[    0.447087] EISA: Probing bus 0 at eisa.0
[    0.447097] Cannot allocate resource for EISA slot 1
[    0.447101] Cannot allocate resource for EISA slot 2
[    0.447126] EISA: Detected 0 cards.
[    0.481633] ata1.00: ATA-6: WDC WD740GD-00FLC0, 33.08F33, max UDMA/133
[    0.481640] ata1.00: 145226112 sectors, multi 16: LBA48
[    0.497375] ata1.00: configured for UDMA/133
[    0.533726] cpuidle: using governor ladder
[    0.533732] cpuidle: using governor menu
[    0.534332] TCP cubic registered
[    0.534595] NET: Registered protocol family 10
[    0.535270] lo: Disabled Privacy Extensions
[    0.535718] NET: Registered protocol family 17
[    0.535800] Using IPI No-Shortcut mode
[    0.535988] PM: Resume from disk failed.
[    0.536009] registered taskstats version 1
[    0.536339]   Magic number: 14:846:530
[    0.536437] rtc_cmos 00:03: setting system clock to 2010-10-29 11:31:56 UTC (1288351916)
[    0.536443] BIOS EDD facility v0.16 2004-Jun-25, 0 devices found

[    0.536443] BIOS EDD facility v0.16 2004-Jun-25, 0 devices found
[    0.536446] EDD information not available.
[    0.619615] Freeing initrd memory: 11000k freed
[    0.651770] ata2.01: ATAPI: LITE-ON DVD SOHD-16P9S, FS09, max UDMA/33
[    0.660081] ata2.01: configured for UDMA/33
[    0.664115] isapnp: No Plug & Play device found
[    0.664299] scsi 0:0:0:0: Direct-Access     ATA      WDC WD740GD-00FL 33.0 PQ: 0 ANSI: 5
[    0.664501] sd 0:0:0:0: [sda] 145226112 512-byte logical blocks: (74.3 GB/69.2 GiB)
[    0.664583] sd 0:0:0:0: Attached scsi generic sg0 type 0
[    0.664616] sd 0:0:0:0: [sda] Write Protect is off
[    0.664623] sd 0:0:0:0: [sda] Mode Sense: 00 3a 00 00
[    0.664676] sd 0:0:0:0: [sda] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA
[    0.665106]  sda:
[    0.665235] scsi 1:0:1:0: CD-ROM            LITE-ON  DVD SOHD-16P9S   FS09 PQ: 0 ANSI: 5
[    0.667152] sr0: scsi3-mmc drive: 4x/48x cd/rw xa/form2 cdda tray
[    0.667157] Uniform CD-ROM driver Revision: 3.20
[    0.667291] sr 1:0:1:0: Attached scsi CD-ROM sr0
[    0.667358] sr 1:0:1:0: Attached scsi generic sg1 type 5
[    0.670682]  sda1 sda2 sda3 sda4 < sda5 >
[    0.692974] sd 0:0:0:0: [sda] Attached SCSI disk
[    0.692994] Freeing unused kernel memory: 684k freed
[    0.693539] Write protecting the kernel text: 4932k
[    0.693599] Write protecting the kernel read-only data: 1976k
[    0.718785] udev[79]: starting version 163
[    0.786776] xor: automatically using best checksumming function: pIII_sse
[    0.803925]    pIII_sse  :  3363.000 MB/sec
[    0.803932] xor: using function: pIII_sse (3363.000 MB/sec)
[    0.878557] tg3.c:v3.110 (April 9, 2010)
[    0.878587] tg3 0000:02:00.0: PCI INT A -> GSI 17 (level, low) -> IRQ 17
[    0.878602] tg3 0000:02:00.0: setting latency timer to 64
[    0.888151] usb 3-1: new low speed USB device using uhci_hcd and address 2
[    0.919168] e100: Intel(R) PRO/100 Network Driver, 3.5.24-k2-NAPI
[    0.919175] e100: Copyright(c) 1999-2006 Intel Corporation
[    0.919237]   alloc irq_desc for 20 on node -1
[    0.919243]   alloc kstat_irqs on node -1
[    0.919256] e100 0000:03:03.0: PCI INT A -> GSI 20 (level, low) -> IRQ 20
[    1.011969] e100 0000:03:03.0: PME# disabled
[    1.034930] tg3 0000:02:00.0: eth0: Tigon3 [partno(BCM95751) rev 4101] (PCI Express) MAC address 00:e0:81:2f:b9:9b
[    1.034939] tg3 0000:02:00.0: eth0: attached PHY is 5750 (10/100/1000Base-T Ethernet) (WireSpeed[1])
[    1.034945] tg3 0000:02:00.0: eth0: RXcsums[1] LinkChgREG[0] MIirq[0] ASF[0] TSOcap[1]
[    1.034950] tg3 0000:02:00.0: eth0: dma_rwctrl[76180000] dma_mask[64-bit]
[    1.037041] device-mapper: dm-raid45: initialized v0.2594b
[    1.040163] Floppy drive(s): fd0 is 1.44M
[    1.049744] e100 0000:03:03.0: eth1: addr 0xd0161000, irq 20, MAC addr 00:e0:81:2f:b9:1b
[    1.049798] firewire_ohci 0000:03:07.0: PCI INT A -> GSI 17 (level, low) -> IRQ 17
[    1.051540] md: linear personality registered for level -1
[    1.056232] md: multipath personality registered for level -4
[    1.059714] FDC 0 is a post-1991 82077
[    1.061999] md: raid0 personality registered for level 0
[    1.067232] md: raid1 personality registered for level 1
[    1.070489] async_tx: api initialized (async)
[    1.139990] raid6: int32x1    746 MB/s
[    1.146157] firewire_ohci: Added fw-ohci device 0000:03:07.0, OHCI v1.0, 4 IR + 8 IT contexts, quirks 0x1
[    1.146390] sata_promise 0000:03:06.0: version 2.12
[    1.146416] sata_promise 0000:03:06.0: PCI INT A -> GSI 16 (level, low) -> IRQ 16
[    1.158762] scsi2 : sata_promise

[    1.146416] sata_promise 0000:03:06.0: PCI INT A -> GSI 16 (level, low) -> IRQ 16
[    1.158762] scsi2 : sata_promise
[    1.160178] scsi3 : sata_promise
[    1.160392] scsi4 : sata_promise
[    1.160478] ata3: SATA max UDMA/133 mmio m4096@0xd0160000 ata 0xd0160200 irq 16
[    1.160485] ata4: SATA max UDMA/133 mmio m4096@0xd0160000 ata 0xd0160280 irq 16
[    1.160491] ata5: PATA max UDMA/133 mmio m4096@0xd0160000 ata 0xd0160300 irq 16
[    1.160716] r8169 Gigabit Ethernet driver 2.3LK-NAPI loaded
[    1.160741] r8169 0000:03:05.0: PCI INT A -> GSI 18 (level, low) -> IRQ 18
[    1.160785] r8169 0000:03:05.0: (unregistered net_device): no PCI Express capability
[    1.162056] r8169 0000:03:05.0: eth2: RTL8110s at 0xf8284000, 00:40:f4:ec:b6:43, XID 04000000 IRQ 18
[    1.167137] usbcore: registered new interface driver hiddev
[    1.181260] input: Dell Dell USB Optical Mouse as /devices/pci0000:00/0000:00:1d.1/usb3/3-1/3-1:1.0/input/input3
[    1.181604] generic-usb 0003:413C:3012.0001: input,hidraw0: USB HID v1.11 Mouse [Dell Dell USB Optical Mouse] on usb-0000:00:1d.1-1/input0
[    1.181854] usbcore: registered new interface driver usbhid
[    1.181859] usbhid: USB HID core driver
[    1.204015] raid6: int32x2    585 MB/s
[    1.272044] raid6: int32x4    764 MB/s
[    1.340013] raid6: int32x8    548 MB/s
[    1.365016] usb 4-1: new low speed USB device using uhci_hcd and address 2
[    1.408009] raid6: mmxx1     1811 MB/s
[    1.476018] raid6: mmxx2     2138 MB/s
[    1.544039] raid6: sse1x1    1107 MB/s
[    1.612030] raid6: sse1x2    1895 MB/s
[    1.680026] raid6: sse2x1    2267 MB/s
[    1.748018] raid6: sse2x2    3224 MB/s
[    1.748022] raid6: using algorithm sse2x2 (3224 MB/s)
[    1.748156] firewire_core: created device fw0: GUID 00e0810000306ebc, S400
[    3.149344] generic-usb 0003:051D:0002.0002: hiddev96,hidraw1: USB HID v1.10 Device [American Power Conversion Back-UPS CS 500 FW:808.q7.I USB FW:q7] on usb-0000:00:1d.2-1/input0
[    6.680017] ata3: link is slow to respond, please be patient (ready=-19)
[   11.216018] ata3: SRST failed (errno=-16)
[   16.732017] ata3: link is slow to respond, please be patient (ready=-19)
[   21.268020] ata3: SRST failed (errno=-16)
[   26.784017] ata3: link is slow to respond, please be patient (ready=-19)
[   56.296019] ata3: SRST failed (errno=-16)
[   56.296025] ata3: limiting SATA link speed to 1.5 Gbps
[   61.308018] ata3: SRST failed (errno=-16)
[   61.308023] ata3: reset failed, giving up
[   61.784053] ata4: SATA link up 1.5 Gbps (SStatus 113 SControl 300)
[   61.799450] ata4.00: ATA-8: WDC WD5001ABYS-01YNA0, 59.01D01, max UDMA/133
[   61.799454] ata4.00: 976773168 sectors, multi 0: LBA48 NCQ (depth 0/32)
[   61.812755] ata4.00: configured for UDMA/133
[   61.812911] scsi 3:0:0:0: Direct-Access     ATA      WDC WD5001ABYS-0 59.0 PQ: 0 ANSI: 5
[   61.813201] sd 3:0:0:0: Attached scsi generic sg2 type 0
[   61.813270] sd 3:0:0:0: [sdb] 976773168 512-byte logical blocks: (500 GB/465 GiB)
[   61.813442] sd 3:0:0:0: [sdb] Write Protect is off
[   61.813448] sd 3:0:0:0: [sdb] Mode Sense: 00 3a 00 00
[   61.813492] sd 3:0:0:0: [sdb] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA
[   61.813808]  sdb: unknown partition table
[   61.821749] sd 3:0:0:0: [sdb] Attached SCSI disk
[   61.981203] md: raid6 personality registered for level 6
[   61.981211] md: raid5 personality registered for level 5
[   61.981215] md: raid4 personality registered for level 4
[   61.991501] md: raid10 personality registered for level 10
[   62.105096] md: bind<sdb>
[   62.143083] EXT3-fs: barriers not enabled
[   62.153044] kjournald starting.  Commit interval 5 seconds
[   62.143083] EXT3-fs: barriers not enabled
[   62.153044] kjournald starting.  Commit interval 5 seconds
[   62.153117] EXT3-fs (sda2): mounted filesystem with ordered data mode
[   69.877281] udev[355]: starting version 163
[   69.883464] Adding 2048280k swap on /dev/sda3.  Priority:-1 extents:1 across:2048280k
[   69.927297] lp: driver loaded but no devices found
[   69.940276] Adding 1020092k swap on /dev/sda5.  Priority:-2 extents:1 across:1020092k
[   70.093217] intel_rng: FWH not detected
[   70.239987] Linux agpgart interface v0.103
[   70.362245] agpgart-intel 0000:00:00.0: Intel 915G Chipset
[   70.380910] parport_pc 00:08: reported by Plug and Play ACPI
[   70.380944] parport0: PC-style at 0x378, irq 7 [PCSPP,TRISTATE,EPP]
[   70.388168] EXT3-fs (sda2): using internal journal
[   70.426593] agpgart-intel 0000:00:00.0: detected 7932K stolen memory
[   70.454519] agpgart-intel 0000:00:00.0: AGP aperture is 256M @ 0xc0000000
[   70.503835] ppdev: user-space parallel port driver
[   70.505369] lp0: using parport0 (interrupt-driven).
[   70.555704] type=1400 audit(1288351986.512:2): apparmor="STATUS" operation="profile_load" name="/sbin/dhclient3" pid=635 comm="apparmor_parser"
[   70.556580] type=1400 audit(1288351986.516:3): apparmor="STATUS" operation="profile_load" name="/usr/lib/NetworkManager/nm-dhcp-client.action" pid=635 comm="apparmor_parser"
[   70.557080] type=1400 audit(1288351986.516:4): apparmor="STATUS" operation="profile_load" name="/usr/lib/connman/scripts/dhclient-script" pid=635 comm="apparmor_parser"
[   70.662251] [drm] Initialized drm 1.1.0 20060810
[   70.671913] EXT3-fs: barriers not enabled
[   70.692592] kjournald starting.  Commit interval 5 seconds
[   70.697394] EXT3-fs (sda1): using internal journal
[   70.697405] EXT3-fs (sda1): mounted filesystem with ordered data mode
[   70.819503] i915 0000:00:02.0: PCI INT A -> GSI 16 (level, low) -> IRQ 16
[   70.819514] i915 0000:00:02.0: setting latency timer to 64
[   70.857367] [drm] set up 7M of stolen space
[   70.858699] vgaarb: device changed decodes: PCI:0000:00:02.0,olddecodes=io+mem,decodes=io+mem:owns=io+mem
[   70.859122] [drm] initialized overlay support
[   71.163357] Console: switching to colour frame buffer device 128x48
[   71.166479] fb0: inteldrmfb frame buffer device
[   71.166482] drm: registered panic notifier
[   71.166487] Slow work thread pool: Starting up
[   71.166571] Slow work thread pool: Ready
[   71.166585] [drm] Initialized i915 1.6.0 20080730 for 0000:00:02.0 on minor 0
[   71.166639] HDA Intel 0000:00:1b.0: PCI INT A -> GSI 16 (level, low) -> IRQ 16
[   71.166700]   alloc irq_desc for 42 on node -1
[   71.166705]   alloc kstat_irqs on node -1
[   71.166722] HDA Intel 0000:00:1b.0: irq 42 for MSI/MSI-X
[   71.166767] HDA Intel 0000:00:1b.0: setting latency timer to 64
[   71.213952] hda_codec: ALC880: BIOS auto-probing.
[   71.213961] hda_codec: Cannot set up configuration from BIOS.  Using 3-stack mode...
uitvoer van lsmod:
@server2:/var/log$ lsmod
Module                  Size  Used by
binfmt_misc             6599  1
snd_hda_codec_realtek   217980  1
snd_hda_intel          22107  2
snd_hda_codec          87552  2 snd_hda_codec_realtek,snd_hda_intel
snd_hwdep               5040  1 snd_hda_codec
i915                  290938  2
snd_pcm                71475  2 snd_hda_intel,snd_hda_codec
snd_seq_midi            4588  0
drm_kms_helper         30200  1 i915
snd_rawmidi            17783  1 snd_seq_midi
snd_seq_midi_event      6047  1 snd_seq_midi
snd_seq                47174  2 snd_seq_midi,snd_seq_midi_event
drm                   168054  3 i915,drm_kms_helper
snd_timer              19067  2 snd_pcm,snd_seq
snd_seq_device          5744  3 snd_seq_midi,snd_rawmidi,snd_seq
ppdev                   5556  0
parport_pc             26058  1
intel_agp              26360  2 i915
snd                    49006  13 snd_hda_codec_realtek,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_pcm,snd_rawmidi,snd_seq,snd_time                                                                              r,snd_seq_device
i2c_algo_bit            5168  1 i915
video                  18712  1 i915
soundcore                880  1 snd
snd_page_alloc          7120  2 snd_hda_intel,snd_pcm
output                  1883  1 video
agpgart                32011  2 drm,intel_agp
lp                      7342  0
parport                31492  3 ppdev,parport_pc,lp
raid10                 22394  0
raid456                53514  0
async_raid6_recov       4883  1 raid456
async_pq                3038  2 raid456,async_raid6_recov
usbhid                 36882  1
hid                    67742  1 usbhid
raid6_pq               80029  2 async_raid6_recov,async_pq
async_xor               2298  3 raid456,async_raid6_recov,async_pq
async_memcpy            1045  2 raid456,async_raid6_recov
async_tx                2135  5 raid456,async_raid6_recov,async_pq,async_xor,async_memcpy
raid1                  20969  0
raid0                   8547  0
multipath               5955  0
linear                  3822  0
floppy                 54311  0
dm_raid45              81721  0
r8169                  36489  0
firewire_ohci          21106  0
firewire_core          46643  1 firewire_ohci
e100                   30356  0
sata_promise            9074  1
crc_itu_t               1383  1 firewire_core
tg3                   123310  0
mii                     4425  2 r8169,e100
xor                    15136  2 async_xor,dm_raid45

@server2:/proc/scsi$ cat scsi
Attached devices:
Host: scsi0 Channel: 00 Id: 00 Lun: 00
  Vendor: ATA      Model: WDC WD740GD-00FL Rev: 33.0
  Type:   Direct-Access                    ANSI  SCSI revision: 05
Host: scsi1 Channel: 00 Id: 01 Lun: 00
  Vendor: LITE-ON  Model: DVD SOHD-16P9S   Rev: FS09
  Type:   CD-ROM                           ANSI  SCSI revision: 05
Host: scsi3 Channel: 00 Id: 00 Lun: 00
  Vendor: ATA      Model: WDC WD5001ABYS-0 Rev: 59.0
  Type:   Direct-Access                    ANSI  SCSI revision: 05
« Laatst bewerkt op: 2010/10/29, 15:32:05 door swestland »

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
Re: ubuntu ziet hardeschijven niet op sata controller
« Reactie #1 Gepost op: 2010/10/29, 15:40:43 »
[    6.680017] ata3: link is slow to respond, please be patient (ready=-19)
[   11.216018] ata3: SRST failed (errno=-16)
[   16.732017] ata3: link is slow to respond, please be patient (ready=-19)
[   21.268020] ata3: SRST failed (errno=-16)
[   26.784017] ata3: link is slow to respond, please be patient (ready=-19)
[   56.296019] ata3: SRST failed (errno=-16)
[   56.296025] ata3: limiting SATA link speed to 1.5 Gbps
[   61.308018] ata3: SRST failed (errno=-16)
[   61.308023] ata3: reset failed, giving up
Dit lijkt me niet helemaal gezond...

Ik zou die harde schijf aansluiten op een andere SATA poort, desnoods even in een andere computer, om te zien of die schijf het daar wel doet. Evt. ook de SATA kabel vervangen.

Aangezien de andere schijf op het Promise-kaartje het wel doet lijkt me dat er met de drivers niets mis is.
Het is wel mogelijk dat het kaartje zelf kapot is, één van de SATA poorten kapot is of het SATA kabeltje rot.


Offline swestland

  • Lid
  • Steunpunt: Nee
Re: ubuntu ziet hardeschijven niet op sata controller
« Reactie #2 Gepost op: 2010/10/29, 15:43:58 »
[    6.680017] ata3: link is slow to respond, please be patient (ready=-19)
[   11.216018] ata3: SRST failed (errno=-16)
[   16.732017] ata3: link is slow to respond, please be patient (ready=-19)
[   21.268020] ata3: SRST failed (errno=-16)
[   26.784017] ata3: link is slow to respond, please be patient (ready=-19)
[   56.296019] ata3: SRST failed (errno=-16)
[   56.296025] ata3: limiting SATA link speed to 1.5 Gbps
[   61.308018] ata3: SRST failed (errno=-16)
[   61.308023] ata3: reset failed, giving up
Dit lijkt me niet helemaal gezond...

Ik zou die harde schijf aansluiten op een andere SATA poort, desnoods even in een andere computer, om te zien of die schijf het daar wel doet. Evt. ook de SATA kabel vervangen.

Aangezien de andere schijf op het Promise-kaartje het wel doet lijkt me dat er met de drivers niets mis is.
Het is wel mogelijk dat het kaartje zelf kapot is, één van de SATA poorten kapot is of het SATA kabeltje rot.

De andere HD is alleen zichtbaar maar niet te gebruiken. Twee dagen terug deed alles het nog prima onder redhat dus het lijkt me sterk dat nu de kaart stuk is of de HD stuk is. Ik ben het wel met je eens dat deze melding niet hoort en kan zijn dat dit er voor zorgt dat de kaart het niet goed doet.

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
Re: ubuntu ziet hardeschijven niet op sata controller
« Reactie #3 Gepost op: 2010/10/29, 15:50:12 »
Die andere hd zou je kunnen gebruiken via mdadm.
Het wordt dan wel een degraded raid1, dat is waarschijnlijk de reden dat mdadm hem niet automatisch start.

Zo uit mijn hoofd zou je de RAID kunnen starten via:
sudo mdadm -v --assemble --scan

Offline swestland

  • Lid
  • Steunpunt: Nee
Re: ubuntu ziet hardeschijven niet op sata controller
« Reactie #4 Gepost op: 2010/10/29, 15:57:55 »
Klopt, zo was ook mijn redenatie alleen is dus deze HD niet te gebruiken:
$ sudo fdisk -l /dev/sdb

Disk /dev/sdb: 500.1 GB, 500107862016 bytes
255 heads, 63 sectors/track, 60801 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x00000000

Disk /dev/sdb doesn't contain a valid partition table
Dus de hele aansturing zit ergens fout naar mijn idee.