Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: [OPGELOST]Heb dual Core maar Ubuntu ziet er maar 1  (gelezen 3016 keer)

Offline icehawk

  • Lid
  • Steunpunt: Nee
[OPGELOST]Heb dual Core maar Ubuntu ziet er maar 1
« Gepost op: 2010/10/23, 22:01:57 »
Een heel vreemd verschijnsel....

Ik heb al enige jaren een pc met een Asus m2n1394 moederbord met een AMD Athlon(tm) 64 X2 Dual Core Processor 4800+. In Systeem zelf is de beschrijving van mijn CPU helemaal correct! Echter als ik in de terminal cat /proc/cpuinfo intik, krijg ik dit te zien! En dan wordt het ook nog eens aangegeven dat hij maar op 1Ghz draait  ??? Uiteraard smp kernel op staan (smp = ondersteuning voor dual core) Heb kernel versie: Linux AMD3000 2.6.32-25-generic #45-Ubuntu SMP Sat Oct 16 19:48:22 UTC 2010 i686 GNU/Linux

---------------->>
jpvzijst@AMD3000:~$ cpuinfo
cpuinfo: command not found
jpvzijst@AMD3000:~$ cat /proc/cpuinfo
processor   : 0
vendor_id   : AuthenticAMD
cpu family   : 15
model      : 107
model name   : AMD Athlon(tm) 64 X2 Dual Core Processor 4800+
stepping   : 1
cpu MHz      : 1000.000
cache size   : 512 KB
physical id   : 0
siblings   : 1
core id      : 0
cpu cores   : 1
apicid      : 0
initial apicid   : 0
fdiv_bug   : no
hlt_bug      : no
f00f_bug   : no
coma_bug   : no
fpu      : yes
fpu_exception   : yes
cpuid level   : 1
wp      : yes
flags      : fpu vme de pse tsc msr pae mce cx8 apic mtrr pge mca cmov pat pse36 clflush mmx fxsr sse sse2 ht syscall nx mmxext fxsr_opt rdtscp lm 3dnowext 3dnow up extd_apicid pni cx16 lahf_lm cmp_legacy svm extapic cr8_legacy 3dnowprefetch
bogomips   : 2009.19
clflush size   : 64
cache_alignment   : 64
address sizes   : 40 bits physical, 48 bits virtual
power management: ts fid vid ttp tm stc 100mhzsteps
----------------->>


Hoe is dit nou goed op te lossen? In de eerste instantie had ik gedacht dat mijn bois geupgrade moest worden. (zie andere topic)http://forum.ubuntu-nl.org/hardware-en-drivers/flashen-bios-met-unetbootin/
Maar dat hielp helaas niet.

Ik weet dat het vreemd overkomt dat ik het nu pas zie. Maar ik zag het nu pas omdat je in het paneel een systeembelastingmetertje neer kon zetten. Het leek mij wel wat. Toen pas besteedde ik er iets meer aandacht aan dan normaal. En toen zag ik het pas!

Googlen..... Veel gedaan, maar echt helemaal niets kunnen vinden wat het nou zou moeten oplossen.

Jullie enig idee?
« Laatst bewerkt op: 2010/10/24, 00:14:07 door icehawk »
Ubuntu verbrijzelde de kop van Windows. Windows beet slechts de hiel van Ubuntu.

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Re: Heb dual Core maar Ubuntu ziet er maar 1
« Reactie #1 Gepost op: 2010/10/23, 22:48:50 »
Bij mij dit:
gijs@gijs-desktop:~$ cat /proc/cpuinfo
processor    : 0
vendor_id    : GenuineIntel
cpu family    : 6
model        : 15
model name    : Intel(R) Core(TM)2 Duo CPU     E4500  @ 2.20GHz
stepping    : 13
cpu MHz        : 1200.000
cache size    : 2048 KB
physical id    : 0
siblings    : 2
core id        : 0
cpu cores    : 2
apicid        : 0
initial apicid    : 0
fpu        : yes
fpu_exception    : yes
cpuid level    : 10
wp        : yes
flags        : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx lm constant_tsc arch_perfmon pebs bts rep_good aperfmperf pni dtes64 monitor ds_cpl est tm2 ssse3 cx16 xtpr pdcm lahf_lm
bogomips    : 4399.42
clflush size    : 64
cache_alignment    : 64
address sizes    : 36 bits physical, 48 bits virtual
power management:

processor    : 1
vendor_id    : GenuineIntel
cpu family    : 6
model        : 15
model name    : Intel(R) Core(TM)2 Duo CPU     E4500  @ 2.20GHz
stepping    : 13
cpu MHz        : 1200.000
cache size    : 2048 KB
physical id    : 0
siblings    : 2
core id        : 1
cpu cores    : 2
apicid        : 1
initial apicid    : 1
fpu        : yes
fpu_exception    : yes
cpuid level    : 10
wp        : yes
flags        : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx lm constant_tsc arch_perfmon pebs bts rep_good aperfmperf pni dtes64 monitor ds_cpl est tm2 ssse3 cx16 xtpr pdcm lahf_lm
bogomips    : 4399.90
clflush size    : 64
cache_alignment    : 64
address sizes    : 36 bits physical, 48 bits virtual
power management:
Met deze kernel:
gijs@gijs-desktop:~$ cat /proc/version
Linux version 2.6.32-25-generic (buildd@yellow) (gcc version 4.4.3 (Ubuntu 4.4.3-4ubuntu5) ) #44-Ubuntu SMP Fri Sep 17 20:05:27 UTC 2010
64 bit versie en deze CPU Intel(R) Core(TM)2 Duo CPU     E4500  @ 2.20GHz
Lijkt mij wat vreemd dat bij jou de AMD niet als dusdanig herkent wordt. ???
Wat geeft dit in de terminal grep processor /proc/cpuinfo | wc -l
« Laatst bewerkt op: 2010/10/23, 22:59:58 door Gijsbert »
In der Beschränkung zeigt sich der Meister.

Offline petervs

  • Lid
  • Steunpunt: Nee
Re: Heb dual Core maar Ubuntu ziet er maar 1
« Reactie #2 Gepost op: 2010/10/23, 22:54:07 »
Citaat
In de eerste instantie had ik gedacht dat mijn bios geupgrade moest worden.
Ik neem aan omdat je in je bios hebt aangegeven dat er gebruik moet worden gemaakt van 2 cores in plaats van 1. Tenminste, die keuze heb ik wel in mijn bios.
Ubuntu MATE 16.04

Offline icehawk

  • Lid
  • Steunpunt: Nee
Re: Heb dual Core maar Ubuntu ziet er maar 1
« Reactie #3 Gepost op: 2010/10/23, 22:59:10 »
Citaat
In de eerste instantie had ik gedacht dat mijn bios geupgrade moest worden.
Ik neem aan omdat je in je bios hebt aangegeven dat er gebruik moet worden gemaakt van 2 cores in plaats van 1. Tenminste, die keuze heb ik wel in mijn bios.

Yeps, je mag nooit meer raden  8)

Tis een vaag verschijnsel he?
Ubuntu verbrijzelde de kop van Windows. Windows beet slechts de hiel van Ubuntu.

Offline joop905

  • Lid
  • Steunpunt: Nee
Re: Heb dual Core maar Ubuntu ziet er maar 1
« Reactie #4 Gepost op: 2010/10/23, 23:07:13 »
En met top, druk dan eens op 1  hoe veel Cpu zie je dan

Offline icehawk

  • Lid
  • Steunpunt: Nee
Re: Heb dual Core maar Ubuntu ziet er maar 1
« Reactie #5 Gepost op: 2010/10/23, 23:20:48 »
En met top, druk dan eens op 1  hoe veel Cpu zie je dan

Hoe bedoel je precies? op 1 drukken? waar? wanneer? :)
Ubuntu verbrijzelde de kop van Windows. Windows beet slechts de hiel van Ubuntu.

Offline joop905

  • Lid
  • Steunpunt: Nee
Re: Heb dual Core maar Ubuntu ziet er maar 1
« Reactie #6 Gepost op: 2010/10/23, 23:28:48 »
Terminal tik in: top
dan zie je Cpu(s)
met op 1 (nummertoets) komt de 2e Cpu(s) tevoorschijn, als alles goed is
« Laatst bewerkt op: 2010/10/23, 23:30:54 door joop905 »

Offline Pfoeh

  • Lid
  • Steunpunt: Nee
Re: Heb dual Core maar Ubuntu ziet er maar 1
« Reactie #7 Gepost op: 2010/10/23, 23:40:10 »
Weer wat geleerd.
Zo'n simpel commando.....
Dank!

Gr
Jeroen
Linux Registered user 485465

Beperkingen voor het vervoer van gevaarlijke stoffen, genoemd onder Tunnelcategorie E in randnummer 1.9.5.2.2. van bijlage 1, gelden voor de ArenAtunnel, gelegen onder de Amsterdam ArenA, te Amsterdam.

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
Re: Heb dual Core maar Ubuntu ziet er maar 1
« Reactie #8 Gepost op: 2010/10/23, 23:43:00 »
Voer eens dit uit in de terminal, en plaats het resultaat hier:

dmesg | grep -i cpu

Offline icehawk

  • Lid
  • Steunpunt: Nee
Re: Heb dual Core maar Ubuntu ziet er maar 1
« Reactie #9 Gepost op: 2010/10/23, 23:49:28 »
Terminal tik in: top
dan zie je Cpu(s)
met op 1 (nummertoets) komt de 2e Cpu(s) tevoorschijn, als alles goed is

Aaaahh, dat :) Te snel gelezen ;) Heb even gekeken. De 2de CPU is wel zichtbaar. Maar dan rijst de vraag.... Hoe kan het dan dat in de systeembelastingmeter maar 1 CPU wordt getoond?
Ubuntu verbrijzelde de kop van Windows. Windows beet slechts de hiel van Ubuntu.

Offline icehawk

  • Lid
  • Steunpunt: Nee
Re: Heb dual Core maar Ubuntu ziet er maar 1
« Reactie #10 Gepost op: 2010/10/24, 00:01:40 »
Voer eens dit uit in de terminal, en plaats het resultaat hier:

dmesg | grep -i cpu
Is wel schrikken hoor.... weer geen 2de CPU zichtbaar!
---------->>
jpvzijst@AMD3000:~$ dmesg | grep -i cpu
[    0.000000] Initializing cgroup subsys cpuset
[    0.000000] Initializing cgroup subsys cpu
[    0.000000] KERNEL supported cpus:
[    0.000000]   Transmeta TransmetaCPU
[    0.000000] x86 PAT enabled: cpu 0, old 0x7040600070406, new 0x7010600070106
[    0.000000] SMP: Allowing 1 CPUs, 0 hotplug CPUs
[    0.000000] NR_CPUS:8 nr_cpumask_bits:8 nr_cpu_ids:1 nr_node_ids:1
[    0.000000] PERCPU: Embedded 14 pages/cpu @c2400000 s36056 r0 d21288 u4194304
[    0.000000] pcpu-alloc: s36056 r0 d21288 u4194304 alloc=1*4194304
[    0.000000] pcpu-alloc:
  • 0

[    0.000000] Initializing CPU#0
[    0.000000] SLUB: Genslabs=13, HWalign=64, Order=0-3, MinObjects=0, CPUs=1, Nodes=1
[    0.000000] HPET: 3 timers in total, 0 timers will be used for per-cpu timer
[    0.004155] Initializing cgroup subsys cpuacct
[    0.004186] CPU: L1 I Cache: 64K (64 bytes/line), D cache 64K (64 bytes/line)
[    0.004188] CPU: L2 Cache: 512K (64 bytes/line)
[    0.004190] CPU: Physical Processor ID: 0
[    0.004192] CPU: Processor Core ID: 0
[    0.004195] mce: CPU supports 5 MCE banks
[    0.036089] weird, boot CPU (#0) not listed by the BIOS.
[    0.040001] Brought up 1 CPUs
[    0.040001] CPU0 attaching NULL sched-domain.
[    0.656532] cpufreq-nforce2: No nForce2 chipset.
[    0.684931] processor LNXCPU:00: registered as cooling_device0
[    0.772035] cpuidle: using governor ladder
[    0.772037] cpuidle: using governor menu
[    0.773302] powernow-k8: Found 1 AMD Athlon(tm) 64 X2 Dual Core Processor 4800+ processors (1 cpu cores) (version 2.20.00)
[   17.106369] [drm] GART: num cpu pages 131072, num gpu pages 131072
[   81.696310] Marking TSC unstable due to cpufreq changes
jpvzijst@AMD3000:~$
-------------->>
Ubuntu verbrijzelde de kop van Windows. Windows beet slechts de hiel van Ubuntu.

Offline icehawk

  • Lid
  • Steunpunt: Nee
Re: Heb dual Core maar Ubuntu ziet er maar 1
« Reactie #11 Gepost op: 2010/10/24, 00:13:41 »
Hoe vaag het misschien ook klinkt, maar ik heb in de bios de cool&quiet eens uitgezet..
Nu zie ik beide CPU's

Ondanks dat ik cool&quiet heb uitgezet, is er gelukkig geen verhoging in de volume ontstaan van de fans :)

Bij deze is het opgelost. Tnx voor alle input!
Ubuntu verbrijzelde de kop van Windows. Windows beet slechts de hiel van Ubuntu.

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
Re: Heb dual Core maar Ubuntu ziet er maar 1
« Reactie #12 Gepost op: 2010/10/24, 00:15:28 »
Toch een BIOS probleem dus...

Misschien toch maar iemand met meer ervaring opzoeken om te helpen met het flashen van je BIOS?

Offline Ron

  • Forumteam
    • r0n
    • Dwarsligger
  • Steunpunt: Ja
Re: [OPGELOST]Heb dual Core maar Ubuntu ziet er maar 1
« Reactie #13 Gepost op: 2010/10/24, 10:42:25 »
Installeer eens de processor-snelheid applet, dan zie je wat er gebeurt.
Zet deze op ondemand, dan zul je zien, dat in 99% van de tijd er maar één processor gebruikt wordt, meestal staat de 2e CPU te slapen, omdat er gewacht wordt op hardware.
Bij het starten van b.v. Firefox zie je weer even 2 CPU's

Het bovenstaande is mijn ervaring op mijn hardware ......
OpenStandaard evangelist, OpenSource promotor, OpenData liefhebber.
Xubuntu gebruiker en voorstander (XFCE).
In Nederland bekend als een Dwarsligger.

Offline icehawk

  • Lid
  • Steunpunt: Nee
Re: Heb dual Core maar Ubuntu ziet er maar 1
« Reactie #14 Gepost op: 2010/10/24, 12:42:07 »
Toch een BIOS probleem dus...

Misschien toch maar iemand met meer ervaring opzoeken om te helpen met het flashen van je BIOS?

De bios is goed. De nieuwere versie staat er al op. Het bijkomend probleem wat er nu is ontstaan wordt nog gekker.....

Ubuntu herkent de CPU helemaal goed. En in de procesbeheer toont hij real-time het gebruik van de 2 cores. Maar als ik windows 7 64 bit in Virtualbox aanzet, krijg ik de foutmelding "
De VT-x/AMD-V hardware versnelling is geactiveerd maar niet operationeel. Uw 64-Bit gast kan de 64 Bit CPU niet herkennen en zal dus niet opstarten.
Verzeker u ervan dat de VT-x/AMD-V instelling correct is aangezet in de BIOS van uw fysieke computer.

Echter de AMD-V is standaard geactiveerd in de bios.
Mogelijk een kernelprobleem?

pffttt, denken denken denken hoe dit nou weer op te lossen is...... :evil:
« Laatst bewerkt op: 2010/10/24, 13:18:29 door icehawk »
Ubuntu verbrijzelde de kop van Windows. Windows beet slechts de hiel van Ubuntu.