Nieuws:

We zijn er weer.

Na lange tijd van afwezigheid zijn we er weer  :laugh:
We hebben alle wachtwoorden gereset, je oude wachtwoord werkt niet meer.Je moet via het "wachtwoord vergeten"-linkje je wachtwoord resetten. Je krijgt hiervoor een mailtje op het adres dat je bij ons geregistreerd hebt.

De komende tijd zijn we nog druk bezig om de rest van de site op te bouwen, dus het kan zijn dat sommige onderdelen (tijdelijk) niet werken.

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Chromium en IE carriage return in link?  (gelezen 692 keer)

Offline MKe

  • Lid
  • Steunpunt: Nee
Chromium en IE carriage return in link?
« Gepost op: 2010/10/18, 10:28:57 »
Hoi,

Ik weet niet of dit hier hoort of in het internet forum, maar aangezien het over html gaat heb ik het hier maar gezet.
Op een webpagina die ik geschreven heb wordt een externe internet tool aangeroepen via een link. Nu is het nodig om in de parameters van deze webtool een carriage return ('%0D%0A') te zetten tussen 2 values. Dit heb ik dus gedaan en het werkt prima in FF. Maar Chroom/Chromium en IE heeft hierin een eigen wil. Deze verwijdert de cr domweg uit de URL van de link. De URL (inclusief de cr code) met de hand intypen gaat weer wel. Het is geen vaste link, de parameters worden uit een database gehaald aan de hand van een query die de gebruiker doet.
Weet iemand wat ik kan doen om de pagina toch compatible te maken met Chroom/Chromium zodat de link werkt? (bahlve de link verwijderen natuurlijk ;)

Voorbeeld van de link:
http://blast.ncbi.nlm.nih.gov/blast/Blast.cgi?PROGRAM=blastp&CMD=put&DATABASE=nr&QUERY=>test%0D%0AMADIQPPDPQINGAPPPLVVSSETVGSKRQRR

de cr code zit dus tussen de 'test' en MADIQ.....

edit: Met IE is het inmiddels opgelost. Er moet een escape character tussen, dus: %250D i.p.v. %0D.
« Laatst bewerkt op: 2010/10/18, 13:33:09 door MKe »
Mijn blokkendoos blog: http://mke21.wordpress.com/