Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: partities niet laten mounten / permissies  (gelezen 432 keer)

Offline Steven Klein Haneveld

  • Lid
  • Steunpunt: Nee
partities niet laten mounten / permissies
« Gepost op: 2010/10/16, 23:31:19 »
Mensen,

Ik heb een verse installatie van Ubuntu 10.04.1. Aangezien ik meerdere partities heb, die ik wil beschermen tegen wijzigingen door onbevoegden, wil ik ervoor zorgen, dat die niet gemount worden en bovendien ook niet gemount kĂșnnen worden door een normale gebruiker.

Dit is het plaatje:
Apparaat Opstart   Begin       Einde     Blokken   ID  Systeem
/dev/sda1   *           1       12748   102398278+   7  HPFS/NTFS
/dev/sda2           12749       25496   102398310    7  HPFS/NTFS
/dev/sda3           25497       47168   174080340   83  Linux
/dev/sda4           47169       60801   109507072+  83  Linux

Schijf /dev/sdb: 500.1 GB, 500107862016 bytes
255 koppen, 63 sectoren/spoor, 60801 cilinders
Eenheid = cilinders van 16065 * 512 = 8225280 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Schijf-ID: 0x000e9ba9

 Apparaat Opstart   Begin       Einde     Blokken   ID  Systeem
/dev/sdb1   *           1        6091    48924672   83  Linux
/dev/sdb2            6091       30407   195312640   83  Linux
/dev/sdb3           30407       31015     4882432   82  Linux wisselgeheugen
/dev/sdb4           31016       60801   239256045    5  Uitgebreid
/dev/sdb5           31016       48053   136857703+  83  Linux
/dev/sdb6           48054       60801   102398278+  83  Linux

Het gaat mij om sda1 en sda2, sda4 en sdb6. Eerste twee zijn ntfs, de laatste twee zijn ext3.

Ik heb er al voor gezorgd, dat betreffende partities gekoppeld worden.
Voorbeeld:
sda4 wordt gekoppeld als /media/ubyrescue
Eigenaar van /media/ubyrescue is root. De rechten staan op 755.

Echter: wanneer ik nu als gebruiker ben aangemeld, kan ik hem toch mounten en beschrijven, want hij omzeilt de rechten door hem ineens te mounten in /media/ubyrescue_

Waarom doet Ubuntu nou zo eigenwijs? Ik wil niet dat een gebruiker die partitie kan mounten, en ik wil al helemaal geen schrijfrechten voor een gebruiker. Hoe vertel ik dat aan mijn systeem?

Alvast dank!

Groetend,

Steven

Offline Progger

  • Lid
  • Steunpunt: Nee
Re: partities niet laten mounten / permissies
« Reactie #1 Gepost op: 2010/10/16, 23:40:18 »
Met
Citaat
De rechten staan op 755.

geef je nog altijd: 5 = 4+1 wordt "r-x" (lezen-uitvoeren)

Misschien de rechten op:

700 = alleen door de eigenaar te lezen, beschrijven en uit te voeren. Verder door niemand

zetten?
« Laatst bewerkt op: 2010/10/16, 23:43:11 door Progger »
Laptop MSI U123 (160 GB) 1 GB ramMint Cinnamon 18 LTS
Laptop Toshiba Tecra  (80GB) 2 GB ram Fedora 24
Dell Latitude D600 Pentium M 1400MHz 512MB ram
Bouwjaar 2003 met Debian 8 (Jessie)

Offline Drummies

  • Lid
  • Steunpunt: Nee
Re: partities niet laten mounten / permissies
« Reactie #2 Gepost op: 2010/10/16, 23:55:17 »
Hoe heb je het precies gedaan @Steven Klein Haneveld
Volgens mij is dit het beste in fstab in te stellen sudo gedit /etc/fstab
Citaat
Je kunt regels in fstab opnemen voor partities die je niet automatisch wilt laten mounten, maar die wel aangeven welke opties gebruikt moeten worden en wat de mount point is. Gebruik dan de optie noauto. Dit is nuttig voor bijvoorbeeld een dvd-speler. Je kunt dan achter mount alleen de devicenaam of de mount point meegeven, bijv. mount /media/cdrom. Voor alle mogelijke opties zie man fstab.

Bron:Mounten
Gestopt als aktief Forumlid 17/10/2011

Offline Steven Klein Haneveld

  • Lid
  • Steunpunt: Nee
Re: partities niet laten mounten / permissies
« Reactie #3 Gepost op: 2010/10/17, 07:46:22 »
Bedankt voor de reacties!

@ Progger,
Jij hebt gelijk, zeker voor mijn Windows systeempartitie. Dat heb ik inmiddels ook gedaan, door umask 700 mee te geven in tstab (is dat een goede manier?)

@ Drummies,
De eigenaar en rechten heb ik in de terminal ingesteld met sudo chown -R en sudo chmod -R.
Het al of niet laten mounten heb ik in fstab gedaan.
Hier is mijn fstab:
# /etc/fstab: static file system information.
#
# Use 'blkid -o value -s UUID' to print the universally unique identifier
# for a device; this may be used with UUID= as a more robust way to name
# devices that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    nodev,noexec,nosuid 0       0
#
# /dev/sdb1
UUID=dd1374e6-a521-4825-899d-5c1907d47498 /               ext4    errors=remount-ro 0       1
#
# /dev/sdb2
UUID=6a8125a6-1f9b-4fd6-87f3-14e6c376a0ce /home           ext4    defaults        0       2
#
# /dev/sdb3
UUID=3b7a79d1-9cad-4fa5-a5fc-fae9205e8770 none            swap    sw              0       0
#
# /dev/sdb5
UUID=468bb04a-116e-4eff-9c0e-e5db14935597 /media/data1    ext4    defaults        0       2
#
# /dev/sdb6
# UUID=f375650b-dd06-4fbb-bde0-c86f8461f1d6 /media/winrescue    ext3    defaults,nouser    0    2
#
# /media/win7os was on /dev/sda1 during installation
# UUID=79DF332000406D78 /media/win7os   ntfs    defaults,nouser,umask=700,gid=46 0       0
#
# /media/windocs was on /dev/sda2 during installation
# UUID=27CAB4267565FB9C /media/windocs  ntfs    defaults,nouser,umask=700,gid=46 0       0
#
# /media/data2 was on /dev/sda3 during installation
UUID=76dc8663-cd3a-405c-8bba-e0ad3f49e95e /media/data2    ext4    defaults        0       2
#
# /media/ubyrescue was on /dev/sda4 during installation
# UUID=052ac62d-3d76-4eb8-958f-0db7ca1e8b14 /media/ubyrescue ext3    defaults,nouser        0       2
#
Zoals je kunt zien, heb ik
- voor elke partitie die ik niet wil mounten een # geplaatst - deze partities worden nu bij opstarten niet gemount.
- achter /dev/sda2 heb ik een argument "nouser" geplaatst. Volgens Bartjens mag een gebruiker die partitie nu niet mounten. Dit kan ik echter nog steeds wel, zoals laten zien, doordat Ubuntu de boel omzeild en hem in een ander koppelpunt zet.

Ik dacht, dat "nouser" gewoon ervoor zorgde, dat alleen root kun mounten, maar ik zal me vergissen? Hoe kan ik het dan wel doen?

Bedankt!


EDIT:

Volgens mij heb ik het inmiddels opgelost.

Ik heb een vergissing gemaakt bij fstab. Ik dacht, dat ik een # moest plaatsen, om te voorkomen dat een partitie niet gemount werd met opstarten. Maar ik realiseerde me niet, dat de hele regel nu niet meer van kracht werd. Dus ook de nouser optie.

Ik heb die # weggehaald en bij de betreffende partities de optie "noauto" gezet. Vermoedelijk is dat mijn oplossing.

Bedankt voor het meedenken!
« Laatst bewerkt op: 2010/10/17, 08:25:58 door Steven Klein Haneveld »