Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: probleem om Apache te starten  (gelezen 453 keer)

Offline rubberbutt

  • Lid
  • Steunpunt: Nee
probleem om Apache te starten
« Gepost op: 2010/10/14, 17:26:00 »
Zucht, weer een probleem.
Ik wil een webwinkel (Tomataocart) installeren.
Daarvoor is PHP-gd en PHP-cURL noodzakelijk.
Ubuntu 10.04 LTS.Heeft standaard geen php-gd, en php-cURL.
Deze 2 packages geinstalleerd met sudo apt-get install php5-gd en sudo apt-get install php5-cURL.
Daarna wil de webserver niet meer starten.
 Bij commando #  ps -e|grep apache zie ik nog een paar processen draaien.
Dan doe ik  #  sudo killall apache2, dan zijn die processen weg.

Start vervolgens apache door /etc/init.d/apache2 start en ik krijg:
(13) Permission denied: make_sock: could not bind to address 0.0.0.0:80  no listening sockets available,shutting down  Unable to open logs.

Wat houdt dit nu weer in ??


Ik heb inmiddels via Webmin Apache gestopt en gestart en nu werkt het weer. Vreemd  ???

Nu nog even uitzoeken hoe ik de default website in /var/www verander naar /var/www/html.
Volgens andere bronnen op dit forum zou dat in /etc/apache2/sites-enabled/000-default/

<VirtualHost *>
        ......
        DocumentRoot /var/www
        <Directory />
                Options FollowSymLinks
                AllowOverride None
        </Directory>
        <Directory /var/www/>
                Options Indexes FollowSymLinks MultiViews
                AllowOverride None
                Order allow,deny
                allow from all
        </Directory>
        .......
</VirtualHost>

Dit werkt op zich wel ,alleen is de layout van de webshop nu vernaggeld  :'(
« Laatst bewerkt op: 2010/10/14, 21:24:49 door rubberbutt »