Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Ubuntu Server - Schijven fysiek verwijderen zonder fstab edit te moeten doen  (gelezen 924 keer)

Offline Fredje

  • Lid
  • Steunpunt: Nee
Hallo allemaal,

Even een situatie schets:

Ubuntu server draait goed.
Al mijn dataschijven worden correct gemount doordat ik fstab heb aangepast.
Als alle entry's in fstab ook hun fysieke schijf kunnen vinden dan is er geen probleem.

MAAR hier komt het probleem:
Als ik de server uitschakel en een schijf fysiek loskoppel (zonder fstab op voorhand aan te passen = weg-commenten), dan wilt de server niet meer booten.
Tijdens het laden van Ubuntu server komt er dan:

fsck utils-.....
/dev/sda1  clean .....    ==> mijn systeem schijf wordt correct gemount.
en dan een flikkerende verticale cursor. Geen CLI, niets

Het komt erop neer dat mijn systeem schijf goed gemount is maar hij blijft dus zoeken naar de schijf die losgekoppeld is (omdat ze nog in fstab staat).

Wat ik zou willen is:
Dat als er een schijf niet gevonden wordt (en toch in fstab staat met UUID), die gewoon wordt overgeslagen en dat de server uiteindelijk geboot raakt zonder die schijf.

Het probleem ligt wel degelijk aan het feit dat ubuntu blijft zoeken naar de schijf met de UUID die niet weg-gecomment is.
Ik dacht de hele uitleg te doen over hoe ik daar achter gekomen ben maar dat werd wat lang.
Hier komt het op neer: veel shutdown's, vaak schijven fysiek aan en afkoppelen en al dan niet fstab entry's (un)commenten.

Ik heb al de hele dag search strings proberen te bedenken om informatie te vinden op het internet maar heb het opgegeven.

Dit is mijn fstab file voor wat meer informatie:

#Systeem disk
UUID=43b6e27d-8c8c-4725-84dd-3fe2f7c553df     /                 ext4       errors=remount-ro    0       1
UUID=f4730416-109f-4a95-b5b1-5f7be6571731     none            swap      sw                         0       0

#Data disk 1
UUID=F898EE8798EE442A                               /media/Maxtor250GB-SATA-Disk1Paar1                      ntfs     defaults     0     0
/media/Maxtor250GB-SATA-Disk1Paar1             /home/fredje/Maxtor250GB-SATA-Disk1Paar1-Films       none    bind          0     0
/media/Maxtor250GB-SATA-Disk1Paar1             /srv/ftp/Schijf1-Films                                              none    bind          0     0

#Het is normaal dat Data disk 1 in ntfs staat. Data disk 1 en Data disk 2 bevatten exact dezelfde data van toen ik nog op windows een ftp server had.
#Ik wil eerst alle problemen oplossen met de ubuntu server voor ik alles omzet naar een linux fs (en niet meer terug kan naar windows - beetje veilig spelen).

#Data disk 2
UUID=da615817-c244-4e08-9f0b-fb41efb528bc     /media/Maxtor250GB-SATA-Disk2Paar1                             xfs      defaults     0     0
/media/Maxtor250GB-SATA-Disk2Paar1                /home/fredje/Maxtor250GB-SATA-Disk2Paar1-BackupFilms    none    bind          0     0


Weet iemand hier raad mee?
fsck uitschakelen (als dat kan) of andere vermeldingen in fstab of andere manier van mouten ...... I'm just guessing.


Alvast bedankt!

Fredje





Offline Buzzin

  • Lid
  • Steunpunt: Nee
Volgens mij moet je dan de optie soft meegeven, die zorgt ervoor dat het booten gewoon doorgaat.
(weet niet 100% of het ook werkt voor fysieke schijven....bij NFS mounts in ieder geval wel)

UUID=da615817-c244-4e08-9f0b-fb41efb528bc     /media/Maxtor250GB-SATA-Disk2Paar1                             xfs      defaults     0     0

zou dan worden

UUID=da615817-c244-4e08-9f0b-fb41efb528bc     /media/Maxtor250GB-SATA-Disk2Paar1                             xfs      soft,<andere opties>     0     0

Je moet die andere opties dan wel even uitzoeken, default werkt dan niet meer en moet je het dus zelf opgeven.
Football: A battle between two teams of mindless thugs over scraps of coloured cloth. Usually accompanied by the spectacle of 22 overpaid primadonnas kicking a ball on a field.
DebianDevuan, KDE & OperaVivaldi addict, RedHat Engineer

Offline Fredje

  • Lid
  • Steunpunt: Nee
Hee,

Thx voor uw berichtje, dat ga ik zeker eens checken.

Op ubuntuforums.org stelde zij mij ook dit voor:
"Adding the "nobootwait" mount option to the data disk fstab entries should prevent future freezes."

Als ik enkel soft of nobootwait mount options plaats, moeten er dan nog options bijgezet worden die in defaults zaten?



Ik heb nog geen tijd gehad om dit te checken maar van zodra ik iets weet post ik het hier ook!.


Grz,
Fredje