Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Geen geluid op laptop met 6.10, wel met 6.06 `live cd`  (gelezen 1228 keer)

Offline Erik N

  • Lid
    • http://www.rubennieuwenhuis.nl
  • Steunpunt: Nee
Geen geluid op laptop met 6.10, wel met 6.06 `live cd`
« Gepost op: 2006/12/23, 20:38:31 »
Allen
Er staat al erg veel in dit forum als je zoekt op `geluid`, maar ik kom er niet uit. Ik heb  6.10 werkend, maar krijg er geen enkel geluid uit. De geluidskaart doet het wel onder windows en het frappante is dat als ik boot vanaf cd met 6.06 hij ook wel het welkomst geluidje speelt. In 6.10 heb ik geen enkel geluid. Wie heeft tips dan wel verwijzingen naar topics waar ik de oplossing vind.
Het betreft hier een acer aspire 3680 laptop.
Ik heb ook al bij systeem > beheer >gebruikers en groepen > gebruikersrechten gekeken, Daar mag ik alles.

Misschien kunnen jullie iets met de output van amixer info:
Card default 'Intel'/'HDA Intel at 0xd0340000 irq 66'
  Mixer name    : 'Realtek ALC883'
  Components    : 'HDA:10ec0883 HDA:11c13026'
  Controls      : 31
  Simple ctrls  : 19
in afwachting van jullie reacties
Erik N.

Offline Kiwinote

  • Lid
    • Launchpad
  • Steunpunt: Nee
Geen geluid op laptop met 6.10, wel met 6.06 `live cd`
« Reactie #1 Gepost op: 2006/12/23, 21:55:11 »
Je hebt alle volumes omhoog in alsamixer?

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
Geen geluid op laptop met 6.10, wel met 6.06 `live cd`
« Reactie #2 Gepost op: 2006/12/23, 22:10:51 »
ter verduidelijking:

- installeer alsamixergui via Toepassingen - Installeren/verwijderen
- start alsamixergui en gooi 's wat schuifjes open

Groet, Pjotr.

Offline Erik N

  • Lid
    • http://www.rubennieuwenhuis.nl
  • Steunpunt: Nee
Geen geluid op laptop met 6.10, wel met 6.06 `live cd`
« Reactie #3 Gepost op: 2006/12/24, 07:59:39 »
Nou, de eerste waar Head... bij staat, kan ik niet open zetten. Dat slotje staat wel open, maar ik kan het schuifje dus niet schuiven. En er zijn er wel een paar meer die ik niet kan open schuiven.

Offline Kiwinote

  • Lid
    • Launchpad
  • Steunpunt: Nee
Geen geluid op laptop met 6.10, wel met 6.06 `live cd`
« Reactie #4 Gepost op: 2006/12/24, 16:40:33 »
Schuiven doe je met page up en page down in de commando "alsamixer", mute, unmute met de m toets.

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
Geen geluid op laptop met 6.10, wel met 6.06 `live cd`
« Reactie #5 Gepost op: 2006/12/24, 17:31:57 »
Citaat van: Kiwinote
Schuiven doe je met page up en page down in de commando "alsamixer", mute, unmute met de m toets.
Hij heeft alsamixergui, h

Offline Erik N

  • Lid
    • http://www.rubennieuwenhuis.nl
  • Steunpunt: Nee
Geen geluid op laptop met 6.10, wel met 6.06 `live cd`
« Reactie #6 Gepost op: 2006/12/24, 19:55:45 »
hmm, heeft nog geen effect of ik op m druk. Head... (de eerste) kan ik nog steeds niet harder schuiven. Met m in alsamixergui verandert wel de instelling van bijv Head.. maar verder geen geluid. Het blijft stil, wat betreft de laptop. Wie wat weet, laat het weten

moet ik de geluidskaart vinden onder /dev/audio? In nautilus staat daar nl. niet een rood kruisje bij zoals bij /dev/hda tot en met /dev/hda4 en ook geen pijltje zoals bij /dev/cdrom.
kan het zijn dat de kaart niet gemount wordt?

Erik N

Offline Kiwinote

  • Lid
    • Launchpad
  • Steunpunt: Nee
Geen geluid op laptop met 6.10, wel met 6.06 `live cd`
« Reactie #7 Gepost op: 2006/12/24, 21:27:17 »
nee, geluidskaarten worden zover ik weet niet 'gemount'.
Werkt het geluid bij een nieuwe gebruiker wel?

Offline Erik N

  • Lid
    • http://www.rubennieuwenhuis.nl
  • Steunpunt: Nee
Geen geluid op laptop met 6.10, wel met 6.06 `live cd`
« Reactie #8 Gepost op: 2006/12/25, 12:10:26 »
Een nieuwe gebruiker heeft ook geen geluid. Inmiddels heb ik verder gegoogeld en ik kwam dit topic tegen:
http://ubuntuforums.org/showthread.php?t=202555&page=5 Ik moet iets gaan patchen.
Ik kom een heel eind maar op een gegeven moment moet er iets gecompileerd worden met gcc. Dat gaat mij volledig boven de pet, maar de melding is ` cannot create executables. See config.log. Die log file drop ik hieronder even. Wat doe ik fout? (ik heb het gewoon en met sudo geprobeerd) Dit is config.log:
This file contains any messages produced by compilers while
running configure, to aid debugging if configure makes a mistake.

It was created by configure, which was
generated by GNU Autoconf 2.59.  Invocation command line was

  $ ./configure --with-cards=hda-intel

## --------- ##
## Platform. ##
## --------- ##

hostname = myComputer
uname -m = i686
uname -r = 2.6.17-10-generic
uname -s = Linux
uname -v = #2 SMP Tue Dec 5 22:28:26 UTC 2006

/usr/bin/uname -p = unknown
/bin/uname -X     = unknown

/bin/arch              = i686
/usr/bin/arch -k       = unknown
/usr/convex/getsysinfo = unknown
hostinfo               = unknown
/bin/machine           = unknown
/usr/bin/oslevel       = unknown
/bin/universe          = unknown

PATH: /usr/local/sbin
PATH: /usr/local/bin
PATH: /usr/sbin
PATH: /usr/bin
PATH: /sbin
PATH: /bin
PATH: /usr/bin/X11
PATH: /usr/games


## ----------- ##
## Core tests. ##
## ----------- ##

configure:1371: checking for gcc
configure:1387: found /usr/bin/gcc
configure:1397: result: gcc
configure:1641: checking for C compiler version
configure:1644: gcc --version &5
gcc (GCC) 4.1.2 20060928 (prerelease) (Ubuntu 4.1.1-13ubuntu5)
Copyright (C) 2006 Free Software Foundation, Inc.
This is free software; see the source for copying conditions.  There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

configure:1647: $? = 0
configure:1649: gcc -v &5
Using built-in specs.
Target: i486-linux-gnu
Configured with: ../src/configure -v --enable-languages=c,c++,fortran,objc,obj-c++,treelang --prefix=/usr --enable-shared --with-system-zlib --libexecdir=/usr/lib --without-included-gettext --enable-threads=posix --enable-nls --program-suffix=-4.1 --enable-__cxa_atexit --enable-clocale=gnu --enable-libstdcxx-debug --enable-mpfr --enable-checking=release i486-linux-gnu
Thread model: posix
gcc version 4.1.2 20060928 (prerelease) (Ubuntu 4.1.1-13ubuntu5)
configure:1652: $? = 0
configure:1654: gcc -V &5
gcc: '-V' option must have argument
configure:1657: $? = 1
configure:1680: checking for C compiler default output file name
configure:1683: gcc    conftest.c  >&5
/usr/bin/ld: crt1.o: No such file: No such file or directory
collect2: ld returned 1 exit status
configure:1686: $? = 1
configure: failed program was:
| /* confdefs.h.  */
|
| #define PACKAGE_NAME ""
| #define PACKAGE_TARNAME ""
| #define PACKAGE_VERSION ""
| #define PACKAGE_STRING ""
| #define PACKAGE_BUGREPORT ""
| /* end confdefs.h.  */
|
| int
| main ()
| {
|
|   ;
|   return 0;
| }
configure:1725: error: C compiler cannot create executables
See `config.log' for more details.

## ---------------- ##
## Cache variables. ##
## ---------------- ##

ac_cv_env_CC_set=
ac_cv_env_CC_value=
ac_cv_env_CFLAGS_set=
ac_cv_env_CFLAGS_value=
ac_cv_env_CPPFLAGS_set=
ac_cv_env_CPPFLAGS_value=
ac_cv_env_CPP_set=
ac_cv_env_CPP_value=
ac_cv_env_LDFLAGS_set=
ac_cv_env_LDFLAGS_value=
ac_cv_env_build_alias_set=
ac_cv_env_build_alias_value=
ac_cv_env_host_alias_set=
ac_cv_env_host_alias_value=
ac_cv_env_target_alias_set=
ac_cv_env_target_alias_value=
ac_cv_prog_ac_ct_CC=gcc

## ----------------- ##
## Output variables. ##
## ----------------- ##

AR=''
ARCH=''
AS=''
CC='gcc'
CFLAGS=''
CONFIG_ALPHA=''
CONFIG_ARCH_PXA=''
CONFIG_ARCH_S3C2410=''
CONFIG_ARCH_SA1100=''
CONFIG_ARM=''
CONFIG_ARM_AMBA=''
CONFIG_BROKEN=''
CONFIG_EXPERIMENTAL=''
CONFIG_FW_LOADER=''
CONFIG_GSC=''
CONFIG_HAVE_PCSP_HOOK=''
CONFIG_HPET=''
CONFIG_I2C=''
CONFIG_I2C_POWERMAC=''
CONFIG_I2C_SENSOR=''
CONFIG_INPUT=''
CONFIG_ISA=''
CONFIG_ISAPNP=''
CONFIG_ISAPNP_KERNEL=''
CONFIG_ISA_DMA_API=''
CONFIG_L3=''
CONFIG_MIPS=''
CONFIG_PARISC=''
CONFIG_PARPORT=''
CONFIG_PCI=''
CONFIG_PCMCIA=''
CONFIG_PM=''
CONFIG_PNP=''
CONFIG_PNP_KERNEL=''
CONFIG_PPC=''
CONFIG_PPC_PMAC=''
CONFIG_PROC_FS=''
CONFIG_RTC=''
CONFIG_SBUS=''
CONFIG_SGI=''
CONFIG_SND=''
CONFIG_SND_AC97_BUS=''
CONFIG_SND_AC97_CODEC=''
CONFIG_SND_AC97_POWER_SAVE=''
CONFIG_SND_AD1816A=''
CONFIG_SND_AD1848=''
CONFIG_SND_AD1848_LIB=''
CONFIG_SND_AD1889=''
CONFIG_SND_ADLIB=''
CONFIG_SND_ALI5451=''
CONFIG_SND_ALS100=''
CONFIG_SND_ALS300=''
CONFIG_SND_ALS4000=''
CONFIG_SND_AOA=''
CONFIG_SND_AOA_FABRIC_LAYOUT=''
CONFIG_SND_AOA_ONYX=''
CONFIG_SND_AOA_SOUNDBUS=''
CONFIG_SND_AOA_SOUNDBUS_I2S=''
CONFIG_SND_AOA_TAS=''
CONFIG_SND_AOA_TOONIE=''
CONFIG_SND_ARMAACI=''
CONFIG_SND_ASIHPI=''
CONFIG_SND_ATIIXP=''
CONFIG_SND_ATIIXP_MODEM=''
CONFIG_SND_AU1X00=''
CONFIG_SND_AU8810=''
CONFIG_SND_AU8820=''
CONFIG_SND_AU8830=''
CONFIG_SND_AZT2320=''
CONFIG_SND_AZT3328=''
CONFIG_SND_BIT32_EMUL=''
CONFIG_SND_BT87X=''
CONFIG_SND_BT87X_OVERCLOCK=''
CONFIG_SND_CA0106=''
CONFIG_SND_CMI8330=''
CONFIG_SND_CMIPCI=''
CONFIG_SND_CS4231=''
CONFIG_SND_CS4231_LIB=''
CONFIG_SND_CS4232=''
CONFIG_SND_CS4236=''
CONFIG_SND_CS4281=''
CONFIG_SND_CS46XX=''
CONFIG_SND_CS46XX_NEW_DSP=''
CONFIG_SND_CS5535AUDIO=''
CONFIG_SND_DARLA20=''
CONFIG_SND_DARLA24=''
CONFIG_SND_DATE=''
CONFIG_SND_DEBUG=''
CONFIG_SND_DEBUG_DETECT=''
CONFIG_SND_DEBUG_MEMORY=''
CONFIG_SND_DT019X=''
CONFIG_SND_DUMMY=''
CONFIG_SND_DYNAMIC_MINORS=''
CONFIG_SND_ECHO3G=''
CONFIG_SND_EMU10K1=''
CONFIG_SND_EMU10K1X=''
CONFIG_SND_ENS1370=''
CONFIG_SND_ENS1371=''
CONFIG_SND_ES1688=''
CONFIG_SND_ES18XX=''
CONFIG_SND_ES1938=''
CONFIG_SND_ES1968=''
CONFIG_SND_ES968=''
CONFIG_SND_FM801=''
CONFIG_SND_FM801_TEA575X=''
CONFIG_SND_FM801_TEA575X_BOOL=''
CONFIG_SND_GINA20=''
CONFIG_SND_GINA24=''
CONFIG_SND_GUSCLASSIC=''
CONFIG_SND_GUSEXTREME=''
CONFIG_SND_GUSMAX=''
CONFIG_SND_GUS_SYNTH=''
CONFIG_SND_HARMONY=''
CONFIG_SND_HDA_INTEL=''
CONFIG_SND_HDSP=''
CONFIG_SND_HDSPM=''
CONFIG_SND_HPET=''
CONFIG_SND_HWDEP=''
CONFIG_SND_ICE1712=''
CONFIG_SND_ICE1724=''
CONFIG_SND_INDIGO=''
CONFIG_SND_INDIGODJ=''
CONFIG_SND_INDIGOIO=''
CONFIG_SND_INTEL8X0=''
CONFIG_SND_INTEL8X0M=''
CONFIG_SND_INTERWAVE=''
CONFIG_SND_INTERWAVE_STB=''
CONFIG_SND_KERNELDIR=''
CONFIG_SND_KORG1212=''
CONFIG_SND_LAYLA20=''
CONFIG_SND_LAYLA24=''
CONFIG_SND_LOOPBACK=''
CONFIG_SND_MAESTRO3=''
CONFIG_SND_MIA=''
CONFIG_SND_MIRO=''
CONFIG_SND_MIXART=''
CONFIG_SND_MIXER_OSS=''
CONFIG_SND_MONA=''
CONFIG_SND_MPU401=''
CONFIG_SND_MPU401_UART=''
CONFIG_SND_MSND_PINNACLE=''
CONFIG_SND_MTPAV=''
CONFIG_SND_MTS64=''
CONFIG_SND_MVERSION=''
CONFIG_SND_NM256=''
CONFIG_SND_OPL3SA2=''
CONFIG_SND_OPL3_LIB=''
CONFIG_SND_OPL4_LIB=''
CONFIG_SND_OPTI92X_AD1848=''
CONFIG_SND_OPTI92X_CS4231=''
CONFIG_SND_OPTI93X=''
CONFIG_SND_OSSEMUL=''
CONFIG_SND_PC98_CS4232=''
CONFIG_SND_PCM=''
CONFIG_SND_PCM_OSS=''
CONFIG_SND_PCM_OSS_PLUGINS=''
CONFIG_SND_PCM_XRUN_DEBUG=''
CONFIG_SND_PCSP=''
CONFIG_SND_PCXHR=''
CONFIG_SND_PDAUDIOCF=''
CONFIG_SND_PDPLUS=''
CONFIG_SND_PORTMAN2X4=''
CONFIG_SND_POWERMAC=''
CONFIG_SND_POWERMAC_AUTO_DRC=''
CONFIG_SND_PXA2XX_AC97=''
CONFIG_SND_PXA2XX_I2SOUND=''
CONFIG_SND_PXA2XX_PCM=''
CONFIG_SND_RAWMIDI=''
CONFIG_SND_RIPTIDE=''
CONFIG_SND_RME32=''
CONFIG_SND_RME9652=''
CONFIG_SND_RME96=''
CONFIG_SND_RTCTIMER=''
CONFIG_SND_S3C2410=''
CONFIG_SND_SA11XX_UDA1341=''
CONFIG_SND_SB16=''
CONFIG_SND_SB16_CSP=''
CONFIG_SND_SB8=''
CONFIG_SND_SBAWE=''
CONFIG_SND_SEQUENCER=''
CONFIG_SND_SEQUENCER_OSS=''
CONFIG_SND_SEQ_DUMMY=''
CONFIG_SND_SEQ_RTCTIMER_DEFAULT=''
CONFIG_SND_SERIALMIDI=''
CONFIG_SND_SERIAL_U16550=''
CONFIG_SND_SGALAXY=''
CONFIG_SND_SONICVIBES=''
CONFIG_SND_SSCAPE=''
CONFIG_SND_SUN_AMD7930=''
CONFIG_SND_SUN_CS4231=''
CONFIG_SND_SUN_DBRI=''
CONFIG_SND_SUPPORT_OLD_API=''
CONFIG_SND_TIMER=''
CONFIG_SND_TRIDENT=''
CONFIG_SND_USB_AUDIO=''
CONFIG_SND_USB_USX2Y=''
CONFIG_SND_VERBOSE_PRINTK=''
CONFIG_SND_VERBOSE_PROCFS=''
CONFIG_SND_VERSION='1.0.12rc3'
CONFIG_SND_VIA82XX=''
CONFIG_SND_VIA82XX_MODEM=''
CONFIG_SND_VIRMIDI=''
CONFIG_SND_VX222=''
CONFIG_SND_VXPOCKET=''
CONFIG_SND_VX_LIB=''
CONFIG_SND_WAVEFRONT=''
CONFIG_SND_YMFPCI=''
CONFIG_SOC_AU1000=''
CONFIG_SOC_AU1100=''
CONFIG_SOC_AU1500=''
CONFIG_SOUND=''
CONFIG_SOUND_PRIME=''
CONFIG_SPARC32=''
CONFIG_SPARC64=''
CONFIG_SPARC=''
CONFIG_USB=''
CONFIG_VIDEO_DEV=''
CONFIG_X86=''
CONFIG_X86_32=''
CONFIG_X86_64=''
CONFIG_X86_PC9800=''
CPP=''
CPPFLAGS=''
CROSS_COMPILE=''
DEFS=''
ECHO_C=''
ECHO_N='-n'
ECHO_T=''
EGREP=''
EXEEXT=''
EXTRA_INCLUDES=''
GENKSYMS=''
INSTALL_DATA=''
INSTALL_PROGRAM=''
INSTALL_SCRIPT=''
KERNEL_INC=''
KLD=''
LDFLAGS=''
LIBOBJS=''
LIBS=''
LTLIBOBJS=''
MAKE_ADDS=''
NEW_KBUILD=''
OBJEXT=''
PACKAGE_BUGREPORT=''
PACKAGE_NAME=''
PACKAGE_STRING=''
PACKAGE_TARNAME=''
PACKAGE_VERSION=''
PATH_SEPARATOR=':'
RANLIB=''
SHELL='/bin/bash'
SRCDIR=''
ac_ct_CC='gcc'
ac_ct_RANLIB=''
bindir='${exec_prefix}/bin'
build_alias=''
c_opts=''
datadir='${prefix}/share'
exec_prefix='NONE'
host_alias=''
includedir='${prefix}/include'
infodir='${prefix}/info'
kaversion=''
kextraversion=''
kpatchlevel=''
ksublevel=''
kversion=''
libdir='${exec_prefix}/lib'
libexecdir='${exec_prefix}/libexec'
localstatedir='${prefix}/var'
m_opts=''
mandir='${prefix}/man'
moddir=''
moddir_tree=''
modsubdir=''
msmp=''
oldincludedir='/usr/include'
prefix='NONE'
processor=''
program_transform_name='s,x,x,'
sbindir='${exec_prefix}/sbin'
sharedstatedir='${prefix}/com'
sysconfdir='${prefix}/etc'
target_alias=''

## ----------- ##
## confdefs.h. ##
## ----------- ##

#define PACKAGE_BUGREPORT ""
#define PACKAGE_NAME ""
#define PACKAGE_STRING ""
#define PACKAGE_TARNAME ""
#define PACKAGE_VERSION ""

configure: exit 77

Offline Kiwinote

  • Lid
    • Launchpad
  • Steunpunt: Nee
Geen geluid op laptop met 6.10, wel met 6.06 `live cd`
« Reactie #9 Gepost op: 2006/12/25, 17:00:50 »
Heb je build-essential geinstalleerd?

Offline Erik N

  • Lid
    • http://www.rubennieuwenhuis.nl
  • Steunpunt: Nee
Geen geluid op laptop met 6.10, wel met 6.06 `live cd`
« Reactie #10 Gepost op: 2006/12/25, 17:55:49 »
Nu wel, met apt-get install build-essential. Maar hoe start ik dat progje en wat kan ik er mee? Als ik nu in de terminal tokkel sudo build-essential zegt ie commando niet gevonden

Offline Kiwinote

  • Lid
    • Launchpad
  • Steunpunt: Nee
Geen geluid op laptop met 6.10, wel met 6.06 `live cd`
« Reactie #11 Gepost op: 2006/12/25, 17:58:36 »
sudo apt-get install build-essential installeert een aantal pakketen die nodig zijn voor het compilen van packages. Probeer nu opnieuw het commando uit te voeren (ik neem aan dat het bij make misging?)

Offline Erik N

  • Lid
    • http://www.rubennieuwenhuis.nl
  • Steunpunt: Nee
Geen geluid op laptop met 6.10, wel met 6.06 `live cd`
« Reactie #12 Gepost op: 2006/12/25, 22:32:05 »
Yesssssss! 't Is opgelost. Dank voor het meedenken. Vervolgens heb ik de stappen uit http://ubuntuforums.org/showthread.php?t=202555&page=5 doorlopen en nu heb ik geluid. Nogmaals dank voor de support.

Erik N.