Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Opstartprobleem met aankoppelen  (gelezen 1539 keer)

Offline WGM50

  • Lid
  • Steunpunt: Nee
Opstartprobleem met aankoppelen
« Gepost op: 2010/10/06, 17:03:33 »
Ik heb iets gedaan met het ontkoppelen van een medium (ik dacht een USB-schijf te ontkoppelen, maar deed mogelijk iets anders). Sindsdien heb ik een melding bij het opstarten:
Het schijfstation voor /media/sdf1 is niet gereed of niet aanwezig.
...druk S om het aankoppelen over te slaan, of M voor handmatig...
De puntjes vallen buiten beeld.
Als ik S kies gaat het opstarten gewoon verder, bij M gebeurt er niets.
Ik heb vast iets zelf verkeerd gedaan, maar weet niet wat.
Hoe los ik dit op?
groet, Pim
Ubuntu 11.10 * Toshiba * Evolution *  Libre Office * Firefox

Offline Thomas de Graaff

  • Lid
  • Steunpunt: Nee
Re: Opstartprobleem met aankoppelen
« Reactie #1 Gepost op: 2010/10/06, 17:10:03 »
Waarschijnlijk staat het medium dat bij het opstarten aangekoppeld wil worden in /etc/fstab. Als je in een terminal het volgende commando uitvoert, en de uitvoer knipt en hier plakt, dan weten we wellicht meer:
cat /etc/fstab

Offline WGM50

  • Lid
  • Steunpunt: Nee
Re: Opstartprobleem met aankoppelen
« Reactie #2 Gepost op: 2010/10/06, 17:15:27 »
Bij genoemd commando krijg ik het volgende:

# /etc/fstab: static file system information.
#
# Use 'blkid -o value -s UUID' to print the universally unique identifier
# for a device; this may be used with UUID= as a more robust way to name
# devices that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc                                       /proc           proc  nodev,noexec,nosuid       0  0 
/dev/sda1                                  /               ext4  errors=remount-ro         0  1 
# swap was on /dev/sda5 during installation
UUID=90efcc38-299f-45ce-aff5-67917c66e84f  none            swap  defaults                  0  0 
/dev/fd0                                   /media/floppy0  auto  rw,user,noauto,exec,utf8  0  0 
/dev/sdf1                                  /media/sdf1     ntfs  defaults                  0  0 

Geeft dat duidelijkheid?
groet, Pim
Ubuntu 11.10 * Toshiba * Evolution *  Libre Office * Firefox

Offline Thomas de Graaff

  • Lid
  • Steunpunt: Nee
Re: Opstartprobleem met aankoppelen
« Reactie #3 Gepost op: 2010/10/06, 18:08:04 »
Ja, de laatste regel is een opdracht om het medium sdf1 automatisch aan te koppelen bij het opstarten. Dat lukt dus niet bij het opstarten.

Als je de situatie na het opstarten nu, als je dus op s gedrukt hebt, is zoals je die wenst, en alle schijven die je nodig hebt zijn aangekoppeld, dan kan je de laatste regel uit /etc/fstab gewoon verwijderen. Dit kan met het volgende commando:

sudo sed -i 's/^.*sdf1.*$//g' /etc/fstab
Waarna je je wachtwoord moet geven.

Maar het kan ook met een editor, bijvoorbeeld gedit. Dan start je deze met sudo op, bijvoorbeeld in een terminal "sudo gedit".

Er is geloof ik ook een grafische tool om fstab te bewerken, maar ik weet zo niet welke dat is.

Offline WGM50

  • Lid
  • Steunpunt: Nee
Re: Opstartprobleem met aankoppelen
« Reactie #4 Gepost op: 2010/10/06, 18:17:29 »
Bedankt Thomas, het is gelukt met je aanwijzingen. De PC start weer gewoon door.

groet, Pim
Ubuntu 11.10 * Toshiba * Evolution *  Libre Office * Firefox

Offline elendil

  • Lid
  • Steunpunt: Nee
Re: Opstartprobleem met aankoppelen
« Reactie #5 Gepost op: 2010/10/06, 18:24:50 »
Ja, de laatste regel is een opdracht om het medium sdf1 automatisch aan te koppelen bij het opstarten. Dat lukt dus niet bij het opstarten.

Als je de situatie na het opstarten nu, als je dus op s gedrukt hebt, is zoals je die wenst, en alle schijven die je nodig hebt zijn aangekoppeld, dan kan je de laatste regel uit /etc/fstab gewoon verwijderen. Dit kan met het volgende commando:

sudo sed -i 's/^.*sdf1.*$//g' /etc/fstab

Thomas, misschien een heel stomme vraag, maar kun je uitleggen wat er met de regel wordt bedoeld?


-=[ Not all those who wander are lost ]=-

Offline Thomas de Graaff

  • Lid
  • Steunpunt: Nee
Re: Opstartprobleem met aankoppelen
« Reactie #6 Gepost op: 2010/10/07, 12:04:35 »
Die laatste regel is in mensentaal: "Zoek in de regels van het bestandje /etc/fstab naar regels waarin de tekst "sdf1" voorkomt, en als je zo'n regel tegenkomt vervang de tekst in deze regel dan door niets, en doe dit als gebruiker met beheerders rechten."

Offline elendil

  • Lid
  • Steunpunt: Nee
Re: Opstartprobleem met aankoppelen
« Reactie #7 Gepost op: 2010/10/07, 19:11:53 »
Die laatste regel is in mensentaal: "Zoek in de regels van het bestandje /etc/fstab naar regels waarin de tekst "sdf1" voorkomt, en als je zo'n regel tegenkomt vervang de tekst in deze regel dan door niets, en doe dit als gebruiker met beheerders rechten."
Even zodat ik het snap (het is nog erger dan het zinsontleden van vroeger) :)

sudo         - beheerder
sed           - gebruik de stream editor
-i              - op de plek
's/^.         - ???
*sdf1.*     - waar je deze tekst tegen komt
$              - in de laatste regel
//             - ???
g              - en vervang die tekst door spatie
/etc/fstab - en wel in de file /ect/fstab 

als ik 'man sed' tenminste goed heb (afgezien van de rode onbekenden) doorgeplozen.


-=[ Not all those who wander are lost ]=-

Offline Thomas de Graaff

  • Lid
  • Steunpunt: Nee
Re: Opstartprobleem met aankoppelen
« Reactie #8 Gepost op: 2010/10/07, 20:10:15 »
Bijna. :)

s    -substitute (vervang) edit: of misschien wel search, dat weet ik niet. ;)
/zoekpatroon/vervangende tekst/
/    - scheidingsteken
g    - globaal (doorzoek het hele document)

in het zoekpatroon een reguliere expressie:
^   - teken dat begin van en regel aangeeft
.     - kan vervangen worden door ieder teken
*    - voorgaande komt 0 of meer malen voor
$    - geeft einde van een regel aan

Zoek maar eens op bash, sed en regular expressions in google, dan vind je zo genoeg voorbeelden.
« Laatst bewerkt op: 2010/10/07, 20:15:47 door Thomas de Graaff »

Offline elendil

  • Lid
  • Steunpunt: Nee
Re: Opstartprobleem met aankoppelen
« Reactie #9 Gepost op: 2010/10/07, 22:45:37 »
Bedankt Thomas!
Het gebruik van dit soort expressies is toch moeilijker dan je denkt. Zal ook wel door de leeftijd komen dat je dingen minder snel oppikt  =D


-=[ Not all those who wander are lost ]=-