Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Philips DVB-T hybrid kaart werkt niet [Opgelost]  (gelezen 1797 keer)

Offline koen_92

  • Lid
  • Steunpunt: Nee
Philips DVB-T hybrid kaart werkt niet [Opgelost]
« Gepost op: 2010/10/05, 16:43:08 »
Hallo,

Ik heb een Philips DVB-T hybrid kaart, die zowel DVB-T (Dus Digitenne) als Kabel-tv kan weergeven.
Kabel-tv heb ik niets aan, want waar ik woon ligt geen kabel, dus ik wil hem voor Digitenne gebruiken.

Het probleem is echter dat dit niet werkt. Het analoge kabel-gedeelte wordt perfect herkend, maar hier heb ik dus niets aan.
Met het DVB-T gedeelte zijn dus wat problemen.

Het gaat om deze kaart:
koen@ubuntu:~$ lspci -v|grep -i saa
03:06.0 Multimedia controller: Philips Semiconductors SAA7134/SAA7135HL Video Broadcast Decoder (rev 01)
Kernel driver in use: saa7134
Kernel modules: saa7134

De saa7134 driver is hier in gebruik. Hiermee is het analoge gedeelte van de kaart te gebruiken.
Voor DVB-T moet de saa7134-dvb driver geladen worden, en hier gaat het dus fout:

koen@ubuntu:~$ sudo insmod /lib/modules/2.6.32-25-generic-pae/kernel/drivers/media/video/saa7134/saa7134-dvb.ko
insmod: error inserting '/lib/modules/2.6.32-25-generic-pae/kernel/drivers/media/video/saa7134/saa7134-dvb.ko': -1 Unknown symbol in module
koen@ubuntu:~$

Weet iemand hier een oplossing voor?

Dit geeft dmesg trouwens over de kaart:
[  211.946422] saa7134_dvb: disagrees about version of symbol module_layout
[  227.731322] saa7134_dvb: Unknown symbol videobuf_dvb_alloc_frontend
[  227.732106] saa7134_dvb: Unknown symbol videobuf_dvb_get_frontend
[  227.733051] saa7134_dvb: Unknown symbol videobuf_dvb_unregister_bus
[  227.733319] saa7134_dvb: Unknown symbol videobuf_dvb_register_bus
[  227.733630] saa7134_dvb: Unknown symbol videobuf_dvb_dealloc_frontends
[  236.974197] saa7134_dvb: Unknown symbol videobuf_dvb_alloc_frontend
[  236.974979] saa7134_dvb: Unknown symbol videobuf_dvb_get_frontend
[  236.975865] saa7134_dvb: Unknown symbol videobuf_dvb_unregister_bus
[  236.976180] saa7134_dvb: Unknown symbol videobuf_dvb_register_bus
[  236.976488] saa7134_dvb: Unknown symbol videobuf_dvb_dealloc_frontends
« Laatst bewerkt op: 2010/10/09, 19:41:17 door koen_92 »

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Re: Philips DVB-T hybrid kaart werkt niet
« Reactie #1 Gepost op: 2010/10/05, 16:58:40 »
Is het merk kaart ook Philips ???
Meestal is het alleen de gebruikte chip die herkent wordt als zodanig.
Van merk tot merk zit er een verschil in zoal het kaartnummer, tuner, audio etc. Dus als je een merk en type weet graag.
 Ik heb bijv een Eminent kaart:
gijs@gijs-desktop:~$ lspci -v|grep -i saa
04:00.0 Multimedia controller: Philips Semiconductors SAA7131/SAA7133/SAA7135 Video Broadcast Decoder (rev d1)
   Kernel driver in use: saa7134
   Kernel modules: saa7134

Dit staat in mijn modprobe.d/saa7134.conf
options saa7134 card=5 tuner=54
##install saa7133 /sbin/modprobe --ignore-install saa7133; /sbin/modprobe saa7133-alsa
options saa7133-alsa index=-2
modprobe tda9887 port1=0 qss=0 Dit verschilt per merk, dit kan je niet zomaar overnemen.
In der Beschränkung zeigt sich der Meister.

Offline koen_92

  • Lid
  • Steunpunt: Nee
Re: Philips DVB-T hybrid kaart werkt niet
« Reactie #2 Gepost op: 2010/10/05, 18:19:37 »
Om precies te zijn heb ik de volgende kaart gekocht:
http://cgi.ebay.com/ws/eBayISAPI.dll?ViewItem&item=220671347907&ssPageName=STRK:MEWNX:IT

Ik heb alleen de kaart thuisggekregen, zonder doosje oid.

Maar hoe kom jij aan die instellingen?

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Re: Philips DVB-T hybrid kaart werkt niet
« Reactie #3 Gepost op: 2010/10/05, 19:42:59 »
Jammer staat er niet ergens een sticker o.i.d.?
Heel veel gelezen op internet over de saa 7134 chip, zelfs de data sheet, en aan de hand daarvan de de diverse instellingen uitgeprobeerd tot dat ik de juiste instelling had. Ik moet nu weg , maar ik zal later op de avond wat links plaatsen.
In der Beschränkung zeigt sich der Meister.

Offline koen_92

  • Lid
  • Steunpunt: Nee
Re: Philips DVB-T hybrid kaart werkt niet
« Reactie #4 Gepost op: 2010/10/09, 14:26:21 »
Ok, bedankt voor de informatie.

Heb jij zelf ook zo'n Philips tv kaart?
En welke dan?

Maar het probleem is opgelost, en wel op een heel vreemde manier:
Het werkt ineens!
Vandaag probeerde ik voor de grap eens met tzap naar een kanaal te tunen, en /dev/dvb/adapter0 bestaat ineens!
Ik heb werkelijk niets veranderd de afgelopen dagen, dus ik heb geen flauw idee hoe dat gekomen is, maar het werkt nu dus.

Het enige nadeel vind ik dit:
koen@ubuntu:~$ tzap -r "Nederland 1"
using '/dev/dvb/adapter0/frontend0' and '/dev/dvb/adapter0/demux0'
reading channels from file '/home/koen/.tzap/channels.conf'
ERROR: failed opening '/dev/dvb/adapter0/frontend0' (Permission denied)
koen@ubuntu:~$

Dit is op te lossen, door hetzelfde commando als root uit te voeren, maar dat wil ik liever niet (want dan moeten grafische programma's als gnome-dvb ook als root draaien)
Weet iemand misschien een manier om dit zonder sudo te doen?

Offline ivo

  • Lid
  • Steunpunt: Nee
Re: Philips DVB-T hybrid kaart werkt niet
« Reactie #5 Gepost op: 2010/10/09, 16:50:48 »
die frontend0 staat nu alleen voor read/write open voor eigenaar root en groep video.

crw-rw----+ 1 root video 212, 3 2010-10-09 11:58 frontend0

Die zou je voor others dan ook op rw moeten zetten
sudo chmod o=rw /dev/dvb/adapter0/frontend0

Óf je kunt jezelf aan de groep video toevoegen, dat is wat veiliger dan bovenstaande.
Hahaha, ik zie nu dat ik dat bij mezelf ook heb gedaan  =D

inaninck@LT9:/etc$ grep video /etc/group
video:x:44:inaninck

There are only 10 types of people in the world; those who understand binary and those who don't.

Offline koen_92

  • Lid
  • Steunpunt: Nee
Re: Philips DVB-T hybrid kaart werkt niet
« Reactie #6 Gepost op: 2010/10/09, 19:41:06 »
He het werkt.

Dankje!