Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: automatisch mounten backup-schijf  (gelezen 1482 keer)

Offline Anke-Ubuntu

  • Lid
  • Steunpunt: Nee
automatisch mounten backup-schijf
« Gepost op: 2010/10/02, 19:58:51 »
Mijn extra schijf (als backup-schijf) in mijn PC-kast zou ik graag automatisch willen mounten.
Ik heb het programmaatje (via synaptic) Mount manager gebruikt
dat is gedeeltelijk goed gegaan, want het geeft aan dat als je geen ROOT bent
dat je dan /etc/fstab content zelf weer moet herstellen.

Ik had de vraag 'administrator'  mag het uitvoeren aangevinkt,
maar dat was dus niet voldoende.
Het vond mij geen Root en dus moet ik het zelf herstellen.
Gevolg:
de schijf is nu dev/sdb1
geeft een foutmelding bij het opstarten van het systeem (ubuntu 10.4)
en ik kan de schijf niet meer handmatig mounten.

ik vind in home: /etc/fstab (01okt.)
en fstab-ntfs-config-save (30 sept.)
zou ik de inhoud van /etc/fstab moet overschrijven met de inhoud van fstab-ntfs-config-save??
en hoe doe ik dat?

Ik hoop dat iemand hierop een duidelijk antwoord weet, want mijn mail staat op deze extra schijf, en ook mijn backup-bestanden staan hierop

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Re: automatisch mounten backup-schijf
« Reactie #1 Gepost op: 2010/10/02, 20:43:48 »
Ik gebruik altijd Systeem>Beheer>Schijfgereedschap hiervoor. Grafisch mounten en umounten.
In der Beschränkung zeigt sich der Meister.

Offline Anke-Ubuntu

  • Lid
  • Steunpunt: Nee
Re: automatisch mounten backup-schijf
« Reactie #2 Gepost op: 2010/10/02, 21:21:02 »
Helaas krijg ik dan onderstaande foutmelding
Error mounting: mount exited with exit code 1: helper failed with:
mount: /media/Backup-schijf not mounted already, or bad option

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Re: automatisch mounten backup-schijf
« Reactie #3 Gepost op: 2010/10/02, 21:59:58 »
Kan je een terminal openen en daar typen sudo gedit /etc/mtab en de uitkomst hier kunnen plaatsen?
En als je toch in de terminal zit sudo fdisk -l
In der Beschränkung zeigt sich der Meister.

Offline Anke-Ubuntu

  • Lid
  • Steunpunt: Nee
Re: automatisch mounten backup-schijf
« Reactie #4 Gepost op: 2010/10/02, 22:09:16 »
sudo gedit /etc/mtab:
/dev/sda1 / ext4 rw 0 0
none /proc proc rw,noexec,nosuid,nodev 0 0
none /sys sysfs rw,noexec,nosuid,nodev 0 0
none /sys/fs/fuse/connections fusectl rw 0 0
none /sys/kernel/debug debugfs rw 0 0
none /sys/kernel/security securityfs rw 0 0
none /dev devtmpfs rw,mode=0755 0 0
none /dev/pts devpts rw,noexec,nosuid,gid=5,mode=0620 0 0
none /dev/shm tmpfs rw,nosuid,nodev 0 0
none /var/run tmpfs rw,nosuid,mode=0755 0 0
none /var/lock tmpfs rw,noexec,nosuid,nodev 0 0
none /lib/init/rw tmpfs rw,nosuid,mode=0755 0 0
binfmt_misc /proc/sys/fs/binfmt_misc binfmt_misc rw,noexec,nosuid,nodev 0 0
gvfs-fuse-daemon /home/kampinga/.gvfs fuse.gvfs-fuse-daemon rw,nosuid,nodev,user=kampinga 0 0

sudo fdisk -l
Schijf /dev/sda: 160.0 GB, 160041885696 bytes
255 koppen, 63 sectoren/spoor, 19457 cilinders
Eenheid = cilinders van 16065 * 512 = 8225280 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Schijf-ID: 0x0004c9d0

 Apparaat Opstart   Begin       Einde     Blokken   ID  Systeem
/dev/sda1   *           1       19084   153283584   83  Linux
/dev/sda2           19084       19458     3004417    5  Uitgebreid
/dev/sda5           19084       19458     3004416   82  Linux wisselgeheugen

Schijf /dev/sdb: 82.0 GB, 81964302336 bytes
255 koppen, 63 sectoren/spoor, 9964 cilinders
Eenheid = cilinders van 16065 * 512 = 8225280 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Schijf-ID: 0x602e8799

 Apparaat Opstart   Begin       Einde     Blokken   ID  Systeem
/dev/sdb1               1        9964    80035798+  83  Linux

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Re: automatisch mounten backup-schijf
« Reactie #5 Gepost op: 2010/10/02, 22:26:22 »
Vreemd? Is sdb1 je USB schijf?

Bij mij staat dit:
Schijf /dev/sdg: 1000.2 GB, 1000204886016 bytes
255 koppen, 63 sectoren/spoor, 121601 cilinders
Eenheid = cilinders van 16065 * 512 = 8225280 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Schijf-ID: 0x00005653

 Apparaat Opstart   Begin       Einde     Blokken   ID  Systeem
/dev/sdg1   *           1      121601   976760001    c  W95 FAT32 (LBA)
In der Beschränkung zeigt sich der Meister.

Offline Anke-Ubuntu

  • Lid
  • Steunpunt: Nee
Re: automatisch mounten backup-schijf
« Reactie #6 Gepost op: 2010/10/02, 22:58:21 »
sdb1 was eerst de backup-schijf (aparte schijf in mijn PC-kast);
ik mounten deze steeds handmatig als backup-schijf,
maar wilde dit automatisch met het starten van het systeem laten doen.

Hiervoor heb ik het programma mount manager gebruikt (via synaptic verkregen).
daardoor is de backup-schijf sdb1 geworden,
bij het opstarten probeert het systeem deze te mounten maar dat lukt niet.
Er komt een foutmelding en de melding S om het mounten over te slaan of M om handmatig te herstellen.
Dit laatste lukt dus niet.

Mount manager heeft de inhoud van fstab gesaved (zie eerste bericht) maar ik weet niet wat
ik precies met die inhoud moet doen om het automatisch mounten mogelijk te maken.
Inmiddels geeft handmatig mounten ook een foutmelding en lukt dus ook niet meer.

inhoud fstab:
UUID=c6d5878a-8bfa-4301-b6e8-57caba2b5890 /media/Backup-schijf ext3 remount,users 1 0
UUID=7591100e-2d9c-4f76-a7c7-a63c0bf92e39 / ext4 defaults 0 1
UUID=f59abcf7-7818-4e2e-bd8d-2a59e1587cc7 swap swap sw 0 0

inhoud fstab-ntfs-config-save:
# /etc/fstab: static file system information.
#
# Use 'blkid -o value -s UUID' to print the universally unique identifier
# for a device; this may be used with UUID= as a more robust way to name
# devices that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    nodev,noexec,nosuid 0       0
/dev/sda1       /               ext4    errors=remount-ro 0       1
# swap was on /dev/sda5 during installation
UUID=f59abcf7-7818-4e2e-bd8d-2a59e1587cc7 none            swap    sw              0       0
/dev/fd0        /media/floppy0  auto    rw,user,noauto,exec,utf8 0       0

misschien moet ik deze laatste inhoud over de inhoud van fstab schrijven?

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Re: automatisch mounten backup-schijf
« Reactie #7 Gepost op: 2010/10/02, 23:16:37 »
Mijn excuses, niet helemaal juist je eerste bericht gelezen.
Open een terminal en type sudo blkid
Open nog een terminal en type cat /etc/fstab
Verander de UUID die niet overeenkomt.
Bij mij ziet het erzo uit.
gijs@gijs-desktop:~$ sudo blkid
[sudo] password for gijs:
/dev/sdb1: UUID="d674dc0b-6e05-4654-ac27-c9ab3ed36d9c" TYPE="ext4"
/dev/sdb3: UUID="f85a28f6-d7d8-4cf2-9aa5-d3d2f44d4cf6" TYPE="ext4"
/dev/sdb5: UUID="897ec714-9176-4834-b6d2-fc8e49378309" TYPE="swap"
/dev/sda1: UUID="55655d6f-46fa-4187-a9be-e8958b6e6cbf" SEC_TYPE="ext2" TYPE="ext3"
/dev/sda2: UUID="fffacf1c-2ca8-4a3a-898a-7832796a3945" TYPE="swap"
/dev/sda3: LABEL="sdahome" UUID="ad93d423-873b-4fe4-a138-30abdace0765" SEC_TYPE="ext2" TYPE="ext3"
/dev/sda4: UUID="5967f20b-5878-43f4-8405-444a9982689c" TYPE="ext4"
/dev/sdg1: LABEL="PACKARDBELL" UUID="1204-4237" TYPE="vfat"
gijs@gijs-desktop:~$ cat /etc/fstab
# /etc/fstab: static file system information.
#
# Use 'blkid -o value -s UUID' to print the universally unique identifier
# for a device; this may be used with UUID= as a more robust way to name
# devices that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    nodev,noexec,nosuid 0       0
# / was on /dev/sdb1 during installation
UUID=d674dc0b-6e05-4654-ac27-c9ab3ed36d9c /               ext4    errors=remount-ro 0       1
# /home was on /dev/sdb3 during installation
UUID=f85a28f6-d7d8-4cf2-9aa5-d3d2f44d4cf6 /home           ext4    defaults        0       2
# swap was on /dev/sdb5 during installation
UUID=897ec714-9176-4834-b6d2-fc8e49378309 none            swap    sw              0       0
/dev/fd0        /media/floppy0  auto    rw,user,noauto,exec,utf8 0       0
gijs@gijs-desktop:~$
In der Beschränkung zeigt sich der Meister.

Offline Wiley

  • Lid
  • Steunpunt: Nee
Re: automatisch mounten backup-schijf
« Reactie #8 Gepost op: 2010/10/02, 23:22:06 »
Hoi,

Je hoeft de fstab niet terug te veranderen, hij doet in principe nog hetzelfde alleen met UUID's in plaats van device namen (/dev/sda1 bijvoorbeeld).

Ik begrijp niet waarom je de opties remount,users hebt staan bij je backup schijf. remount lijkt me niet nodig, en users is alleen nodig als je jezelf en andere gebruikers de schijf  continu wil laten mounten en unmounten. Maar als je de backupschijf gewoon net zoals de andere schijf continu  gemount wil hebben (en evt. met sudo umounten) dan kun je beter defaults kiezen:
UUID=c6d5878a-8bfa-4301-b6e8-57caba2b5890 /media/Backup-schijf ext3 defaults 0 2Aan het eind heb ik ook nog 1 0 gewijzigd in 0 2 (geen dump, wel filesystem check).

De tip van Gijsbert is ook goed, zeker even doen, hoewel ik vermoed dat het aan de remount,users moet liggen, gezien de foutmelding van 'schijfgereedschap';  Je kan ook dan ook nog eens sudo mount -a uitproberen, zien of daar dezelfde foutmelding uit komt.

« Laatst bewerkt op: 2010/10/02, 23:28:20 door Wiley »

Offline Anke-Ubuntu

  • Lid
  • Steunpunt: Nee
Re: automatisch mounten backup-schijf
« Reactie #9 Gepost op: 2010/10/03, 12:31:12 »
Kan ik zondermeer de ene regel in Fstab wijzigen?
moet dat via de terminal?
of het tekstbestandje wijzigen?

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Re: automatisch mounten backup-schijf
« Reactie #10 Gepost op: 2010/10/03, 12:48:41 »
Ja alleen de ene regel wijzigen. In de terminal sudo gedit /etc/fstab
In der Beschränkung zeigt sich der Meister.

Offline Anke-Ubuntu

  • Lid
  • Steunpunt: Nee
OPGELOST:Re: automatisch mounten backup-schijf
« Reactie #11 Gepost op: 2010/10/03, 13:14:13 »
Ja, het is gelukt, de backup-schijf wordt automatisch bij het opstarten gemount.
Hartelijk dank.
Anke