Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: [Min of meer opgelost]Raar geluid bij Terratec DMX Sixpack5.1 onder Ubuntu 10.04  (gelezen 1212 keer)

Offline aartje

  • Lid
  • Steunpunt: Nee
Ik heb al tijden een Terratec DMX Sixpack 5.1 geluidskaart
in mijn computer en er eigenlijk nooit problemen  mee gehad
onder Slackware-, Redhat-,Suse- en Ubuntu 7.04, 7.10, 8.10 -linux
Nu heb ik Ubuntu 10.04 ge-installeerd en krijg ik rare effecten bij
het afspelen van een mp3-bestand. Het geluid valt soms uit,
begint hard te brommen en te kraken en soms als je een
beetje met de volumeslider speelt heb je wel geluid. Er is geen
peil op te trekken. Onder win98se (dualboot) dat er ook
nog op staat is er niets aan de hand, dus de hardware mankeert
niets.
Wie heeft er een tip voor me ?
« Laatst bewerkt op: 2010/10/03, 11:58:49 door aartje »

Offline aartje

  • Lid
  • Steunpunt: Nee
Re: Raar geluid bij Terratec DMX Sixpack5.1 onder Ubuntu 10.04
« Reactie #1 Gepost op: 2010/10/03, 09:32:44 »
Met een oudere Knoppix werkt alles wel prima. Met de Live-CD van
Ubuntu10.04.1 gaat het ook niet goed.
Ik heb het idee dat Ubuntu een beetje degradeert na er 4 jaar prima
mee gewerkt te hebben. Op mijn "hoofdsysteem" kan ik niet upgraden
van 8.04 naar 10.04 wegens de 845/855 bug die nog niet opgelost
is (en  voorlopig ook niet wordt). OP dit systeem werkt opeens
mijn geluidskaart niet meer goed en is de USB fout er weer ingeslopen
(als je een USB-stick er in duwt verschijnt er geen gemount filesysteem).

Is er niemand die ook deze Terratec kaart onder Ubuntu10.04 aan de
praat heeft gekregen of probeert te krijgen ?

Offline aartje

  • Lid
  • Steunpunt: Nee
Re: Raar geluid bij Terratec DMX Sixpack5.1 onder Ubuntu 10.04
« Reactie #2 Gepost op: 2010/10/03, 11:57:39 »
Na het volgende gedaan te hebben kan ik tenminste weer
audio-bestanden afspelen.
=============================================================
 Sound in my Ubuntu Karmic Koala desktop used to freeze and I was into real problem. The process “pulseaudio” used to hog the CPU and sound would stop at times. So I replaced it with esound and it is fine now. This is how I did it.

Lanched Synaptic (System>Administration>Synaptic Package Manager) and then searched for pulseaudio.
Then right clicked on it and then Marked it for Complete Removal.
Then searched for esound and then Marked it for installation. If it is already installed, you may want to Mark it for reinstallation.

Hope this helps.
===========================================================

Ik snap er niets van, het blijft onduidelijk. Ik denk er over mijn soundkaart er uit
te halen en dan maar mijn (inferieure) onboard sound hardware te proberen.

Vreemd dat niemand hier op reageert, of is iedereen met zo'n soundcard al op
Ubuntu afgeknapt ?

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Niet zo vreemd dat niemand reageert, de meeste kaartjes zijn wel aan de gang te krijgen met wat algemene instellingen, sommige helaas niet mede omdat de kaart die jij hebt niet zo algemeen is. Ik heb een geluidsprobleem met mijn tv kaart die niet bekend is. Maar met veel zoek en probeer werk is het wel tot leven te wekken. Ik zoek altijd via www.google.nl/linux, vind ik wat ga ik dat uitproberen. Daar kan ik je wel bij helpen. :) Over het algemeen, ligt een oplossing voor exotische software niet voor het oprapen, mede omdat een hardware fabrikant niet snel linux drivers maakt, jammer genoeg. Dus hulp kan ik je bieden, uitproberen helaas niet.
En wat Pulse-audio betreft, dat is mijn ding niet, ik gebruik Alsa, vind ik persoonlijk duidelijker.
« Laatst bewerkt op: 2010/10/03, 18:05:21 door Gijsbert »
In der Beschränkung zeigt sich der Meister.

Offline aartje

  • Lid
  • Steunpunt: Nee
Over het algemeen, ligt een oplossing voor exotische software niet voor het oprapen, mede omdat een hardware fabrikant niet snel linux drivers maakt, jammer genoeg. Dus hulp kan ik je bieden, uitproberen helaas niet.
En wat Pulse-audio betreft, dat is mijn ding niet, ik gebruik Alsa, vind ik persoonlijk duidelijker.
Zo exotisch is die hardware volgens mij niet, hij zit er al sinds 2002 in en heeft het altijd prima
gedaan onder diverse Linux-versies. Het vreemde is dat er een fout inkomt die er nooit geweest is,
dat maak ik wel meer mee, vooral sinds 10.04
Je ziet door te googelen dat er meer mensen met dat probleem zitten, er worden suggesties
aangedragen, geprobeerd, het blijkt dan toch niet goed helemaal goed te zijn en op een
gegeven moment stopt de discussie in zo'n forum. Ik heb het idee dat er dan heel wat mensen
afgehaakt zijn. Ik kan me voorstellen dat er met een normale versie wel eens ge-experimenteerd
wordt, maar in een LTS-versie zou dit soort dingen eigenlijk niet voor moeten komen.

Dat vind ik ook met problemen met de 845/855 Intel grafische chipset, die één van de meest
voorkomende is, daar begint de discussie ook steeds meer te stokken en daar is ook nog
steeds geen definitieve oplossing voor (ook niet aangekondigd), terwijl die computer
het bij mij toch ook al jaren goed gedaan had onder 5 opvolgende Ubuntu-versies.

Wat ook wel meespeelt , volgens mij, is dat de computerwereld zo gewend is om
iedere 2 a 3 jaar hun computer te vernieuwen, omdat je nou een maal mee moet
gaan met de nieuwste Miscrosoft-software.

De charme van Linux vind (vond?) ik juist dat je ook nog prima met je 5 jaar oude
computer overweg kan  en het er op begint te lijken dat de meeste aandacht naar
de computers met de nieuwste hardware gaat.

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Ik kan je frustatie(als ik het zo mag noemen) levendig voorstellen, zoals eerder geschreven heb ik dat met de tv-kaart, zowel de nieuwe als oude. Met de oude moest ik ook elke keer opnieuw beginnen met het geluid. Waarom? Dat vraag ik me nu ook nog af. Ik ben nu niet thuis, maar vanavond begin ik wel een speurtocht naar de juiste driver/c.q. geluidsprogramma, als jij dat nog wilt. Jammer dat zulke dingen nodig zijn en dat het in een oudere versie wel werkte. Waar het aanligt? Andere kernel, misschien? Ik kan het je niet vertellen.
Video en geluids problemen komen nog het meest voor mijn inziens. Het is jammer dat hiervoor nog steeds geen boek/handleiding voor is, maar wie weet. :)
In der Beschränkung zeigt sich der Meister.

Offline aartje

  • Lid
  • Steunpunt: Nee
Bedankt Gijsbert, voor je meedenken. Wat natuurlijk ook wel meespeelt is dat
mijn hardware (volgens computerwereldbegrippen) vrij oud is en natuurlijk
steeds minder mensen die hardware gebruiken, dus fouten ook met minder
mensen worden opgelost. (AMD XP+ 1400 , 512MB, SCSI2904, Nvidia MX200 32MB)
Waar ik ook achtergekomen ben is dat het "pulseaudio"-systeem de problemen
veroorzaakt en vooral bij oudere hardware. Als lapmiddel wordt dan maar
"esound" gebruikt en zo heb ik het ook gedaan.
Alleen de volume-applet is er dan niet meer (het geluid moet je met een
alsa-mixer regelen). Verder kan ik er de geluidskaart niet zomaar uittrekken
en gebruik maken van de onboard-geluidskaart, want ik heb er ook nog
een win98se-syteem (jawel  =D =D) opstaan en ik ben niet echt blij om
dat om te bouwen voor dat onboard geluid (hoewel ik windows misschien
nog maar in 1% van de tijd gebruik).

Verder blijf ik enthousiast over Linux als sinds de tijd dat ik in 1992 ,
ongeveer, een slackware-versie vanaf 25 floppies op een 486DX50
systeem met 16 MB installeerde, maar ik blijf het idee houden dat er
wat steekjes beginnen te vallen wat oudere (natuurlijk niet zo oud!)
betreft en dat vind ik jammer en jij ook denk ik als ik je motto
goed begrijp "Linux is leuk voor ouwe meuk. Komt dat even goed uit."



Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Mij motto komt ergens anders vandaan, uit een artikel van een "journalist", waarin hij zijn ervaring beschrijft. Hij doelde daar mee op de oude knarren die al tig jaar bezig zijn met Linux,zoals ik, en dat Linux niks is voor mensen die net beginnen, flauwekul vind ik. Voor mensen die een lange tijd bezig zijn met Windows, komt Linux misschien wat moeilijker over, omdat Linux net even anders in elkaar zit. :)
Inderdaad Linux is ook uitermate geschikt voor de oudere computer, leuk om een servertje van te maken, o.i.d.

Daarom gebruik ik ook Alsa i.p.v. Pulse, het is niet mijn ding. Als je de Gnome-alsamixer installeert, kan je ook een icoontje plaatsen op de balk. Ik heb alles van Pulse verwijdert.
Maar het lijkt er wel op dat de oude zooi wat in de vergetelheid raakt, toch maar weer terug naar het zelf compileren van de kernel?
In der Beschränkung zeigt sich der Meister.