Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: X.org foutmelding na update  (gelezen 977 keer)

Offline driesv

  • Lid
  • Steunpunt: Nee
X.org foutmelding na update
« Gepost op: 2010/10/01, 11:03:05 »
Hallo,

In mijn computer zit een ATI-grafische kaart, geïntegreerde op het moederbord, namelijk HD 4290.
Hiervoor had ik de gesloten driver van ATI/AMD geïnstalleerd en dat ging tot nu toe zeer vlot, geen enkel probleem met het grafische, alles werkte vlot.

Maar gisteren kreeg ik een automatische update binnen van Ubuntu, en zoals update ik alles, maar achteraf gezien had ik dat beter niet gedaan.
Mijn grafische omgeving wilt niet opstarten, na die update.

Bij het opstarten krijg ik deze foutmelding
Vervolgens kies ik voor ok en dan krijg ik dit.
Daar kies ik dan eerst voor De fout oplossen en dan krijg ik vervolgens dit, dan kies ik opstartfout inzien en dat geeft deze informatie.

Ik heb al vanalles geprobeerd, maar ik krijg het niet opgelost.

Ik zou graag deze driver blijven gebruiken omdat die perfect werkt, maar als het niet anders kan, dan mag de open-source driver ook (heb ik ook al geprobeerd, maar dan sluit mijn pc niet meer af).

/etc/X11/xorg.conf (bij de eerste crash, deze werkte zeker een maand perfect)
Section "ServerLayout"
    Identifier     "aticonfig Layout"
    Screen      0  "aticonfig-Screen[0]-0" 0 0
EndSection

Section "Module"
EndSection

Section "Monitor"
    Identifier   "aticonfig-Monitor[0]-0"
    Option        "VendorName" "ATI Proprietary Driver"
    Option        "ModelName" "Generic Autodetecting Monitor"
    Option        "DPMS" "true"
EndSection

Section "Device"
    Identifier  "aticonfig-Device[0]-0"
    Driver      "fglrx"
    BusID       "PCI:1:5:0"
EndSection

Section "Screen"
    Identifier "aticonfig-Screen[0]-0"
    Device     "aticonfig-Device[0]-0"
    Monitor    "aticonfig-Monitor[0]-0"
    DefaultDepth     24
    SubSection "Display"
        Viewport   0 0
        Depth     24
    EndSubSection
EndSection
/etc/X11/xorg.conf (na xorg.conf te verwijderen en driver opnieuw te installeren)
Section "Screen"
    Identifier    "Default Screen"
    DefaultDepth    24
EndSection

Section "Module"
    Load    "glx"
EndSection

Section "Device"
    Identifier    "Default Device"
    Driver    "fglrx"
EndSection
« Laatst bewerkt op: 2010/10/01, 11:04:46 door driesv »

Offline jolo

  • Lid
  • Steunpunt: Nee
Re: X.org foutmelding na update
« Reactie #1 Gepost op: 2010/10/01, 20:52:56 »
Heb je nog wel gecheckt om wat voor een updates het gaat, in je /var/log/apt/history.log ? Want veiligheidsupdates kun je het beste wel installeren. Dit omdat je anders niet meer veilig kunt internetten en internetbankieren. Ook bugfixes zou je over het algemeen veilig kunnen installeren. Hoewel ook daarin fouten kunnen zitten. Je zou de onderstaande hyperlinks kunnen checken.
https://wiki.ubuntu.com/X/Troubleshooting/FglrxInteferesWithRadeonDriver
http://www.thinkwiki.org/wiki/Problems_with_fglrx

Ook zou het mogelijk kunnen zijn, dat een volgende update je probleem oplost.
Hoofd PC september 2011 Asus P8Z68-V Pro i7 2600K 8 GB RAM GT730 Ubuntu 14.04
PC 2007 Asus P5B E6600 2GB RAM 8800GTS  
Notebook 2008 Lenovo ThinkPad R61i 8932GMG 2,5 GB RAM
Test pc's AthlonXP 1700+ PC 1,5 GB RAM nVidia 7600GS en Dual P3 1000 MHz 1 GB RAM X1650Pro

Offline driesv

  • Lid
  • Steunpunt: Nee
Re: X.org foutmelding na update
« Reactie #2 Gepost op: 2010/10/02, 11:28:20 »
Ik heb ondertussen gevonden dat het aan de nieuwe kernel ligt.

De ATI-driver (fglrx) heb ik goed kunnen verwijderen. Ondertussen draai ik dus de alternatieve open-source driver, werkt heel goed (zelfs beter dan degene van ATI), buiten OpenGL werkt niet.

Als ik nu de ATI-driver installeer via Systeem>Beheer>Stuurprogramma's, dan draait dat ook stabiel en werkt OpenGL, alleen krijg ik dat watermerk.
Vervolgens heb ik dat watermerk ("unsupported hardware") proberen weg te krijgen, maar dan kreeg ik terug die foutmeldingen van tevoren. Dus terug driver terug verwijdert en terug open-source driver.

Ondertussen is het probleem op de ATI-site ook naar boven gekomen.
http://support.amd.com/us/kbarticles/Pages/GPU83ATICatalystLinuxHotfix.aspx

Ik heb dat eens toegepast, maar dat geeft bij mij dezelfde foutmelding.

Momenteel ga ik gewoon een tijdje de open-source driver gebruiken (dus geen supertuxkart, xmoto, ...) en wachten op een nieuwe kernelupdate of een update van de ATI-driver.


Offline jolo

  • Lid
  • Steunpunt: Nee
Re: X.org foutmelding na update
« Reactie #3 Gepost op: 2010/10/02, 12:11:34 »
Ik heb ondertussen gevonden dat het aan de nieuwe kernel ligt.
Dat zou kunnen. Je zou deze bugmelding kunnen checken https://bugs.launchpad.net/ubuntu/lucid/+source/fglrx-installer/+bug/642518 Als de foutmeldingen overeenkomen, dan zul je de fix binnenkort in een update kunnen tegenkomen. (Overigens kun je afbeeldingen beter elders hosten. Uploadhouse is niet altijd bereikbaar.)
De ATI-driver (fglrx) heb ik goed kunnen verwijderen. Ondertussen draai ik dus de alternatieve open-source driver, werkt heel goed (zelfs beter dan degene van ATI), buiten OpenGL werkt niet.
Omdat jij een HD4290 hebt. Zie hyperlink  https://help.ubuntu.com/community/RadeonDriver
Citaat

2D modesetting only

HD 3xxx / R600 based cards
HD 4xxx / R700 based cards
Ikzelf heb in de Dual P3 uit mijn onderschrift een ATI 1650Pro. Die is op de R530 gebaseerd, en heeft daardoor goede 3D ondersteuning. Daar staat tegenover dat er geen fglrx drivers voor beschikbaar zijn.
Hoofd PC september 2011 Asus P8Z68-V Pro i7 2600K 8 GB RAM GT730 Ubuntu 14.04
PC 2007 Asus P5B E6600 2GB RAM 8800GTS  
Notebook 2008 Lenovo ThinkPad R61i 8932GMG 2,5 GB RAM
Test pc's AthlonXP 1700+ PC 1,5 GB RAM nVidia 7600GS en Dual P3 1000 MHz 1 GB RAM X1650Pro