Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: (opgelost) usb mount probleem  (gelezen 2824 keer)

Offline valk

  • Lid
    • mpvalk
  • Steunpunt: Nee
(opgelost) usb mount probleem
« Gepost op: 2010/09/14, 22:00:05 »
Ik krijg bijgevoegde melding als ik een usb stick in mijn computer steek. Dit sinds een week of zoiets en ik heb eigenlijk geen idee wat ik zelf gewijzigd zou hebben wat dit veroorzaakt?
Maar ik kan nu onder mijn gewone gebruikersnaam geen usb sticks of mp3 speler aankoppelen, dat is best irritant? Iemand een suggestie hoe ik dat weer op kan lossen?

Alvast dank!

« Laatst bewerkt op: 2010/09/16, 17:53:17 door valk »

Offline walterav

  • Lid
  • Steunpunt: Nee
Re: usb mount probleem
« Reactie #1 Gepost op: 2010/09/14, 22:04:56 »
Kijk eens of de map /media/ al mappen bevat voordat er een USB-device etc word aangesloten. Kijk anders even bij je gebruikers en daar op geavanceerd of je in de huidige gebruiker nog wel de rechten heb om apparaten te mounten.

Offline valk

  • Lid
    • mpvalk
  • Steunpunt: Nee
Re: usb mount probleem
« Reactie #2 Gepost op: 2010/09/14, 22:16:16 »
Het systeem wilde de stick koppelen als sdc1 en daar was inderdaad al een map voor. Die heb ik verwijderd, maar daarna nog steeds dezelfde melding.

In /media alleen 2 mappen die inderdaad gemount zijn?

Offline heir4c

  • Lid
  • Steunpunt: Nee
Re: usb mount probleem
« Reactie #3 Gepost op: 2010/09/14, 23:22:48 »
Blijkbaar is hij enkel aan te koppelen met rootrechten.


Plug de usb in en dan:
Klik op Alt+F2 en tik in:
cat /etc/fstaben
cat /etc/mtab
Post hier je fstab en mtab eens.


Zie je hem trouwens onder Systeem>Beheer>Schijfgereedschap?

En zet de "Schijfkoppelaar" eens op je panel (werkbalk bovenaan). Klik rechts op het panel en kies voor "Toevoegen aan paneel" en dan in de lijst "Schijfkoppelaar". Normaal zou je de usb dan moeten zien verschijnen in het paneel.

Offline valk

  • Lid
    • mpvalk
  • Steunpunt: Nee
Re: usb mount probleem
« Reactie #4 Gepost op: 2010/09/15, 18:01:57 »
Hierbij mijn fstab en mtab, maar de stick wordt wel gewoon herkend volgens mij (ik zie het ook in nautilus). Het wordt helaas niet aangekoppeld ivm de rechten?

Wat doen die stukjes code nou eigenlijk?

mtab:
/dev/sda1 / ext4 rw,errors=remount-ro 0 0
proc /proc proc rw,noexec,nosuid,nodev 0 0
none /sys sysfs rw,noexec,nosuid,nodev 0 0
none /sys/fs/fuse/connections fusectl rw 0 0
none /sys/kernel/debug debugfs rw 0 0
none /sys/kernel/security securityfs rw 0 0
none /dev devtmpfs rw,mode=0755 0 0
none /dev/pts devpts rw,noexec,nosuid,gid=5,mode=0620 0 0
none /dev/shm tmpfs rw,nosuid,nodev 0 0
none /var/run tmpfs rw,nosuid,mode=0755 0 0
none /var/lock tmpfs rw,noexec,nosuid,nodev 0 0
none /lib/init/rw tmpfs rw,nosuid,mode=0755 0 0
/dev/sda6 /media/sda6 ext4 rw,noexec,nosuid,nodev 0 0
/dev/sdb1 /media/sdb1 fuseblk rw,nosuid,nodev,allow_other,blksize=4096 0 0
binfmt_misc /proc/sys/fs/binfmt_misc binfmt_misc rw,noexec,nosuid,nodev 0 0
gvfs-fuse-daemon /home/maarten/.gvfs fuse.gvfs-fuse-daemon rw,nosuid,nodev,user=maarten 0 0

fstab:
# /etc/fstab: static file system information.
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>

proc   /proc   proc   nodev,noexec,nosuid   0   0
#Entry for /dev/sda1 :
UUID=2f0387f1-0a95-4ccd-957b-cd1096ece41f   /   ext4   errors=remount-ro   0   1
#Entry for /dev/sda6 :
UUID=c2ac5d27-06a8-4d28-ab3b-9747211b2147   /media/sda6   ext4   users,user   0   0
#Entry for /dev/sdb1 :
UUID=43E1A94F53D99B98   /media/sdb1   ntfs-3g   defaults,locale=nl_NL.UTF-8   0   0
#Entry for /dev/sda5 :
UUID=4dd628f6-6c59-434c-a695-db1ecc152fa0   none   swap   sw   0   0
/dev/sdc1   /media/sdc1   ext4   noauto   0   0

Offline nomko

  • Lid
    • Ubuntu Linux Gebruiker Site
  • Steunpunt: Nee
Re: usb mount probleem
« Reactie #5 Gepost op: 2010/09/15, 18:18:12 »
#Entry for /dev/sda5 :
/dev/sdc1   /media/sdc1   ext4   noauto   0   0

Moet het niet zijn:

/dev/sdc1   /media/sdc1   ext4   defaults,relatime    0       2


Maar is die usb stick wel bij een vorige gebruik op een correcte manier ontkoppeld??
« Laatst bewerkt op: 2010/09/15, 20:21:21 door nomko »
Handige site voor de Ubuntu gebruiker:
https://sites.google.com/site/ubuntulinuxgebruiker
-------------------------
https://www.dropbox.com/referrals/NTQ4MzUwNDc5
-------------------------
Linux user number 515471
----------------------

Offline valk

  • Lid
    • mpvalk
  • Steunpunt: Nee
Re: usb mount probleem
« Reactie #6 Gepost op: 2010/09/15, 22:43:34 »
Ik heb geen idee wat het moet zijn eerlijk gezegd? Maar ik kan wel eens op mijn media center kijken, daar staat in principe dezelfde installatie op.

Het is overigens niet dezelfde usb stick. Het maakt eigenlijk niet uit welke usb stick of apparaat ik erin steek, ze geven allemaal dezelfde melding?

Ik bedenk me overigens dat mijn ex-vriendin (ja we wonen momenteel nog samen) wel bezig is geweest met het volzetten van haar ipod shuffle vanaf de betreffende pc. Kan het zijn dat ze die niet goed afgekoppeld heeft en dat ervoor zorgt dat overige usb apparaten vervolgens niet goed gekoppeld worden?

Offline heir4c

  • Lid
  • Steunpunt: Nee
Re: usb mount probleem
« Reactie #7 Gepost op: 2010/09/15, 23:36:16 »
Dat zou kunnen. Is dat onder windows gebeurd? Zo ja, start windows dan terug op met de schijf in geplugd en ontkoppel die dan in windows.

Offline valk

  • Lid
    • mpvalk
  • Steunpunt: Nee
Re: usb mount probleem
« Reactie #8 Gepost op: 2010/09/16, 07:31:37 »
Nee, dat is niet onder windows gebeurd want er staat geen Windows meer op die pc...

Maar kan ik die regel niet gewoon verwijderen uit fstab, zodat die opnieuw aangemaakt wordt?

Offline nomko

  • Lid
    • Ubuntu Linux Gebruiker Site
  • Steunpunt: Nee
Re: usb mount probleem
« Reactie #9 Gepost op: 2010/09/16, 07:40:24 »
Je kan het wellicht proberen. Maar of die regel er weer automatisch erin wordt gezet betwijfel ik. En waarom zou je het willen ook? Het is een verwisselbare medium.
Handige site voor de Ubuntu gebruiker:
https://sites.google.com/site/ubuntulinuxgebruiker
-------------------------
https://www.dropbox.com/referrals/NTQ4MzUwNDc5
-------------------------
Linux user number 515471
----------------------

Offline vanadium

  • Lid
  • Steunpunt: Nee
Re: usb mount probleem
« Reactie #10 Gepost op: 2010/09/16, 08:40:55 »
Dit wordt inderdaad mooi opgelost door de regel voor /dev/sdc1 in /etc/fstab te verwijderen. Een USB stick hoort niet thuis in /etc/fstab, behalve als je echt op de oude manier wil werken en telkens handmatig de stick wil aan-of afkoppelen. Maar wie wil dat nog voor een verwijderbare schijf?

Verwijder de regel voor /dev/sdc1, en verwijder ook het koppelpunt /media/sdc1. Dan computer opnieuw opstarten.

Offline valk

  • Lid
    • mpvalk
  • Steunpunt: Nee
Re: usb mount probleem
« Reactie #11 Gepost op: 2010/09/16, 17:52:55 »
Heren, allen bedankt voor de suggesties!
En @vanadium, na de betreffende regel verwijderd te hebben werkt het weer als vanouds!

Ik snap alleen nog niet hoe die regel in mijn fstab terecht is gekomen  ???

Offline vanadium

  • Lid
  • Steunpunt: Nee
Re: (opgelost) usb mount probleem
« Reactie #12 Gepost op: 2010/09/16, 20:45:01 »
Misschien heb je ooit eens geëxperimenteerd met pysdm, een grafisch tooltje om partities in je fstab op te nemen.

Offline valk

  • Lid
    • mpvalk
  • Steunpunt: Nee
Re: (opgelost) usb mount probleem
« Reactie #13 Gepost op: 2010/09/17, 07:35:15 »
Ik gebruik pysdm inderdaad om een tweetal andere partities automatisch te koppelen. Misschien heb ik dan inderdaad ergens een keertje een ketser gemaakt met de het kiezen van de partitie...