Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: [Opgelost] Partitie "aankoppelen" bij opstarten (dropbox).  (gelezen 7987 keer)

Offline Wim3065

  • Lid
  • Steunpunt: Nee
[Opgelost] Partitie "aankoppelen" bij opstarten (dropbox).
« Gepost op: 2010/09/02, 10:04:37 »
Hoi,

Ik heb overlaatst Windows terug op mijn pc moeten plaatsen ivm tekenpakketten. Nu, ik heb nog een extra partitie gemaakt met "gezamenlijke" bestanden.  Zo kan ik er gemakkelijk aan in Windows en Ubuntu (muziek, dropbox etc...). Het probleem is nu dat je in Ubuntu steeds deze partitie moet aanklikken voor Ubuntu hem herkend. Aangezien mijn dropbox erop staat krijg ik bij de opstart steeds een foutmelding dat de dropbox map niet gevonden kan worden.
Is er een manier dat mijn partitie direct geopend wordt tijdens het opstarten van Ubuntu.
Het gaat hier btw om een FAT32 partitie. Een NTFS wordt niet door Windows herkend?

Wim
« Laatst bewerkt op: 2010/09/02, 14:08:35 door Wim3065 »

Offline Thomas de Graaff

  • Lid
  • Steunpunt: Nee
Re: Partitie "aankoppelen" bij opstarten (dropbox).
« Reactie #1 Gepost op: 2010/09/02, 10:48:24 »
Partities die tijdens het opstarten aangekoppeld dienen te worden moeten in /etc/fstab staan.

Ik geloof dat er een gui interface is om dit in te stellen, zelf heb ik hier echter nooit mee gewerkt, staat in de repo's:

pysdm


Offline heir4c

  • Lid
  • Steunpunt: Nee
Re: Partitie "aankoppelen" bij opstarten (dropbox).
« Reactie #2 Gepost op: 2010/09/02, 13:30:36 »
Je kan ook het volgende doen:
Je koppelt de partitie aan.
Dan in terminal het volgende intikken:
cat /etc/mtabDaar zoek je de lijn van de partitie (volledig dus ook de parameters die er achter /dev/sda* of /media/sda* of ... staan) en kopieer en plak je in /etc/fstab

Die open je het best via Alt+F2 en tik daar in:
gksudo gedit /etc/fstabZet de lijn er onderaan bij. Klik op de Knop 'Opslaan'.
Nu zou de partitie automatisch moeten aankoppelen.


En een NTFS word door windows herkend. Normaal gezien gebruikt men tegenwoordig standaard ntfs om windows te installeren. Maar je kan dus ook FAT32 blijven gebruiken.

Offline Wim3065

  • Lid
  • Steunpunt: Nee
Re: Partitie "aankoppelen" bij opstarten (dropbox).
« Reactie #3 Gepost op: 2010/09/02, 14:08:17 »
Hmm, wat me nu opvalt is dat de dropbox mapjes anders zijn onder linux en windows :).
Onder windows is het "my dropbox" terwijl het onder linux dropbox is. Vervelend!

Maar, dankjewel voor de info over het aankoppelen, dit is bij deze opgelost!

Offline Rachid

  • Lid
    • rachidbm
    • Mijn blog
  • Steunpunt: Nee
Re: [Opgelost] Partitie "aankoppelen" bij opstarten (dropbox).
« Reactie #4 Gepost op: 2010/09/02, 14:37:43 »
Hmm, wat me nu opvalt is dat de dropbox mapjes anders zijn onder linux en windows :).
Onder windows is het "my dropbox" terwijl het onder linux dropbox is. Vervelend!
Dat klopt, komt door de dropbox (client) software zelf.
Waarom vind je dit vervelend? Misschien kunnen we je helpen...
Ben je ook blij dat Ubuntu zo toegankelijk en gratis is, en wil je graag net als ik iets terugdoen, kijk dan eens rond bij mwanzo, dé poort naar het bijdragen aan Ubuntu en haar gemeenschap!

Offline Wim3065

  • Lid
  • Steunpunt: Nee
Re: [Opgelost] Partitie "aankoppelen" bij opstarten (dropbox).
« Reactie #5 Gepost op: 2010/11/02, 09:29:58 »
Hmm, wat me nu opvalt is dat de dropbox mapjes anders zijn onder linux en windows :).
Onder windows is het "my dropbox" terwijl het onder linux dropbox is. Vervelend!
Dat klopt komt door de dropbox (client) software zelf.
Waarom vind je dit vervelend? Misschien kunnen we je helpen...

Ik ben een beetje heeeeel laat met mijn reactie!
Eum, dit is vervelend omdat ik op mijn partitie dus de dropbox map geplaatst heb. En ik was van plan om dezelfde map te gebruiken voor zowel in Windows als in Ubuntu up te loaden... Maar misschien lukt dit gewoon niet? Anders heb ik 2x een dropbox map op deze partitie... En aangezien dropbox hier enorm veel gebruikt wordt, is dit redelijk veel ruimteverlies....

Wim

Offline Thomas de Graaff

  • Lid
  • Steunpunt: Nee
Re: [Opgelost] Partitie "aankoppelen" bij opstarten (dropbox).
« Reactie #6 Gepost op: 2010/11/04, 12:34:09 »
Je kan links maken naar mappen met het commando ln. Zo kan je ervoor zorgen dat mappen die verschillende namen hebben, toch naar dezelfde inhoud verwijzen.

Als je je dropbox map in linux wilt laten verwijzen naar dezelfde map in Windows, dan kan dit als volgt:

ln -s /pad/naar/linuxmap /pad/naar/windowsmap

Offline fvc

  • Lid
  • Steunpunt: Nee
Re: [Opgelost] Partitie "aankoppelen" bij opstarten (dropbox).
« Reactie #7 Gepost op: 2011/03/26, 08:49:02 »
Ik had hetzelfde probleem, mijn partitie 'data' werd niet automatisch aangekoppeld. Ik deed bijgevolg wat werd voorgeschreven, maar nu kan ik die partitie helemaal niet meer aankoppelen. Bij het opstarten krijg ik de mededeling : Er is een fout opgetreden tijdens het aankoppelen van /media/data. Druk s om het aankoppelen over te slaan.
als ik na het opstarten handmatig probeer aan te koppelen krijg ik de melding: Error mounting : mount exited with exit code 1 : helper failed with : mount : omly root can mount /dev/sda7 on /media/data

HELP

Offline Thomas de Graaff

  • Lid
  • Steunpunt: Nee
Re: [Opgelost] Partitie "aankoppelen" bij opstarten (dropbox).
« Reactie #8 Gepost op: 2011/03/26, 09:33:06 »
Geef eens precies aan welke stappen je hebt uitgevoerd?

Offline fvc

  • Lid
  • Steunpunt: Nee
Re: [Opgelost] Partitie "aankoppelen" bij opstarten (dropbox).
« Reactie #9 Gepost op: 2011/03/26, 09:39:27 »
iK HEB DE STAPPEN GEVOLGD DIE HIER HOGER STONDEN OPGEGEVEN


Je kan ook het volgende doen:
Je koppelt de partitie aan.
Dan in terminal het volgende intikken:
Code:

cat /etc/mtab

Daar zoek je de lijn van de partitie (volledig dus ook de parameters die er achter /dev/sda* of /media/sda* of ... staan) en kopieer en plak je in /etc/fstab

Die open je het best via Alt+F2 en tik daar in:
Code:

gksudo gedit /etc/fstab

Zet de lijn er onderaan bij. Klik op de Knop 'Opslaan'.
Nu zou de partitie automatisch moeten aankoppelen.

Offline grizzler

  • Lid
  • Steunpunt: Nee
Re: [Opgelost] Partitie "aankoppelen" bij opstarten (dropbox).
« Reactie #10 Gepost op: 2011/03/26, 09:53:46 »
De foutmelding die je bij het opstarten krijgt, lijkt erop te wijzen dat bij het toevoegen van de regel met /dev/sda7 iets niet helemaal goed is gegaan. Laat eens zien hoe het bestand /etc/fstab er precies uitziet (zet de tekst als het even kan tussen code-tags).

Hoe heb je het handmatig aankoppelen geprobeerd? De foutmelding die je daarop krijgt, suggereert dat je dat zonder sudo hebt gedaan.

Offline BaukeP

  • Lid
  • Steunpunt: Nee
Re: [Opgelost] Partitie "aankoppelen" bij opstarten (dropbox).
« Reactie #11 Gepost op: 2011/03/26, 17:42:16 »
Bestaat het mountpoint wel? /media/Data

Als de map niet bestaat kun je er ook niks 'mounten´.

Bauke (my 2 cents)

Offline fvc

  • Lid
  • Steunpunt: Nee
Re: [Opgelost] Partitie "aankoppelen" bij opstarten (dropbox).
« Reactie #12 Gepost op: 2011/03/27, 20:32:12 »
Ik vrees dat een beetje boven mijn petje gaat.
Ik heb hetvolgende ingegeven in een terminalvenster: cat /etc/mtab
en het resultaat is:

fons@fons-mini:~$ cat /etc/mtab
/dev/sda5 / ext4 rw,errors=remount-ro 0 0
proc /proc proc rw,noexec,nosuid,nodev 0 0
none /sys sysfs rw,noexec,nosuid,nodev 0 0
none /sys/fs/fuse/connections fusectl rw 0 0
none /sys/kernel/debug debugfs rw 0 0
none /sys/kernel/security securityfs rw 0 0
none /dev devtmpfs rw,mode=0755 0 0
none /dev/pts devpts rw,noexec,nosuid,gid=5,mode=0620 0 0
none /dev/shm tmpfs rw,nosuid,nodev 0 0
none /var/run tmpfs rw,nosuid,mode=0755 0 0
none /var/lock tmpfs rw,noexec,nosuid,nodev 0 0
none /lib/init/rw tmpfs rw,nosuid,mode=0755 0 0
binfmt_misc /proc/sys/fs/binfmt_misc binfmt_misc rw,noexec,nosuid,nodev 0 0
gvfs-fuse-daemon /home/fons/.gvfs fuse.gvfs-fuse-daemon rw,nosuid,nodev,user=fons 0 0

Ik begrijp er niets van maar wel dat de gezochte partitie(/dev/sda7) niet gevonden wordt.
Dank voor de hulp,
Fons

Offline fvc

  • Lid
  • Steunpunt: Nee
Re: [Opgelost] Partitie "aankoppelen" bij opstarten (dropbox).
« Reactie #13 Gepost op: 2011/03/27, 20:39:06 »
Op de vraag : Bestaat het mountpoint wel? /media/Data
weet ik niet wat antwoorden. Hoe kan ik dat controleren?
Fons

Offline vanadium

  • Lid
  • Steunpunt: Nee
Re: [Opgelost] Partitie "aankoppelen" bij opstarten (dropbox).
« Reactie #14 Gepost op: 2011/03/27, 21:03:38 »
Geef ook eens de output van
cat /etc/fstab
sudo blkid
mount
Om nog beter te zien wat er fout is, geef ook de (eventuele) uitkomst van
sudo mount -a

Offline fvc

  • Lid
  • Steunpunt: Nee
Re: [Opgelost] Partitie "aankoppelen" bij opstarten (dropbox).
« Reactie #15 Gepost op: 2011/03/28, 22:20:21 »
Ik kan helemaal niet meer verder. Toevallig of niet, maar ik kan niet meer opstarten, mijn harde schijf wordt niet meer gevonden. Ik krijg de boodschap : no module name found. Aborted.
Dat zal ik dus eerst moeten oplossen. Alles herinstalleren, wellicht. Tenzij iemand hiervoor een eenvoudiger oplossing weet.
In ieder geval bedankt voor de hulp.
Fons

Offline Mikkel

  • Lid
  • Steunpunt: Nee
Re: [Opgelost] Partitie "aankoppelen" bij opstarten (dropbox).
« Reactie #16 Gepost op: 2011/03/29, 00:48:43 »
Heb je toevallig een Dell-pc? Dan staat hier misschien de oorzaak van (en de oplossing voor) die foutmelding.

Offline fvc

  • Lid
  • Steunpunt: Nee
Re: [Opgelost] Partitie "aankoppelen" bij opstarten (dropbox).
« Reactie #17 Gepost op: 2011/03/29, 07:41:16 »
Inderdaad, een Dell! Ik probeer de voorgeschreven oplossing. Thanks!

Offline Mikkel

  • Lid
  • Steunpunt: Nee
Re: [Opgelost] Partitie "aankoppelen" bij opstarten (dropbox).
« Reactie #18 Gepost op: 2011/03/29, 16:53:26 »
Graag gedaan. Dat wordt dus het verwijderen van Dell DataSafe?

Ik kan helemaal niet meer verder. Toevallig of niet, maar ik kan niet meer opstarten, mijn harde schijf wordt niet meer gevonden.

Mocht je pc ook niet meer willen opstarten in Windows, start hem dan op met de Windows-cd. Op een gegeven moment krijg je de mogelijkheid de optie R(epair) te kiezen om het een en ander te herstellen. Kies in het verschijnende consolevenster het nummer van de Windows-partitie, normaal gesproken een 1 voor C:\Windows, en typ het Administrator-wachtwoord. Heb je nooit een Admin-wachtwoord ingevoerd, dan druk je gewoon op de Enter-toets.
Typ vervolgens eerst het commando
fixboot C:druk op de Enter-toets en typ daarna het commando
fixmbrgevolgd door een Enter.
Hierbij wordt ervan uitgegaan dat C: de letter van de Windows-partitie is. Staat Windows bij jou op een andere partitie, dan pas je die C: uiteraard aan. ;)

Dit werkt met een Windows XP-cd. Of het met een latere Windows-versie op dezelfde manier gaat, weet ik niet.

Offline fvc

  • Lid
  • Steunpunt: Nee
Re: [Opgelost] Partitie "aankoppelen" bij opstarten (dropbox).
« Reactie #19 Gepost op: 2011/03/29, 22:52:56 »
Ik kan opnieuw opstarten dank zij :
  sudo mount /dev/sda3 /mnt
  sudo grub-install --recheck --root-directory=/mnt /dev/sda

en ik hoop dat met
  sudo dd if=/dev/sda of=/good_mbr  count=63
het verder opgelost is.

Hoe ik Dell Data safe moet verwijderen weet ik niet...


en verder :


fons@fons-mini:~$ cat /etc/fstab
# /etc/fstab: static file system information.
#
# Use 'blkid -o value -s UUID' to print the universally unique identifier
# for a device; this may be used with UUID= as a more robust way to name
# devices that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    nodev,noexec,nosuid 0       0
# / was on /dev/sda5 during installation
UUID=8a9614ff-d9bc-438c-94ce-235b9fb0682a /               ext4    errors=remount-ro 0       1
# swap was on /dev/sda6 during installation
UUID=1bc146d5-298f-403d-93e2-077bd28a473d none            swap    sw              0       0
/dev/sda7 /media/data fuseblk rw,nosuid,nodev,allow_other,blksize=4096,default_permissions 0 0
fons@fons-mini:~$ sudo blkid
/dev/sda1: SEC_TYPE="msdos" LABEL="DellUtility" UUID="3030-3030" TYPE="vfat"
/dev/sda2: LABEL="RECOVERY" UUID="7052E5BB52E585E6" TYPE="ntfs"
/dev/sda3: LABEL="OS" UUID="5CE6E7A6E6E77EA0" TYPE="ntfs"
/dev/sda5: UUID="8a9614ff-d9bc-438c-94ce-235b9fb0682a" TYPE="ext4"
/dev/sda6: UUID="1bc146d5-298f-403d-93e2-077bd28a473d" TYPE="swap"
/dev/sda7: LABEL="data" UUID="28E1320427B0E174" TYPE="ntfs"
fons@fons-mini:~$ mount


en ook :

fons@fons-mini:~$ sudo mount -a
[sudo] password for fons:
mount: onjuiste bestandssysteemsoort, ongeldige optie, ontbrekende codepagina,
       ontbrekend hulpprogramma, slecht superblok op /dev/sda7, of een andere fout
       Soms staat er nuttige informatie in het systeemlog --
       probeer zoiets als:  dmesg | tail


Offline Mikkel

  • Lid
  • Steunpunt: Nee
Re: [Opgelost] Partitie "aankoppelen" bij opstarten (dropbox).
« Reactie #20 Gepost op: 2011/03/29, 23:46:45 »
fons@fons-mini:~$ cat /etc/fstab

/dev/sda7 /media/data fuseblk rw,nosuid,nodev,allow_other,blksize=4096,default_permissions 0 0

fons@fons-mini:~$ sudo blkid

/dev/sda7: LABEL="data" UUID="28E1320427B0E174" TYPE="ntfs"

Wat je in ieder geval moet wijzigen in /etc/fstab is die regel van /dev/sda7
Volgens mij moet dat zoiets worden:
#/dev/sda7
UUID=28E1320427B0E174   /media/data   ntfs   defaults,uid=1000,utf8,fmask=0177,dmask=0077   0  0

Daarnaast moet er in de map /media een map data (=het koppelpunt) staan.
Zowel fstab aanpassen als een map data aanmaken doe je via de terminal. Open een terminal via menu Toepassingen, Hulpmiddelen, Terminalvenster, en typ hierin het commando gksudo nautilus
Druk op de Enter-toets, typ je wachtwoord en druk nogmaals op de Enter-toets, waarna Nautilus opent.
Je opent in de map /etc het bestand fstab, verwijdert de regel betreffende /dev/sda7 en plakt die regels die ik hierboven gezet heb ervoor in de plaats. Daarna bestand opslaan en sluiten.
Dan ga je naar de map /media en maakt hierin een nieuwe map aan met de naam data. Sluit het Nautilus-venster.
Als je nu in de terminal het commando sudo mount -a typt, zou er geen foutmelding meer moeten komen.

Maar wacht even op wat een kenner hiervan zegt. ;)
« Laatst bewerkt op: 2011/03/30, 00:02:11 door Mikkel »

Offline BaukeP

  • Lid
  • Steunpunt: Nee
Re: [Opgelost] Partitie "aankoppelen" bij opstarten (dropbox).
« Reactie #21 Gepost op: 2011/03/30, 01:08:03 »
de directory waar je iets wil mounten moet bestaan. Als dat /mnt/Data is kun je die dir. simpel opzoeken met nautilus. Vind je hem niet dan bestaat ie dus niet en moet je hem aanmaken met bv:
sudo mkdir /mnt/Data

Bauke

Offline grizzler

  • Lid
  • Steunpunt: Nee
Re: [Opgelost] Partitie "aankoppelen" bij opstarten (dropbox).
« Reactie #22 Gepost op: 2011/03/30, 13:47:36 »
In mijn fstab staan meerdere regels voor NTFS-partities, allemaal op vergelijkbare manier opgebouwd. Eén daarvan is:
/dev/sda2  /mnt/data  ntfs-3g  defaults,locale=nl_NL.UTF-8  0  0

Voor jouw computer zou dat bijvoorbeeld kunnen worden:
/dev/sda7  /media/data  ntfs-3g  defaults,locale=nl_NL.UTF-8  0  0
of:
UUID=28E1320427B0E174   /media/data  ntfs-3g  defaults,locale=nl_NL.UTF-8  0  0

Verder wat Bauke zegt, maar dan met sudo mkdir /media/data in plaats van /mnt/Data. :)

Offline fvc

  • Lid
  • Steunpunt: Nee
Re: [Opgelost] Partitie "aankoppelen" bij opstarten (dropbox).
« Reactie #23 Gepost op: 2011/04/02, 13:56:29 »
Ik heb intussenom nog andere redenen beslist om een ubuntu volledig opnieuw te installeren - dat is iets dat niet boven mijn petje gaat en een zeker resultaat oplevert. Toch hiet ook een vraag : kan in de 2 dell partities gewoon verwijderen, of ga ik dan problemen krijgen om windows te gebruiken, of nog andere problemen?
Fons

Offline grizzler

  • Lid
  • Steunpunt: Nee
Re: [Opgelost] Partitie "aankoppelen" bij opstarten (dropbox).
« Reactie #24 Gepost op: 2011/04/03, 09:03:50 »
Durf ik geen harde uitspraak over te doen. Op Windows-installaties vind je tegenwoordig allerlei soorten ondersteunings- en recoverypartities. De labels 'DellUtility' en 'RECOVERY' van sda1 en sda2 lijken erop te wijzen dat ze er niet voor niets zijn. Ik zou ze gewoon laten staan, tenzij uit eventuele documentatie die je bij die computer hebt gekregen heel duidelijk blijkt dat ze weg kunnen.