Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: [OPGELOST!] canon pixma mp540 werkt niet  (gelezen 3144 keer)

Offline meknoy

  • Lid
  • Steunpunt: Nee
[OPGELOST!] canon pixma mp540 werkt niet
« Gepost op: 2010/08/24, 11:12:11 »
Ik probeer de canon aan de praat te krijgen en begin wat opzoek werk.
Zo kom ik op deze pagina en volg de instructies.

http://kubuntuforums.net/forums/index.php?topic=3104415.0

 ik heb die driver dan ook gedownload en uitgepakt.

Als ik dan het pakket "cnijfilter-mp540series_3.00-1_i386.deb" probeer te installeren krijg ik een foutmelding.
Die is : Fout: Aan de volgende afhankelijkheid kon niet voldaan worden: cnijfilter-common (>= 3.00)
Weet er iemand hoe dit komt en wat ik eraan kan doen?
Alvast bedankt
« Laatst bewerkt op: 2010/08/26, 15:29:43 door meknoy »

Offline nomko

  • Lid
    • Ubuntu Linux Gebruiker Site
  • Steunpunt: Nee
Re: canon pixma mp540 werkt niet
« Reactie #1 Gepost op: 2010/08/24, 11:15:37 »
Ik probeer de canon aan de praat te krijgen en begin wat opzoek werk.
Zo kom ik op deze pagina en volg de instructies.

http://kubuntuforums.net/forums/index.php?topic=3104415.0

 ik heb die driver dan ook gedownload en uitgepakt.

Als ik dan het pakket "cnijfilter-mp540series_3.00-1_i386.deb" probeer te installeren krijg ik een foutmelding.
Die is : Fout: Aan de volgende afhankelijkheid kon niet voldaan worden: cnijfilter-common (>= 3.00)
Weet er iemand hoe dit komt en wat ik eraan kan doen?
Alvast bedankt

Kijk in synaptic of je die ontbrekende pakket kan vinden.
Dat is wat die foutmelding werkelijk betekend: het pakket cnijfilter-common kan niet gevonden worden op je systeem omdat het niet geïnstalleerd is.

Ps.: op mijn site staat uitleg hoe je Canon drivers kan vinden.
Misschien kan je daar kijken of je de juiste driver hebt voor jouw Canon product.
Handige site voor de Ubuntu gebruiker:
https://sites.google.com/site/ubuntulinuxgebruiker
-------------------------
https://www.dropbox.com/referrals/NTQ4MzUwNDc5
-------------------------
Linux user number 515471
----------------------

Online koos4401

  • Lid
  • Steunpunt: Nee
Re: canon pixma mp540 werkt niet
« Reactie #2 Gepost op: 2010/08/24, 11:35:58 »
Nomko schreef:
Citaat
Kijk in synaptic of je die ontbrekende pakket kan vinden.
Dat is wat die foutmelding werkelijk betekend: het pakket cnijfilter-common kan niet gevonden worden op je systeem omdat het niet geïnstalleerd is.
Ik denk het niet, Nomko: TS schreef juist dat hij bezig was met installeren:
Citaat
Als ik dan het pakket "cnijfilter-mp540series_3.00-1_i386.deb" probeer te installeren krijg ik een foutmelding
Laat onverlet dat TS jouw site kan raadplegen.
Op 27-okt-2009 om 08.20 GMT geregistreerd als gebruiker nr.: 498523

Offline nomko

  • Lid
    • Ubuntu Linux Gebruiker Site
  • Steunpunt: Nee
Re: canon pixma mp540 werkt niet
« Reactie #3 Gepost op: 2010/08/24, 12:18:50 »
Nomko schreef:
Citaat
Kijk in synaptic of je die ontbrekende pakket kan vinden.
Dat is wat die foutmelding werkelijk betekend: het pakket cnijfilter-common kan niet gevonden worden op je systeem omdat het niet geïnstalleerd is.
Ik denk het niet, Nomko: TS schreef juist dat hij bezig was met installeren:
Citaat
Als ik dan het pakket "cnijfilter-mp540series_3.00-1_i386.deb" probeer te installeren krijg ik een foutmelding
Laat onverlet dat TS jouw site kan raadplegen.

@koos:
Ik denk niet dat je  begrijpt wat ik bedoel. Als je bezig bent met installeren van een pakket, dan wordt  er gekeken of alle dependencies (=afhankelijkheden) al geïnstalleerd zijn op je systeem. Dit is een controle tijdens de installatie. Wordt er een dependency niet gevonden, dan stopt de installatieprocedure. Je bent dan "verplicht" om de ontbrekende bestanden te installeren. In het geval van de TS is dit: cnijfilter-common (>= 3.00). Deze dient eerst voorgeïnstalleerd te zijn op het systeem, anders wordt de Canon driver niet geïnstalleerd. De TS krijgt inderdaad bij het installeren van het pakket cnijfilter-mp540series_3.00-1_i386.deb een foutmelding die te maken heeft met cnijfilter-common (>= 3.00). Dat wil niet zeggen dat die .deb pakket fout is, of corrupt, of niet deugd om alles samen te vatten. Het zegt alleen dat het een pakket mist die al geïnstalleerd had moeten zijn voordat TS die .deb pakket trachtte te installeren.

Jij haalt, mijn inziens, nu 2 dingen door elkaar heen. Jij begint eerst over mijn site om te eindigen met de foutmelding. Verkeerde volgorde en totaal niet relevant aan elkaar. Mijn site heeft niks te doen met die foutmelding. Op mijn site staat alleen uitleg hoe je de juiste Canon driver kan vinden voor je Canon product.

En daarbij sta ik niet van te kijken dat TS een foutmelding krijgt. Als je buiten synaptic om iets wilt installeren, dan is het inderdaad de realiteit dat er niet geheel wordt voldaan aan de dependencies. Deze dien je dan zelf via synaptic te installeren. Dit zegt verder niks over de kwaliteit van het pakket wat je wilt installeren. Klaarblijkelijk is er door de makers van pakketten (als voorbeeld het .deb pakket van TS) ervoor gekozen om bepaalde bestanden niet in hun eigen pakket te stoppen om comptabiliteitsconflicten, versieconflicten te voorkomen. Vaak zijn bepaalde library bestanden, common bestanden via Ubuntu Update nieuwer dan dat er geleverd wordt via zo'n .deb pakketje. Reden genoeg dus om bepaalde bestanden buiten zo'n .deb bestand te houden die je via sites van hardwareleveranciers e.d. kan downloaden.

« Laatst bewerkt op: 2010/08/24, 12:23:26 door nomko »
Handige site voor de Ubuntu gebruiker:
https://sites.google.com/site/ubuntulinuxgebruiker
-------------------------
https://www.dropbox.com/referrals/NTQ4MzUwNDc5
-------------------------
Linux user number 515471
----------------------

Offline heir4c

  • Lid
  • Steunpunt: Nee
Re: canon pixma mp540 werkt niet
« Reactie #4 Gepost op: 2010/08/24, 13:15:17 »
Er zitten normaal gezien twee .deb bestanden in. Het ene is (in jouw geval): "cnijfilter-mp540series_3.00-1_i386.deb
Het tweede is het cnijfilter-common_3.00-1_i386.deb bestand.

Eerst installeer je dus het cnijfilter-common bestand en dan het cnijfilter-mp540series bestand.

Offline nomko

  • Lid
    • Ubuntu Linux Gebruiker Site
  • Steunpunt: Nee
Re: canon pixma mp540 werkt niet
« Reactie #5 Gepost op: 2010/08/24, 13:32:27 »
Er zitten normaal gezien twee .deb bestanden in. Het ene is (in jouw geval): "cnijfilter-mp540series_3.00-1_i386.deb
Het tweede is het cnijfilter-common_3.00-1_i386.deb bestand.

Eerst installeer je dus het cnijfilter-common bestand en dan het cnijfilter-mp540series bestand.

Dat had de TS niet vermeld dat die common ook een .deb pakket is, tevens kon ik dat niet uitzoeken omdat ik nu niet werk met een Linux pc. En dan nog veranderd aan het hele verhaal niks. Eerst het een, dan het andere.
Bedankt voor je opmerking over de beide .deb pakketten!
Handige site voor de Ubuntu gebruiker:
https://sites.google.com/site/ubuntulinuxgebruiker
-------------------------
https://www.dropbox.com/referrals/NTQ4MzUwNDc5
-------------------------
Linux user number 515471
----------------------

Offline vanadium

  • Lid
  • Steunpunt: Nee
Re: canon pixma mp540 werkt niet
« Reactie #6 Gepost op: 2010/08/24, 14:11:44 »
Je moet de debs inderdaad in de juiste volgorde installeren, eerst cnijfilter-common en dan cnijfilter-mp540series_3.00-1_i386.deb.

Ook bij cnijfilter-common zal je een dependencyfout krijgen. Dat komt omdat er in latere versies van ubuntu een aantal dingen veranderd zijn. Daarom zal je een transitiepakket nodig hebben om die oudere Canon pakketten te kunnen installeren. daarbij komt dat het "transitiepakket" zich niet meer in de repo's van 10.04 bevindt. Je kan echter het pakket van Jaunty ook in de huidige versie installeren. Dus:

* Download libcupsys2_1.3.9-17ubuntu3.1_all.deb vanaf hier: http://packages.ubuntu.com/jaunty/all/libcupsys2/download en installeer het door erop te dubbelklikken
* Installeer cnijfilter-common.deb en daarna cnijfilter-mp540series_3.00-1_i386.deb.

Offline heir4c

  • Lid
  • Steunpunt: Nee
Re: canon pixma mp540 werkt niet
« Reactie #7 Gepost op: 2010/08/24, 14:54:02 »
Dat had de TS niet vermeld dat die common ook een .deb pakket is, tevens kon ik dat niet uitzoeken omdat ik nu niet werk met een Linux pc. En dan nog veranderd aan het hele verhaal niks. Eerst het een, dan het andere.
Bedankt voor je opmerking over de beide .deb pakketten!

Nomko, dat zou ik ook niet geweten hebben als ik geen canon printer had. Ikzelf heb een iP2600. Het is namelijk een ingepakte bestand waar 2 .deb bestanden in zitten.


offtopic
zie ook: http://forum.ubuntu-nl.org/documentatie/howto-ip-2600/
Maar dit is niet voor de printer van de TS bedoeld. Maar hij is er misschien wel wat mee.

Offline meknoy

  • Lid
  • Steunpunt: Nee
Re: canon pixma mp540 werkt niet
« Reactie #8 Gepost op: 2010/08/26, 15:28:58 »
Hij doet het perfect!!
Iedereen is heel erg bedankt voor de moeite en tijd.
Het "transitiepakket" van vanadium heeft het gedaan.

Tot de volgende keer!
groeten,

meknoy