Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: aMSN 0.96 in Dapper  (gelezen 3205 keer)

Basic

  • Gast
aMSN 0.96 in Dapper
« Gepost op: 2006/12/15, 22:24:48 »
Wil graag de nieuwste aMSN (0.96). Deze zit niet in de Dapper repositories. Hij staat wel op de site van aMSN: http://amsn-project.net/linux-downloads.php .

Mijn vraag: kan ik aMSN installeren met de GENERIC INSTALLER/AUTOPACKAGE op hun site of is dit niet veilig (stabiliteit ...)?

Alfredo

  • Gast
aMSN 0.96 in Dapper
« Reactie #1 Gepost op: 2006/12/16, 02:47:18 »
Bij mij draait v0.96 perfect op Dapper, nog geen crashes gehad ofzo.

Offline Soul-Sing

  • Lid
  • Steunpunt: Nee
aMSN 0.96 in Dapper
« Reactie #2 Gepost op: 2006/12/16, 10:36:18 »
Citaat van: Basic
Wil graag de nieuwste aMSN (0.96). Deze zit niet in de Dapper repositories. Hij staat wel op de site van aMSN: http://amsn-project.net/linux-downloads.php .

Mijn vraag: kan ik aMSN installeren met de GENERIC INSTALLER/AUTOPACKAGE op hun site of is dit niet veilig (stabiliteit ...)?
het verdient altijd de voorkeur programma's via de synaptic te installeren.
overigens, heeft de nieuwe versie extra functionaliteit?

Offline summer of 69

  • Lid
  • Steunpunt: Nee
aMSN 0.96 in Dapper
« Reactie #3 Gepost op: 2006/12/16, 10:43:59 »
Hay,
Even een vraagje. Om een account aan te maken in aMSN, ben je dan aangewezen op een hotmail account of kan dat ook anders
:)
dierenliefde is onvoorwaardeljk, dierenleed ten zeerste verwerpelijk

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
aMSN 0.96 in Dapper
« Reactie #4 Gepost op: 2006/12/16, 10:51:52 »
Citaat van: Summer of 69
Hay,
Even een vraagje. Om een account aan te maken in aMSN, ben je dan aangewezen op een hotmail account of kan dat ook anders
:)
Kan ook anders, Goddank. Hier thuis hebben we allemaal Gmail in combinatie met aMSN. Het MSN-netwerk staat dat blijkbaar toe, mogelijk uit angst voor Europese maatregelen tegen monopolisme.

Groet, Pjotr.

Offline Soul-Sing

  • Lid
  • Steunpunt: Nee
aMSN 0.96 in Dapper
« Reactie #5 Gepost op: 2006/12/16, 10:57:26 »
Citaat van: pjotr123
Citaat van: Summer of 69
Hay,
Even een vraagje. Om een account aan te maken in aMSN, ben je dan aangewezen op een hotmail account of kan dat ook anders
:)
Kan ook anders, Goddank. Hier thuis hebben we allemaal Gmail in combinatie met aMSN. Het MSN-netwerk staat dat blijkbaar toe, mogelijk uit angst voor Europese maatregelen tegen monopolisme.

Groet, Pjotr.
idd ik krijg steeds meer mensen in mijn GAIM lijstje met gmail.
goede zaak dat er alternatieven zijn voor hotmail.( overigens ook voor gmail :) )

Offline jopy

  • Lid
  • Steunpunt: Nee
aMSN 0.96 in Dapper
« Reactie #6 Gepost op: 2006/12/16, 12:10:42 »
Citaat van: leoquant
het verdient altijd de voorkeur programma's via de synaptic te installeren.
overigens, heeft de nieuwe versie extra functionaliteit?
Het heeft wel extra functionaliteit, bijvoorbeeld persoonlijke berichten, je kan bestanden sturen naar mensen met live messenger en je hebt andere menu's en de contactpersonen lijst ziet er anders uit.
Ik gebruik nu .96 ongeveer sinds ik kon updaten, ik heb nog geen problemen gehad die ik bij 0.95 nog niet had.

Basic

  • Gast
aMSN 0.96 in Dapper
« Reactie #7 Gepost op: 2006/12/19, 20:20:34 »
Bedankt voor de reacties allemaal!

@Alfredo en jopy: neem aan dat jullie beiden hebben ge

Basic

  • Gast
aMSN 0.96 in Dapper
« Reactie #8 Gepost op: 2006/12/19, 20:27:35 »
Overigens loopt mijn webcam regelmatig vast in aMSN, kan dit liggen aan het feit dat ik een oudere comp., te weinig werkgeheugen of zo?

Offline profoX

  • Lid
    • wesley
    • Lionslink
  • Steunpunt: Nee
aMSN 0.96 in Dapper
« Reactie #9 Gepost op: 2006/12/19, 20:30:36 »
Nadelen van die autopackage:

- pakket is niet zichtbaar in synaptic, moet dus op een andere manier verwijderd worden
- gebruikt geen gedeelde libraries, wat een veiligheidsrisico zou kunnen betekenen (statisch gelinkte libraries hebben echter ook voordelen...)
Human Knowledge Belongs To The World -- Antitrust (2001)
Nederlandstalige Ubuntu documentatie van Ubuntu-NL (wiki)

Basic

  • Gast
aMSN 0.96 in Dapper
« Reactie #10 Gepost op: 2006/12/19, 20:41:11 »
Hoi proFox,

wat bedoel je precies met

Citaat
- gebruikt geen gedeelde libraries, wat een veiligheidsrisico zou kunnen betekenen (statisch gelinkte libraries hebben echter ook voordelen...)
kun je mij heel simpel uitleggen hoe dat zit? Wat zijn dat eigenlijk precies ' libraries ', en wat is het verschil en veiligheidsrisico of juist voordeel van de 1 ten opzichte van de ander?

Offline profoX

  • Lid
    • wesley
    • Lionslink
  • Steunpunt: Nee
aMSN 0.96 in Dapper
« Reactie #11 Gepost op: 2006/12/19, 21:00:06 »
Citaat van: Basic
Hoi proFox,

wat bedoel je precies met

Citaat
- gebruikt geen gedeelde libraries, wat een veiligheidsrisico zou kunnen betekenen (statisch gelinkte libraries hebben echter ook voordelen...)
kun je mij heel simpel uitleggen hoe dat zit? Wat zijn dat eigenlijk precies ' libraries ', en wat is het verschil en veiligheidsrisico of juist voordeel van de 1 ten opzichte van de ander?
Als ik het goed heb begrepen dan zijn de pakketten die ingepakt zijn met Autopackage het programma + de nodige libraries.

Libraries zijn aparte bestanden die gebruikt kunnen worden door een programma om extra functionaliteit toe te voegen aan het programma via dat library bestand.

Als er gedeelde libraries gebruikt worden dan zullen die libraries regelmatig geupdate worden door apt als er een veiligheidsupdate ofzo voorzien is... maar als die libraries statisch bij het programma gevoegd worden als extra bestanden, dan zullen die niet automatisch mee ge-upgrade worden.

Het voordeel van de Autopackage methode is dan weer dat je gewoon een andere library versie kan hebben dan degene die je gedeeld op je systeem hebt staan, en dit kan wel kopzorgen besparen.

Ik hoop dat het klopt wat ik zeg, want het is allemaal een beetje uit het hoofd... misschien maar eens nachecken bij Google of wat ik zeg wel klopt :)
Human Knowledge Belongs To The World -- Antitrust (2001)
Nederlandstalige Ubuntu documentatie van Ubuntu-NL (wiki)

Offline Samuel Rave

  • Lid
    • http://www.familie-rave.de/
  • Steunpunt: Nee
aMSN 0.96 in Dapper
« Reactie #12 Gepost op: 2006/12/19, 21:03:06 »
Het is overigens heel eenvoudig zelf een .deb te maken van de te downloaden source-pakketje.

Basic

  • Gast
aMSN 0.96 in Dapper
« Reactie #13 Gepost op: 2006/12/19, 21:31:26 »
Oke het wordt al wat duidelijker voor me. De autopackage bevat aMSN + statisch libraries in 1 bundel. Hier wordt niks automatisch voor geupdate, en evt. beveiligingsupdates zul je van de aMSN-site moeten halen (mits aangeboden).

Maar hoe zit dat dan met zo'n zelfgebouwde .deb? Is dit dan enkel het prog aMSN, en maakt dit gebruik van aanwezige dynamische (automatisch geupdate) libraries op het systeem? En valt het prog dan WEL te verwijderen met Synaptic?

En proFox bedoel je DIT met de kopzorgen: dat er misschien in het geval van .deb, libraries worden geupdate waardoor de statische .deb van aMSN hiermee niet meer overweg kan?

Offline Samuel Rave

  • Lid
    • http://www.familie-rave.de/
  • Steunpunt: Nee
aMSN 0.96 in Dapper
« Reactie #14 Gepost op: 2006/12/19, 22:03:19 »
Citaat van: Basic
Maar hoe zit dat dan met zo'n zelfgebouwde .deb? Is dit dan enkel het prog aMSN, en maakt dit gebruik van aanwezige dynamische (automatisch geupdate) libraries op het systeem? En valt het prog dan WEL te verwijderen met Synaptic?

En proFox bedoel je DIT met de kopzorgen: dat er misschien in het geval van .deb, libraries worden geupdate waardoor de statische .deb van aMSN hiermee niet meer overweg kan?
Beste Basic...je begrijpt het systeem nog niet helemaal...
synaptic werkt alleen met *.deb's
dus wanneer je een .deb bouwt dan is dat ALTIJD en JUIST te deinstalleren met synaptic. EN worden ALTIJD de benodigde lib's erbij geinstalleerd.

Het hele systeem ubuntu is gebouwd met .deb's...alle programma's die je download van de repositories zijn .deb's...dus .debs is ALTIJD het beste vooral wanneer specifiek voor ubuntu.

Wanneer .libs geupdate worden zal het nooit problemen geven,tenzij een foute update, maar die worden in een korte tijd gecorrigeerd.
Verder zullen libs alleen problemen wanneer er nieuwere versie libs gebruikt worden, zoals het verschil in sommige libs tussen Edgy en Dapper.
Dus amsn gebouwd voor Dapper kan problemen geven bij installatie op Edgy.
Dat is ook de reden dat in de sources.list de regels in edgy specifiek voor Edgy zijn, en de list in Dapper specifiek voor Dapper.

Offline Ronnie

  • Artworkteam
    • ronnie.vd.c
  • Steunpunt: Nee
aMSN 0.96 in Dapper
« Reactie #15 Gepost op: 2006/12/19, 22:22:47 »
.deb pakketje maken lukt mij niet echt,
./configure kom ik nog wel doorheen, een aantal progs installeren.
make, daar loop ik al vast. ik krijg een aantal foutmeldingen waarvan ik geen idee heb hoe ik ze op moet lossen.

Zou iemand een .deb voor mij kunnen maken en dan opsturen naar:
peterpuk@gmailcom

Dan kan ik ook fantsoenlijk msn, zoals ik dat op win kan

Heeft trouwens iemand een idee wanneer de nieuwe versie in de respo zit
Ben je ook blij dat Ubuntu zo toegankelijk en gratis is, en wil je graag net als ik iets terugdoen, kijk dan eens rond bij mwanzo, dé poort naar het bijdragen aan Ubuntu en haar gemeenschap!

Documentatie Terminal

Offline bartek

  • Lid
    • http://bartek.blogsome.com
  • Steunpunt: Nee
aMSN 0.96 in Dapper
« Reactie #16 Gepost op: 2006/12/19, 22:39:36 »
Citaat
$ tar -xjf amsn-0.96.tar.bz2
$ cd amsn-0.96 $ ./configure --with-tcl=/usr/lib/tcl8.4 --with-tk=/usr/lib/tk8.4
$ make
$ make deb
http://avecpinguin.kikkum.net/2006/12/amsn-096.html
| Deliberando saepe perit occasio |

"Car la vie est un bien perdu quand on n'a pas vécu comme on l'aurait voulu"

Offline Samuel Rave

  • Lid
    • http://www.familie-rave.de/
  • Steunpunt: Nee
aMSN 0.96 in Dapper
« Reactie #17 Gepost op: 2006/12/19, 23:40:38 »
Citaat van: bartek
./configure --with-tcl=/usr/lib/tcl8.4 --with-tk=/usr/lib/tk8.4
http://avecpinguin.kikkum.net/2006/12/amsn-096.html
Dit extra info in de commandline hoeft echt niet.
Die krijg je namelijk omdat een standaard ubuntu installatie ervan uitgaat dat je zelf geen deb packages gaat bouwen.
Je hebt alleen de dev (=develop) packages nodig.
Bij alle errors en foutmeldigen ga zoeken in synaptic naar pakketten die de naam hebben die aangegeven worden bij de errors, installeer de dev-packages en de normale.

Installeer wel ff extra bijvoorbeeld de pakketten:
sudo apt-get install dpkg-dev debian-builder debhelper cdbs build-essential cmake debmake dh-make debnest

de nieuwe versie van amsn komt in de repo's bij de nieuwe ubuntu versie 7.04

Toevallig was ik laatst er nog mee bezig ;)
http://forum.ubuntu-nl.org/topic/5747

Offline Samuel Rave

  • Lid
    • http://www.familie-rave.de/
  • Steunpunt: Nee
aMSN 0.96 in Dapper
« Reactie #18 Gepost op: 2006/12/20, 00:18:24 »
bijvoorbeeld een aantal van de bestanden die echt geinstalleerd moeten worden, speciefiek voor het configureren van amsn:
sudo apt-get install tcl8.4 tcl8.4-dev tk8.4 tk8.4-dev

Offline Samuel Rave

  • Lid
    • http://www.familie-rave.de/
  • Steunpunt: Nee
aMSN 0.96 in Dapper
« Reactie #19 Gepost op: 2006/12/20, 00:35:37 »
Ohw jah...helaas kan ik je mijn pakketje niet sturen want de mijne is alleen geschikt voor PPC-architectuur, oftewel voor AppleMacintosh computers.

Offline bartek

  • Lid
    • http://bartek.blogsome.com
  • Steunpunt: Nee
aMSN 0.96 in Dapper
« Reactie #20 Gepost op: 2006/12/20, 08:31:06 »
Citaat van: CORVUS_CORAX
de nieuwe versie van amsn komt in de repo's bij de nieuwe ubuntu versie 7.04

Toevallig was ik laatst er nog mee bezig ;)
http://forum.ubuntu-nl.org/topic/5747
Ik heb gisteren nog ff gekeken en nog steeds aMSN 0.95 in de Feisty repo's
| Deliberando saepe perit occasio |

"Car la vie est un bien perdu quand on n'a pas vécu comme on l'aurait voulu"

Offline Samuel Rave

  • Lid
    • http://www.familie-rave.de/
  • Steunpunt: Nee
aMSN 0.96 in Dapper
« Reactie #21 Gepost op: 2006/12/20, 10:05:01 »
Citaat van: bartek
Ik heb gisteren nog ff gekeken en nog steeds aMSN 0.95 in de Feisty repo's
Ik geef ze nog de kans, Feisty komt volgend jaar April officieel uit.

Basic

  • Gast
aMSN 0.96 in Dapper
« Reactie #22 Gepost op: 2006/12/20, 18:51:47 »
Heb voor de stabiliteit gekozen voor Dapper aangezien ik geen techneut ben en niet trek heb in crashes... Weet dus niet of de volgende versie van Ubuntu al voor mij is. Ubuntu Dapper 6.06 LTS is in juni 2006 uitgekomen en wordt 3 jaar gesupport, als ik het goed heb komt er elke 1,5 jaar een LTS-versie uit, bedoeld voor het grote publiek die net als ik niet techneut is, en alleen maar stabiel wil kunnen PC-en. Dan zal ik dus nog even moeten wachten op de nieuwe aMSN.

OF...

.deb maken kan misschien wel makkelijk zijn maar heb hier nog geen ervaring mee dus weet niet of dit voor mij ook geldt, en zoals gezegd ben geen techneut. Maar misschien ga ik hier nog wel even naar kijken.

Maar het heeft ook nog kans dat ik de Autopackage ga proberen, aangezien dit de minste technische kennis vraagt voor de installatie.

Of ik laat de upgrade toch zitten...

Ben d'r dus nog niet uit maar zal het wel even laten weten ALS ik ga upgraden.

Bedankt,

Basic

Offline Gandyman

  • Lid
  • Steunpunt: Nee
aMSN 0.96 in Dapper
« Reactie #23 Gepost op: 2006/12/23, 02:51:24 »
Ik wilde ff dat .deb pakketje maken maar bij de ./configure opdracht loop ik tegen een melding aan.
Citaat
checking for png_read_info in -lpng... no
configure: error: libpng is required
Vrij simpel dus ik kijk in de synaptic en daar is wel de libpng geinstalleerd.
Citaat
libpng12-0
PNG library - runtime
Reeds een herinstall gedaan, echter zonder succes, ik blijf deze melding krijgen ????

erm ? en nu ?

:P
I don't suffer from insanity, I enjoy every minute of it.
Microsoft geeft je een raam, Linux geeft je een heel huis :D

Offline Samuel Rave

  • Lid
    • http://www.familie-rave.de/
  • Steunpunt: Nee
aMSN 0.96 in Dapper
« Reactie #24 Gepost op: 2006/12/23, 04:43:32 »
Citaat van: Gandyman
Ik wilde ff dat .deb pakketje maken maar bij de ./configure opdracht loop ik tegen een melding aan.
Citaat
checking for png_read_info in -lpng... no
configure: error: libpng is required
Vrij simpel dus ik kijk in de synaptic en daar is wel de libpng geinstalleerd.
Citaat
libpng12-0
PNG library - runtime
Reeds een herinstall gedaan, echter zonder succes, ik blijf deze melding krijgen ????

erm ? en nu ?

:P
je moet natuurlijk de libpng12-dev hebben he! Dus wanneer je een pakketje wil compilen dan ben je developer en die heeft essentieel de *-dev.pakketjes nodig ;)
Bij alle errors die je krijgt moet je dus wel de dev pakketten installeren.

Ohw jah, ff het volgende, na ./configure zonder enige error, moet je make doen,
daarna moet je make deb