Nieuws:

We zijn er weer.

Na lange tijd van afwezigheid zijn we er weer  :laugh:
We hebben alle wachtwoorden gereset, je oude wachtwoord werkt niet meer.Je moet via het "wachtwoord vergeten"-linkje je wachtwoord resetten. Je krijgt hiervoor een mailtje op het adres dat je bij ons geregistreerd hebt.

De komende tijd zijn we nog druk bezig om de rest van de site op te bouwen, dus het kan zijn dat sommige onderdelen (tijdelijk) niet werken.

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: [OPGELOST] 10.04 krijgt alleen IPv6 adres, geen internet verbinding  (gelezen 2150 keer)

Offline tabasco

  • Lid
  • Steunpunt: Nee
Hallo allemaal :)

Op dit PC'tje werkt het internet (bedraad) plots niet meer.
Ubuntu (10.04) geeft ineens een IPv6 adres i.p.v. een IPv4 adres en kan niet meer op internet komen.
Sinds april heeft dit altijd goed gewerkt, en alle updates zijn doorgevoerd.

Het betreft een Telenet verbinding met 1 pc bedraad aangesloten.
Ik heb getest met een andere kabel; zelfde resultaat.
Ik heb getest met een Ubuntu notebook (9.10); zelfde resultaat.

Voor de zekerheid heb ik ook met de Telenet helpdesk gebeld, waar ik heel vriendelijk te woord ben gestaan maar zij konden mij op dit moment nog niet verder helpen...

Code: (~$ ifconfig) [Selecteer]
eth0      Link encap:Ethernet  HWaddr 00:07:e9:63:3f:f7
          inet6 addr: fe80::207:e9ff:fe63:3ff2/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:1643 errors:0 dropped:0 overruns:0 frame:0
          TX packets:18 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:158795 (158.7 KB)  TX bytes:1404 (1.4 KB)

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:348 errors:0 dropped:0 overruns:0 frame:0
          TX packets:348 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:26680 (26.6 KB)  TX bytes:26680 (26.6 KB)

Code: (~$ lshw) [Selecteer]
*-network
                description: Ethernet interface
                product: 82562EZ 10/100 Ethernet Controller
                vendor: Intel Corporation
                physical id: 8
                bus info: pci@0000:02:08.0
                logical name: eth0
                version: 02
                serial: 00:07:e9:63:3f:f7
                width: 32 bits
                clock: 33MHz
                capabilities: bus_master cap_list ethernet physical
                configuration: broadcast=yes driver=e100 driverversion=3.5.24-k2-NAPI firmware=N/A latency=64 maxlatency=56 mingnt=8 multicast=yes
                resources: irq:20 memory:fcfff000-fcffffff ioport:df40(size=64)

Heeft iemand een idee hoe ik verder kan ?
Dank!
        
« Laatst bewerkt op: 2010/08/17, 23:23:17 door tabasco »

Offline tabasco

  • Lid
  • Steunpunt: Nee
Re: 10.04 krijgt alleen IPv6 adres, geen internet verbinding
« Reactie #1 Gepost op: 2010/08/17, 23:20:21 »
Opgelost door wat geklooi...
Helaas weet ik niet de oorzaak.

Ik heb de nm-applet even aangezet en daar netwerk aangezet en geselecteerd.
Deze stond uit, zie deze post, vanwege 1 enkele vaste verbinding.

Wie kan mij vertellen welke commando's de networkmanager applet uitvoert?
Zodat ik het in het vervolg zelf in de terminal kan oplossen...
Dit icoontje in de taakbalk gebruik ik namelijk verder helemaal niet.

En ik vraag mij af wat er geburt is en waarom, updates?, afwachten of het probleem zich herhaalt wellicht.


Offline heir4c

  • Lid
  • Steunpunt: Nee
Re: 10.04 krijgt alleen IPv6 adres, geen internet verbinding
« Reactie #2 Gepost op: 2010/08/17, 23:25:18 »
Eerste mogelijkheid:
Rechtsklikken op het netwerkicoon. Dan kiezen voor: Verbindingen bewerken. Selecteer je verbinding (onder Kabel, Draadloos, ...) en klik op de knop 'Bewerken'.
Nu opent zich een venster. Daar ga je naar het tabblad IPv4 verbindingen. Daar kan je instellen hoe hij verbinding moet leggen. Dan ga je naar het tabblad IPv6 verbindingen en kies je voor de Methode: "Negeren". En dan op de knop "Toepassen" onderaan.
Werkt het nu? (eventueel eens uitloggen en weer inloggen of zelfs eens herstarten.


Tweede mogelijkheid:
Je kan grub aanpassen zodat hij de ipv6 automatisch negeerd.
Klik Ctrl+F2 en tik in:
gksudo gedit /etc/default/grubZoek de volgende regel:
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
Die moet je zodanig aanpassen dat die zo word:
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash ipv6.disable=1"
Opslaan
En dan een terminal openen en daar intikken:
sudo update-grubAls je nu je comp herstart zou hij dus automatisch ipv4 moeten gebruiken.

Probeer het eens, werkt het internet nog niet dan verwijder je die bijvoeging terug, op de zelfde manier als je die toegevoegd hebt.
En als het wel werkt kan je dat later altijd nog verwijderen als er standaard overal IPv6 adressen zullen gebruikt worden.

Succes! en laat iets weten wat werkt.

Met vriendelijke groet,
heir4c


Edit: Je bericht gelezen toen ik het mijne verzond. Ik laat het eerste deel maar staan ter info voor anderen.
Commando's: daar heb ik nog te weinig kennis over om dat te weten. Dus anderen zullen je moeten helpen of even via google zoeken op: netwerkmanager commandline ubuntu  (of zoiets).