Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Ubuntu server start niet meer  (gelezen 1653 keer)

Offline Hillman5100

  • Lid
  • Steunpunt: Nee
Ubuntu server start niet meer
« Gepost op: 2010/08/16, 22:16:09 »
Hallo allemaal,

Ik heb dit probleem nu al meerdere keren achter elkaar gehad en ik ben echt de weg kwijt nu.

Ik heb een oude pc gedoneerd gekregen die ik wil omtoveren tot een klein servertje voor in mijn eigen netwerk.
Hierop heb ik (meerder malen) Ubuntu Server 10.04 geinstalleerd.
Dit gaat allemaal prima.

Normaal als ik opstart gaat hij gewoon opstarten en krijg ik de gebruikelijke tekst op men scherm, en uiteindelijk kan ik inloggen op tty1.

Maar na 2 keer opstarten gaat er een cursor 2 keer in de linker bovenhoek knipperen, dit gaat daarna weg, tot dat mijn scherm zegt (no input). En dan blijft hij hier op staan, en gebeurt er niks meer. De server is na de eerste keer opstarten benaderbaar via samba en ssh. Maar nu reageert de server nergen meer op.

Dit vind ik vreemd want het is nog steeds een schone installatie. Want ik heb tot dus ver niks geinstalleerd, en aangepast. Alleen een paar enkele verbindingen via putty naar de server gelegd. En gekeken of de server detecteerbaar was bij netwerk.

Weet iemand een oplossing voor dit probleem? Het lijkt op een bug namelijk, want ik heb de herinstallatie al 3 keer uitgeprobeerd met hetzelfde resultaat.

Alvast bedank,

Hillman5100

Offline walterav

  • Lid
  • Steunpunt: Nee
Re: Ubuntu server start niet meer
« Reactie #1 Gepost op: 2010/08/16, 22:51:59 »

Normaal als ik opstart gaat hij gewoon opstarten en krijg ik de gebruikelijke tekst op men scherm, en uiteindelijk kan ik inloggen op tty1.

Maar na 2 keer opstarten gaat er een cursor 2 keer in de linker bovenhoek knipperen, dit gaat daarna weg, tot dat mijn scherm zegt (no input). En dan blijft hij hier op staan, en gebeurt er niks meer. De server is na de eerste keer opstarten benaderbaar via samba en ssh. Maar nu reageert de server nergen meer op.

Hillman5100

Denk dat het KMS "kernel mode setting" is die je resolutie probeert te verhogen... i.c.m. plymouth en dan wellicht crasht.
« Laatst bewerkt op: 2010/08/16, 22:55:35 door walterav »

Offline Hillman5100

  • Lid
  • Steunpunt: Nee
Re: Ubuntu server start niet meer
« Reactie #2 Gepost op: 2010/08/16, 22:58:21 »

Normaal als ik opstart gaat hij gewoon opstarten en krijg ik de gebruikelijke tekst op men scherm, en uiteindelijk kan ik inloggen op tty1.

Maar na 2 keer opstarten gaat er een cursor 2 keer in de linker bovenhoek knipperen, dit gaat daarna weg, tot dat mijn scherm zegt (no input). En dan blijft hij hier op staan, en gebeurt er niks meer. De server is na de eerste keer opstarten benaderbaar via samba en ssh. Maar nu reageert de server nergen meer op.

Hillman5100

Denk dat het KMS "kernel mode setting" is die je resolutie probeert te verhogen... i.c.m. plymouth en dan wellicht crasht.

Ok, de eerste keer wanneer ik opstarte deed hij het goed, en nam hij ook de juiste resolutie aan. Maar crasht ie daar dus schijnbaar op. Is er een manier om dit op te lossen?

Offline walterav

  • Lid
  • Steunpunt: Nee
Re: Ubuntu server start niet meer
« Reactie #3 Gepost op: 2010/08/16, 23:02:16 »
Ok, de eerste keer wanneer ik opstarte deed hij het goed, en nam hij ook de juiste resolutie aan. Maar crasht ie daar dus schijnbaar op. Is er een manier om dit op te lossen?

Wellicht werkt het na de eerste keer inloggen niet meer vanwege het laden van updates? Probeer anders PC te starten zonder
monitor als die blijft crashen en log in via SSH.

Kun je dan de output van "lspci" geven? Kijken om welke videokaart het gaat.

https://wiki.ubuntu.com/X/KernelModeSetting

Offline Hillman5100

  • Lid
  • Steunpunt: Nee
Re: Ubuntu server start niet meer
« Reactie #4 Gepost op: 2010/08/16, 23:07:14 »
Ok, de eerste keer wanneer ik opstarte deed hij het goed, en nam hij ook de juiste resolutie aan. Maar crasht ie daar dus schijnbaar op. Is er een manier om dit op te lossen?

Wellicht werkt het na de eerste keer inloggen niet meer vanwege het laden van updates? Probeer anders PC te starten zonder
monitor als die blijft crashen en log in via SSH.

Kun je dan de output van "lspci" geven? Kijken om welke videokaart het gaat.

https://wiki.ubuntu.com/X/KernelModeSetting
Ik heb de kabel van de moitor er uit getrokken, en dit heeft geholpen  =D
het was toch zowiezo al de bedoeling dat er geen monitor op kwam.
Ik kan weer via putty inloggen.
En hierbij de output van lspci.

root@erik-server:/home/erik# lspci
00:00.0 Host bridge: Intel Corporation 82865G/PE/P DRAM Controller/Host-Hub Interface (rev 02)
00:02.0 VGA compatible controller: Intel Corporation 82865G Integrated Graphics Controller (rev 02)
00:06.0 System peripheral: Intel Corporation 82865G/PE/P Processor to I/O Memory Interface (rev 02)
00:1d.0 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI Controller #1 (rev 02)
00:1d.1 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI Controller #2 (rev 02)
00:1d.2 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI Controller #3 (rev 02)
00:1d.3 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI Controller #4 (rev 02)
00:1d.7 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB2 EHCI Controller (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev c2)
00:1f.0 ISA bridge: Intel Corporation 82801EB/ER (ICH5/ICH5R) LPC Interface Bridge (rev 02)
00:1f.1 IDE interface: Intel Corporation 82801EB/ER (ICH5/ICH5R) IDE Controller (rev 02)
00:1f.2 IDE interface: Intel Corporation 82801EB (ICH5) SATA Controller (rev 02)
00:1f.3 SMBus: Intel Corporation 82801EB/ER (ICH5/ICH5R) SMBus Controller (rev 02)
00:1f.5 Multimedia audio controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) AC'97 Audio Controller (rev 02)
01:08.0 Ethernet controller: Intel Corporation 82557/8/9/0/1 Ethernet Pro 100 (rev 05)
01:0c.0 Ethernet controller: Intel Corporation 82540EM Gigabit Ethernet Controller (rev 02)

Offline walterav

  • Lid
  • Steunpunt: Nee
Re: Ubuntu server start niet meer
« Reactie #5 Gepost op: 2010/08/16, 23:41:37 »
root@erik-server:/home/erik# lspci
00:02.0 VGA compatible controller: Intel Corporation 82865G Integrated Graphics Controller (rev 02)

Zo te zien een intel VGA uit de 865G serie welke helaas problematisch is met Ubuntu 10.04. Ik denk dat die zonder monitor perfect werkt, maar dat is geen echte oplossing  XD.

Als oplossing zou je nog een kernel bootflag kunnen toevoegen waarmee je KMS uitzet "weet niet zeker of die wel aanstaat", probeer deze eerst even voordat je aan de GRUB files gaat rommelen.
Dus SHIFT toets ingedrukt houden tijdens booten dan verschijnt GRUB2 menut en dan de juiste kernel aankiezen, die editen en daar iets achter typen in de trend van intel mode Zie opnieuw deze link voor je videokaart.
https://wiki.ubuntu.com/X/KernelModeSetting

Een andere oplossing lees anders eerste paar posts uit onderstaande link, daar staat hoe je een andere driver kan toevoegen.
http://forum.ubuntu-nl.org/installatie/problemen-met-ll-installatie-op-intel-845855gm-chipset-hier-is-de-oplossing!/