Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: apple magic mouse  (gelezen 3011 keer)

Offline hans_4

  • Lid
  • Steunpunt: Nee
apple magic mouse
« Gepost op: 2010/08/13, 15:17:51 »
beste forumers,

ik heb een apple magic mouse en ik ben hem werkend aan het proberen krijgen volgens deze tutorial http://ubuntuforums.org/showpost.php?p=8777663&postcount=21
nu kom ik vast te zitten bij dit deel:
git checkout Ubuntu-2.6.31-19.56ik kan nergens mijn volledig kernel versie vinden bij het opstarten krijg ik 2.6.32-24.

met vriendelijke groet

Hans


edit: titel veranderd.
« Laatst bewerkt op: 2010/08/14, 19:15:40 door hans_4 »

Offline MauRice2

  • Lid
  • Steunpunt: Nee
Re: apple magic mouse
« Reactie #1 Gepost op: 2010/08/13, 19:28:40 »
Hans_4,

Kijk eens of in je huidige kernel de code  'Apple Magic Mouse' is verwerkt is.
Info: http://www.kernel.org/

Zoniet, zal je alle source-code, patchen en dergelijke voor je huidige kernel moeten gaan zoeken.
Die van het forum-topic zijn voor Ubuntu 9.10 met kernel-versie 2.6.31-19.56.


« Laatst bewerkt op: 2010/12/30, 07:49:39 door MauRice2 »
MvG,
MauRice
Registered Linux user: 473556

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Re: apple magic mouse
« Reactie #2 Gepost op: 2010/08/14, 14:03:46 »
Om de kernel versie op te vragen type je in de terminal uname -r
Om de kernel versie met uitgebreiderde inf op te vragen type je in de terminal uname -a

Bij mij ziet het er zo uit:
gijs@gijs-lucid:~$ uname -r
2.6.32-24-generic
gijs@gijs-lucid:~$ uname -a
Linux gijs-lucid 2.6.32-24-generic #39-Ubuntu SMP Wed Jul 28 05:14:15 UTC 2010 x86_64 GNU/Linux
In der Beschränkung zeigt sich der Meister.

Offline hans_4

  • Lid
  • Steunpunt: Nee
Re: apple magic mouse
« Reactie #3 Gepost op: 2010/08/14, 17:11:13 »
ik zal wel eventjes wachten op 10.10. http://digitizor.com/2010/08/02/ubuntu-10-10-supports-magic-mouse-out-of-the-box/

bedankt voor de input maar ik vind het gewoon teveel werk voor zo'n stomme muis.
moet ik hier nu [opgelost] voorzetten?


met vriendelijke groet

hans_4

Offline hans_4

  • Lid
  • Steunpunt: Nee
Re: apple magic mouse
« Reactie #4 Gepost op: 2010/08/14, 19:18:37 »
ok, ik heb nu de cd van maverick er in zitten en, de muis werkt  XD
heeft iemand een goede tutorial om de maverick kernel in lucid te krijgen.

alvast bedankt

hans_4
« Laatst bewerkt op: 2010/08/14, 20:37:49 door hans_4 »

Offline Vistaus

  • Webteam
    • vistaus
  • Steunpunt: Nee
Re: apple magic mouse
« Reactie #5 Gepost op: 2010/08/14, 20:16:34 »
Klopt, de Magic Mouse wordt ondersteund sinds kernel 2.6.34 RC. In Maverick zit 2.6.35

Ik heb hier de 2.6.35 Maverick-kernel draaien op 10.04 Lucid, draait superstabiel en mijn Magic Mouse doet het perfect :) (op de multitouch na dan).

Offline hans_4

  • Lid
  • Steunpunt: Nee
Re: apple magic mouse
« Reactie #6 Gepost op: 2010/08/14, 20:35:48 »
bij mij werkt multitouch perfect in maverick. daarom wil ik de kernel van maverick in lucid krijgen. in lucid werkt de muis behalve de multitouch wat juist het belangrijkste is.

met vriendelijke groet

Hans_4
« Laatst bewerkt op: 2010/09/13, 22:24:51 door hans_4 »

Offline MauRice2

  • Lid
  • Steunpunt: Nee
Re: apple magic mouse
« Reactie #7 Gepost op: 2010/08/14, 21:15:58 »
bij mij werkt multitouch perfect in maverick. daarom wil ik de kernel van maverick in lucid krijgen. in lucid werkt de muis behalve de multitouch wat juist het belangrijkste is.

met vriendelijke groet

Hans_4
Hans_4,

Zomaar de kernel van Maverick installeren in Lucid.....
De kans is groot om moelijkheden te vragen.

Veel veiliger is gaan 'backpoorten'.
Het komt er op neer om de source-deb kernel-pakket van Maverick te nemen.
En deze te gaan hercompileren op een Lucid systeem.

Op een RPM gebaseerde distro, oa Fedora en Mandriva, kan ik je dat haarfijn uitleggen.
Met Ubuntu heb ik het iets moeilijker.
Ik vind zo 123(45) niet de source-deb pakketten van oa Maverick op hun ftp-server's mochten deze bestaan.



« Laatst bewerkt op: 2010/12/30, 07:51:04 door MauRice2 »
MvG,
MauRice
Registered Linux user: 473556

Offline Vistaus

  • Webteam
    • vistaus
  • Steunpunt: Nee
Re: apple magic mouse
« Reactie #8 Gepost op: 2010/08/14, 21:45:47 »
bij mij werkt multitouch perfect in maverick. daarom wil ik de kernel van maverick in lucid krijgen. in lucid werkt de muis behalve de multitouch wat juist het belangrijkste is.

met vriendelijke groet
Hans,

Zomaar de kernel van Maverick installeren in Lucid.....
De kans is groot om moelijkheden te vragen.

Veel veiliger is gaan 'backpoorten'.
Het komt er op neer om de source-deb kernel-pakket van Maverick te nemen.
En deze te gaan hercompileren op een Lucid systeem.

Op een RPM gebaseerde distro, oa Fedora en Mandriva, kan ik je dat haarfijn uitleggen.
Met Ubuntu heb ik het iets moeilijker.
Ik vind zo 123(45) niet de source-deb pakketten van oa Maverick op hun ftp-server's mochten deze bestaan.





@Maurice: Volgens mij heb je mijn reactie hierboven over het hoofd gezien.
Ik heb hier de 2.6.35 van Maverick op 10.04 draaien en alles draait perfect :)
Deze is beschikbaar gesteld voor Lucid door het officiële kernel-team in hun PPA:
https://launchpad.net/~kernel-ppa/+archive/ppa
« Laatst bewerkt op: 2010/12/30, 20:25:28 door Vistaus »

Offline MauRice2

  • Lid
  • Steunpunt: Nee
Re: apple magic mouse
« Reactie #9 Gepost op: 2010/08/15, 09:39:09 »
bij mij werkt multitouch perfect in maverick. daarom wil ik de kernel van maverick in lucid krijgen. in lucid werkt de muis behalve de multitouch wat juist het belangrijkste is.

met vriendelijke groet

Hans_4
Hans_4,

Zomaar de kernel van Maverick installeren in Lucid.....
De kans is groot om moelijkheden te vragen.

Veel veiliger is gaan 'backpoorten'.
Het komt er op neer om de source-deb kernel-pakket van Maverick te nemen.
En deze te gaan hercompileren op een Lucid systeem.

Op een RPM gebaseerde distro, oa Fedora en Mandriva, kan ik je dat haarfijn uitleggen.
Met Ubuntu heb ik het iets moeilijker.
Ik vind zo 123(45) niet de source-deb pakketten van oa Maverick op hun ftp-server's mochten deze bestaan.

@Maurice: Volgens mij heb je mijn reactie hierboven over het hoofd gezien.
Ik heb hier de 2.6.35 van Maverick op 10.04 draaien en alles draait perfect :)
Deze is beschikbaar gesteld voor Lucid door het officiële kernel-team in hun PPA:
https://launchpad.net/~kernel-ppa/+archive/ppa

Vistaus,

Hoe de ontwikkeling van Ubuntu in elkaar zit, daar kom ik langzaam uit.

Je heb niet de Maverick-2.6.35-kernel op je Lucid systeem.
Maar de backport voor Lucid van de Maverick-2.6.35-kernel, hergecompileerd op een Lucid systeem door hun.
En dat is precies wat ik bedoelde.
Bespaart je tijd en kopzorgen.

De volgende vraag wordt dan:
Hoe heb je deze repository toegevoegd, of deze backport-kernel geinstalleerd?
Niet zo zeer voor mij, mijn hardware is al aardig bejaard, maar eerder voor diegene die de laatste snufjes hebben.
oa. die 'apple magic mouse', touchscreen waarin je met de venster kan spelen,  etc etc...

« Laatst bewerkt op: 2010/12/30, 07:51:39 door MauRice2 »
MvG,
MauRice
Registered Linux user: 473556

Offline Thomas de Graaff

  • Lid
  • Steunpunt: Nee
Re: apple magic mouse
« Reactie #10 Gepost op: 2010/08/15, 11:15:57 »
Hier staat uitgelegd hoe een ppa repo toe te voegen:

http://wiki.ubuntu-nl.org/community/PpaToevoegen?highlight=%28ppa%29

Offline hans_4

  • Lid
  • Steunpunt: Nee
Re: apple magic mouse
« Reactie #11 Gepost op: 2010/08/15, 15:33:11 »
ik heb de ppa toegevoegd en in synaptic alles met 2.6.35-15 geinstalleerd maar, mijn videodriver van ati werkt nu niet meer, alle vensters bewegen schokkerig als ik ze versleep, scrollen gaat bijna niet en, de magicmouse word zelfs niet herkend  :'(

met vriendelijke groet

Hans_4

Offline MauRice2

  • Lid
  • Steunpunt: Nee
Re: apple magic mouse
« Reactie #12 Gepost op: 2010/08/15, 16:23:50 »
ik heb de ppa toegevoegd en in synaptic alles met 2.6.35-15 geinstalleerd maar, mijn videodriver van ati werkt nu niet meer, alle vensters bewegen schokkerig als ik ze versleep, scrollen gaat bijna niet en, de magicmouse word zelfs niet herkend  :'(

met vriendelijke groet

Hans_4
Hans_4,

Is het een Ati-kaart die nog door de ati-fglrx-driver wordt ondersteund.
Zo neen, dan mag het volgens mij niet uitmaken welke kernel-versie je op het moment gebruikt.

Zo ja:
Is het de driver van de ATi site zelf, of van de repo 'restricted' (non-free).
Voor beiden heb je de minimale kernel-source-code 3.6.35-15 nodig, de header-bestanden.

Als je de driver van de ATi-site heb, dan moet je deze opnieuw aanmaken door de "installer" weer uit te voeren.
Komt de driver vanaf de 'restricted' (non-free) repo, dan vermoed ik dat je de fglrx voor kernel 3.6.35-15 ontbreekt.

En nog veel erger dat het je magicmouse niet herkent wordt.

Backporten is makkelijker gezegd dan uitgevoerd!!





« Laatst bewerkt op: 2010/12/30, 07:51:59 door MauRice2 »
MvG,
MauRice
Registered Linux user: 473556

Offline hans_4

  • Lid
  • Steunpunt: Nee
Re: apple magic mouse
« Reactie #13 Gepost op: 2010/08/15, 22:37:59 »
ik heb geprobeerd de driver van de ati site te installeren maar, het werkte niet. ik heb 2.6.35-15 ingetypt in synaptic en alles verwijdert. na het herstarten werkt alles beter maar, ik krijg de ati drivers niet geinstalleerd. gewoon systeem>beheer>stuurprogrammas. ik kan niet meer updaten omdat er 1 pakket "gebroken" is. het was een update van fglrx. nu zag ik dat fglrx niet geinstalleerd was. als ik het probeer te installeren krijg ik dit:
(Database inlezen ... 268508 bestanden en mappen geïnstalleerd.)
Uitpakken van fglrx (uit .../fglrx_2%3a8.723.1-0ubuntu4_i386.deb) ...

[Warning] Uninstall : inst_path_default or inst_path_override
 does not exist in /etc/ati.  This suggests that the ATI driver
 is not installed, the ATI driver is only partially installed,
 or the current ATI driver installed is an older version than the
 one this script was designed for.  Both files listed above are
 required for determining where installed files are located.
 To force uninstallation of the driver by guessing where the
 uninstallation files are located, set the FORCE_ATI_UNINSTALL
 environment variable and re-run /usr/share/ati/fglrx-uninstall.sh (this is not recommended).

dpkg: fout bij afhandelen van /var/cache/apt/archives/fglrx_2%3a8.723.1-0ubuntu4_i386.deb (--unpack):
 subproces nieuw pre-installation script gaf een foutwaarde 1 terug
Selecteren van voorheen niet geselecteerd pakket fglrx-kernel-source.
Uitpakken van fglrx-kernel-source (uit .../fglrx-kernel-source_2%3a8.723.1-0ubuntu4_i386.deb) ...
Selecteren van voorheen niet geselecteerd pakket xorg-driver-fglrx.
Uitpakken van xorg-driver-fglrx (uit .../xorg-driver-fglrx_2%3a8.723.1-0ubuntu4_i386.deb) ...
Fouten gevonden tijdens behandelen van:
 /var/cache/apt/archives/fglrx_2%3a8.723.1-0ubuntu4_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
Een pakket kon niet geïnstalleerd worden. Er wordt geprobeerd om te herstellen:
dpkg: vereistenproblemen verhinderen de configuratie van xorg-driver-fglrx:
 xorg-driver-fglrx is afhankelijk van fglrx; maar:
  Pakket `fglrx' is niet geïnstalleerd.
dpkg: fout bij afhandelen van xorg-driver-fglrx (--configure):
 vereistenproblemen - blijft ongeconfigureerd
dpkg: vereistenproblemen verhinderen de configuratie van fglrx-kernel-source:
 fglrx-kernel-source is afhankelijk van fglrx; maar:
  Pakket `fglrx' is niet geïnstalleerd.
dpkg: fout bij afhandelen van fglrx-kernel-source (--configure):
 vereistenproblemen - blijft ongeconfigureerd
dpkg: vereistenproblemen verhinderen de configuratie van fglrx-amdcccle:
 fglrx-amdcccle is afhankelijk van fglrx; maar:
  Pakket `fglrx' is niet geïnstalleerd.
dpkg: fout bij afhandelen van fglrx-amdcccle (--configure):
 vereistenproblemen - blijft ongeconfigureerd
Fouten gevonden tijdens behandelen van:
 xorg-driver-fglrx
 fglrx-kernel-source
 fglrx-amdcccle

 sudo apt-get update && sudo apt-get upgrade geeft dit. maar ik krijg fglrx niet geinstalleerd. -f helpt niet.
hans@hans-desktop:~$ sudo apt-get update && sudo apt-get upgrade
Geraakt http://archive.canonical.com lucid Release.gpg
Genegeerd http://archive.canonical.com/ubuntu/ lucid/partner Translation-nl   
Geraakt http://ppa.launchpad.net lucid Release.gpg                             
Genegeerd http://ppa.launchpad.net/arduino-ubuntu-team/ppa/ubuntu/ lucid/main Translation-nl
Geraakt http://mirror.liteserver.nl lucid Release.gpg                         
Geraakt http://archive.canonical.com lucid Release.gpg                         
Genegeerd http://archive.canonical.com/ lucid/partner Translation-nl           
Geraakt http://archive.canonical.com lucid Release                             
Geraakt http://ppa.launchpad.net lucid Release.gpg                             
Genegeerd http://ppa.launchpad.net/kernel-ppa/ppa/ubuntu/ lucid/main Translation-nl
Geraakt http://ppa.launchpad.net lucid Release.gpg                             
Genegeerd http://ppa.launchpad.net/tualatrix/ppa/ubuntu/ lucid/main Translation-nl
Geraakt http://ppa.launchpad.net lucid Release                                 
Geraakt http://archive.canonical.com lucid Release                             
Geraakt http://mirror.liteserver.nl/pub/ubuntu/ lucid/main Translation-nl     
Geraakt http://ppa.launchpad.net lucid Release                                 
Geraakt http://ppa.launchpad.net lucid Release                                 
Geraakt http://archive.canonical.com lucid/partner Packages                   
Geraakt http://archive.canonical.com lucid/partner Packages                   
Geraakt http://ppa.launchpad.net lucid/main Packages                           
Geraakt http://mirror.liteserver.nl/pub/ubuntu/ lucid/restricted Translation-nl
Geraakt http://ppa.launchpad.net lucid/main Packages                           
Geraakt http://ppa.launchpad.net lucid/main Packages                           
Geraakt http://mirror.liteserver.nl/pub/ubuntu/ lucid/universe Translation-nl 
Geraakt http://mirror.liteserver.nl/pub/ubuntu/ lucid/multiverse Translation-nl
Geraakt http://mirror.liteserver.nl lucid-updates Release.gpg                 
Genegeerd http://mirror.liteserver.nl/pub/ubuntu/ lucid-updates/main Translation-nl
Genegeerd http://mirror.liteserver.nl/pub/ubuntu/ lucid-updates/restricted Translation-nl
Geraakt http://archive.getdeb.net lucid-getdeb Release.gpg                     
Genegeerd http://archive.getdeb.net/ubuntu/ lucid-getdeb/apps Translation-nl
Genegeerd http://mirror.liteserver.nl/pub/ubuntu/ lucid-updates/universe Translation-nl
Genegeerd http://mirror.liteserver.nl/pub/ubuntu/ lucid-updates/multiverse Translation-nl
Geraakt http://mirror.liteserver.nl lucid-security Release.gpg                 
Genegeerd http://mirror.liteserver.nl/pub/ubuntu/ lucid-security/main Translation-nl
Genegeerd http://mirror.liteserver.nl/pub/ubuntu/ lucid-security/restricted Translation-nl
Genegeerd http://mirror.liteserver.nl/pub/ubuntu/ lucid-security/universe Translation-nl
Genegeerd http://mirror.liteserver.nl/pub/ubuntu/ lucid-security/multiverse Translation-nl
Geraakt http://mirror.liteserver.nl lucid Release                             
Geraakt http://mirror.liteserver.nl lucid-updates Release                     
Geraakt http://mirror.liteserver.nl lucid-security Release                     
Geraakt http://mirror.liteserver.nl lucid/main Packages                       
Geraakt http://mirror.liteserver.nl lucid/restricted Packages                 
Geraakt http://archive.getdeb.net lucid-getdeb Release                     
Geraakt http://mirror.liteserver.nl lucid/main Sources                         
Geraakt http://mirror.liteserver.nl lucid/restricted Sources               
Geraakt http://mirror.liteserver.nl lucid/universe Packages                   
Geraakt http://mirror.liteserver.nl lucid/universe Sources                     
Geraakt http://mirror.liteserver.nl lucid/multiverse Packages                 
Geraakt http://mirror.liteserver.nl lucid/multiverse Sources                   
Geraakt http://mirror.liteserver.nl lucid-updates/main Packages               
Geraakt http://mirror.liteserver.nl lucid-updates/restricted Packages         
Geraakt http://archive.getdeb.net lucid-getdeb/apps Packages                   
Geraakt http://mirror.liteserver.nl lucid-updates/main Sources                 
Geraakt http://mirror.liteserver.nl lucid-updates/restricted Sources       
Geraakt http://mirror.liteserver.nl lucid-updates/universe Packages
Geraakt http://mirror.liteserver.nl lucid-updates/universe Sources
Geraakt http://mirror.liteserver.nl lucid-updates/multiverse Packages
Geraakt http://mirror.liteserver.nl lucid-updates/multiverse Sources       
Geraakt http://mirror.liteserver.nl lucid-security/main Packages           
Geraakt http://mirror.liteserver.nl lucid-security/restricted Packages
Geraakt http://mirror.liteserver.nl lucid-security/main Sources           
Geraakt http://mirror.liteserver.nl lucid-security/restricted Sources     
Geraakt http://mirror.liteserver.nl lucid-security/universe Packages       
Geraakt http://mirror.liteserver.nl lucid-security/universe Sources
Geraakt http://mirror.liteserver.nl lucid-security/multiverse Packages
Geraakt http://mirror.liteserver.nl lucid-security/multiverse Sources
Pakketlijsten worden ingelezen... Klaar
W: Duplicate sources.list entry http://archive.canonical.com/ubuntu/ lucid/partner Packages (/var/lib/apt/lists/archive.canonical.com_ubuntu_dists_lucid_partner_binary-i386_Packages)
W: U kunt misschien 'apt-get update' uitvoeren om deze problemen te verhelpen
Pakketlijsten worden ingelezen... Klaar
Boom van vereisten wordt opgebouwd       
De status informatie wordt gelezen... Klaar
U kunt 'apt-get -f install' uitvoeren om dit op te lossen.
De volgende pakketten hebben niet-voldane vereisten:
  fglrx-amdcccle: Vereisten: fglrx maar het is niet geïnstalleerd
  fglrx-kernel-source: Vereisten: fglrx maar het is niet geïnstalleerd
  xorg-driver-fglrx: Vereisten: fglrx maar het is niet geïnstalleerd
E: Er zijn vereisten waaraan niet voldaan is. Probeer -f te gebruiken.

Offline Vistaus

  • Webteam
    • vistaus
  • Steunpunt: Nee
Re: apple magic mouse
« Reactie #14 Gepost op: 2010/08/15, 22:40:50 »
@hans: Ik had hier hetzelfde. De 2.6.35-kernel wordt niet ondersteund door de Ati-driver uit de repo's. Je moet de nieuwste van de Ati-site halen en die installeren.

https://help.ubuntu.com/community/BinaryDriverHowto/ATI#Install the fglrx Driver from ATI Catalyst 10.4 For Ubuntu 9.10 Karmic
Alleen dan moet je dan toepassen voor Lucid ipv voor Karmic ;)

Offline hans_4

  • Lid
  • Steunpunt: Nee
Re: apple magic mouse
« Reactie #15 Gepost op: 2010/08/15, 22:56:03 »
ik heb geen 2.6.35-kernel meer, ik heb gewoon de 2.6.32 en ik wil terug een werkende videokaart. ik zal wel wachten op maverick voor de muis te gebruiken.


edit: alles werkt al  =D ik moest eerst de ati driver van de ati site verwijderen, dan alle videosettings verwijderen, herstarten en flrgx terug installeren. nu werkt alles terug als vroeger.

bedankt voor de hulp.

met vriendelijke groet

Hans_4
« Laatst bewerkt op: 2010/08/15, 23:11:07 door hans_4 »

Offline MauRice2

  • Lid
  • Steunpunt: Nee
Re: apple magic mouse
« Reactie #16 Gepost op: 2010/08/16, 08:28:31 »
ik heb geen 2.6.35-kernel meer, ik heb gewoon de 2.6.32 en ik wil terug een werkende videokaart. ik zal wel wachten op maverick voor de muis te gebruiken.


edit: alles werkt al  =D ik moest eerst de ati driver van de ati site verwijderen, dan alle videosettings verwijderen, herstarten en flrgx terug installeren. nu werkt alles terug als vroeger.

bedankt voor de hulp.

met vriendelijke groet

Hans_4

Hans_4,

Geen dank.

Geduld is een schone zaak. Geld hier ook.
Al bij al, denk ik dat dit een leerzaam topic is.

Backporten is iets apart.
Bij de ene werkt het, bij de andere niet.
Vraag mij niet waarom.
En weer teug gaan naar de begin status zonder een her installatie gaat ook.

« Laatst bewerkt op: 2010/12/30, 07:52:36 door MauRice2 »
MvG,
MauRice
Registered Linux user: 473556