Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: [OPGELOST] Partitie  (gelezen 5544 keer)

Offline Remcoo

  • Lid
  • Steunpunt: Nee
[OPGELOST] Partitie
« Gepost op: 2010/08/09, 19:35:36 »
Ik heb een nieuwe computer gekocht en daar Ubuntu opgezet. Tijdens het installeren van Ubuntu heb ik windows7 overschreven maar een herstelpartitie wel laten staan. De harde schijf van 500 GB heb ik verdeeld in 5 partities.
6 GB   /dev/sda1 (wisselgeheugen).
20 GB /dev/sda2 (root, Ubuntu), Ext4, koppelpunt /.
12 GB /dev/sda3 (herstelpartitie, fabriekspartitie), NTFS, niet gekoppeld.
462 GB /dev/sda4 (houder voor logische partities)
100 GB /dev/sda5 (bestanden ed), Ext4, koppelpunt /home.
362 GB /dev/sda6 (bestanden ed), Ext4, koppelpunt /usr/local. Deze laatste partitie kan ik niet terug vinden. Wel als ik kijk met mijn 'schijfgereedschap', maar niet onder locaties > computer Bestandsbeheer. Wat heb ik niet goedgedaan. Kan iemand stapsgewijs aangeven hoe ik deze ruimte onder bestandsbeheer ook te zien krijg.

ps. Ik ben een beginnende Ubuntugebruiker
« Laatst bewerkt op: 2010/08/13, 13:12:57 door Remcoo »

Offline heir4c

  • Lid
  • Steunpunt: Nee
Re: Partitie
« Reactie #1 Gepost op: 2010/08/09, 20:17:17 »
Mmm... Je hebt daar je /usr/local apart gezet. Dat is niet nodig en ook naar ik mij herinner ergens gelezen te hebben niet goed om /usr op een aparte partitie te zetten en dan nog zo'n grote partitie, dat is zeker niet nodig. Die grote ruimte zou je dan beter gebruiken als data partities.

Wil je met de LiveCD eens opstarten en dan via Systeem>Beheer>gParted (Partitiemanager) een screenshot daarvan hier posten.
(eerst uploaden via een uploadsite (bijv. Tinypic.com) en dan de link met de IMG tag hier neerzetten.
Zo hebben we een beter overzicht van de zaken.

(Je kan evt. ook gParted installeren via Synaptic en van daaruit de partities bekijken.)

Offline schwarzproductions

  • Lid
    • Open Bron Blog
  • Steunpunt: Nee
Re: Partitie
« Reactie #2 Gepost op: 2010/08/09, 21:36:54 »
Enkel 4 primaire partities, logische zoveel je wilt ( AFAIK )
Wat verschil is kan ik echter niet vertellen, dat ontglipt me nu even

Offline heir4c

  • Lid
  • Steunpunt: Nee
Re: Partitie
« Reactie #3 Gepost op: 2010/08/09, 21:58:13 »
Hij heeft maar 4 partities. 3 zijn Primaire en 1 is een extended (sda4):

Citaat
462 GB /dev/sda4 (houder voor logische partities)

Daaronder zitten dan de 2 logische partities: sda5 sda6

De sda6 zal niet te zien zijn omdat hij die gemount heeft onder /usr/local en die staat in onder /usr

Offline Prosper

  • Forumteam
  • Steunpunt: Nee
Re: Partitie
« Reactie #4 Gepost op: 2010/08/09, 22:08:03 »
Als hij gewoon via "locaties" naar /usr/local gaat, dan komt hij terecht op die grote partitie...

Ben ook wel akkoord met de opmerking dat dit een zeer slechte keuze van koppelpunt is. In die map worden sommige handmatig geïnstalleerde programma's en/of instellingen geplaatst en is echt niet bedoeld als data-gebied.
Kan die partitie beter aankoppelen als /data of /home/zijnnaam/data
Omwille van de besparingen hebben ze het licht aan het eind van de tunnel ook uitgedaan...

Offline Remcoo

  • Lid
  • Steunpunt: Nee
Re: Partitie
« Reactie #5 Gepost op: 2010/08/10, 11:05:35 »
Bedankt voor de reacties tot nu toe. Waarschijnlijk heb ik tijdens het partioneren iets niet goed gedaan want de mogelijkheid om van de vrije ruimte een data-partitie te maken was er niet. Daarom eerst maar anders, ik dacht dat later wel te kunnen veranderen. Ik heb GParted geinstalleerd en de schijf losgekoppelt maar het lukt me nu niet om hem ergens anders weer aan te koppelen. Ook een schermafdruk gemaakt: .

Phr3ak

  • Gast
Re: Partitie
« Reactie #6 Gepost op: 2010/08/10, 14:29:34 »
6 GB   /dev/sda1 (wisselgeheugen).

Is dat niet iet wat overdreven veel !?   ???

Offline Remcoo

  • Lid
  • Steunpunt: Nee
Re: Partitie
« Reactie #7 Gepost op: 2010/08/10, 15:09:27 »
Op wiki.ubuntu staat: bij voldoende schijfruimte 2x het werkgeheugen. Dus dat heb ik maar aangehouden.

Maaar hoe koppel ik /dev/sda6 nu juist aan? Het ontkoppelen is schijnbaar niet gelukt dus alles ziet er nog steeds zo uit als in bovenstaande afbeelding.
« Laatst bewerkt op: 2010/08/10, 15:25:04 door Remcoo »

Offline jan11000

  • Lid
  • Steunpunt: Nee
Re: Partitie
« Reactie #8 Gepost op: 2010/08/10, 16:13:55 »
Begin opnieuw.

swap, home en / heb je nodig.

swap 6 GB, / ?GB, de rest naar home. Overgebleven schijven of partities verbinden met een map in je home(dus bijv "/home/piet/opslag1", dus dit is een map die bij de gebruiker komt te staan).

Zo heb ik het gedaan:
/         10 GB
/home 27 GB
swap   6.5 GB (ik heb 6 GB geheugen).
/home/piet/opslag1  850 GB (overgebleven ruimte van de 1 e harde schijf)
/home/piet/opslag2  850 GB(2e  harde schijf)
De opslag 1 en 2 heb ik gedaan zodat als je opnieuw gaat installeren, deze staan kunnen blijven met de data.
Home gebruik ik maar gedeeltelijk, alles word opgeslagen naar opslag1, anders loopt home vol.

Offline Remcoo

  • Lid
  • Steunpunt: Nee
Re: Partitie
« Reactie #9 Gepost op: 2010/08/10, 17:56:56 »
Ik wil graag een partitie die ook voor andere gebruikers (van mijn pc) te benaderen is. Een partitie waar fotoś en muziek op staan. Als ik deze partitie aan mijn home koppel weet ik niet of deze te benaderen is door andere gebruikers.

Ik heb de partitie weer ontkoppelt en het volgende in mijn terminalvenster ingevoerd: 'sudo mount /dev/sda6 /media/DATA'.
ik krijg dan de volgende melding: 'mount: aankoppelingspunt /media/DATA bestaat niet'.

Ik wacht nog even reacties af, werkt niets, dan installeer Ubuntu maar opnieuw.

Offline Prosper

  • Forumteam
  • Steunpunt: Nee
Re: Partitie
« Reactie #10 Gepost op: 2010/08/10, 18:34:42 »
Je moet eerst de bewuste map aanmaken:
sudo mkdir /media/DATAGeef dan ook ineens iedereen lees- en schrijfrechtensudo chmod 777 /media/DATADaarna kun je ze aankoppelen, maar vermits ze nu nog aangekoppeld is, moet je ze eerst ontkoppelen:sudo umount /dev/sda6
sudo mount /dev/sda6 /media/DATA

Post daarna eens de uitkomst van beide volgende commando's (geven de inhoud van elk een file weer:cat /etc/fstab
cat /etc/mtab
Dan kan iemand je vertellen welke regel van mtab je kopieert naar fstab, waarin je waarschijnlijk(misschien) eerst één regel zult moeten wissen...
Omwille van de besparingen hebben ze het licht aan het eind van de tunnel ook uitgedaan...

Offline Remcoo

  • Lid
  • Steunpunt: Nee
Re: Partitie
« Reactie #11 Gepost op: 2010/08/10, 19:25:38 »
Bedankt! het is gelukt. Alleen iedereen ineens lees- en schrijfrechten te geven nog niet.
De laatste 2 commando's heb ik ook uitgevoerd zie hieronder. Het zegt mij niets. Ook 'mtab' en 'fstab' zegt mij niets.

remco@remco-desktop:~$ cat /etc/fstab
# /etc/fstab: static file system information.
#
# Use 'blkid -o value -s UUID' to print the universally unique identifier
# for a device; this may be used with UUID= as a more robust way to name
# devices that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    nodev,noexec,nosuid 0       0
/dev/sda2       /               ext4    errors=remount-ro 0       1
/dev/sda5       /home           ext4    defaults        0       2
# /usr/local was on /dev/sda6 during installation
UUID=e08cb87b-bb1b-4134-bb45-8b552f4fd60a /usr/local      ext4    defaults        0       2
/dev/sda1       none            swap    sw              0       0
remco@remco-desktop:~$ cat /etc/mtab
/dev/sda2 / ext4 rw,errors=remount-ro 0 0
proc /proc proc rw,noexec,nosuid,nodev 0 0
none /sys sysfs rw,noexec,nosuid,nodev 0 0
none /sys/fs/fuse/connections fusectl rw 0 0
none /sys/kernel/debug debugfs rw 0 0
none /sys/kernel/security securityfs rw 0 0
none /dev devtmpfs rw,mode=0755 0 0
none /dev/pts devpts rw,noexec,nosuid,gid=5,mode=0620 0 0
none /dev/shm tmpfs rw,nosuid,nodev 0 0
none /var/run tmpfs rw,nosuid,mode=0755 0 0
none /var/lock tmpfs rw,noexec,nosuid,nodev 0 0
none /lib/init/rw tmpfs rw,nosuid,mode=0755 0 0
/dev/sda5 /home ext4 rw 0 0
binfmt_misc /proc/sys/fs/binfmt_misc binfmt_misc rw,noexec,nosuid,nodev 0 0
gvfs-fuse-daemon /home/remco/.gvfs fuse.gvfs-fuse-daemon rw,nosuid,nodev,user=remco 0 0
/dev/sda6 /media/DATA ext4 rw 0 0
remco@remco-desktop:~$

Ik wacht af welke regel ik moet kopieren ed.
« Laatst bewerkt op: 2010/08/10, 19:38:14 door Remcoo »

Offline Remcoo

  • Lid
  • Steunpunt: Nee
Re: Partitie
« Reactie #12 Gepost op: 2010/08/10, 21:17:22 »
TOCH NIET GELUKT.

Ik heb de computer opnieuw opgestart maar mijn partitie is weer gekoppeld aan /usr/local.

Hoe verander ik dit definitief?

Offline heir4c

  • Lid
  • Steunpunt: Nee
Re: Partitie
« Reactie #13 Gepost op: 2010/08/10, 21:40:48 »
Wat staat er nu op de sda6?

Offline Remcoo

  • Lid
  • Steunpunt: Nee
Re: Partitie
« Reactie #14 Gepost op: 2010/08/10, 22:01:34 »
niets, geen bestanden in ieder geval.

Offline heir4c

  • Lid
  • Steunpunt: Nee
Re: Partitie
« Reactie #15 Gepost op: 2010/08/10, 22:04:32 »
Er is anders wel 5,48 GiB gebruikt. ???

Offline Remcoo

  • Lid
  • Steunpunt: Nee
Re: Partitie
« Reactie #16 Gepost op: 2010/08/10, 22:12:12 »
Ja, snap ik ook niets van. Maar ik heb 500 GB en als ik alles wat beschikbaar is optel kom ik op 465 GB.  ???

Offline heir4c

  • Lid
  • Steunpunt: Nee
Re: Partitie
« Reactie #17 Gepost op: 2010/08/10, 22:36:57 »
Begin gewoon opnieuw zoals jan hier in de link aangeeft:
http://forum.ubuntu-nl.org/installatie/partitie-57343/msg636769/#msg636769
Dat lijkt mij het minste werk.
Dan het topic nog eens doorlezen om de rechten van die data partitie goed te zetten (zie berichten Prosper)

Offline Remcoo

  • Lid
  • Steunpunt: Nee
Re: Partitie
« Reactie #18 Gepost op: 2010/08/10, 22:41:17 »
Ja, ik ga maar opnieuw beginnen. Ben nu bezig de herstelpartitie naar een andere harde schijf te kopiëren, dan is die ook maar weg. Scheelt weer ruimte.

Offline Prosper

  • Forumteam
  • Steunpunt: Nee
Re: Partitie
« Reactie #19 Gepost op: 2010/08/11, 03:34:07 »
Sorry voor de radiostilte...

Als je nog eens doet wat ik in mijn vorig bericht schreef, dan staat het weer goed. Daarna doe je in een terminal:gksu gedit /etc/fstabDaarmee open je het bewuste bestand in een tekstverwerker, met rootrechten.
In dat bestand (dat aangeeft waar welke partities moeten aangekoppeld worden bij het opstarten) verander je de volgende regels:# /usr/local was on /dev/sda6 during installation
UUID=e08cb87b-bb1b-4134-bb45-8b552f4fd60a /usr/local      ext4    defaults        0       2
in/dev/sda6 /media/DATA ext4 rw 0 0Deze regel komt uit de file /etc/mtab, dat is degene die bijhoudt hoe op een bepaald moment de koppelingen ZIJN. Daarom dat het belangrijk is dat je dus weer eerst die nieuwe koppeling maakte zoals in mijn vorig bericht...
Dan opslaan en sluiten. Als je nu reboot, dan staat het nog altijd goed...
Omwille van de besparingen hebben ze het licht aan het eind van de tunnel ook uitgedaan...

Offline heir4c

  • Lid
  • Steunpunt: Nee
Re: Partitie
« Reactie #20 Gepost op: 2010/08/11, 06:54:03 »
Ter aanvulling:
Die regel die Prosper als laatste meegeeft:
/dev/sda6 /media/DATA ext4 rw 0 0
staat reeds in je fstab. Dus verwijder enkel de # /usr/local was on /dev/sda6 during.......enz. (tot en met de 2 op de tweede lijn.)
Of zet voor de UUID=.... een commentaar teken: #
Zo leest het systeem deze regel niet meer.

Offline Remcoo

  • Lid
  • Steunpunt: Nee
Re: Partitie
« Reactie #21 Gepost op: 2010/08/11, 17:00:50 »
Nou, inmiddels Ubuntu al weer 2x geïnstalleerd. De 2de x een cd van een kennis geleend waarvan ik zeker weet dat die goed is. Maar ik blijf GB's missen. Van de 500 GB blijft volgens GParted +/- 465 GB over. Bovendien is er schijfruimte in gebruik maar ik heb nog geen bestanden op de pc staan. ??? Volgens schijfgereedschap onder Systeem niet.
Bovendien krijg ik bij het installeren/partitioneren niet de keuzemogelijkheid van /media/data dus typ ik dat zelf maar in. Weet niet of dat goed is.



Onder locaties is de vrije ruimte nog steeds niet te benaderen.
Waar gaat het fout?


« Laatst bewerkt op: 2010/08/11, 17:03:56 door Remcoo »

Offline heir4c

  • Lid
  • Steunpunt: Nee
Re: Partitie
« Reactie #22 Gepost op: 2010/08/11, 19:24:04 »
Ik zie het al. In gParted staat /media/data en in de fstab staat: /media/DATA. Dat zijn twee verschillende zaken, want Linux is hoofdlettergevoelig. Dus je kan dus: data, Data, DATA, enz schrijven en dat zijn allemaal verschillende aankoppelpunten. Dus verander in fstab /media/DATA in /media/data en dan zou het goed moeten zijn.
Klik Alt+F2 en tik in het invoerveld het volgende:
gksudo gedit /etc/fstabwant je hebt rootrechten nodig om dit te veranderen.
Start voor alle zekerheid de comp terug op.

Offline Remcoo

  • Lid
  • Steunpunt: Nee
Re: Partitie
« Reactie #23 Gepost op: 2010/08/11, 19:56:45 »
In fstab staat /media/data. Ik heb er niets aan veranderd. Maar misschien kun je wat met de gegevens.

Offline heir4c

  • Lid
  • Steunpunt: Nee
Re: Partitie
« Reactie #24 Gepost op: 2010/08/11, 20:06:30 »
Ja, tuurlijk, het was eerst sda6 maar door het her-partitioneren is het sda4 geworden.
Ik had even je fstab gezien die je gekregen had door: cat /etc/fstab in te typen.
Kijk een onder /media of daar een /data staat. Kan je via daar in de vrije ruimte? Zo ja, Sleep die naar links in het overzicht (in nautilus/bestandssysteem)