Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: toevoegen data harde schijf  (gelezen 4477 keer)

Offline wolterkabolter

  • Lid
  • Steunpunt: Nee
toevoegen data harde schijf
« Gepost op: 2006/12/13, 17:18:11 »
Hoe kan ik mijn harde schijf met data uit mijn oude pc (Win XP) gebruiken in Ubuntu?
Dit zijn mijn harde schijfgegevens:
Citaat
Disk /dev/hda: 20.4 GB, 20490559488 bytes
255 heads, 63 sectors/track, 2491 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

   Device Boot      Start         End      Blocks   Id  System
/dev/hda1   *           1        2398    19261903+  83  Linux
/dev/hda2            2399        2491      747022+   5  Extended
/dev/hda5            2399        2491      746991   82  Linux swap / Solaris

Disk /dev/hdb: 9115 MB, 9115361280 bytes
255 heads, 63 sectors/track, 1108 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

   Device Boot      Start         End      Blocks   Id  System
/dev/hdb1   *           1        1108     8899978+   c  W95 FAT32 (LBA)
Het gaat dus om /dev/hdb1.

Offline bartek

  • Lid
    • http://bartek.blogsome.com
  • Steunpunt: Nee
toevoegen data harde schijf
« Reactie #1 Gepost op: 2006/12/13, 17:56:15 »
Wat zegt dit wanneer je 't ingeeft in je terminal:
df
?

Na edit: Ik heb deze link gevonden, kan je misschien wat verder helpen:
http://ubuntuguide.org/wiki/Dapper#How_to_mount_Windows_partitions_.28NTFS.29_on_boot-up.2C_and_allow_all_users_to_read_only
| Deliberando saepe perit occasio |

"Car la vie est un bien perdu quand on n'a pas vécu comme on l'aurait voulu"

Offline wolterkabolter

  • Lid
  • Steunpunt: Nee
toevoegen data harde schijf
« Reactie #2 Gepost op: 2006/12/13, 18:04:08 »
Citaat van: bartek
Wat zegt dit wanneer je 't ingeeft in je terminal:
df
?
Dit:
Citaat
hartog@jaap-pentium4-19:~$ df
Filesystem           1K-blocks      Used Available Use% Mounted on
/dev/hda1             18959536   2994336  15002108  17% /
varrun                  127984        96    127888   1% /var/run
varlock                 127984         4    127980   1% /var/lock
procbususb               10240       108     10132   2% /proc/bus/usb
udev                     10240       108     10132   2% /dev
devshm                  127984         0    127984   0% /dev/shm
lrm                     127984     18132    109852  15% /lib/modules/2.6.17-10-386/volatile

Offline bartek

  • Lid
    • http://bartek.blogsome.com
  • Steunpunt: Nee
toevoegen data harde schijf
« Reactie #3 Gepost op: 2006/12/13, 18:09:18 »
Met het commando df krijgt ge dus een totaal overzicht van aangekoppelde bestandssystemen:

hdb1 zit er niet tussen, ik denk dus dat je deze nog zult moeten mounten.
De tips in de link die ik je gegeven heb zal je waarschijnlijk verder helpen:
Citaat
How to mount Windows partitions (FAT) on boot-up, and allow all users to read/write

    * Read #General Notes
    * Read #How to list partition tables

    e.g. Assumed that /dev/hda1 is the location of Windows partition (FAT)
    Local mount folder: /media/windows

sudo mkdir /media/windows
sudo cp /etc/fstab /etc/fstab_backup
gksudo gedit /etc/fstab

    * Append the following line at the end of file

/dev/hda1    /media/windows vfat  iocharset=utf8,umask=000  0    0

    * Save the edited file
    * Read #How to remount /etc/fstab without rebooting
http://ubuntuguide.org/wiki/Dapper#How_to_mount_Windows_partitions_.28NTFS.29_on_boot-up.2C_and_allow_all_users_to_read_only

let wel voor uw geval is 't dus wel hdb1 en niet hda1 h
| Deliberando saepe perit occasio |

"Car la vie est un bien perdu quand on n'a pas vécu comme on l'aurait voulu"

Offline wolterkabolter

  • Lid
  • Steunpunt: Nee
toevoegen data harde schijf
« Reactie #4 Gepost op: 2006/12/13, 18:34:29 »
Ja bedankt!
Het is gelukt. Maar waar heb ik er nu toegang tot?

Offline bartek

  • Lid
    • http://bartek.blogsome.com
  • Steunpunt: Nee
toevoegen data harde schijf
« Reactie #5 Gepost op: 2006/12/13, 18:46:21 »
als je enkel 't bestand wil lezen doe je dat met 't commando:
gedit /etc/fstab
Wil je ook aanpassingen maken zul je jezelf root moeten maken met 't commando sudo
sudo gedit /etc/fstab

Voor meer info over de terminal en zijn commando's moet je eens op de link hieronder klikken die over Terminal gaat.

edit: ik lees nu pas de commando's terug er staat in de howto gksudo gedit /etc/fstab dat is grafische manier om root te worden, lukt deze niet zo goed doe dan gewoon sudo in plaats van gksudo.
| Deliberando saepe perit occasio |

"Car la vie est un bien perdu quand on n'a pas vécu comme on l'aurait voulu"

Offline wolterkabolter

  • Lid
  • Steunpunt: Nee
toevoegen data harde schijf
« Reactie #6 Gepost op: 2006/12/13, 18:49:16 »
Bedankt. Ik begin het langzaam te begrijpen. Maar waar heb ik er nu toegang tot?
Groetjes

Offline bartek

  • Lid
    • http://bartek.blogsome.com
  • Steunpunt: Nee
toevoegen data harde schijf
« Reactie #7 Gepost op: 2006/12/13, 18:50:56 »
ok, 't is gelukt blijkbaar.
Ga nu eens naar je root folder, dat kun je doen door via lokaties -> persoonlijke map -> daarna 2 keer op 't pijltje klikken dat verwijst naar de bovenliggende map (omhoog). Nu zit je in de root folder /.
Daar gaat ge naar media en dan naar de map Windows
Tadaa
| Deliberando saepe perit occasio |

"Car la vie est un bien perdu quand on n'a pas vécu comme on l'aurait voulu"

Offline bartek

  • Lid
    • http://bartek.blogsome.com
  • Steunpunt: Nee
toevoegen data harde schijf
« Reactie #8 Gepost op: 2006/12/13, 18:52:35 »
hmmm, zou 't kunnen dat je een engelse versie hebt van Ubuntu?
| Deliberando saepe perit occasio |

"Car la vie est un bien perdu quand on n'a pas vécu comme on l'aurait voulu"

Offline wolterkabolter

  • Lid
  • Steunpunt: Nee
toevoegen data harde schijf
« Reactie #9 Gepost op: 2006/12/13, 18:56:43 »
Hmm, maar geen bestanden :S. En 14,3 GB ruimte, terwijl het een 8Gb harde schijf is :S

Ja, blijkbaar een engelse ja.

Offline bartek

  • Lid
    • http://bartek.blogsome.com
  • Steunpunt: Nee
toevoegen data harde schijf
« Reactie #10 Gepost op: 2006/12/13, 19:02:26 »
Doe eens:
sudo mount -a

Hebt ge bewust een engelse versie of wilt ge een nederlandse versie?
| Deliberando saepe perit occasio |

"Car la vie est un bien perdu quand on n'a pas vécu comme on l'aurait voulu"

Offline wolterkabolter

  • Lid
  • Steunpunt: Nee
toevoegen data harde schijf
« Reactie #11 Gepost op: 2006/12/13, 19:13:05 »
Citaat
mount point /media/wolterdata does not exist
Voor alle duidelijkheid: ik heb de dir dus media/wolterdata genoemd, maar dacht toch dat dat geen probleem zou opleveren?

Het gekke is dat de hoofdtitels van het startmenu in het engels staatn (Applications - Places - System) en de rest in het NL's.

Offline bartek

  • Lid
    • http://bartek.blogsome.com
  • Steunpunt: Nee
toevoegen data harde schijf
« Reactie #12 Gepost op: 2006/12/13, 20:16:00 »
Voor de taalkeuze moet je eens kijken onder systeem->beheer->taalondersteuning en daar Nederlands in selecteren. Daarna doe je eens een update en upgrade
sudo apt-get update
sudo apt-get upgrade

Kun je eens navigeren naar de map wolterdata om te kijken of ie aangemaakt is.
Indien niet doe je nog eens:
sudo mkdir /media/wolterdata
Normaal gezien mag ie geen errors geven nu tenzij dat hij zegt dat de map reeds bestaat.

mkdir staat voor make directory
| Deliberando saepe perit occasio |

"Car la vie est un bien perdu quand on n'a pas vécu comme on l'aurait voulu"

Offline wolterkabolter

  • Lid
  • Steunpunt: Nee
toevoegen data harde schijf
« Reactie #13 Gepost op: 2006/12/13, 20:39:15 »
Bedankt.

De directory bestaat gewoon.

Offline wolterkabolter

  • Lid
  • Steunpunt: Nee
toevoegen data harde schijf
« Reactie #14 Gepost op: 2006/12/13, 22:12:51 »
Nu krijg ik dit:

Citaat
mount: wrong fs type, bad option, bad superblock on /dev/hdb1,
       missing codepage or other error
       In some cases useful info is found in syslog - try
       dmesg | tail  or so

Offline wolterkabolter

  • Lid
  • Steunpunt: Nee
toevoegen data harde schijf
« Reactie #15 Gepost op: 2006/12/13, 22:16:56 »
Inmiddels werkt het!!! :-)
Bedankt!

Offline wolterkabolter

  • Lid
  • Steunpunt: Nee
toevoegen data harde schijf
« Reactie #16 Gepost op: 2006/12/13, 22:36:30 »
Wat is de beste manier om mijn bestanden veilig te bewaren? Op een aparte harde schijf houden zeker? Is er een gebruikersvriendelijke manier om direct toegang te krijgen tot de oude 'mijn documenten'  van Windows?

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
toevoegen data harde schijf
« Reactie #17 Gepost op: 2006/12/13, 22:37:57 »
Citaat van: wolterkabolter
Wat is de beste manier om mijn bestanden veilig te bewaren? Op een aparte harde schijf houden zeker? Is er een gebruikersvriendelijke manier om direct toegang te krijgen tot de oude 'mijn documenten'  van Windows?
Aparte FAT32-partitie erbij cre

Offline wolterkabolter

  • Lid
  • Steunpunt: Nee
toevoegen data harde schijf
« Reactie #18 Gepost op: 2006/12/14, 16:27:23 »
Hoe zorg ik dat via mijn persoonlijke map op mijn data harde schijf kom?

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
toevoegen data harde schijf
« Reactie #19 Gepost op: 2006/12/14, 16:29:00 »
Kopi

Offline wolterkabolter

  • Lid
  • Steunpunt: Nee
toevoegen data harde schijf
« Reactie #20 Gepost op: 2006/12/14, 16:33:22 »
FF voor de duidelijkheid om fouten te voorkomen.

Het mount point voor de data harde schijf is nu /media/windows. Moet ik deze map kopieeren naar de persoonlijke map?

Offline profoX

  • Lid
    • wesley
    • Lionslink
  • Steunpunt: Nee
toevoegen data harde schijf
« Reactie #21 Gepost op: 2006/12/14, 16:36:22 »
Citaat van: wolterkabolter
Hoe zorg ik dat via mijn persoonlijke map op mijn data harde schijf kom?
Je zou ook gewoon een symlink kunnen maken van je persoonlijke map naar de map waar de dataschijf op is aangekoppeld ofzo (of de dataschijf gewoon rechtstreeks aankoppelen op een map in je persoonlijke map, maar dat is een andere zaak)

dat doe je bijvoorbeeld op deze manier:

ln -sf /media/windows ~/windowsdata

dit commando zal een map "windowsdata" aanmaken in je persoonlijke map (~ is een afkorting voor je persoonlijke map; dus een afkorting voor /home/$USER waar $USER dus je gebruikersnaam is)

en wanneer je die map "windowsdata" opendoet zal je de inhoud zien van "/media/windows"

edit: "/media/data" moet bij jou dus "/media/windows" zijn.. bericht aangepast
Human Knowledge Belongs To The World -- Antitrust (2001)
Nederlandstalige Ubuntu documentatie van Ubuntu-NL (wiki)

Offline wolterkabolter

  • Lid
  • Steunpunt: Nee
toevoegen data harde schijf
« Reactie #22 Gepost op: 2006/12/14, 16:41:24 »
OK, bedankt. (weer een nieuwe functie geleerd).

Zou ik hem ook kunnen mounten op mijn persoonlijke map, of is dat onverstandig?

Offline profoX

  • Lid
    • wesley
    • Lionslink
  • Steunpunt: Nee
toevoegen data harde schijf
« Reactie #23 Gepost op: 2006/12/14, 16:44:26 »
onverstandig ;)

want in je persoonlijke map staan al allerlei dingen die je niet weg mag halen... maar je kan eventueel wel een extra keuze aanmaken in het menu of op het bureaublad om bv. rechtstreeks naar /media/windows of naar de gesymlinkte versie /home/wolterkabolter/windowsdata te gaan...
Human Knowledge Belongs To The World -- Antitrust (2001)
Nederlandstalige Ubuntu documentatie van Ubuntu-NL (wiki)

Offline wolterkabolter

  • Lid
  • Steunpunt: Nee
toevoegen data harde schijf
« Reactie #24 Gepost op: 2006/12/14, 22:10:01 »
Citaat van: bartek
Voor de taalkeuze moet je eens kijken onder systeem->beheer->taalondersteuning en daar Nederlands in selecteren. Daarna doe je eens een update en upgrade
sudo apt-get update
sudo apt-get upgrade
Ik heb ergens een probleem met de taalinstellingen. Kan het zijn dat ik een sleutel mis?

Als ik sudo apt-get update krijg ik talloze foutmeldingen. Dit lijkt me het hoofdprobleem:

Citaat
W: GPG error: http://mirror.ubuntulinux.nl edgy-seveas Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 49A120FD1135D466
Mis ik ergens een key ofzo?