Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Dubbel probleem met Samba  (gelezen 1041 keer)

MuddyMagical

  • Gast
Dubbel probleem met Samba
« Gepost op: 2010/07/28, 22:09:13 »
Probleem 1:
Ik gebruik Backuppc om een Windows XP machine te backuppen en dat gaat geweldig. Ik heb ook nog een Wind7 machine, maar daar kom ik maar niet op.
Onderstaande werkt perfect na het invoeren van het wachtwoord
smbclient -L //mowgli/rene -U backup
Maar Backuppc komt terug met:
Running: /usr/bin/smbclient \\\\mowgli\\rene -I 192.168.1.101 -U backup -E -d 1 -c tarmode\ full -Tc -
full backup started for share rene
Xfer PIDs are now 5343,5342
session setup failed: NT_STATUS_LOGON_FAILURE
session setup failed: NT_STATUS_LOGON_FAILURE
tarExtract: Done: 0 errors, 0 filesExist, 0 sizeExist, 0 sizeExistComp, 0 filesTotal, 0 sizeTotal
Got fatal error during xfer (No files dumped for share rene)
Backup aborted (No files dumped for share rene)
Not saving this as a partial backup since it has fewer files than the prior one (got 0 and 0 files versus 0
Dit terwijl er wel degelijk bestanden staan.

Probleem 2:
Ik kom met de SMBClient niet op mijn werklaptop.
Share aangemaakt op de laptop(Win XP) maar smbclient -L //nlzz190018/neverbackup -U nlserie1 werkt niet. De foutmelding:
rene@baloe:~$ smbclient -L  //192.168.1.104/neverbackup -U NLEY/nlserie1
Enter NLEY/nlserie1's password:
Connection to 192.168.1.104 failed (Error NT_STATUS_HOST_UNREACHABLE)
rene@baloe:~$ ping 192.168.1.104
PING 192.168.1.104 (192.168.1.104) 56(84) bytes of data.
64 bytes from 192.168.1.104: icmp_seq=1 ttl=128 time=43.0 ms
64 bytes from 192.168.1.104: icmp_seq=2 ttl=128 time=63.2 ms
^C
--- 192.168.1.104 ping statistics ---
2 packets transmitted, 2 received, 0% packet loss, time 1000ms
rtt min/avg/max/mdev = 43.080/53.146/63.213/10.069 ms
rene@baloe:~$ smbclient -L  //nlzz190018/neverbackup -U NLEY/nlserie1
Enter NLEY/nlserie1's password:
Connection to nlzz190018 failed (Error NT_STATUS_BAD_NETWORK_NAME)
rene@baloe:~$

Iemand een idee waar ik nog kan zoeken?

Offline donpedroII

  • Lid
  • Steunpunt: Nee
Re: Dubbel probleem met Samba
« Reactie #1 Gepost op: 2010/07/31, 03:23:06 »
Lees het volgende eens door, het heeft schijnbaar te maken met de NTLM & NTLMv2 settings te maken.
http://www.tomshardware.com/forum/75-63-windows-samba-issue

Citaat
believe the behavior results from the LMCompatibilityLevel settings on the Windows OS. There are 6 authentication level in Windows OS:
0-    Use LM and NTLM authentication, never use NTLMv2 session security.
1-    Use LM and NTLM authentication, use NTLM 2 session security if negotiated.
2-    Use only NTLM authentication, use NTLMv2 session security if the server supports it.
3-    Use only NTLMv2 authentication, use NTLMv2 session security if the server supports it.
4-    Use only NTLMv2 authentication, use NTLMv2 session security if the server supports it. Refuse LM responses.
5-    Use only NTLMv2 authentication, use NTLMv2 session security if the server supports it. Refuse LM and NTLM responses (accept only NTLM 2).


Windows XP uses level 0 by default while Windows 7 & Vista have level 3. To work through this problem, you may lower the level on Windows 7 & Vista or elevate the level on the server side. However, please be aware of the potential security issues if you want to lower the level on Windows 7 & Vista. For more information about LMCompatibilityLevel, you may refer to:

How to enable NTLM 2 authentication

http://support.microsoft.com/kb/239869
Had hier ook een buurman met een NAS die Samba draaide, hier kon hij ook geen goede verbinding mee opzetten.
Het bovenstaand heeft hem toen ook verder geholpen.
« Laatst bewerkt op: 2010/07/31, 03:27:57 door donpedroII »