Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Nieuwe server en disken, probleem met nfs mounts  (gelezen 1580 keer)

Offline Bigtwin

  • Lid
  • Steunpunt: Nee
Nieuwe server en disken, probleem met nfs mounts
« Gepost op: 2010/07/28, 15:17:19 »
Ik heb een server geinstalleerd met Ubuntu 10.04 server, zonder grafische schil.

In deze server zit: 1 systeem disk en 4 disken die straks de NAS moeten gaan vormen, nu nog leeg.

Ik probeer deze via een nfs mount beschikbaar te stellen, maar dat lukt me maar niet. Ik heb de diverse documentatie waar in dit forum naar wordt verwezen allemaal geprobleerd, maar het lukt me niet.

Ik heb de disken met de Ubuntu 10.04 desktop bootable usb stick, met gparted op ext4 geformatteerd, in de /exports opgenomen etc. Ik begin met 1 disk, die is nu ook gemount onder /export/disk1

Als ik nu vanaf mijn dreambox een mount probeer te maken, krijg ik steeds permission denied. Vanaf mijn Ubuntu laptop geeft mounten de volgende melding:

mount: onjuiste bestandssysteemsoort, ongeldige optie, ontbrekende codepagina,
       ontbrekend hulpprogramma, slecht superblok op userver:/export/disk1, of een andere fout
       (voor sommige bestandssystemen (bijvoorbeeld nfs of cifs) kan
       een /sbin/mount.<type> hulpprogramma nodig zijn)
       Soms staat er nuttige informatie in het systeemlog --
       probeer zoiets als:  dmesg | tail

Die dmesg zegt verder niets over harddisks en mounts.

Wie kan me hierbij helpen? Ik heb de disken in de nas dus op ext4 geformatteerd, en gemount via de fstab, zonder de uuid gegevens (weet niet of dat laatste goed is):

# NAS disken
/dev/sdb1   /media/disk1            ext4   errors=remount-ro 0   1
# NAS exports
/media/disk1    /export/disk1               none    bind  0  0

Dan geef ik op de laptop de opdracht sudo mount userver:/export/disk1 /media/nas, waarna de foutmelding volgt.





« Laatst bewerkt op: 2010/07/28, 15:29:31 door Bigtwin »

Offline shinger

  • Lid
    • shingeri
  • Steunpunt: Nee
Re: Nieuwe server en disken, probleem met nfs mounts
« Reactie #1 Gepost op: 2010/07/28, 17:32:29 »
Kun je misschien even webmin installeren, dat is wat makkelijker om alles te bedienen. Hoef je namelijk niet constant in shell te gaan.

het installeren doe het als volgt:

eerst paar benodigde spullentjes installeren

sudo apt-get install perl5 libnet-ssleay-perl
als je deze hebt geinstalleerd kun je laatste versie van webmin binnen halen en installeren.

wget http://prdownloads.sourceforge.net/webadmin/webmin_1.510-2_all.debAls die gedownload is voer dit uit

sudo dpkg -i *.deb als je webmin hebt geinstalleerd kun je jou server bereiken door naar je webbrowser te gaan en dit te typen:
<ipadres>:10000

Hier heb je dan via webinterface of makkelijker alles te mounten.

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
Re: Nieuwe server en disken, probleem met nfs mounts
« Reactie #2 Gepost op: 2010/07/28, 18:30:07 »
Webmin installeren alleen om een nfs server aan het werk te krijgen?
Dat lijkt me nou niet echt een oplossing, eerder een oorzaak voor een nieuw probleem.

Probeer dit eens als mount commando:
sudo mount.nfs -v userver:/export/disk1 /media/nas

Offline Bigtwin

  • Lid
  • Steunpunt: Nee
Re: Nieuwe server en disken, probleem met nfs mounts
« Reactie #3 Gepost op: 2010/07/29, 00:43:26 »
Op die opdracht komt de volgende foutmelding:

sudo /sbin/mount.nfs4 userver:/export/disk1 /media/nas -v
mount.nfs4: timeout set for Thu Jul 29 00:42:15 2010
mount.nfs4: text-based options: 'clientaddr=192.168.178.24,addr=192.168.178.38'
mount.nfs4: mount(2): Permission denied
mount.nfs4: access denied by server while mounting userver:/export/disk1

Zou dus iets met rechten moeten zijn denk ik dan. Hoe moet ik die zetten? Of is er iets anders fout?

Mijn voorkeur gaat inderdaad uit naar command-line oplossingen.
« Laatst bewerkt op: 2010/07/29, 00:54:49 door Bigtwin »

Offline Bigtwin

  • Lid
  • Steunpunt: Nee
Re: Nieuwe server en disken, probleem met nfs mounts
« Reactie #4 Gepost op: 2010/07/29, 01:45:20 »
Ik ben na lang proberen iets verder... Of niet.

Nu geeft deze opdracht de volgende melding:

sudo mount -t nfs4 -o proto=tcp,port=2049 userver:/export/disk1 /media/nas

mount.nfs4: mounting userver:/export/disk1 failed, reason given by server:
  No such file or directory


Terwijl op de server in de fstab o.a. staat:
# NAS disken
/dev/sdb1   /media/disk1            ext4   errors=remount-ro 0   1

# NAS exports
/media/disk1   /export/disk1              none    bind  0  0

en op de server het mount commando ook geeft:

/media/disk1 on /export/disk1 type none (rw,bind)

en op de server:
ll /export

drwxr-xr-x  4 rob  rob  4096 2010-07-28 14:20 disk1/

Rob, dat ben ik dus, is de user op beide machines, beide uid 1000 groep 1000.

Ik weet het niet meer, ga nu dan toch maar weer eens naar bed, na veel te lang hobbyen.


Offline jan11000

  • Lid
  • Steunpunt: Nee
Re: Nieuwe server en disken, probleem met nfs mounts
« Reactie #5 Gepost op: 2010/07/29, 06:53:42 »
Ik gebruik samba en moet ook "user name" en "password" met fstab meegeven.( of in ieder geval een verwijzing , zodat hij niet voor iedereen leesbaar is). Of jij dat moet doen weet ik niet.

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
Re: Nieuwe server en disken, probleem met nfs mounts
« Reactie #6 Gepost op: 2010/07/29, 07:52:45 »
Ik ben na lang proberen iets verder... Of niet.

Nu geeft deze opdracht de volgende melding:

sudo mount -t nfs4 -o proto=tcp,port=2049 userver:/export/disk1 /media/nas

mount.nfs4: mounting userver:/export/disk1 failed, reason given by server:
  No such file or directory
Dit lijkt het probleem te zijn.
Heb je /export/disk1 wel opgenomen in /etc/exports ??
In /etc/exports zou zoiets moeten staan:
/export/disk1 192.168.1.0/255.255.255.0(rw,sync,no_subtree_check)
(pas het wel helemaal aan naar jouw eigen situatie, dit is maar een voorbeeld)


Citaat
Terwijl op de server in de fstab o.a. staat:
# NAS disken
/dev/sdb1   /media/disk1            ext4   errors=remount-ro 0   1

# NAS exports
/media/disk1   /export/disk1              none    bind  0  0

en op de server het mount commando ook geeft:

/media/disk1 on /export/disk1 type none (rw,bind)

en op de server:
ll /export

drwxr-xr-x  4 rob  rob  4096 2010-07-28 14:20 disk1/

Rob, dat ben ik dus, is de user op beide machines, beide uid 1000 groep 1000.
Dat lijkt allemaal in orde, om een NFSv4 server te hebben.


Ik gebruik samba en moet ook "user name" en "password" met fstab meegeven.( of in ieder geval een verwijzing , zodat hij niet voor iedereen leesbaar is). Of jij dat moet doen weet ik niet.
Samba is wel weer heel wat anders dan NFS, ook al kan je daarmee over het netwerk bestanden delen.

Offline Bigtwin

  • Lid
  • Steunpunt: Nee
Re: Nieuwe server en disken, probleem met nfs mounts
« Reactie #7 Gepost op: 2010/07/29, 12:09:01 »
Ja, met de /etc/exports ben ik ook druk in de weer geweest. Daar staat nu:


#/export                192.168.1.0/24(rw,fsid=0,insecure,no_subtree_check,async)
/export         *(rw,fsid=0,insecure,no_subtree_check,async)
/export/disk1   *(rw,nohide,insecure,no_subtree_check,async)
#/export/disk1  192.168.1.0/24(rw,nohide,insecure,no_subtree_check,async)
#/export/disk1  192.168.1.22(rw,nohide,insecure,no_subtree_check,async)

Het mount commando op de server geeft ook:

/media/disk1 on /export/disk1 type none (rw,bind)


Ik heb het ook met de # regels geprobeerd, maar ben maar afgestapt van die ip adressen en gewoon alles open gezet voor iedereen, door er een * voor te zetten i.p.v. een ip range. Hier op mijn lannetje zitten toch niet zoveel mensen. Als het een keer werkt, ga ik wel kijken wat ik nog dicht kan/moet zetten.

Voor nu, zou dit volgens mij ook goed moeten zijn.
« Laatst bewerkt op: 2010/07/29, 12:17:00 door Bigtwin »

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
Re: Nieuwe server en disken, probleem met nfs mounts
« Reactie #8 Gepost op: 2010/07/29, 13:21:16 »
Voer op de server eens het mount commando uit.
Plaats het resultaat hier.

Doe hetzelfde voor dit commando:
sudo exportfs -rav

En kijk vervolgens in /var/log/daemon.log of daar toevallig iets bijzonders in staat mbt nfs.

Deze wikipagina is waarschijnlijk ook wel handig om eens door te kijken:
https://help.ubuntu.com/community/NFSv4Howto
En natuurlijk deze:
https://help.ubuntu.com/community/SettingUpNFSHowTo

Offline Bigtwin

  • Lid
  • Steunpunt: Nee
Re: Nieuwe server en disken, probleem met nfs mounts
« Reactie #9 Gepost op: 2010/07/29, 16:21:35 »
Opgelost.

Ik heb vanaf mijn ubuntue laptop steeds het verkeerde mount commando gegeven. Ik gaf steeds mount userver:/export/disk1. Dat moest zonder export, dus mount userver:/disk1.

Het gekke is dat ik vanaf mijn dreambox (Linux kernel 2.16.18-7.3 die alleen nfs3 mounts aankan) weer wel het commando met de /export ervoor moet geven.

Dank voor jullie bijdragen, het is opgelost.