Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: [opgelost]alweer een geluid probleem  (gelezen 2150 keer)

Offline Schapenvelleke

  • Lid
  • Steunpunt: Nee
[opgelost]alweer een geluid probleem
« Gepost op: 2010/07/28, 11:06:19 »
Hoi hoi

Ik heb gisteren een dual install gedaan met de nieuwste ubuntuu 10.04 en windows7
En zoals vele op dit forum werkt mijn geluid niet in linux (windows wel)
Het gaat over een onboard soundcard.

Ik heb alsamixer geinstalleerd en er staan geen knoppen op mute ofzo, heb al veel afgelezen op het forum maar ik vind geen oplossing.
Als ik muziek/film afspeel dan loopt het bestand wel maar dus geen geluid.
Ik heb het gevoel dat ik een verkeerde driver heb, maar ik ik ben daar een beetje een noob in.
Als iemand mij kan helpen bij voorbaat dank.

sudo lspci -v
00:10.1 Audio device: nVidia Corporation MCP51 High Definition Audio (rev a2)
Subsystem: ASUSTeK Computer Inc. Device 81cb
Flags: bus master, 66MHz, fast devsel, latency 0, IRQ 22
Memory at fe024000 (32-bit, non-prefetchable) [size=16K]
Capabilities: [44] Power Management version 2
Capabilities: [50] Message Signalled Interrupts: Mask+ 64bit+ Queue=0/0 Enable-
Capabilities: [6c] HyperTransport: MSI Mapping Enable- Fixed+
Kernel driver in use: HDA Intel
Kernel modules: snd-hda-intel

sudo lshw -C multimedia
  *-multimedia            
       description: Audio device
       product: MCP51 High Definition Audio
       vendor: nVidia Corporation
       physical id: 10.1
       bus info: pci@0000:00:10.1
       version: a2
       width: 32 bits
       clock: 66MHz
       capabilities: pm msi ht bus_master cap_list
       configuration: driver=HDA Intel latency=0 maxlatency=5 mingnt=2
       resources: irq:22 memory:fe024000-fe027fff

aplay -l
**** Lijst van PLAYBACK hardware-apparaten ****
kaart 0: NVidia [HDA NVidia], apparaat 0: AD198x Analog [AD198x Analog]
  Sub-apparaten: 1/1
  Sub-apparaat #0: subdevice #0
kaart 0: NVidia [HDA NVidia], apparaat 1: AD198x Digital [AD198x Digital]
  Sub-apparaten: 1/1
  Sub-apparaat #0: subdevice #0

« Laatst bewerkt op: 2010/07/28, 22:45:05 door Schapenvelleke »

Offline Roc.am

  • Lid
  • Steunpunt: Nee
Re: alweer een geluid probleem
« Reactie #1 Gepost op: 2010/07/28, 11:54:27 »
Welkom op ons forum Schapenvelleke,

Heb je de installatie afgerond ?

http://wiki.ubuntu-nl.org/DirectDoen

Je kunt op onder staande link ook nog kijken of je hiermee verder komt:

http://sites.google.com/site/computertip/geengeluid

Is de site van een forumlid maar wordt vaak geraadpleegd bij problemen.

- Roc
Is je vraag opgelost? Markeer het als [OPGELOST] in de titel van je bericht!

Offline mrGee

  • Lid
  • Steunpunt: Nee
Re: alweer een geluid probleem
« Reactie #2 Gepost op: 2010/07/28, 12:33:57 »
Hallo

Kun je ook een keer
cat /proc/asound/* 2>/dev/null
in een terminal doen en hier posten?
Volgens mij zie ik nl. een onverwachte AD198x bij die aplay -l ,
dat strookt eigenlijk niet met het MCP51 hda gebeuren.

Waarschijnlijk moet er een regel toegevoegd gaan worden( afhankelijk van de codec
die op gaat duiken uit die cat opdracht), in de /etc/modprobe.d/alsa-base.conf
wat heb je daar eigenlijk op dit moment in staan?

toe te voegen regel zal waarschijnlijk deze worden (van wat ik van de mcp51 tegen kwam,
zit vaak in medion en targa laptops);
options snd-hda-intel model=targa-2ch-dig
en om die file te kunnen bewerken;
sudo gedit /etc/modprobe.d/alsa-base.conf
vanuit een terminal.

Na een herstart heb je misschien al geluid.
Dus je kunt al aan het werk met dit, maar post ook hier de uitkomst van die cat opdracht.
Wat voor laptop is dit eigenlijk (is het wel een laptop trouwens)?

Groeten Gerrit
-- = >  simplify if you can   -- = >

Offline Schapenvelleke

  • Lid
  • Steunpunt: Nee
Re: alweer een geluid probleem
« Reactie #3 Gepost op: 2010/07/28, 13:29:08 »
 bart@Schaapje:~$ cat /proc/asound/* 2>/dev/null
 0 [NVidia         ]: HDA-Intel - HDA NVidia
                      HDA NVidia at 0xfe024000 irq 22
 1 [UART           ]: MPU-401 UART - MPU-401 UART
                      MPU-401 UART at 0x330, irq 10
  2:        : timer
  3:        : sequencer
  4: [ 1- 0]: raw midi
  5: [ 1]   : control
  6: [ 0- 1]: digital audio playback
  7: [ 0- 0]: digital audio playback
  8: [ 0- 0]: digital audio capture
  9: [ 0- 0]: hardware dependent
 10: [ 0]   : control
00-00: HDA Codec 0
 0 snd_hda_intel
 1 snd_mpu401
00-00: AD198x Analog : AD198x Analog : playback 1 : capture 1
00-01: AD198x Digital : AD198x Digital : playback 1
G0: system timer : 4000.000us (10000000 ticks)
P0-0-0: PCM playback 0-0-0 : SLAVE
P0-0-1: PCM capture 0-0-1 : SLAVE
P0-1-0: PCM playback 0-1-0 : SLAVE
Advanced Linux Sound Architecture Driver Version 1.0.21.

Nee het is een gewone desktop pc amd64

Offline Schapenvelleke

  • Lid
  • Steunpunt: Nee
Re: alweer een geluid probleem
« Reactie #4 Gepost op: 2010/07/28, 13:42:11 »
heb het getest met die regel toe te voegen maar brengt niet veel op :)
ik heb ook de installatie afgerond zoals Roc mij had aangeraden maar na het installeren van enkele codex ook geen verandering

Nu als ik bij geluidsvoorkeuren -> Hardware ga kijken kan ik nog is kiezen uit 5 profielen
Analog stereo input
digital stereo duplex (IEC958)
digital stereo(IEC958) + analog stereo input
analog stereo output
analog stereo duplex

waar moet die eigenlijk juist op staan ?

Offline Progger

  • Lid
  • Steunpunt: Nee
Re: alweer een geluid probleem
« Reactie #5 Gepost op: 2010/07/28, 13:46:11 »
Bij mij staat die op analog stereo duplex, je kan altijd eens proberen hé.
Laptop MSI U123 (160 GB) 1 GB ramMint Cinnamon 18 LTS
Laptop Toshiba Tecra  (80GB) 2 GB ram Fedora 24
Dell Latitude D600 Pentium M 1400MHz 512MB ram
Bouwjaar 2003 met Debian 8 (Jessie)

Offline mrGee

  • Lid
  • Steunpunt: Nee
Re: alweer een geluid probleem
« Reactie #6 Gepost op: 2010/07/28, 13:51:37 »
Hallo

Inderdaad gaat die wijziging nu niets opbrengen in die file, maak dat maar
alvast weer ongedaan. En herstart daarna weer de machine.

Kun je even de
linux-backports-modules-alsa
bij installeren van de kernel versie die je nu gebruikt
( in terminal uname -a doen en je ziet de kernel versie)

Daarna herstarten en kijken of dit wat brengt, voor een aantal chipset
was dit een oplossing (met name voor microfoon en hooftelefoon mute ed.)

Anders wordt het zoeken op mogelijkheden met die AD198x  
(blijf het vreemd vinden dat ie opduikt overigens.)
Is dit trouwens de enige soundkaart in de machine?

Staat je onboard soundkaart trouwens netjes op enabled of staat ie op auto
in je bios (sommige hebben alleen maar keuze tussen auto en disabled)
Zet hem anders eens expliciet op enabled, mocht die keuze er ook zijn.

Voor een normaal te gebruiken profiel zou je de analog stereo output kunnen benutten.

Groeten Gerrit
-- = >  simplify if you can   -- = >

Offline Schapenvelleke

  • Lid
  • Steunpunt: Nee
Re: alweer een geluid probleem
« Reactie #7 Gepost op: 2010/07/28, 14:07:14 »
ok file terug aangepast.

uname -a geeft dit weer
Linux Schaapje 2.6.32-24-generic #38-Ubuntu SMP Mon Jul 5 09:22:14 UTC 2010 i686 GNU/Linux

linux-backports-modules-alsa  wat bedoel je hier precies mee ?

soundcard staat op enable, ik heb de midi port uitgeschakeld, maar dat hielp ook niet
kheb nog een op mobo gekeken en het is een Asus m2npv-vm am2





Offline Cumulus007

  • Lid
  • Steunpunt: Nee
Re: alweer een geluid probleem
« Reactie #8 Gepost op: 2010/07/28, 14:18:21 »
ok file terug aangepast.

uname -a geeft dit weer
Linux Schaapje 2.6.32-24-generic #38-Ubuntu SMP Mon Jul 5 09:22:14 UTC 2010 i686 GNU/Linux

linux-backports-modules-alsa  wat bedoel je hier precies mee ?

soundcard staat op enable, ik heb de midi port uitgeschakeld, maar dat hielp ook niet
kheb nog een op mobo gekeken en het is een Asus m2npv-vm am2





Dat moederbord heb ik dus ook gehad, werkelijk nog nooit problemen gehad met het geluid.

Offline Schapenvelleke

  • Lid
  • Steunpunt: Nee
Re: alweer een geluid probleem
« Reactie #9 Gepost op: 2010/07/28, 14:21:51 »
ja heb nog eens int boekske gekeken en de soundcard is een
SoundMAX® ADI AD1986A 5.1-channel CODEC
Supports Jack Sensing technology
S/PDIF out interface

Cumulus enig idee hoe mijn alsa base conf eruit moet zien ?
# autoloader aliases
install sound-slot-0 /sbin/modprobe snd-card-0
install sound-slot-1 /sbin/modprobe snd-card-1
install sound-slot-2 /sbin/modprobe snd-card-2
install sound-slot-3 /sbin/modprobe snd-card-3
install sound-slot-4 /sbin/modprobe snd-card-4
install sound-slot-5 /sbin/modprobe snd-card-5
install sound-slot-6 /sbin/modprobe snd-card-6
install sound-slot-7 /sbin/modprobe snd-card-7

# Cause optional modules to be loaded above generic modules
install snd /sbin/modprobe --ignore-install snd $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-ioctl32 ; /sbin/modprobe --quiet --use-blacklist snd-seq ; }
#
# Workaround at bug #499695 (reverted in Ubuntu see LP #319505)
install snd-pcm /sbin/modprobe --ignore-install snd-pcm $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-pcm-oss ; : ; }
install snd-mixer /sbin/modprobe --ignore-install snd-mixer $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-mixer-oss ; : ; }
install snd-seq /sbin/modprobe --ignore-install snd-seq $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq-midi ; /sbin/modprobe --quiet --use-blacklist snd-seq-oss ; : ; }
#
install snd-rawmidi /sbin/modprobe --ignore-install snd-rawmidi $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq-midi ; : ; }
# Cause optional modules to be loaded above sound card driver modules
install snd-emu10k1 /sbin/modprobe --ignore-install snd-emu10k1 $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-emu10k1-synth ; }
install snd-via82xx /sbin/modprobe --ignore-install snd-via82xx $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq ; }

# Load saa7134-alsa instead of saa7134 (which gets dragged in by it anyway)
install saa7134 /sbin/modprobe --ignore-install saa7134 $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist saa7134-alsa ; : ; }
# Prevent abnormal drivers from grabbing index 0
options bt87x index=-2
options cx88_alsa index=-2
options saa7134-alsa index=-2
options snd-atiixp-modem index=-2
options snd-intel8x0m index=-2
options snd-via82xx-modem index=-2
options snd-usb-audio index=-2
options snd-usb-us122l index=-2
options snd-usb-usx2y index=-2
options snd-usb-caiaq index=-2
# Ubuntu #62691, enable MPU for snd-cmipci
options snd-cmipci mpu_port=0x330 fm_port=0x388
# Keep snd-pcsp from being loaded as first soundcard
options snd-pcsp index=-2

Offline Cumulus007

  • Lid
  • Steunpunt: Nee
Re: alweer een geluid probleem
« Reactie #10 Gepost op: 2010/07/28, 14:29:37 »
Dat weet ik allemaal niet. Alles werkte meteen. Je weet zeker dat het geluid niet is gedempt?

Offline mrGee

  • Lid
  • Steunpunt: Nee
Re: alweer een geluid probleem
« Reactie #11 Gepost op: 2010/07/28, 16:00:38 »
Kun je ook een
lsmod |grep snd_hda
in een terminal doen, om te kijken of deze is geladen?

Die Adi chipset zou inderdaad eigenlijk direct moeten werken, maar ik zie
toch uit je eerste post;
sudo lspci -v
00:10.1 Audio device: nVidia Corporation MCP51 High Definition Audio (rev a2)
Subsystem: ASUSTeK Computer Inc. Device 81cb
Flags: bus master, 66MHz, fast devsel, latency 0, IRQ 22
Memory at fe024000 (32-bit, non-prefetchable) [size=16K]
Capabilities: [44] Power Management version 2
Capabilities: [50] Message Signalled Interrupts: Mask+ 64bit+ Queue=0/0 Enable-
Capabilities: [6c] HyperTransport: MSI Mapping Enable- Fixed+
Kernel driver in use: HDA Intel
Kernel modules:[b] snd-hda-inte[/b]l

een snd-hda-intel opduiken?

Groeten Gerrit
-- = >  simplify if you can   -- = >

Offline Schapenvelleke

  • Lid
  • Steunpunt: Nee
Re: alweer een geluid probleem
« Reactie #12 Gepost op: 2010/07/28, 19:25:13 »
bart@Schaapje:~$ lsmod |grep snd_hda
snd_hda_codec_analog    58598  1
snd_hda_intel          21941  1
snd_hda_codec          74201  2 snd_hda_codec_analog,snd_hda_intel
snd_hwdep               5412  1 snd_hda_codec
snd_pcm                70662  3 snd_hda_intel,snd_hda_codec,snd_pcm_oss
snd                    54148  14 snd_hda_codec_analog,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_seq_oss,snd_rawmidi,snd_seq,snd_timer,snd_seq_device
snd_page_alloc          7076  2 snd_hda_intel,snd_pcm

Offline Schapenvelleke

  • Lid
  • Steunpunt: Nee
Re: alweer een geluid probleem
« Reactie #13 Gepost op: 2010/07/28, 21:31:12 »
Ha

kheb reinstall gedaan en alles werkt.
Kheb nu de raad gevolgd van Roc om als eerste de 'eerstdoen' pagina af te werken.

Bedankt voor jullie aandacht
en see you later

Offline mrGee

  • Lid
  • Steunpunt: Nee
Re: alweer een geluid probleem
« Reactie #14 Gepost op: 2010/07/28, 22:18:19 »
Hallo

Is inderdaad ook een manier; zou je er nog een [Opgelost] voor kunnen
zetten in je eerste topic title

Ik ben eigenlijk wel nieuwsgierig; duikt die snd_hda nog op als je
lsmod |grep snd_hd
doet
en wat zegt
aplay -l
nu?

Groeten Gerrit
-- = >  simplify if you can   -- = >

Offline Schapenvelleke

  • Lid
  • Steunpunt: Nee
Re: alweer een geluid probleem
« Reactie #15 Gepost op: 2010/07/28, 22:44:45 »
bart@schaapje:~$ lsmod | grep snd_hd
snd_hda_codec_analog    58598  1
snd_hda_intel          21941  5
snd_hda_codec          74201  2 snd_hda_codec_analog,snd_hda_intel
snd_hwdep               5412  1 snd_hda_codec
snd_pcm                70662  4 snd_hda_intel,snd_hda_codec,snd_pcm_oss
snd                    54148  21 snd_hda_codec_analog,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_seq_oss,snd_rawmidi,snd_seq,snd_timer,snd_seq_device
snd_page_alloc          7076  2 snd_hda_intel,snd_pcm

bart@schaapje:~$ aplay -l
**** Lijst van PLAYBACK hardware-apparaten ****
kaart 0: NVidia [HDA NVidia], apparaat 0: AD198x Analog [AD198x Analog]
  Sub-apparaten: 0/1
  Sub-apparaat #0: subdevice #0
kaart 0: NVidia [HDA NVidia], apparaat 1: AD198x Digital [AD198x Digital]
  Sub-apparaten: 1/1
  Sub-apparaat #0: subdevice #0


Ik zie maar 1 verschil bij aplay staat er sub-apparaat: 0/1 en vroeger 1/1 ??

:D

Offline mrGee

  • Lid
  • Steunpunt: Nee
Re: [opgelost]alweer een geluid probleem
« Reactie #16 Gepost op: 2010/07/29, 09:19:06 »
Bedankt voor het terugmelden =D, ik kan hier ook even niets zinnigs over
zeggen. (voor zover dat al mogelijk is  ;))
-- = >  simplify if you can   -- = >