Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Wireless Lan en WPA  (gelezen 8446 keer)

Offline Johan van der Vliet

  • Lid
    • http://www.waco-nederland.nl
  • Steunpunt: Nee
Wireless Lan en WPA
« Gepost op: 2006/01/27, 23:30:12 »
Hallo Ubuntuers.

Wil er iemand stap voor stap uitleggen hoe je WPA moet installeren?

Mijn Draadloze netwerkkaart werkt wel alleen weet ik niet hoe ik met WPA om moet gaan. Ik heb al diverse howto' s geprobeerd maar ik kom er niet uit.

Wie o wie kan dit in fatsoenlijk Nederlands uitleggen?

Alvast hartelijk dank.

J, van der Vliet
Ubuntu gebruiker # 14919

Offline Dennis Kaarsemaker

  • Administrator
    • dennis
    • http://www.kaarsemaker.net
  • Steunpunt: Nee
Wireless Lan en WPA
« Reactie #1 Gepost op: 2006/01/27, 23:41:08 »
Voordat we beginnen wil ik eerst even het volgende weten:

Hoe ziet /etc/network/interfaces er nu uit?
Hoe ziet /etc/default/wpasupplicant er nu uit?
Hoe ziet /etc/wpa_supplicant.conf er nu uit? (zonder de wachtwoorden)

Als je deze bestanden meepost kan ik je in (hopelijk) 1 bericht op weg helpen :)

Offline Johan van der Vliet

  • Lid
    • http://www.waco-nederland.nl
  • Steunpunt: Nee
Wireless Lan en WPA
« Reactie #2 Gepost op: 2006/01/28, 10:20:03 »
/etc/network/interfaces:

# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

# This is a list of hotpluggable network interfaces.
# They will be activated automatically by the hotplug subsystem.
mapping hotplug
   script grep
   map eth0

iface ra0 inet static
address 192.168.0.3
netmask 255.255.255.0
gateway 192.168.0.1
wireless-essid belkin54g



auto ra0

____________________________________________________________________________

/etc/default/wpasupplicant:

# /etc/default/wpasupplicant

# WARNING! Make sure you have a configuration file!

ENABLED=0

# Useful flags:
#  -D       Wireless drive, typically optional.
#  -i       Interface
#  -c    Configuration file
#  -d          Debugging (-dd for more)
#  -w         Wait for interface to come up

# See the manual page wpa_supplicant(1) for more options and information.

OPTIONS="-w"

# EXAMPLES:

# OPTIONS="-i wlan0 -D hostap -c /etc/wpa_supplicant.conf"
# OPTIONS="-i ath0 -D madwifi -c /etc/wpa_supplicant.conf"


____________________________________________________________________________

/etc/wpa_supplicant.conf

# Minimal /etc/wpa_supplicant.conf to associate with open
#  access points. Please see
#  /usr/share/doc/wpasupplicant/wpa_supplicant.conf.gz for more complete
#  configuration parameters.

ctrl_interface=/var/run/wpa_supplicant
ctrl_interface_group=0

eapol_version=1
ap_scan=0
fast_reauth=1

### Associate with any open access point
###  Scans/ESSID changes can be done with wpa_cli

###johan@johan:~$ wpa_passphrase NetworkEssid TextPassphrase
network={
        ssid="belkin54g"
        #psk="testkeyvoormij"
   
}

network={
        ssid="belkin54g   "
        scan_ssid=0 # only needed if your access point uses a hidden ssid
        proto=WPA
        key_mgmt=WPA-PSK
   
}

____________________________________________________________________________


ALVAST HARTELIJK DANK!!!
Ubuntu gebruiker # 14919

Offline Dennis Kaarsemaker

  • Administrator
    • dennis
    • http://www.kaarsemaker.net
  • Steunpunt: Nee
Wireless Lan en WPA
« Reactie #3 Gepost op: 2006/01/28, 11:42:28 »
Oeh, ralink... die is eng en gebruikt geen wpa_supplicant :)

In /etc/network/interfaces doe je zoits als dit:

iface ra0 inet static
pre-up iwconfig ra0 essid YOUR-SSID
pre-up iwconfig ra0 mode managed
pre-up iwpriv ra0 set Channel=11
pre-up iwpriv ra0 set AuthMode=WPAPSK
pre-up iwpriv ra0 set EncrypType=AES
pre-up iwpriv ra0 set WPAPSK="YOUR-WPA-PSK"
pre-up iwpriv ra0 set TxRate=0

en de rest....

Offline Johan van der Vliet

  • Lid
    • http://www.waco-nederland.nl
  • Steunpunt: Nee
Wireless Lan en WPA
« Reactie #4 Gepost op: 2006/01/28, 15:44:46 »
wat en de rest?

Ik heb het geprobeerd. Nog geen resultaat.
Moeten die andere bestanden ook nog geconfigureerd worden?
Ubuntu gebruiker # 14919

Offline Dennis Kaarsemaker

  • Administrator
    • dennis
    • http://www.kaarsemaker.net
  • Steunpunt: Nee
Wireless Lan en WPA
« Reactie #5 Gepost op: 2006/01/28, 16:59:11 »
Deze rest:

address 192.168.0.3
netmask 255.255.255.0
gateway 192.168.0.1

Offline Johan van der Vliet

  • Lid
    • http://www.waco-nederland.nl
  • Steunpunt: Nee
Wireless Lan en WPA
« Reactie #6 Gepost op: 2006/01/28, 18:55:53 »
Citaat van: Dennis
Deze rest:

address 192.168.0.3
netmask 255.255.255.0
gateway 192.168.0.1
Dit heb ik al in /etc/network/interfaces  al ingevoerd.

Nu /etc/wpa_supplicant.conf en
/etc/default/wpasupplicant  nog.

Of is dit niet nodig?
Ubuntu gebruiker # 14919

Offline Dennis Kaarsemaker

  • Administrator
    • dennis
    • http://www.kaarsemaker.net
  • Steunpunt: Nee
Wireless Lan en WPA
« Reactie #7 Gepost op: 2006/01/28, 19:23:13 »
Nee, die hoeven dus niet, rt2500 doet het op z'n eigen manier.

Post je huidige /etc/network/interfaces eens

Offline Johan van der Vliet

  • Lid
    • http://www.waco-nederland.nl
  • Steunpunt: Nee
Wireless Lan en WPA
« Reactie #8 Gepost op: 2006/02/04, 20:22:16 »
Dennis,

Het is gelukt. Maar nu nog een probleem:

Ubuntu gooit de Windows pc' s er uit.

Als ik mijn pc aan zet en het is opgestart kan ik het internet op. Maar dan liggen alle Windows XP/2000 machines eruit. De netwerkverbinding in Windows XP/2000 vallen iedere keer weg.

Als ik mijn pc uitschakel, dan kunnen ze het internet op.

Als ik WPA uitzet op de router en alle pc' s dan kunnen zowel Ubuntu en windows tegelijk het internet op. Is hier een oplossing voor?
Ubuntu gebruiker # 14919

Offline Dennis Kaarsemaker

  • Administrator
    • dennis
    • http://www.kaarsemaker.net
  • Steunpunt: Nee
Wireless Lan en WPA
« Reactie #9 Gepost op: 2006/02/04, 22:10:40 »
Woah, is je rt3500 zo sterk?

Offline Johan van der Vliet

  • Lid
    • http://www.waco-nederland.nl
  • Steunpunt: Nee
Wireless Lan en WPA
« Reactie #10 Gepost op: 2006/02/04, 23:12:33 »
Het ligt niet aan de rt2500 maar het zit em in Ubuntu Linux of de router. Dit geintje had ik ook met Mandriva 2006 met de netwerkkaart van Linksys. Nu staat WPA gewoon uit, en alles kan gewoon internet op,
Ubuntu gebruiker # 14919

DrDefault

  • Gast
Wireless Lan en WPA
« Reactie #11 Gepost op: 2006/02/19, 09:53:47 »
Ik neem aan dat je op de WIN bakken OOK de WPA (via util disk fabrikant ofzo) hebt ingesteld?

Anders zet jouw ubuntu bak de zaak op WPA versleuteld, en daar snapt de WEP van windows niet veel meer van gok ik ;0(

Linux: "Vanaf nu praten we WPA". Router: OK!
Windows bak: WP-HOEVEEL?!

Offline Johan van der Vliet

  • Lid
    • http://www.waco-nederland.nl
  • Steunpunt: Nee
Wireless Lan en WPA
« Reactie #12 Gepost op: 2006/02/20, 08:29:10 »
Ja dat heb ik zeker al geprobeerd. Maar geen effect. En ook andere netwerkkaarten geprobeerd.
Ubuntu gebruiker # 14919

dennispater

  • Gast
Wireless Lan en WPA
« Reactie #13 Gepost op: 2007/10/18, 02:08:08 »
Hoe kan je deze bestanden wijzigen, want dat krijg ik niet voor elkaar.

Dank jullie wel
Dennis