Nieuws:

We zijn er weer.

Na lange tijd van afwezigheid zijn we er weer  :laugh:
We hebben alle wachtwoorden gereset, je oude wachtwoord werkt niet meer.Je moet via het "wachtwoord vergeten"-linkje je wachtwoord resetten. Je krijgt hiervoor een mailtje op het adres dat je bij ons geregistreerd hebt.

De komende tijd zijn we nog druk bezig om de rest van de site op te bouwen, dus het kan zijn dat sommige onderdelen (tijdelijk) niet werken.

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: [OPGELOST] Geen verbinding met Wireless USB Adapter DWA-140  (gelezen 3077 keer)

Offline 10o

  • Lid
  • Steunpunt: Nee
[OPGELOST] Geen verbinding met Wireless USB Adapter DWA-140
« Gepost op: 2010/07/17, 17:29:11 »
Het lukt me vooralsnog niet om een draadloze verbinding tot stand te brengen tussen mijn nieuwe D-Link Wireless N Gigabit Router DIR-655 en de Wireless N USB Adapter DWA-140. Draadloze verbindingen komen op mijn Nokia E51 telefoon en de interne wireless van mijn Acer 5310 laptop wel tot stand.

Omdat de desktop binnenkort naar een andere kamer moet, waar géén kabel-verbinding mogelijk is, hoop ik dat de D-Link-combinatie een snelle draadloze verbinding tot stand kan brengen.

Wat heb ik reeds gedaan? Conform Pjotr's instructies (http://sites.google.com/site/computertip/ralink):

gksudo gedit /etc/modprobe.d/rt2870sta.confinstall rt2870sta modprobe --ignore-install rt2870sta ; /bin/echo "1737 0078" > /sys/bus/usb/drivers/rt2870/new_idsudo modprobe -rf rt2870sta
sudo modprobe rt2870sta
dmesg | egrep 'rt28|usb|Phy'
iwconfig
gksudo gedit /etc/modules
rt2870sta
Na reboot waren er nog steeds geen beschikbare draadloze verbindingen zichtbaar. Toen viel mij op dat lsusb een ander ID bij de USB Adapter weergaf. Daarom heb ik bovenstaande commando's nog een keer gedaan, met deze aangepaste regel:
install rt2870sta modprobe --ignore-install rt2870sta ; /bin/echo "7d1 3c0a" > /sys/bus/usb/drivers/rt2870/new_id
Nu zijn de mogelijke aansluitpunten na reboot netjes zichtbaar.

Als ik vervolgens contact maak middels mijn beschikbaar wireless wordt er - zoals verwacht - om mijn ingestelde wachtwoord gevraagd, daarna komt de verbinding echter maar niet tot stand. Na enkele minuten verschijnt ook deze notificatie.

Natuurlijk heb ik her en der al gezocht naar oplossingen, maar helaas nog niets gevonden...

Wie weet raad?
« Laatst bewerkt op: 2010/07/18, 00:15:04 door 10o »
Workstation:  i7-5820K 16GiB - GeForce GTX 960 2GiB - 4K  (Ubuntu 16.04.1)
Server: Asus E35M1-I Deluxe - AMD Fusion APU E-350 (Ubuntu Server 16.04.1)

Offline 10o

  • Lid
  • Steunpunt: Nee
Re: Geen verbinding met Wireless USB Adapter DWA-140
« Reactie #1 Gepost op: 2010/07/17, 19:53:48 »
Als ik de WPA-Personal Security Mode uitzet, krijg ik wel verbinding... Zonder deze beveiliging werkt het dus wel, maar dat is natuurlijk ongewenst.

Dit heb ik ook nog geprobeerd:
sudo gedit /etc/modprobe.d/blacklist.confblacklist rt2800usb
Hierdoor blijft bij sudo lsmod | grep rt28 alleen rt2870sta over. Geeft geen ongewenste bijeffecten, maar niet het gewenste resultaat.



« Laatst bewerkt op: 2010/07/17, 20:03:34 door 10o »
Workstation:  i7-5820K 16GiB - GeForce GTX 960 2GiB - 4K  (Ubuntu 16.04.1)
Server: Asus E35M1-I Deluxe - AMD Fusion APU E-350 (Ubuntu Server 16.04.1)

Offline 10o

  • Lid
  • Steunpunt: Nee
[OPGELOST] Geen verbinding met Wireless USB Adapter DWA-140
« Reactie #2 Gepost op: 2010/07/18, 00:11:37 »
De bug wordt hier beschreven: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/543836
Pas bij #25 ging uiteindelijk het licht aan.

Alle her en der beschreven (én uitgeprobeerde) ingewikkelde "oplossingen" ten spijt, met onderstaand pakket werkt het gewoon:
sudo apt-get install linux-backports-modules-wireless-lucid-generic
Het bestand /etc/Wireless/RT2870STA/RT2870STA.dat met daarin
#The word of "Default" must not be removed
Default
of de uitgebreide versie daarvan blijkt niet nodig.

Op de desktop is het wel nodig dat de usb-drivers op de blacklist blijven staan (wellicht door de - inmiddels - overbodige tussenoplossingen die ik uitgeprobeerd heb?):
sudo gedit /etc/modprobe.d/blacklist.confblacklist rt2500usb
blacklist rt2800usb

Installatie van de backports maakt alle in eerdere posts van dit topic beschreven procedures (incl. Pjotr's advies omtrent deze Ralink chipset) feitelijk overbodig. Dat blijkt ook uit installatie op de laptop die ik op deze wijze (na het uitschakelen van de interne wireless adapter) heb uitgevoerd. Zie http://forum.ubuntu-nl.org/internet-en-draadloos/wlan-adapter-uitschakelen/msg627105/#msg627105
« Laatst bewerkt op: 2010/07/18, 09:42:37 door 10o »
Workstation:  i7-5820K 16GiB - GeForce GTX 960 2GiB - 4K  (Ubuntu 16.04.1)
Server: Asus E35M1-I Deluxe - AMD Fusion APU E-350 (Ubuntu Server 16.04.1)