Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: [OPGELOST] Asus 1201n ubuntu 10.04 + nvidia driver Loading screens raar en...  (gelezen 3066 keer)

Offline Support4u

  • Lid
  • Steunpunt: Nee
Hey gasten!

Niet echt een super probleem, maar wel een beetje raar. Met de normale out of the box nouveau driver zijn de loadingscreens ( als je ubuntu opstart en afsluit ) netjes en mooi. Maar na de installatie van de opgegeven Nvidia videodriver worden de ubuntu loadingscreens uitgestrekt en raar weergegeven. ( alsof ze een lage resolutie aannemen )

Kan dit nog herstelt worden.. alles is nou mooi 3d, en high res enzo.. dus die loading screens zou ik ook graag mooi terug zien :P

Iemand een idee?!

Erg bedankt alvast
« Laatst bewerkt op: 2010/07/19, 16:58:53 door Support4u »

Offline Gr8Jen

  • Lid
  • Steunpunt: Nee
ik had laatst een resolutie aangemaakt met onderstaande link:

http://www.ubuntugeek.com/how-change-display-resolution-settings-using-xrandr.html

en hierbij is het opstart en afsluitscherm 1920 x 1080  :rolleyes:

EDIT:

ik bedacht me dat ik gegevens van meerdere sites had gecombineerd. Dus bij deze:

gtf 1920 1080 75
heeft als resultaat:

  # 1920x1080 @ 75.00 Hz (GTF) hsync: 84.60 kHz; pclk: 220.64 MHz
  Modeline [i][b]"1920x1080_75.00"  220.64  1920 2056 2264 2608  1080 1081 1084 1128  -HSync +Vsync[/b][/i]


met die gegevens maak je het volgende:

xrandr --newmode [i][b]"1920x1080_75.00"  220.64  1920 2056 2264 2608  1080 1081 1084 1128  -HSync +Vsync[/b][/i]
xrandr  --addmode VGA1 1920x1080_75.00

selecteer de resolutie even die je hebt aangemaakt en check of het werkt.
indien succes:

gksudo gedit /etc/gdm/Init/Default

zoek naar:
PATH=/usr/bin:$PATH
OLD_IFS=$IFS

en zet direct daaronder:

xrandr --newmode [b][i]"1920x1080_75.00"  220.64  1920 2056 2264 2608  1080 1081 1084 1128  -HSync +Vsync[/i][/b]
xrandr  --addmode VGA1 1920x1080_75.00
$ xrandr –output VGA1 –mode 1920x1080_75.00

« Laatst bewerkt op: 2010/07/15, 17:43:43 door Gr8Jen »

Offline Support4u

  • Lid
  • Steunpunt: Nee
hehe awesome!  :D
Ik ga het proberen! maare is dit wel noob vriendelijk?
want ik ben een echte linux noobs. vooral als we code's gaan gebruiken :P  :P

Offline Gr8Jen

  • Lid
  • Steunpunt: Nee
je zal als super user moeten inloggen om het bestandje aan te passen:

Citaat
sudo su

en dan je wachtwoord invullen
 en het gaat goed zolang:

zolang je het resultaat gebruikt van wat jij krijgt voor je resolutie
in dit geval het resultaat van jouw kaart wat hier dik gedrukt is:

Citaat
# 1920x1080 @ 75.00 Hz (GTF) hsync: 84.60 kHz; pclk: 220.64 MHz
  Modeline "1920x1080_75.00"  220.64  1920 2056 2264 2608  1080 1081 1084 1128  -HSync +Vsync

en van te voren eerst testen of de monitor het kan hebben anders wordt het moeilijk om het terug te zetten als die resolutie is ingesteld voor opstarten: het is dan ook de resolutie die geldt wanneer is opgestart.

je hoeft geen kernel te compileren of iets dergelijks dus er kan weinig fout gaan
« Laatst bewerkt op: 2010/07/15, 19:43:06 door Gr8Jen »

Offline Support4u

  • Lid
  • Steunpunt: Nee
this een laptop dus thet word 1280 x 980 ofzo mot ik morgu effu nachecken. men laptop ligt nog op het werk.
in ieder geval erg bedankt alvast!


Offline Support4u

  • Lid
  • Steunpunt: Nee
Okeey het gaat al weer mis!

xrandr  --addmode VGA1 1920x1080_75.00
bestaat niet als commando of is incorrect

gksudo gedit /etc/gdm/Init/Default
bestaat niet, ik krijg dus een leeg document te zien.


wat nu?


Offline Support4u

  • Lid
  • Steunpunt: Nee
Hierboven +

VGA1 bestaat niet? VGA0 en 2 ook niet.. dus het commando is niet correct of volledig..

Offline Gr8Jen

  • Lid
  • Steunpunt: Nee
je hebt dus voor je laptop de term:

gtf 1920 1080 75
en het gaf een resultaat zonder errorcode?

heb je gekopieerd wat er als resultaat werd gegeven (bij mij hetgeen wat dikgedrukt is)

Citaat
# 1920x1080 @ 75.00 Hz (GTF) hsync: 84.60 kHz; pclk: 220.64 MHz
  Modeline "1920x1080_75.00"  220.64  1920 2056 2264 2608  1080 1081 1084 1128  -HSync +Vsync

heb je toen ingelogd als superuser?

sudo su en wachtwoord invullen (ik denk het niet anders had je het bestand wel gevonden)

heb je toen een regel gemaakt met het resultaat van jouw commando

xrandr --newmode <modeline>
in dit geval dus

Citaat
xrandr --newmode "1920x1080_75.00"  220.64  1920 2056 2264 2608  1080 1081 1084 1128  -HSync +Vsync
alleen dan het dikgedrukte vervangen met het resultaat van jouw commando

---------------------------------------------------------------------------------------------------

mijn fout ik bedenk me nu dat jij met een laptop stoeit

typ in de terminal:
Citaat
xrandr

en kijk naar de uitkomst

bij mij staat er een regel:
Citaat
Screen 0: minimum 320 x 200, current 1440 x 960, maximum 8192 x 8192
VGA1 connected 1440x960+0+0 (normal left inverted right x axis y axis) 330mm x 250mm

het gaat om de "VGA1" waarschijnlijk staat er bij jou "default" in plaats van VGA1
als dat zo is verander je het commando in:

Citaat
xrandr  --addmode default 1920x1080_75.00

vervolgens kies je het door jou aangemaakte resolutie in System->Preferences->window (geen idee wat het in het engels is)

als het werkt kun je het volgende in "/etc/gdm/Init/Default"zetten

xrandr --newmode [b][i]"1920x1080_75.00"  220.64  1920 2056 2264 2608  1080 1081 1084 1128  -HSync +Vsync[/i][/b]
xrandr  --addmode default 1920x1080_75.00
xrandr –output default –mode 1920x1080_75.00

omdat je met een laptop werkt zal het waarschijnlijk beter zijn als je alleen met 60Hz werkt.
ik kan het nu niet testen omdat ik alleen een oude laptop bij me heb die gaan hogere resolutie aankan

EDIT:

lagere resoluties kan ik aanmaken met 0 Hz dus misschien kun je die proberen aangezien tft schermpjes geen refershrate hebbben ;)
« Laatst bewerkt op: 2010/07/16, 11:34:15 door Gr8Jen »

Offline Support4u

  • Lid
  • Steunpunt: Nee
Cool dat je weer antwoord. we komen er wel!

xrandr --addmode 1366x768_60.00
xrandr cannot find mode 1366x768_60.00

 ???


Offline Gr8Jen

  • Lid
  • Steunpunt: Nee
xrandr --addmode default 1366x768_60.00  ;)

indien bij jouw xrandr ook "default" geeft in plaats van "VGA1"op je laptop

Offline Support4u

  • Lid
  • Steunpunt: Nee
lomp van me dat ik het niet juist naar je stuurt.

xrandr --addmode default 1366x768_60.00
geeft dus cannot find mode blah blah

Offline Progger

  • Lid
  • Steunpunt: Nee
Is het niet gemakkelijker voor de helper(s) om de uitkomst van het commando xrandr hier neer te zetten voor de duidelijkheid?  ;) Dit is bijvoorbeeld de mijne op mijn netbook:

djf@djf-laptop:~$ xrandr
Screen 0: minimum 320 x 200, current 1024 x 600, maximum 4096 x 4096
VGA1 disconnected (normal left inverted right x axis y axis)
LVDS1 connected 1024x600+0+0 (normal left inverted right x axis y axis) 222mm x 130mm
   1024x600       60.0*+
   800x600        85.1     72.2     75.0     60.3     56.2 
   640x480        85.0     72.8     75.0     59.9 
   720x400        85.0 
   640x400        85.1 
   640x350        85.1
« Laatst bewerkt op: 2010/07/16, 12:06:18 door Progger »
Laptop MSI U123 (160 GB) 1 GB ramMint Cinnamon 18 LTS
Laptop Toshiba Tecra  (80GB) 2 GB ram Fedora 24
Dell Latitude D600 Pentium M 1400MHz 512MB ram
Bouwjaar 2003 met Debian 8 (Jessie)

Offline Support4u

  • Lid
  • Steunpunt: Nee
Ik krijg zoiets inderdaad te zien.
alleen het commando werkt niet..

Offline Progger

  • Lid
  • Steunpunt: Nee
Wat staat er bij jou aangegeven op het vetgedrukte bij mij?

VGA1 disconnected (normal left inverted right x axis y axis)
LVDS1 connected 1024x600+0+0 (normal left inverted right x axis y axis) 222mm x 130mm
Laptop MSI U123 (160 GB) 1 GB ramMint Cinnamon 18 LTS
Laptop Toshiba Tecra  (80GB) 2 GB ram Fedora 24
Dell Latitude D600 Pentium M 1400MHz 512MB ram
Bouwjaar 2003 met Debian 8 (Jessie)

Offline Support4u

  • Lid
  • Steunpunt: Nee
user26800@Asus1201n:~$ xrandr
Screen 0: minimum 320 x 175, current 1366 x 768, maximum 1366 x 768
default connected 1366x768+0+0 0mm x 0mm
   1366x768       50.0*
   1024x768       51.0     52.0 
   960x540        53.0 
   840x525        54.0 
   832x624        55.0 
   800x600        56.0     57.0     58.0     59.0     60.0 
   800x512        61.0 
   720x450        62.0 
   720x400        63.0 
   700x525        64.0 
   680x384        65.0     66.0 
   640x512        67.0     68.0 
   640x480        69.0     70.0     71.0     72.0     73.0 
   640x400        74.0 
   640x350        75.0 
   576x432        76.0     77.0     78.0     79.0     80.0     81.0     82.0 
   512x384        83.0     84.0     85.0     86.0     87.0 
   416x312        88.0 
   400x300        89.0     90.0     91.0     92.0     93.0 
   360x200        94.0 
   320x240        95.0     96.0     97.0     98.0 
   320x200        99.0 
   320x175       100.0 
user26800@Asus1201n:~$

Offline Progger

  • Lid
  • Steunpunt: Nee
Hoe kan het, dat je refresh op  1366x768       50.0* staat, heb je dat zelf zo aangepast? Een laptop staat standaard op 60.
Laptop MSI U123 (160 GB) 1 GB ramMint Cinnamon 18 LTS
Laptop Toshiba Tecra  (80GB) 2 GB ram Fedora 24
Dell Latitude D600 Pentium M 1400MHz 512MB ram
Bouwjaar 2003 met Debian 8 (Jessie)

Offline Support4u

  • Lid
  • Steunpunt: Nee
Ik heb niks gedaan, het is een verse installatie + nvidia driver

Maar dit heeft toch verder niks te maken met wat Gr8Jen me probeert te laten doen?

Offline Gr8Jen

  • Lid
  • Steunpunt: Nee
die output van jou laat zien welke modes momenteel ondersteund worden.

aangezien jij wel een aparte videokaart hebt is het misschien "minder moeilijk" om de juiste resolutie weer te geven.

met het volgende commando kun je kijken hoe de instellingen zijn voor je driver:
(niet als superuser inloggen zodat je ook niets kan wijzigen en mischien iets verpesten)

nano /etc/X11/xorg.conf
als deze bestaat zok dan naar section "screen" en kijk welke modes daarin vermeld staan
misschien staat 1366x768 niet als eerste vermeld waardoor dit niet meteen bij opstarten  van X (video) geselecteerd wordt

Section "Screen"
       Identifier      "Default Screen"
       Device          "geforce256"
       Monitor         "S/M 950p"
       DefaultDepth    24
       SubSection "Display"
               Depth           8
               Modes           "1600x1200" "1280x1024" "1024x768" "800x600" "640x480"
       EndSubSection
       SubSection "Display"
               Depth           16
               Modes           "1600x1200" "1280x1024" "1024x768" "800x600" "640x480"
       EndSubSection
       SubSection "Display"
               Depth           24
               Modes           "1600x1200" "1280x1024" "1024x768" "800x600" "640x480"
       EndSubSection
EndSection

graag even kopiƫren en plakken zodat we kunnen zien wat er staat

Offline Support4u

  • Lid
  • Steunpunt: Nee
gedit  /etc/X11/xorg.conf,

Section "Screen"
   Identifier   "Default Screen"
   DefaultDepth   24
EndSection

Section "Module"
   Load   "glx"
EndSection

Section "Device"
   Identifier   "Default Device"
   Driver   "nvidia"
   Option   "NoLogo"   "True"
EndSection


Alstublieft, wat nu?

Offline Gr8Jen

  • Lid
  • Steunpunt: Nee
inloggen als superuser met sudo su

en verander section screen in "Default Screen"


Section "Screen"
   Identifier   "Default Screen"
   DefaultDepth   24
   SubSection "Display"
          Depth      24
          Modes      "1366x768" "1024x768" "800x600" "640x480"
   EndSubSection
EndSection

en bevestigen dat je het wil veranderen zodat het wordt opgeslagen.

zodra X gestart wordt moet deze dan meteen in 1366 bij 768 opstarten en die wordt gestart als het opstartscherm begint.

Offline Support4u

  • Lid
  • Steunpunt: Nee
 :'( :(


Section "Screen"
   Identifier   "Default Screen"
   DefaultDepth   24
    SubSection "Display"
          Depth      24
          Modes      "1366x768" "1024x768" "800x600" "640x480"
   EndSubSection
EndSection

Section "Module"
   Load   "glx"
EndSection

Section "Device"
   Identifier   "Default Device"
   Driver   "nvidia"
   Option   "NoLogo"   "True"
EndSection


rebootx
and manual reboot, Loading screens are still ugly and stretched.. ( cry )

Offline Gr8Jen

  • Lid
  • Steunpunt: Nee
ok dan moeten nu de echte goeroes aan de slag. XD

mijn goocheldoos is leeg. tot nu heeft het altijd gewerkt bij mij dus weet niets anders om het op te lossen. :(

Offline Support4u

  • Lid
  • Steunpunt: Nee
naja in iedergeval erg bedankt voor de moeite!

goeroes come and get me! 

:o

Offline Support4u

  • Lid
  • Steunpunt: Nee
http://news.softpedia.com/news/How-to-Fix-the-Big-and-Ugly-Plymouth-Logo-in-Ubuntu-10-04-140810.shtml

De link hierboven ziet er veel belovend uit! Ik moet alleen wachten tot ik thuis ben om het uit te proberen. Maar ik denk dat dit DE oplossing is voor mijn probleem! dus ik wacht nog even met dit topic te sluiten.


Offline Gr8Jen

  • Lid
  • Steunpunt: Nee
ziet er goed uit.

waarschijnlijk is het inderdaad zo opgelost omdat de afbeelding die wordt gebruikt voor splash screen misschien ook 1024x76 is. succes nog ermee