Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: UFW aan, inloggen via SSH heel traag!  (gelezen 2318 keer)

Offline RogierVLD

  • Lid
  • Steunpunt: Nee
UFW aan, inloggen via SSH heel traag!
« Gepost op: 2010/07/09, 10:40:53 »
Hoi,

Ik ben bezig een V-Server aan het inrichten en tot dus ver lukt het allemaal aardig.
Nu heb ik de firewall aangezet, eerst natuurlijk een joekel van een blunder gemaakt.

UFW Enable, en dus niet even een regel toegevoegd dat ik wel op SSH mocht inloggen....

Anyway, herstelt, nu wel een paar regels toegevoegd maar ik doe denk ik iets verkeerd.
Als ik via Putty, een verbinding wil maken met de server zit er ineens heel veel tijd tussen de gebruikersnaam en het wachtwoord. Vervolgens kom je er wel in.
Als je dan sudo apt-get update intoetsts krijg je een hele reeks foutmeldingen. Hij kan de servers met de update bestanden niet vinden.

De volgende regels heb ik aan de Firewall toegevoegd:

ufw allow from <thuis ip adres>
ufw allow from <kantoor ip adres>
ufw allow from 127.0.0.1
ufw enable

Met deze configuratie kan ik wel de webserver goed werkend zien, Mysql die eraan gekoppeld is werkt ook, maar andere dingen gaan dus lastiger.
Als ik klaar ben met testen voeg ik nog een regel toe dat iedereen naar poort 80 mag.
Ik dacht, door de 127.0.0.1 regel toe toe voegen dat je alles hebt gevangen wat op de computer zelf gebeurd.

Wat doe ik fout?

Alvast bedankt
Greetings,

Rogier



Offline Dooitze de Jong

  • Lid
    • dooitze
    • Dooitze de Jong
  • Steunpunt: Nee
Re: UFW aan, inloggen via SSH heel traag!
« Reactie #1 Gepost op: 2010/07/09, 11:29:31 »
Waarschijnlijk heb je bij het inschakelen van UFW ook het blokkeren van uitgaande verbindingen geblokkeerd
Linux User : 491909
Ubuntu User: 2928
Word geen 100 % Offtopic-spammer, maar help ook eens anderen!
[size=10]Soms plaats ik berichten met mijn pda, dus er kunnen spellingsfouten in zitten[/size]

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
Re: UFW aan, inloggen via SSH heel traag!
« Reactie #2 Gepost op: 2010/07/09, 18:18:15 »
Wat zegt het commando: sudo ufw status verbose
En zie je ook meldingen van de firewall in je logbestanden?
Bijvoorbeeld met dit commando: grep '\[UFW' /var/log/messages

Offline RogierVLD

  • Lid
  • Steunpunt: Nee
Re: UFW aan, inloggen via SSH heel traag!
« Reactie #3 Gepost op: 2010/07/12, 18:53:32 »
Hoi,

Er staan geen LOG meldingen. Als ik loggen aanzet krijg ik, net als wanneer ik de firewall aanzet:
ERROR: problem running init script

Welke regel zou ik moeten toevoegen om het uitaande verkeer toe te staan? Nu gaat er duidelijk iets verkeerd. WinSCP werkt niet en in SSH zit een enorme vertraging bij het inloggen.

Als ik toch de fout aan het zoeken ben. Hoe kan ik die init script opsporen? Als ik de computer reboot wordt de firewall wel geladen. Bepaalde regels lijken effect te hebben: webserver of ssh blokken of niet. Je merkt het meteen als je er niet in komt.

Alvast bedankt.

Rogier

Offline RogierVLD

  • Lid
  • Steunpunt: Nee
Re: UFW aan, inloggen via SSH heel traag!
« Reactie #4 Gepost op: 2010/07/12, 19:14:01 »
Nog verder wat info. Het lijkt erop dat niet alles goed staat geinstalleerd. Ik heb echter al een uninstall en een nieuwe install gedaan:



sudo /etc/init.d/ufw force-reload
 * Stopping firewall: ufw...                                                                                                                                     [ OK ]
 * Starting firewall: ufw...                                                                                                                                            /etc/init.d/ufw: line 45: modprobe: command not found
/etc/init.d/ufw: line 45: modprobe: command not found
/etc/init.d/ufw: line 45: modprobe: command not found
/etc/init.d/ufw: line 45: modprobe: command not found
iptables-restore: line 71 failed
 * Problem running '/etc/ufw/before.rules'...                                                                                                                           error: "Operation not permitted" setting key "net.ipv6.conf.all.accept_redirects"
error: "Operation not permitted" setting key "net.ipv6.conf.default.accept_redirects"
error: "Operation not permitted" setting key "net.ipv4.icmp_echo_ignore_broadcasts"
error: "Operation not permitted" setting key "net.ipv4.icmp_echo_ignore_all"
error: "Operation not permitted" setting key "net.ipv4.icmp_ignore_bogus_error_responses"
error: "Operation not permitted" setting key "net.ipv4.tcp_syncookies"
error: "Operation not permitted" setting key "net.ipv4.tcp_sack"
                                                                                                                                                                 [fail]
Rogier

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
Re: UFW aan, inloggen via SSH heel traag!
« Reactie #5 Gepost op: 2010/07/12, 19:58:12 »
Welke versie van Ubuntu draai je?
Wat zegt het commando "which modprobe"?
Nogmaals: wat zegt "sudo ufw status verbose"?.
Welke pakketten heb je verwijderd en opnieuw geïnstalleerd, en hoe heb je dat gedaan?
Beantwoord alle vragen aub, anders moet ik ze nog een keer stellen en duurt het alleen maar langer voordat de oplossing gevonden is.

Verder zou je niet meer de commando's met /etc/init.d/ufw moeten gebruiken, maar "sudo start ufw", "sudo restart ufw" enz.

Welke regels je zou moeten toevoegen of verwijderen hangt helemaal af van de regels die er nu al in staan, en de andere algemene instellingen voor ufw.

Offline RogierVLD

  • Lid
  • Steunpunt: Nee
Re: UFW aan, inloggen via SSH heel traag!
« Reactie #6 Gepost op: 2010/07/12, 22:28:11 »
Hoi,

Bedankt voor de antwoorden. Op internet kon ik wat dingen vinden die met de kernel te maken hadden.
Ik ben een Linux beginner. Mijn Excuses voor eventuele domheid van mijn kant.

sudo ufw status verbose

rogier@h1751090:~$ sudo ufw status verbose
Firewall loaded

To                         Action  From
--                         ------  ----
Anywhere                   ALLOW   62.163.xx.xxx
Anywhere                   ALLOW   79.143.xxx.xx
Anywhere                   ALLOW   127.0.0.1
Anywhere                   ALLOW   192.168.0.1
22:tcp                     ALLOW   Anywhere
22:udp                     ALLOW   Anywhere

which modprobe , zegt niets, ook niet met sudo ervoor.

Versie Ubuntu:

rogier@h1751090:~$ cat /etc/lsb-release
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=8.04
DISTRIB_CODENAME=hardy
DISTRIB_DESCRIPTION="Ubuntu 8.04.4 LTS"

Let op! Via Strato geinstalleerd op virtuele server.

grep '\[UFW' /var/log/messages, staat niets. Logging krijg ik volgens mij ook niet aan... als ik sudo ufw logging on intoets.


sudo /etc/init.d/ufw start (sudo start ufw, werkt niet)
 * Starting firewall: ufw...                                                                          /etc/init.d/ufw: line 45: modprobe: command not found
/etc/init.d/ufw: line 45: modprobe: command not found
/etc/init.d/ufw: line 45: modprobe: command not found
/etc/init.d/ufw: line 45: modprobe: command not found
iptables-restore: line 71 failed
 * Problem running '/etc/ufw/before.rules'...                                                         error: "Operation not permitted" setting key "net.ipv6.conf.all.accept_redirects"
error: "Operation not permitted" setting key "net.ipv6.conf.default.accept_redirects"
error: "Operation not permitted" setting key "net.ipv4.icmp_echo_ignore_broadcasts"
error: "Operation not permitted" setting key "net.ipv4.icmp_echo_ignore_all"
error: "Operation not permitted" setting key "net.ipv4.icmp_ignore_bogus_error_responses"
error: "Operation not permitted" setting key "net.ipv4.tcp_syncookies"
error: "Operation not permitted" setting key "net.ipv4.tcp_sack"
                                                                                               [fail]

Moet ik misschien als Root inloggen? Nu gebruik ik een users, met root rechten via SUDO.

Op internet las ik wat zaken dat de kernel niet up to date zou zijn. Zoiets.

Alvast bedankt!
En wat log bestanden betreft? In welk bestand moet ik zoeken?

Rogier

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
Re: UFW aan, inloggen via SSH heel traag!
« Reactie #7 Gepost op: 2010/07/12, 23:29:20 »
8.04 is wel een oudere versie, vandaar dat UFW een aantal dingen nog niet ondersteunt.
En blijkbaar is het ook nog eens een niet-standaard installatie, of staan er wat dingen fout.
Dat het een virtuele machine is zou ook nog mee kunnen spelen.

Krijg je als je als root inlogt hetzelfde resultaat bij deze commando's?
Wel sudo weglaten in dit geval.

Het feit dat hij het modprobe commando niet kan vinden is wel vreemd. Het is ook een waarschijnlijke oorzaak van je probleem. Want hierdoor kan UFW niet compleet opstarten en werkt het niet zoals zou moeten.

Verder moet je voor vragen bij Strato zijn denk ik, want zij hebben de server opgezet.

Offline testcees

  • Documentatieteam
    • testcees
    • www.testcees.nl
  • Steunpunt: Nee
Re: UFW aan, inloggen via SSH heel traag!
« Reactie #8 Gepost op: 2010/07/12, 23:58:19 »
Krijg je als je als root inlogt hetzelfde resultaat bij deze commando's?
Wel sudo weglaten in dit geval.
Voor de duidelijkheid, met
sudo -i
kan je als root "inloggen".
`Wie wil de Nederlandstalige Ubuntu documentatie wiki onderhouden? https://wiki.ubuntu-nl.org

Offline RogierVLD

  • Lid
  • Steunpunt: Nee
Re: UFW aan, inloggen via SSH heel traag!
« Reactie #9 Gepost op: 2010/07/14, 10:54:30 »
Ha,

Bedankt voor de antwoorden.

Ik heb modprobe geinstalleerd, maar de foutmeldingen blijven muv de modprobe foutmelding.
Strato gebeld, maar ze bieden geen support. En ja, ik weet, ze zijn goedkoop, dus....

Ik geef het op met UFW. Het frustrerende is dat het thuis gewoon werkt op een Virtual machine (die ik met de standaard Ubuntu ISO heb geinstalleerd).

Bedankt voor de antwoorden in ieder geval. Ik beschouw dit maar als Ubuntu voor gevorderden.
Ik ga nu Shorewall proberen.

Ik wil alleen maar poort 80 openzetten, SSH op 2 IP adressen openzetten. Verder maak ik met een SSH tunnel contact met de computer naar MySQL. Deze moet dan volgens mij op de Localhost openstaan.
Is Shorewall aan te raden?

Rogier

p.s. Voor de rest gaat het installeren van een webserver eigenlijk heel goed en vind ik Ubuntu echt heel mooi en krachtig!