Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Verlies CUPS in Lucid  (gelezen 1292 keer)

Offline MKe

  • Lid
  • Steunpunt: Nee
Verlies CUPS in Lucid
« Gepost op: 2010/07/05, 20:39:44 »
Ik heb aan mijn Ubuntu 10.04 bak een oude laserjet 1100 hangen. Deze printer doet het nog zeer goed. Ik gebruik hem niet zo vaak, maar het valt mij op dat als ik hem wil gebruiken, Ubuntu de printer vaak kwijt is. Ik heb dan alleen de keuze van de 'generic' printer, wat dus niet werkt. Ik heb ontdekt dat als ik het pakket cups herinstalleer in synaptic, de printer gewoon weer herkent wordt onder de naam die ik het had gegeven en de printer ook weer prima afdrukt. Bij herstart doet de printer het dan ook gewoon weer. Ik weet niet wanneer en hoe Ubuntu de printer kwijt raakt aangezien het vaak enkele weken duurt voordat ik hem weer gebruik. Ik vermoed dat het gebeurt bij de een-of-ander update. Bij Karmic had ik hier echter geen last van. Hebben meer mensen dit probleem en weet iemand hoe het komt?

Offline timosha

  • Lid
  • Steunpunt: Nee
Re: Verlies CUPS in Lucid
« Reactie #1 Gepost op: 2010/07/06, 08:46:07 »
Geef in een terminal eens het volgende commando in:

sudo apt-get install dpkg --reinstall
Stabiele OS: Solaris 10 - OS X 10.6.4 - Linux Mint 9 - Windows 7
Project OS: Linux Mint 9 Isadora
Test OS: Ubuntu 10.04 - 10.10
Server: Windows Server 2008 R2 - Exchange 2010

Contra verbosos noli contendere verbis: sermo datur cunctis, animi sapientia paucis.


Offline vanadium

  • Lid
  • Steunpunt: Nee
Re: Verlies CUPS in Lucid
« Reactie #2 Gepost op: 2010/07/06, 09:37:04 »
Je hebt wellicht te maken met de bug die ik ook heb vastgesteld op een Packard Bell computer enkele dagen geleden: cups start niet (steeds) op. Ongelofelijk voor een long term release, maar waar. Hier heb ik aangegeven hoe ik dat heb opgelapt: http://forum.ubuntu-nl.org/software-en-configuratie/cups-server-eenvoudiger-activeren-(10-04)/msg621121/#msg621121
Je vindt daar ook andere mogelijkheden: aan jou de keuze.

Blijkt van de computer af te hangen: op twee andere laptopjes (waaronder de mijne) geen probleem.

Offline mrGee

  • Lid
  • Steunpunt: Nee
Re: Verlies CUPS in Lucid
« Reactie #3 Gepost op: 2010/07/06, 10:01:42 »
Hallo

Zelfde gebeurt mij ook af en toe op mijn Asus p6t icm. 64 bit ubuntu.
Opvallend is dat dan de cups server niet draait en ook mijn Virtualbox
dan dienst weigert, pas bij herstart van respectievelijk cups en vboxdrv
loopt de zaak weer.
Dit gebeurt dus af en toe. Ik heb het regeltje er ook maar ingezet

Groeten Gerrit
-- = >  simplify if you can   -- = >

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
Re: Verlies CUPS in Lucid
« Reactie #4 Gepost op: 2010/07/06, 10:24:31 »
Je hebt wellicht te maken met de bug die ik ook heb vastgesteld op een Packard Bell computer enkele dagen geleden: cups start niet (steeds) op. Ongelofelijk voor een long term release, maar waar. Hier heb ik aangegeven hoe ik dat heb opgelapt: http://forum.ubuntu-nl.org/software-en-configuratie/cups-server-eenvoudiger-activeren-(10-04)/msg621121/#msg621121
Je vindt daar ook andere mogelijkheden: aan jou de keuze.

Blijkt van de computer af te hangen: op twee andere laptopjes (waaronder de mijne) geen probleem.

Heel vervelend. Is er al een foutmelding van op Launchpad? Zo ja, dan zou ik daar graag de koppeling van willen hebben. Alvast bedankt.  :)

Offline ruujan

  • Lid
  • Steunpunt: Nee
Re: Verlies CUPS in Lucid
« Reactie #5 Gepost op: 2010/07/06, 10:58:59 »
Bij mijn laptop gebeurt hetzelfde. Na het opstarten komt WICD met de vraag dat er een wachtwoord nodig is voor toegang tot de netwerkkaarten en vervolgens blijkt CUPS ook niet te draaien, al is het netwerk dan gewoon in de lucht. Na een herstart is alles weer normaal. Ik ben er al eens op aan het zoeken geweest en het probleem leek te zitten in de overgang naar upstart. Ik kon in ieder geval geen goede oplossing vinden toen.

Offline MKe

  • Lid
  • Steunpunt: Nee
Re: Verlies CUPS in Lucid
« Reactie #6 Gepost op: 2010/07/06, 19:19:10 »
Bedankt, ik ga de mogelijkheden proberen. Vandaag deed ie het weer niet.


Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
Re: Verlies CUPS in Lucid
« Reactie #8 Gepost op: 2010/07/06, 21:40:28 »
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/554172

Dank.  :)

De zaak is inmiddels bekend bij Till Kamppeter, zie ik, want hij heeft het belang op Critical gezet.... Dat is een vooraanstaande ontwikkelaar, dus dat komt binnenkort wel goed, verwacht ik.

Offline vanadium

  • Lid
  • Steunpunt: Nee
Re: Verlies CUPS in Lucid
« Reactie #9 Gepost op: 2010/07/06, 21:47:35 »
Dit is dan ook een kemel van een bug. Dergelijke kanjers zouden het nooit mogen maken in een final release. Het moet toch ook weer met hardware te maken hebben, want niet alle systemen hebben er last van.

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
Re: Verlies CUPS in Lucid
« Reactie #10 Gepost op: 2010/07/06, 22:34:32 »
Dit is dan ook een kemel van een bug. Dergelijke kanjers zouden het nooit mogen maken in een final release. Het moet toch ook weer met hardware te maken hebben, want niet alle systemen hebben er last van.

Sh*t happens.  :)

Offline MKe

  • Lid
  • Steunpunt: Nee
Re: Verlies CUPS in Lucid
« Reactie #11 Gepost op: 2010/07/07, 06:35:40 »
Ik heb vanadium's oplossing geprobeerd en die van Timosha. Maar hij was de printer weer kwijt vanochtend :(

Offline vanadium

  • Lid
  • Steunpunt: Nee
Re: Verlies CUPS in Lucid
« Reactie #12 Gepost op: 2010/07/07, 09:13:06 »
En zou het helpen de wait time in mijn oplossing met 5 seconden te verhogen?

Iets wat wel werkt, is cups op te starten via System - Preferences - Startup applications. Dan moet je echter telkens je paswoord ingeven omdat je dat met sudo moet doen. In launchpad staat dan aangegeven hoe je vooralsnog dat paswoord kan elimineren:

sudo visudoop het einde toevoegen:
username ALL=NOPASSWD: /usr/bin/service
(met jou gebruikersnaam in de plaats van username).