Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: XWindows, i810 en terugschakelen naar console  (gelezen 551 keer)

linuxbak

  • Gast
XWindows, i810 en terugschakelen naar console
« Gepost op: 2006/12/08, 12:08:44 »
Hallo,

Ik heb een dell optiflex gx110 waarop ik Ubuntu 6.10 geinstalleerd heb. Deze heeft een onboard videokaart en wel de Intel i810. Na het starten van XWindows wil ik terugschakelen naar de consolemodus via b.v. Ctrl+Alt+F1. Echter men krijgt geen normaal textbeeld maar een snelbewegend beeld van gekleurde blokken. Start ik Ubuntu in de recoverymode op dan treedt dit probleem niet op. Het verschil is waarschijnlijk het normale grafische startscherm (met de progressiebar) die de videokaart in een bepaalde mode brengt waaruit hij standaard niet meer komt. Ik heb al het volgende geprobeerd om de boel te herstellen echter zonder succes:
Toevoegen Option InitPrimary aan section serverflags in /etc/X11/xorg.conf: Primair beeldscherm initialiseren voor opstarten X
Toevoegen Option Option VBERestore aan section Device in /etc/X11/xorg.conf: Herstellen tekstmodus voor de i810
Als alternatief denk ik aan het uitschakelen van de grafische startmodus maar ik moet nog uitzoeken hoe.
Weet iemand een alternatief?
Bestaat er een commando in de console om de textmodus te herstellen.

Groet,

Roy

Offline Kiwinote

  • Lid
    • Launchpad
  • Steunpunt: Nee
XWindows, i810 en terugschakelen naar console
« Reactie #1 Gepost op: 2006/12/08, 13:32:19 »
Start eens een console, of recovery mode en typ hetvolgend commando in:
sudo dpkg-reconfigure xserver-xorgKies voor een vesa driver, maar laat de rest allemaal bij de standaard instellingen

linuxbak

  • Gast
XWindows, i810 en terugschakelen naar console
« Reactie #2 Gepost op: 2006/12/08, 14:35:32 »
Helaas was dit eerst de gevonden standaardinstelling en daarmee trad het probleem ook al op. Hetzelfde effect treed al op voor inschakeling van X. Dus tussen het startvoortgangsscherm en het inschakelen van X komt even tussendoor ook een flikkerend scherm met blokken gelijkend het scherm dat later verkregen wordt door b.v. Ctrl+Alt+F1 te drukken. Het probleem zit dus al voor het inschakelen van X. Aangezien debian een vervanger heeft genomen voor sysvinit genaamd upstart vermoed ik dat hier het probleem zit. Want bij het opstarten in de recovery mode is het startvoortgangsscherm niet zichtbaar. Indien men vervolgens X opstart (door de recovery mode af te sluiten met exit) is het terugschakelen naar de console mode geen probleem.
Ik heb nog een keer geprobeerd het scherm in de vesa mode te zetten maar hierbij loopt X nu vast.

linuxbak

  • Gast
XWindows, i810 en terugschakelen naar console
« Reactie #3 Gepost op: 2006/12/12, 14:54:50 »
Ik heb een workaround/omweg gevonden waarmee het wel normaal werkt. Zie:

http://ubuntu.wordpress.com/2006/02/20/restoring-the-ubuntu-usplash-after-a-kubuntu-install/

De oplossing is in grub de normale bootopties veranderen zodat het splashscherm niet getoond wordt. Dit doe je door in /boot/grub/menu.lst

kernel /vmlinuz-2.6.17-10-generic root=/dev/mapper/Ubuntu-root ro quiet splash

te veranderen in:

kernel /vmlinuz-2.6.17-10-generic root=/dev/mapper/Ubuntu-root ro

Hiermee wordt het opstartscherm/splashscherm niet getoond en werkt het na de start in ieder geval goed. Er gebeurt in het opstartscherm(usplash?)  inderdaad iets waardoor de i810 van slag raakt.