Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: [OPGELOST] na upgrade naar 1004 werkt dual boot niet meer  (gelezen 2370 keer)

Offline davesontheroad

  • Lid
  • Steunpunt: Nee
[OPGELOST] na upgrade naar 1004 werkt dual boot niet meer
« Gepost op: 2010/06/20, 23:06:40 »
na een upgrade naar 10.04 werkt mijn dual boot niet meer. heeft altijd gewerkt onder 09.04.
als ik nu in het menu kies voor XP dan start toch ubuntu weer op.


heb al sudo update-grub gedaan en dit is het resultaat. wat is hier aan de hand.
heb al gezocht op forum maar als enige oplossing lees ik vaak sudo update-grub. help

Generating grub.cfg ...
Found linux image: /boot/vmlinuz-2.6.32-22-generic
Found initrd image: /boot/initrd.img-2.6.32-22-generic
Found linux image: /boot/vmlinuz-2.6.31-22-generic
Found initrd image: /boot/initrd.img-2.6.31-22-generic
Found memtest86+ image: /boot/memtest86+.bin
Found Microsoft Windows XP Professional on /dev/sda1
done
« Laatst bewerkt op: 2010/07/05, 15:56:03 door davesontheroad »

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Re: na upgrade naar 1004 werkt dual boot niet meer
« Reactie #1 Gepost op: 2010/06/20, 23:37:32 »
Probeer eens deze commando's
sudo os-prober        <---- Hiermee wordt gekeken welke besturingssystemen er zijn

sudo update-grub     <---- En hier schrijf je het weg in Grub

Even opnieuw starten en je zou weer moeten kunnen kiezen.
In der Beschränkung zeigt sich der Meister.

Offline davesontheroad

  • Lid
  • Steunpunt: Nee
Re: na upgrade naar 1004 werkt dual boot niet meer
« Reactie #2 Gepost op: 2010/06/24, 18:40:29 »
helaas nog geen tijd gehad, maar zodra ik meer weet, dan post ik het

Probeer eens deze commando's
sudo os-prober        <---- Hiermee wordt gekeken welke besturingssystemen er zijn

sudo update-grub     <---- En hier schrijf je het weg in Grub

Even opnieuw starten en je zou weer moeten kunnen kiezen.

Offline davesontheroad

  • Lid
  • Steunpunt: Nee
Re: na upgrade naar 1004 werkt dual boot niet meer
« Reactie #3 Gepost op: 2010/06/25, 20:00:44 »
helaas nog geen tijd gehad, maar zodra ik meer weet, dan post ik het

Probeer eens deze commando's
sudo os-prober        <---- Hiermee wordt gekeken welke besturingssystemen er zijn

sudo update-grub     <---- En hier schrijf je het weg in Grub

Even opnieuw starten en je zou weer moeten kunnen kiezen.

met sudo os-prober krijg ik het volgende:
[sudo] password for dave:
/dev/sda1:Microsoft Windows XP Professional:Windows:chain
dave@dave-desktop:~$
hierna sudo update-grub:
dave@dave-desktop:~$ sudo update-grub
Generating grub.cfg ...
Found linux image: /boot/vmlinuz-2.6.32-22-generic
Found initrd image: /boot/initrd.img-2.6.32-22-generic
Found linux image: /boot/vmlinuz-2.6.31-22-generic
Found initrd image: /boot/initrd.img-2.6.31-22-generic
Found memtest86+ image: /boot/memtest86+.bin
Found Microsoft Windows XP Professional on /dev/sda1
done

toch kom ik niet in xp?? na restart kies ik voor xp en toch start ubuntu weer op.
iemand een idee

« Laatst bewerkt op: 2010/06/25, 20:04:09 door davesontheroad »

Offline donpedroII

  • Lid
  • Steunpunt: Nee
Re: na upgrade naar 1004 werkt dual boot niet meer
« Reactie #4 Gepost op: 2010/06/26, 01:30:18 »
Voer eens het volgende commando uit in de Terminal en plaats de output hier eens.
sudo blkidensudo fdisk -l
Begrijp dat je dus wel je Grub menu krijgt met de selectie mogelijkheden.
Als dit menu in beeld is, selecteer dan eerst eens je Ubuntu versie en druk hierna op de 'e', noteer deze gegevens eens.
Doe dit ook voor de Windows selectie.

Post de volledige gegevens voor elke selectie hier eens.
De opbouw van de grub.cfg is in zijn geheel script gedreven, maar het lijkt erop dat er een verkeede verwijzing wordt aangemaakt voor je loader.

Offline davesontheroad

  • Lid
  • Steunpunt: Nee
Re: na upgrade naar 1004 werkt dual boot niet meer
« Reactie #5 Gepost op: 2010/06/28, 12:41:08 »
als ik ubuntu kies en op e druk krijg ik het volgende:

gnu grub versie 1.98-1ubuntu6

recordfail
insmod ext 2
set root= '(hdo,5)'
search --no-floppy --fs--uuid -set f2b522fa-638-4f53-9b11-b1d3a376f/ 38f
linux (boot)vmlinuz-2.6.32-22-generic root=uuid=f2b522fa-638f-4f53-9/b11-bcd3a376f38f ro quit splash
initrd /boot/initrd.img -2.6.32.22-generic

als ik xp kies:

insmod ntfs
set root= '(hdo, 1)'
search --n-floppy--fs--uuid--set 58fc900afc88e39a
drivemap -s (hd0) $(root)
chainloader +1

ik hoop dat je hiermee uit kunt komen donpedro, dit is te technisch voor mij.
vast bedankt dat je ernaar wil kijken.

sudo blkid geeft het volgende:
/dev/sda1: UUID="58FC890AFC88E39A" TYPE="ntfs"
/dev/sda5: UUID="f2b522fa-638f-4f53-9b11-bcd3a376f38f" TYPE="ext4"
/dev/sda6: UUID="2aa465fc-d976-4c67-8b6e-d7f747ffc688" TYPE="swap"
/dev/sdb1: LABEL="MY BOOK" UUID="F66CBE346CBDF00B" TYPE="ntfs"
dave@dave-desktop:~$

sudo fdisk -l geeft het volgende:

dave@dave-desktop:~$ sudo fdisk -l

Schijf /dev/sda: 120.0 GB, 120034123776 bytes
255 koppen, 63 sectoren/spoor, 14593 cilinders
Eenheid = cilinders van 16065 * 512 = 8225280 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Schijf-ID: 0xf54cf54c

 Apparaat Opstart   Begin       Einde     Blokken   ID  Systeem
/dev/sda1   *           1        8400    67472968+   7  HPFS/NTFS
/dev/sda2            8401       14593    49745272+   5  Uitgebreid
/dev/sda5            8401       14334    47664823+  83  Linux
/dev/sda6           14335       14593     2080386   82  Linux wisselgeheugen

Schijf /dev/sdb: 1000.2 GB, 1000204886016 bytes
255 koppen, 63 sectoren/spoor, 121601 cilinders
Eenheid = cilinders van 16065 * 512 = 8225280 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Schijf-ID: 0xe8900690

 Apparaat Opstart   Begin       Einde     Blokken   ID  Systeem
/dev/sdb1               1      119560   960365668+   7  HPFS/NTFS
dave@dave-desktop:~$


« Laatst bewerkt op: 2010/06/28, 12:45:19 door davesontheroad »

Offline donpedroII

  • Lid
  • Steunpunt: Nee
Re: na upgrade naar 1004 werkt dual boot niet meer
« Reactie #6 Gepost op: 2010/06/28, 23:26:56 »
Ben wel even aan het spitten, maar een echte oplossing niet gevonden.
De uitwerking van jou probleem lijkt het meest op dat men na selectie een zwart scherm krijgt.
Maar dat krijg je niet.

De verwijzingen in je Grub lijken te kloppen, dus op 1 of andere manier is er een error.
Mijn vermoeden is dat er in de bootsector van je Windows XP iets niet in orde is.

Je schrijft dat je van 9.04 naar 10.04 bent gegaan?
Dus ben je van Grub 0.97 naar Grub2 1.98 overgegaan, zonder dat je het eigenlijk in de gaten had.
Denk dat het daar ook wel eens iets mee van doen kan hebben.

Waar ik wel eens benieuwd naar ben, en daar is een goed script voor boot_info_script.
Met dat betreffende scirpt, kunnen we wat beter in detail bekijken wie wat waar naar kijkt.

Lees deze link eens door :
http://ubuntuforums.org/showthread.php?t=1291280

En wat ik dan eigenlijk wil zien, maar de rest denk ik ook in het resultaat ergens
sda1: ___________________________________________
    File system:       ntfs
    Boot sector type:  Windows XP
    Boot sector info:  No errors found in the Boot Parameter Block.
    Operating System:  Windows XP
    Boot files/dirs:   /boot.ini /ntldr /NTDETECT.COM


In vergelijk hier bij mij voor Ubuntu 10.04 LTS en Windows XP
sdb1: _________________________________________________________________________

    File system:       ntfs
    Boot sector type:  Windows XP
    Boot sector info:  No errors found in the Boot Parameter Block.
    Operating System:  Windows XP
    Boot files/dirs:   /boot.ini /ntldr /NTDETECT.COM

sdb2: _________________________________________________________________________

    File system:       reiserfs
    Boot sector type:  -
    Boot sector info: 
    Operating System:  Ubuntu 10.04 LTS
    Boot files/dirs:   /boot/grub/menu.lst /boot/grub/grub.cfg /etc/fstab
                       /boot/grub/core.img
« Laatst bewerkt op: 2010/06/28, 23:28:49 door donpedroII »

Offline davesontheroad

  • Lid
  • Steunpunt: Nee
Re: na upgrade naar 1004 werkt dual boot niet meer
« Reactie #7 Gepost op: 2010/06/28, 23:57:17 »
Don,
ik heb de link even snel gelezen, dit gaat boven mijn pet.
maar ik zal het uitvoeren en het resultaat posten, geduld...


Offline donpedroII

  • Lid
  • Steunpunt: Nee
Re: na upgrade naar 1004 werkt dual boot niet meer
« Reactie #8 Gepost op: 2010/06/29, 09:34:07 »
Het is niet al te complex.
Download Boot script info en sla deze op op je buroblad (Desktop).

Daarna open je je terminal en type hier het volgendesudo bash ~/Desktop/boot_info_script055.shGeeft een <ENTER> dan je paswoord (niet zichtbaar) en wederom <ENTER>

Dan flitst er wat details over je terminalscherm (voorbeeld)
Identifying MBRs...
Computing Partition Table of /dev/sda...
Computing Partition Table of /dev/sdb...
Computing Partition Table of /dev/sdc...
Searching sda1 for information...
Searching sda2 for information...
Searching sdb1 for information...
Searching sdc1 for information...
Searching sdc2 for information...
Searching sdc3 for information...
Searching sdc4 for information...
Finished. The results are in the file RESULTS.txt located in /home/<username>/Desktop

En levert een RESULTS.txt file op je Desktop.

Offline davesontheroad

  • Lid
  • Steunpunt: Nee
Re: na upgrade naar 1004 werkt dual boot niet meer
« Reactie #9 Gepost op: 2010/06/29, 23:14:12 »
Don, hier komt ie:
                Boot Info Script 0.55    dated February 15th, 2010                   

============================= Boot Info Summary: ==============================

 => Grub 2 is installed in the MBR of /dev/sda and looks on the same drive in
    partition #5 for /boot/grub.
 => Grub 2 is installed in the MBR of /dev/sdb and looks on the same drive in
    partition #5 for /boot/grub.

sda1: _________________________________________________________________________

    File system:       ntfs
    Boot sector type:  Grub 2
    Boot sector info:  Grub 2 is installed in the boot sector of sda1 and
                       looks at sector 135240655 of the same hard drive for
                       core.img, but core.img can not be found at this
                       location. No errors found in the Boot Parameter Block.
    Operating System:  Windows XP
    Boot files/dirs:   /boot.ini /ntldr /NTDETECT.COM

sda2: _________________________________________________________________________

    File system:       Extended Partition
    Boot sector type:  -
    Boot sector info: 

sda5: _________________________________________________________________________

    File system:       ext4
    Boot sector type:  -
    Boot sector info: 
    Operating System:  Ubuntu 10.04 LTS
    Boot files/dirs:   /boot/grub/grub.cfg /etc/fstab /boot/grub/core.img

sda6: _________________________________________________________________________

    File system:       swap
    Boot sector type:  -
    Boot sector info: 

sdb1: _________________________________________________________________________

    File system:       ntfs
    Boot sector type:  Grub 2
    Boot sector info:  Grub 2 is installed in the boot sector of sdb1 and
                       looks at sector 135224527 of the same hard drive for
                       core.img, but core.img can not be found at this
                       location. No errors found in the Boot Parameter Block.
    Operating System: 
    Boot files/dirs:   

=========================== Drive/Partition Info: =============================

Drive: sda ___________________ _____________________________________________________

Schijf /dev/sda: 120.0 GB, 120034123776 bytes
255 koppen, 63 sectoren/spoor, 14593 cilinders, totaal 234441648 sectoren
Eenheid = sectoren van 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes

Partition  Boot         Start           End          Size  Id System

/dev/sda1    *             63   134,945,999   134,945,937   7 HPFS/NTFS
/dev/sda2         134,946,000   234,436,544    99,490,545   5 Extended
/dev/sda5         134,946,063   230,275,709    95,329,647  83 Linux
/dev/sda6         230,275,773   234,436,544     4,160,772  82 Linux swap / Solaris


Drive: sdb ___________________ _____________________________________________________

Schijf /dev/sdb: 1000.2 GB, 1000204886016 bytes
255 koppen, 63 sectoren/spoor, 121601 cilinders, totaal 1953525168 sectoren
Eenheid = sectoren van 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes

Partition  Boot         Start           End          Size  Id System

/dev/sdb1                  63 1,920,731,399 1,920,731,337   7 HPFS/NTFS


blkid -c /dev/null: ____________________________________________________________

Device           UUID                                   TYPE       LABEL                         

/dev/sda1        58FC890AFC88E39A                       ntfs                                     
/dev/sda2: PTTYPE="dos"
/dev/sda5        f2b522fa-638f-4f53-9b11-bcd3a376f38f   ext4                                     
/dev/sda6        2aa465fc-d976-4c67-8b6e-d7f747ffc688   swap                                     
/dev/sda: PTTYPE="dos"
/dev/sdb1        F66CBE346CBDF00B                       ntfs       MY BOOK                       
/dev/sdb: PTTYPE="dos"

============================ "mount | grep ^/dev  output: ===========================

Device           Mount_Point              Type       Options

/dev/sda5        /                        ext4       (rw,errors=remount-ro)
/dev/sdb1        /media/MY BOOK_          fuseblk    (rw,nosuid,nodev,allow_other,blksize=4096,default_permissions)


================================ sda1/boot.ini: ================================

[boot loader]

timeout=30

default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS

[operating systems]

multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professional" /fastdetect /NoExecute=OptIn


=========================== sda5/boot/grub/grub.cfg: ===========================

#
# DO NOT EDIT THIS FILE
#
# It is automatically generated by /usr/sbin/grub-mkconfig using templates
# from /etc/grub.d and settings from /etc/default/grub
#

### BEGIN /etc/grub.d/00_header ###
if [ -s $prefix/grubenv ]; then
  load_env
fi
set default="0"
if [ ${prev_saved_entry} ]; then
  set saved_entry=${prev_saved_entry}
  save_env saved_entry
  set prev_saved_entry=
  save_env prev_saved_entry
  set boot_once=true
fi

function savedefault {
  if [ -z ${boot_once} ]; then
    saved_entry=${chosen}
    save_env saved_entry
  fi
}

function recordfail {
  set recordfail=1
  if [ -n ${have_grubenv} ]; then if [ -z ${boot_once} ]; then save_env recordfail; fi; fi
}
insmod ext2
set root='(hd0,5)'
search --no-floppy --fs-uuid --set f2b522fa-638f-4f53-9b11-bcd3a376f38f
if loadfont /usr/share/grub/unicode.pf2 ; then
  set gfxmode=640x480
  insmod gfxterm
  insmod vbe
  if terminal_output gfxterm ; then true ; else
    # For backward compatibility with versions of terminal.mod that don't
    # understand terminal_output
    terminal gfxterm
  fi
fi
insmod ext2
set root='(hd0,5)'
search --no-floppy --fs-uuid --set f2b522fa-638f-4f53-9b11-bcd3a376f38f
set locale_dir=($root)/boot/grub/locale
set lang=nl
insmod gettext
if [ ${recordfail} = 1 ]; then
  set timeout=-1
else
  set timeout=10
fi
### END /etc/grub.d/00_header ###

### BEGIN /etc/grub.d/05_debian_theme ###
set menu_color_normal=white/black
set menu_color_highlight=black/light-gray
### END /etc/grub.d/05_debian_theme ###

### BEGIN /etc/grub.d/10_linux ###
menuentry 'Ubuntu, met Linux 2.6.32-22-generic' --class ubuntu --class gnu-linux --class gnu --class os {
   recordfail
   insmod ext2
   set root='(hd0,5)'
   search --no-floppy --fs-uuid --set f2b522fa-638f-4f53-9b11-bcd3a376f38f
   linux   /boot/vmlinuz-2.6.32-22-generic root=UUID=f2b522fa-638f-4f53-9b11-bcd3a376f38f ro   quiet splash
   initrd   /boot/initrd.img-2.6.32-22-generic
}
menuentry 'Ubuntu, met Linux 2.6.32-22-generic (herstelmodus)' --class ubuntu --class gnu-linux --class gnu --class os {
   recordfail
   insmod ext2
   set root='(hd0,5)'
   search --no-floppy --fs-uuid --set f2b522fa-638f-4f53-9b11-bcd3a376f38f
   echo   'Linux 2.6.32-22-generic laden ...'
   linux   /boot/vmlinuz-2.6.32-22-generic root=UUID=f2b522fa-638f-4f53-9b11-bcd3a376f38f ro single
   echo   'Initiële ramdisk laden ...'
   initrd   /boot/initrd.img-2.6.32-22-generic
}
menuentry 'Ubuntu, met Linux 2.6.31-22-generic' --class ubuntu --class gnu-linux --class gnu --class os {
   recordfail
   insmod ext2
   set root='(hd0,5)'
   search --no-floppy --fs-uuid --set f2b522fa-638f-4f53-9b11-bcd3a376f38f
   linux   /boot/vmlinuz-2.6.31-22-generic root=UUID=f2b522fa-638f-4f53-9b11-bcd3a376f38f ro   quiet splash
   initrd   /boot/initrd.img-2.6.31-22-generic
}
menuentry 'Ubuntu, met Linux 2.6.31-22-generic (herstelmodus)' --class ubuntu --class gnu-linux --class gnu --class os {
   recordfail
   insmod ext2
   set root='(hd0,5)'
   search --no-floppy --fs-uuid --set f2b522fa-638f-4f53-9b11-bcd3a376f38f
   echo   'Linux 2.6.31-22-generic laden ...'
   linux   /boot/vmlinuz-2.6.31-22-generic root=UUID=f2b522fa-638f-4f53-9b11-bcd3a376f38f ro single
   echo   'Initiële ramdisk laden ...'
   initrd   /boot/initrd.img-2.6.31-22-generic
}
### END /etc/grub.d/10_linux ###

### BEGIN /etc/grub.d/20_memtest86+ ###
menuentry "Memory test (memtest86+)" {
   insmod ext2
   set root='(hd0,5)'
   search --no-floppy --fs-uuid --set f2b522fa-638f-4f53-9b11-bcd3a376f38f
   linux16   /boot/memtest86+.bin
}
menuentry "Memory test (memtest86+, serial console 115200)" {
   insmod ext2
   set root='(hd0,5)'
   search --no-floppy --fs-uuid --set f2b522fa-638f-4f53-9b11-bcd3a376f38f
   linux16   /boot/memtest86+.bin console=ttyS0,115200n8
}
### END /etc/grub.d/20_memtest86+ ###

### BEGIN /etc/grub.d/30_os-prober ###
menuentry "Microsoft Windows XP Professional (on /dev/sda1)" {
   insmod ntfs
   set root='(hd0,1)'
   search --no-floppy --fs-uuid --set 58fc890afc88e39a
   drivemap -s (hd0) ${root}
   chainloader +1
}
### END /etc/grub.d/30_os-prober ###

### BEGIN /etc/grub.d/40_custom ###
# This file provides an easy way to add custom menu entries.  Simply type the
# menu entries you want to add after this comment.  Be careful not to change
# the 'exec tail' line above.
### END /etc/grub.d/40_custom ###

=============================== sda5/etc/fstab: ===============================

# /etc/fstab: static file system information.
#
# Use 'blkid -o value -s UUID' to print the universally unique identifier
# for a device; this may be used with UUID= as a more robust way to name
# devices that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    defaults        0       0
# / was on /dev/sda5 during installation
UUID=f2b522fa-638f-4f53-9b11-bcd3a376f38f /               ext4    errors=remount-ro 0       1
# swap was on /dev/sda6 during installation
UUID=2aa465fc-d976-4c67-8b6e-d7f747ffc688 none            swap    sw              0       0
/dev/scd1       /media/cdrom0   udf,iso9660 user,noauto,exec,utf8 0       0
/dev/fd0        /media/floppy0  auto    rw,user,noauto,exec,utf8 0       0

=================== sda5: Location of files loaded by Grub: ===================


  69.2GB: boot/grub/core.img
  71.4GB: boot/grub/grub.cfg
  70.4GB: boot/initrd.img-2.6.31-22-generic
  71.1GB: boot/initrd.img-2.6.32-22-generic
  70.5GB: boot/vmlinuz-2.6.31-22-generic
  70.3GB: boot/vmlinuz-2.6.32-22-generic
  71.1GB: initrd.img
  70.4GB: initrd.img.old
  70.3GB: vmlinuz
  70.5GB: vmlinuz.old

ik hoop dat je eruit kan komen, vast bedankt...

Offline donpedroII

  • Lid
  • Steunpunt: Nee
Re: na upgrade naar 1004 werkt dual boot niet meer
« Reactie #10 Gepost op: 2010/07/04, 12:05:40 »
Werkend vanuit deze info:
Boot sector type:  Grub 2Boot sector info:  Grub 2 is installed in the boot sector of sda1 and
                       looks at sector 135240655 of the same hard drive for
                       core.img, but core.img can not be found at this
                       location. No errors found in the Boot Parameter Block.

Na wat leeswerk lijkt het erop dat je de Windwos bootsector hebt overschreven, waardoor de verwijzing naar je Windows niet meer correct is ( looks at sector xxxxx ).
Een werkende oplossing ( zelf niet geprobeerd ) zou zijn om je windows bootsector te herstellen met een programma vanuit Ubuntu zelf 'testdisk'

Lees de volgende pagina eens aandachtig door : Boot Problems:Boot Sector

Hoop dat je hiermee iets dichterbij een oplossing komt.

Offline davesontheroad

  • Lid
  • Steunpunt: Nee
[OPGELOST] Re: na upgrade naar 1004 werkt dual boot niet meer
« Reactie #11 Gepost op: 2010/07/05, 15:55:28 »
Dankzij Don is het probleem opgelost. Ik ben zo'n noob, wist niet in welke richting ik moest zoeken.

Ik heb als oplossing de 'sudo apt-get install testdisk en dan sudo testdisk'  gedaan, daarna de beschrijving van elke window die voorbijkwam opgevolgd. hierna heb ik een reboot gedaan. toen kwam de keuzemenu van dualboot, hier XP gekozen en YES ! XP starte gelukkig op.

Don, ik ben zo blij met je....mijn dank is grenzeloos

vr.
Dave
deze toppic kan gesloten worden