Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: (opgelost) audio uit doen t nie op EEEPC 1001PX  (gelezen 2885 keer)

Offline filibus

  • Lid
  • Steunpunt: Nee
(opgelost) audio uit doen t nie op EEEPC 1001PX
« Gepost op: 2010/06/16, 21:22:59 »
Ik loop al een weekje te speuren naar een oplossing voor een merkwaardig probleem bij de EEEPC 1001PX.
er komt geen geluid uit de koptelefoon uitgang; de interne speakers gaan wel uit.
Bij het opstarten en afsluiten hoor ik wel en klik, dus de hardware doet t wel.
Het lijkt me dus dat er bij het laden van de drivers iets misgaat.
Na zonder succes xubuntu 9.04/9.10/10/04 en ubuntu 9.10 en 10.04 heb ik nu 10.04-x64 draaien, maar bij alle heb ik hetzelfde probleem..............
« Laatst bewerkt op: 2010/06/19, 21:10:29 door filibus »

Offline asphyxia

  • Forumteam
  • Steunpunt: Nee
Re: audio uit doen t nie op EEEPC 1001PX
« Reactie #1 Gepost op: 2010/06/16, 21:54:12 »
Jouw type pc is onlangs met andersoortige (WiFi) problemen hier langs geweest, audio zou het gewoon moeten doen, dus dit lijkt mij in eerste instantie geen driverprobleem.
Kijk eens bij de geluidinstellingen of er niks op 'mute' staat. En anders kan je via Synaptic alsamixergui installeren, daar kan je alle instellingen controleren.

In je gnome-mixer moet er een vinkje staan bij headphones.
« Laatst bewerkt op: 2010/06/16, 21:58:32 door asphyxia »
Als de werkelijkheid er niet was, zou de wereld er heel anders uitzien. [Theo Maassen]
Alles is te kraken, niets is veilig, zorg dus voor zoveel mogelijk niets. [Ramana]
It's always darkest before the dawn. [Florence Welch]

Offline filibus

  • Lid
  • Steunpunt: Nee
Re: audio uit doen t nie op EEEPC 1001PX
« Reactie #2 Gepost op: 2010/06/16, 22:56:17 »
alsmixergui geinstalleerd, maar ik krijg maar 2 schuifjes;
master en capture, nergens headphones....
er staat bovenaan wel card: pulseaudio en chip: pulseaudio, moet dat niet alsa zijn?
ik zie niet waar ik iets kan veranderen...
btw die topic over wifi heb ik ook gelezen en de oplossing werkte ook bij mij, dank aan de meedenker(s)!
Nu alleen dit nog oplossen....

Offline yokke

  • Lid
  • Steunpunt: Nee
Re: audio uit doen t nie op EEEPC 1001PX
« Reactie #3 Gepost op: 2010/06/16, 23:25:23 »
alsmixergui geinstalleerd, maar ik krijg maar 2 schuifjes;
master en capture, nergens headphones....
er staat bovenaan wel card: pulseaudio en chip: pulseaudio, moet dat niet alsa zijn?
ik zie niet waar ik iets kan veranderen...
btw die topic over wifi heb ik ook gelezen en de oplossing werkte ook bij mij, dank aan de meedenker(s)!
Nu alleen dit nog oplossen....

Ik zal mij er vanaf morgen ook eens opzetten en het is proberen werkende te krijgen.
www.linux-answered.com
Remember, when using Linux, you're the one in control

Offline asphyxia

  • Forumteam
  • Steunpunt: Nee
Re: audio uit doen t nie op EEEPC 1001PX
« Reactie #4 Gepost op: 2010/06/16, 23:28:17 »
@filibus,

wat al zou kunnen werken, is via synaptic dit installeren: linux-backports-modules-alsa-lucid-generic
Check ook eens je geluidkaart in de terminal met aplay -l, (l = kleine letter L) en post dat eens hier.
Het zou ook kunnen zijn, dat je last hebt van 'jack sensing', nl. dat die aansluiting niet wordt doorgegeven. Daar ben ik niet zo goed in thuis, anders moet je even wachten tot MrGee zich meldt  ;)
« Laatst bewerkt op: 2010/06/16, 23:29:50 door asphyxia »
Als de werkelijkheid er niet was, zou de wereld er heel anders uitzien. [Theo Maassen]
Alles is te kraken, niets is veilig, zorg dus voor zoveel mogelijk niets. [Ramana]
It's always darkest before the dawn. [Florence Welch]

Offline yokke

  • Lid
  • Steunpunt: Nee
Re: audio uit doen t nie op EEEPC 1001PX
« Reactie #5 Gepost op: 2010/06/16, 23:31:57 »
Ik heb het meteen gedaan (ik heb exact dezelfde laptop)

Dit is mijn output

*** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: ALC269 Analog [ALC269 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
www.linux-answered.com
Remember, when using Linux, you're the one in control

Offline asphyxia

  • Forumteam
  • Steunpunt: Nee
Re: audio uit doen t nie op EEEPC 1001PX
« Reactie #6 Gepost op: 2010/06/16, 23:40:12 »
Aha, ik heb al even gegoogled, met dit kaartje zijn vaker soortgelijke problemen gemeld.
Probeer nog eens de backports installeren.

Edit: na installeren, pc herstarten en daarna controleren.
« Laatst bewerkt op: 2010/06/17, 11:51:48 door asphyxia »
Als de werkelijkheid er niet was, zou de wereld er heel anders uitzien. [Theo Maassen]
Alles is te kraken, niets is veilig, zorg dus voor zoveel mogelijk niets. [Ramana]
It's always darkest before the dawn. [Florence Welch]

Offline filibus

  • Lid
  • Steunpunt: Nee
Re: audio uit doen t nie op EEEPC 1001PX
« Reactie #7 Gepost op: 2010/06/17, 12:49:15 »
Die backports had ik al eerder geprobeerd  in xubuntu maar toen hielp het niet, ik ga het vanavond nog maar een keer proberen, hopelijk werkt t dit keer wel......

Offline asphyxia

  • Forumteam
  • Steunpunt: Nee
Re: audio uit doen t nie op EEEPC 1001PX
« Reactie #8 Gepost op: 2010/06/17, 15:40:32 »
Ok filibus en yokke,

Probeer sowieso dat installeren van die backports files (en daarna herstarten).
Ik heb nog even gezocht, deze bug komt vaker voor, lijkt wel een regressiebug te zijn, niet alleen bij de Asus (ook bij Sony Vaio bv.) en niet alleen bij 10.04. Het is bekend via launchpad.
Soms kan dit opgelost worden (zo heb ik op enkele sites gelezen) door aanpassing van wat regels in de file alsabase.conf. Ik durf het niet aan om daar iets in te adviseren, want ik ben daar nauwelijks in thuis, daar wil ik eerlijk in zijn.
Mocht het met de backports-files niet lukken, is het even wachten op MrGee of een ander die hier beter in detail van wanten weet.
Als de werkelijkheid er niet was, zou de wereld er heel anders uitzien. [Theo Maassen]
Alles is te kraken, niets is veilig, zorg dus voor zoveel mogelijk niets. [Ramana]
It's always darkest before the dawn. [Florence Welch]

Offline filibus

  • Lid
  • Steunpunt: Nee
Re: audio uit doen t nie op EEEPC 1001PX
« Reactie #9 Gepost op: 2010/06/17, 19:37:49 »
nou moe?
net de backports via synaptic geinstalleerd, maar na een herstart geen verandering.
wel zie ik bij geluidsvoorkeuren in het tabblad hardware een nieuwe profiel; "uit" maar dan is het apparaat uitgeschakeld en heb ik helemaal geen geluid.

verder kan ik ook nergens een schuif vinden om het geluid van de koptelefoonuitgang harder of zachter te kunnen zetten.

in terminal krijg ik op aplay -l

**** Lijst van PLAYBACK hardware-apparaten ****
kaart 0: Intel [HDA Intel], apparaat 0: ALC269 Analog [ALC269 Analog]
  Sub-apparaten: 0/1
  Sub-apparaat #0: subdevice #0



Offline mrGee

  • Lid
  • Steunpunt: Nee
Re: audio uit doen t nie op EEEPC 1001PX
« Reactie #10 Gepost op: 2010/06/19, 00:58:15 »
Hallo

En wat heb je op dit moment in je /etc/modprobe.d/alsa-base.conf
staan? ( doe alt+f2, tik in; gedit /etc/modprobe.d/alsa-base.conf)
en kijk wat er als model in de volgende regel staat;
options snd-hda-intel model=..........

edit; na wat googelen denk ik dat er qua model niets zal staan in die alsa-base.conf.
er zou een regel (meestal de laatste) in kunnen/moeten staan

Je kunt op de volgende manier daar anders die regel aan toevoegen met de juiste opties,
Volgens de laatste 10.04 lijst die bij de alc269 opduikt zijn dit allemaal geldige opties;
ALC269
======
  basic      Basic preset
  quanta   Quanta FL1
  eeepc-p703   ASUS Eeepc P703 P900A
  eeepc-p901   ASUS Eeepc P901 S101
  fujitsu   FSC Amilo
  lifebook   Fujitsu Lifebook S6420
  auto      auto-config reading BIOS (default)

(optie is het eerste deel voor de spaties)

waarbij ik als eerste de eeepc-p901 en als dat niet werkt, als eerstvolgende de auto
zou proberen.

Doe
alt+f2
Tik in;
gksudo /etc/modprobe.d/alsa-base.conf
(wachtwoord invullen)
Voeg de volgende regel toe
options snd-hda-intel model=eeepc-p901
(of verander de model= als die regel er al stond)
Opslaan en machine herstarten
Geluid ? gefeliciteerd  8)
Geen geluid; goto: Doe alt+f2, etc etc waarbij je een volgende model=............ invoert en opslaat en herstart.

Nu zag ik nog ergens een extraatje opduiken; nl. om de volgende regel in je
/etc/modprobe.d/blacklist.conf toe te voegen;
snd-hda-codec-intelhdmi
(google er anders maar eens op icm. het woord alc269)
Dus misschien worden die model=.... opties in de alsa-base.conf pas netjes verwerkt
als eerst die blacklist.conf is aangepast! ('t lijkt me in ieder geval geen kwaad
te kunnen, hooguit wordt een evt. niet bestaande/gebruikte module geblacklist, test anders
eens uit wat er direct na het blacklisten en heropstarten is veranderd)

Om dat te bewerken;
alt+f2, gksudo /etc/modprobe.d/blacklist.conf
voeg die regel als laatste toe, sla op en reset machine, ga dan met die alsa-base.conf aan de
slag.
Goed, tal van opties te verwerken 't is even doorbijten, maar loont vaak en dan is het alc269 lijstje nog
relatief klein  ;)

Groeten Gerrit
« Laatst bewerkt op: 2010/06/19, 10:31:08 door mrGee »
-- = >  simplify if you can   -- = >

Offline filibus

  • Lid
  • Steunpunt: Nee
Re: audio uit doen t nie op EEEPC 1001PX
« Reactie #11 Gepost op: 2010/06/19, 20:15:59 »
in /etc/modprobe.d/alsa-base.conf staat het volgende:

# autoloader aliases
install sound-slot-0 /sbin/modprobe snd-card-0
install sound-slot-1 /sbin/modprobe snd-card-1
install sound-slot-2 /sbin/modprobe snd-card-2
install sound-slot-3 /sbin/modprobe snd-card-3
install sound-slot-4 /sbin/modprobe snd-card-4
install sound-slot-5 /sbin/modprobe snd-card-5
install sound-slot-6 /sbin/modprobe snd-card-6
install sound-slot-7 /sbin/modprobe snd-card-7

# Cause optional modules to be loaded above generic modules
install snd /sbin/modprobe --ignore-install snd $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-ioctl32 ; /sbin/modprobe --quiet --use-blacklist snd-seq ; }
#
# Workaround at bug #499695 (reverted in Ubuntu see LP #319505)
install snd-pcm /sbin/modprobe --ignore-install snd-pcm $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-pcm-oss ; : ; }
install snd-mixer /sbin/modprobe --ignore-install snd-mixer $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-mixer-oss ; : ; }
install snd-seq /sbin/modprobe --ignore-install snd-seq $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq-midi ; /sbin/modprobe --quiet --use-blacklist snd-seq-oss ; : ; }
#
install snd-rawmidi /sbin/modprobe --ignore-install snd-rawmidi $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq-midi ; : ; }
# Cause optional modules to be loaded above sound card driver modules
install snd-emu10k1 /sbin/modprobe --ignore-install snd-emu10k1 $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-emu10k1-synth ; }
install snd-via82xx /sbin/modprobe --ignore-install snd-via82xx $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq ; }

# Load saa7134-alsa instead of saa7134 (which gets dragged in by it anyway)
install saa7134 /sbin/modprobe --ignore-install saa7134 $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist saa7134-alsa ; : ; }
# Prevent abnormal drivers from grabbing index 0
options bt87x index=-2
options cx88_alsa index=-2
options saa7134-alsa index=-2
options snd-atiixp-modem index=-2
options snd-intel8x0m index=-2
options snd-via82xx-modem index=-2
options snd-usb-audio index=-2
options snd-usb-us122l index=-2
options snd-usb-usx2y index=-2
options snd-usb-caiaq index=-2
# Ubuntu #62691, enable MPU for snd-cmipci
options snd-cmipci mpu_port=0x330 fm_port=0x388
# Keep snd-pcsp from being loaded as first soundcard
options snd-pcsp index=-2




inderdaad niets over model.
ik ga je handleiding uitproberen en post de resultaten.....


Offline filibus

  • Lid
  • Steunpunt: Nee
Re: audio uit doen t nie op EEEPC 1001PX
« Reactie #12 Gepost op: 2010/06/19, 20:55:48 »
Tot nu toe nog geen succes;
na het veranderen van modprobe.d/alsa-base.conf met gksudo gedit modprobe.d/alsa-base.conf
geven de opties eepc-p901 en auto geen verandering, bij basic blijven de interne speakers gewoon aan maar verder niks.

Ik ben nu bezig het hele rijtje af te gaan,maar ik hat nog even een vraagje over die zin:
toevoegen in /etc/modprobe.d/blacklist.conf de regel snd-hda-codec-intelhdmi
moet daar dan niet ook options voor gezet worden? en bedoel je dat ik eerst de blacklist.conf moet veranderen voordat ik met de alsa-base.conf aan de slag ga of eerst alle alsa-base.conf optie doorproberen en als dat niets opleverd de blacklist.conf aanpassen en overnieuw beginnen met de alsa-base.conf?
Dat laatste ben ik nu in ieder geval aan het doen..

Offline filibus

  • Lid
  • Steunpunt: Nee
Re: audio uit doen t nie op EEEPC 1001PX
« Reactie #13 Gepost op: 2010/06/19, 21:09:58 »
hoera, de lifebook optie deed het m!
gelukt...
mrGee (en alle andere meedenkers) bedankt!

Offline mrGee

  • Lid
  • Steunpunt: Nee
Re: (opgelost) audio uit doen t nie op EEEPC 1001PX
« Reactie #14 Gepost op: 2010/06/20, 00:04:48 »
Mooi, zo  8)

resumerend; betekent het dat je dus alleen die lifebook  optie in alsa-base.conf
moest zetten, of heb je daar bij die snd-hda-codec-intelhdmi ook eerst in
de /etc/modprobe.d/blacklist gezet? Of was dat helemaal niet nodig?

Groeten Gerrit



-- = >  simplify if you can   -- = >

Offline filibus

  • Lid
  • Steunpunt: Nee
Re: (opgelost) audio uit doen t nie op EEEPC 1001PX
« Reactie #15 Gepost op: 2010/06/20, 00:43:39 »
ik ben gewoon stap voor stap aan het werk gegaan,
ik heb dus eerst alle opties afgelopen om pas als dat niet werkte de blacklist variant te proberen, maar die blijkt niet nodig te zijn, de asus 1001px werkt prima met  de aanvulling model=lifebook in /etc/modprobe.d/alsa-base.conf
die aanpassing in de blacklist was de volgende optie als dit niet zou werken..

en nogmaals thanx, hier was ik zelf niet uit gekomen, ik ben al ruim een week aan het puzzelen op de ubuntu- fora voor een oplossing en eindelijk werkt het gewoon, dus nogmaals; bedankt

ps het duurde even voordat ik doorhad dat ik na de gksudo eerst gedit moest zetten, anders gebeurt er niets...

het is dus in terminal (of alt-f2) gksudo gedit /etc/modprobe.d/alsa-base.conf
dan onderaan toevoegen: options snd-hda-intel model=lifebook

opslaan en herstarten dan zou je geluid uit de microfoonuitgang  moeten krijgen.

de blacklist heb ik dus niet nodig gehad..
« Laatst bewerkt op: 2010/06/20, 00:46:54 door filibus »

Offline yokke

  • Lid
  • Steunpunt: Nee
Re: (opgelost) audio uit doen t nie op EEEPC 1001PX
« Reactie #16 Gepost op: 2010/06/20, 10:41:02 »
Ook deze fix doet het bij mij. Op naar het volgende probleem met de asus eeepc 1001 px.
Bedankt voor het helpen allemaal.
www.linux-answered.com
Remember, when using Linux, you're the one in control