Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: broken dependencies  (gelezen 958 keer)

Offline bramhermelink

  • Lid
  • Steunpunt: Nee
broken dependencies
« Gepost op: 2010/06/09, 21:17:57 »
Hallo!

Ik krijg dit bericht als ik mijn update manager wil starten;

There are broken dependecies on your system. Please use an advanced package manage e.g. Synaptic or aptitude to resolve this situation.

Als ik dan via aptitude de 'kapotte' file (iets van flash) wil verwijderen krijg ik dit;
(Database inlezen ... 110144 bestanden en mappen geïnstalleerd.)
flashplugin-installer wordt verwijderd ...
dpkg (subproces): kan installed pre-removal script niet uitvoeren: Verkeerd uitvoerbaar bestand
dpkg: fout bij afhandelen van flashplugin-installer (--remove):
 subproces installed pre-removal script gaf een foutwaarde 2 terug
dpkg (subproces): kan installed post-installation script niet uitvoeren: Verkeerd uitvoerbaar bestand
dpkg: fout tijdens opruimen:
 subproces installed post-installation script gaf een foutwaarde 2 terug
Fouten gevonden tijdens behandelen van:
 flashplugin-installer
E: Sub-process /usr/bin/dpkg returned an error code (1)
Bevestigd! Er is iets ergs gebeurd bij het installeren van pakketten. Erwordt geprobeerd van te herstellen:
Druk op return om verder te gaan.


Hoe kan ik ervoor zorgen dat alles weer gaat werken???

Offline RioKuro

  • Lid
    • RioKuro - Camera - Colors - Visual Effects
  • Steunpunt: Nee
Re: broken dependencies
« Reactie #1 Gepost op: 2010/06/09, 21:48:47 »
Wat ik zou proberen is flashplugin-installer te force removen zeg maar.
daarna hem meteen weer installeren, dat zou heel goed kunnen helpen

sudo apt-get purge flashplugin-installer -f

als dat werkt hem weer installeren

sudo apt-get install flashplugin-installer

Offline foxofinfinety

  • Lid
    • foxofinfinety
    • Foxofinfinety.com
  • Steunpunt: Nee
Re: broken dependencies
« Reactie #2 Gepost op: 2010/06/09, 22:20:18 »
beter van niet, want kan anders:
sudo apt-get --fix-broken installen deze:
sudo apt-get --fix-missing installdan repareert hij alle kapotte pakketten en installeert hij ook gelijk alle ontbrekende dependencies
(en als er een pakket kapot is mis die vaak ook gelijk wat dus deze worden meestal beide gebruikt, kan ook geen kwaad want als er niks mist doet die 2de gewoon niks.)


ADSL? nee, neem ADHD, dat is pas snel!

Offline bramhermelink

  • Lid
  • Steunpunt: Nee
Re: broken dependencies
« Reactie #3 Gepost op: 2010/06/10, 14:22:22 »
@ Richard:
Ik heb gedaan wat je zei en krijg deze resultaten:
bram@bram:~$ sudo apt-get --fix-broken install
[sudo] password for bram:
Pakketlijsten worden ingelezen... Klaar
Boom van vereisten wordt opgebouwd       
De status informatie wordt gelezen... Klaar
Vereisten worden gecorrigeerd... Klaar
De volgende extra pakketten zullen geïnstalleerd worden:
  nspluginwrapper
De volgende NIEUWE pakketten zullen geïnstalleerd worden:
  nspluginwrapper
0 pakketten opgewaardeerd, 1 pakketten nieuw geïnstalleerd, 0 te verwijderen en 0 niet opgewaardeerd.
1 pakketten niet volledig geïnstalleerd of verwijderd.
Er moeten 0B/198kB aan archieven opgehaald worden.
Door deze operatie zal er 565kB extra schijfruimte gebruikt worden.
Wilt u doorgaan [J/n]? j
Selecteren van voorheen niet geselecteerd pakket nspluginwrapper.
(Database inlezen ... 110145 bestanden en mappen geïnstalleerd.)
Uitpakken van nspluginwrapper (uit .../nspluginwrapper_1.2.2-0ubuntu6_amd64.deb) ...
Processing triggers for man-db ...
Instellen van nspluginwrapper (1.2.2-0ubuntu6) ...
plugin dirs: :/var/lib/flashplugin-installer/
Auto-update plugins from /usr/lib/mozilla/plugins
Looking for plugins in /usr/lib/mozilla/plugins
Auto-update plugins from /usr/lib64/mozilla/plugins
Looking for plugins in /usr/lib64/mozilla/plugins
Auto-update plugins from /usr/lib/firefox/plugins
Looking for plugins in /usr/lib/firefox/plugins
Auto-update plugins from /usr/lib64/firefox/plugins
Looking for plugins in /usr/lib64/firefox/plugins
Auto-update plugins from /var/lib/flashplugin-installer/
Looking for plugins in /var/lib/flashplugin-installer/
Auto-update plugins from /root/.mozilla/plugins
Looking for plugins in /root/.mozilla/plugins

Instellen van flashplugin-installer (10.0.45.2ubuntu1) ...
dpkg (subproces): kan installed post-installation script niet uitvoeren: Verkeerd uitvoerbaar bestand
dpkg: fout bij afhandelen van flashplugin-installer (--configure):
 subproces installed post-installation script gaf een foutwaarde 2 terug
Fouten gevonden tijdens behandelen van:
 flashplugin-installer
E: Sub-process /usr/bin/dpkg returned an error code (1)   


en voor de tweede

bram@bram:~$ sudo apt-get --fix-missing install                                                                                                                                                           
Pakketlijsten worden ingelezen... Klaar                                                                                                                                                                   
Boom van vereisten wordt opgebouwd                                                                                                                                                                         
De status informatie wordt gelezen... Klaar                                                                                                                                                               
0 pakketten opgewaardeerd, 0 pakketten nieuw geïnstalleerd, 0 te verwijderen en 0 niet opgewaardeerd.                                                                                                     
1 pakketten niet volledig geïnstalleerd of verwijderd.                                                                                                                                                     
Door deze operatie zal er 0B extra schijfruimte gebruikt worden.                                                                                                                                           
Instellen van flashplugin-installer (10.0.45.2ubuntu1) ...                                                                                                                                                 
dpkg (subproces): kan installed post-installation script niet uitvoeren: Verkeerd uitvoerbaar bestand                                                                                                     
dpkg: fout bij afhandelen van flashplugin-installer (--configure):                                                                                                                                         
 subproces installed post-installation script gaf een foutwaarde 2 terug                                                                                                                                   
Fouten gevonden tijdens behandelen van:
 flashplugin-installer
E: Sub-process /usr/bin/dpkg returned an error code (1)


Ondanks de errors kan ik weer via softwarebeheer van alles downloaden. Betekent dit dat alles weer goed is, of moet ik nog meer doen om het weer helemaal OK te krijgen?

Bedankt voor jullie reactie! Echt een groot voordeel van (K)ubuntu dat er zo veel mensen bereid zijn te helpen bij problemen...