Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: geluid van moederboard ASUS A8N-SLI  (gelezen 5036 keer)

Offline Johnny vdl

  • Lid
  • Steunpunt: Nee
geluid van moederboard ASUS A8N-SLI
« Gepost op: 2010/06/07, 14:13:24 »
Ubuntu 10.04 LTS geinstalleerd op een systeem met een ASUS A8N-SLI moederboard.

De geluidshardware wordt niet herkend door ubuntu. Het icoontje voor de geluidsvoorkeuren rechtsboven in het scherm blijft een lege luidspreker die wel vult wanneer ik een usb telefoon aansluit (apparaat = 9980), maw de chip werkt dus wel!

Nu heb ik dit topic voor eerdere versies van ubuntu ook al gezien, maar heb daar geen antwoord gevonden dat voor mij werkt.

Offline foxofinfinety

  • Lid
    • foxofinfinety
    • Foxofinfinety.com
  • Steunpunt: Nee
Re: geluid van moederboard ASUS A8N-SLI
« Reactie #1 Gepost op: 2010/06/07, 14:16:22 »
even ter informatie:
het betreft hier een Realtek ALC850 audio chip.
volgens mij maakt realtek wel gewoon linux drivers echter...


ADSL? nee, neem ADHD, dat is pas snel!

Offline nomko

  • Lid
    • Ubuntu Linux Gebruiker Site
  • Steunpunt: Nee
Re: geluid van moederboard ASUS A8N-SLI
« Reactie #2 Gepost op: 2010/06/07, 14:18:47 »
Ubuntu 10.04 LTS geinstalleerd op een systeem met een ASUS A8N-SLI moederboard.

De geluidshardware wordt niet herkend door ubuntu. Het icoontje voor de geluidsvoorkeuren rechtsboven in het scherm blijft een lege luidspreker die wel vult wanneer ik een usb telefoon aansluit (apparaat = 9980), maw de chip werkt dus wel!

Nu heb ik dit topic voor eerdere versies van ubuntu ook al gezien, maar heb daar geen antwoord gevonden dat voor mij werkt.

Johnny:
Heb je alle nieuwste updates binnengehaald? En wat staat er hier: Systeem > Voorkeuren > Geluid > tabblad Hardware.

@Johnny: open een terminal en tik in: lspci en post de uitkomst hier op het forum. Je soundchip zal te zien moeten zijn in de uitkomst.

*edit*
Die onboard soundchip moet dan zeker wel werken. Laat ie eerst de nieuwe updates binnenhalen. Misschien dat er iets meekomt waardoor het wel werkt.
« Laatst bewerkt op: 2010/06/07, 14:20:58 door nomko »
Handige site voor de Ubuntu gebruiker:
https://sites.google.com/site/ubuntulinuxgebruiker
-------------------------
https://www.dropbox.com/referrals/NTQ4MzUwNDc5
-------------------------
Linux user number 515471
----------------------

Offline Johnny vdl

  • Lid
  • Steunpunt: Nee
Re: geluid van moederboard ASUS A8N-SLI
« Reactie #3 Gepost op: 2010/06/07, 14:48:35 »
Systeem>Beheer>Updatebeheer>
Dit systeem is up to date
de pakketinformatie is 4 uur geleden voor het laatst bijgewerkt

Je tweede vraag:
john@john-desktop:~$ lspci
00:00.0 Memory controller: nVidia Corporation CK804 Memory Controller (rev a3)
00:01.0 ISA bridge: nVidia Corporation CK804 ISA Bridge (rev a3)
00:01.1 SMBus: nVidia Corporation CK804 SMBus (rev a2)
00:02.0 USB Controller: nVidia Corporation CK804 USB Controller (rev a2)
00:02.1 USB Controller: nVidia Corporation CK804 USB Controller (rev a3)
00:04.0 Multimedia audio controller: nVidia Corporation CK804 AC'97 Audio Controller (rev a2)
00:06.0 IDE interface: nVidia Corporation CK804 IDE (rev f2)
00:07.0 IDE interface: nVidia Corporation CK804 Serial ATA Controller (rev f3)
00:08.0 IDE interface: nVidia Corporation CK804 Serial ATA Controller (rev f3)
00:09.0 PCI bridge: nVidia Corporation CK804 PCI Bridge (rev a2)
00:0a.0 Bridge: nVidia Corporation CK804 Ethernet Controller (rev a3)
00:0b.0 PCI bridge: nVidia Corporation CK804 PCIE Bridge (rev a3)
00:0c.0 PCI bridge: nVidia Corporation CK804 PCIE Bridge (rev a3)
00:0d.0 PCI bridge: nVidia Corporation CK804 PCIE Bridge (rev a3)
00:0e.0 PCI bridge: nVidia Corporation CK804 PCIE Bridge (rev a3)
00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control
01:00.0 VGA compatible controller: nVidia Corporation G80 [GeForce 8800 GTS] (rev a2)
05:06.0 Ethernet controller: Atheros Communications Inc. Atheros AR5001X+ Wireless Network Adapter (rev 01)
05:0b.0 FireWire (IEEE 1394): Texas Instruments TSB43AB22/A IEEE-1394a-2000 Controller (PHY/Link)
john@john-desktop:~$ dir

In de geluidsvoorkeuren komt dus enkel de 9980 voor wanneer ik de usb telefoon aansluit. Géén andere hardware!

Offline nomko

  • Lid
    • Ubuntu Linux Gebruiker Site
  • Steunpunt: Nee
Re: geluid van moederboard ASUS A8N-SLI
« Reactie #4 Gepost op: 2010/06/07, 16:47:57 »
Hij wordt wel herkend dus:
00:04.0 Multimedia audio controller: nVidia Corporation CK804 AC'97 Audio Controller (rev a2)
Wel apart dat ie niet herkent wordt, ik heb ook een onboard audiochip, een Realtek ALC662, en die wordt als een  Intel Corporation N10/ICH 7 Family High Definition Audio Controller (rev 01) herkend. En de drivers zijn gewoon geïnstalleerd.

Hier is iets te vinden voor een AC'97 geluidschip. Onderaan staat een Linux Driver.
http://www.realtek.com/downloads/downloadsView.aspx?Langid=1&PNid=14&PFid=23&Level=4&Conn=3&DownTypeID=3&GetDown=false
Hoop dat het hiermee lukt voor je.




Handige site voor de Ubuntu gebruiker:
https://sites.google.com/site/ubuntulinuxgebruiker
-------------------------
https://www.dropbox.com/referrals/NTQ4MzUwNDc5
-------------------------
Linux user number 515471
----------------------

Offline Cumulus007

  • Lid
  • Steunpunt: Nee
Re: geluid van moederboard ASUS A8N-SLI
« Reactie #5 Gepost op: 2010/06/07, 17:13:43 »
is het geluid soms gedempt?

Offline nomko

  • Lid
    • Ubuntu Linux Gebruiker Site
  • Steunpunt: Nee
Re: geluid van moederboard ASUS A8N-SLI
« Reactie #6 Gepost op: 2010/06/07, 17:20:58 »
is het geluid soms gedempt?

De geluidschip zelve wordt niet herkend. Dus dan zal er ook geen geluid uitkomen.
Handige site voor de Ubuntu gebruiker:
https://sites.google.com/site/ubuntulinuxgebruiker
-------------------------
https://www.dropbox.com/referrals/NTQ4MzUwNDc5
-------------------------
Linux user number 515471
----------------------

Offline Johnny vdl

  • Lid
  • Steunpunt: Nee
Re: geluid van moederboard ASUS A8N-SLI
« Reactie #7 Gepost op: 2010/06/08, 09:15:31 »
Op de site van ASUS staat een Linux driver tussen de raampjes. Die heb ik gedownload. Wat moet ik nu met dit bestand in ubuntu 10.04 (ALC850.zip)?  ???

Wanneer ik unzip krijg ik de hierna volgende handleiding... Die lijkt mij echter gedateerd. (note de drijver is van 2005)


<quote>
The source code copy from www.alsa-project.org.      ver:A2.7

Linux Source Code for ALC audio codec



Installation:

This Source Code is from www.alsa-project.org.

For driver installation, please follow below steps.



Step 1. unzip source code

        tar xfvj alcsound.tar.bz2



Step 2. Turn on sound support (soundcore module, default turn on)



Step 3. Complied source code

   a. ./configure

   b. make

   c. make install

   d. ./snddevices



Step 4. Edit your /etc/modules.conf or conf.modules depending on the distribution

    (Please refer to the attached modules.conf)



Step 5. reboot your machine



Note:    1. The most detail information, can refer the alsa-kernel/Documenttation/ALSA-Configuration.txt
      in the alcsound.tar.bz2.

   2. Kernel Version must be 2.2.14 or later.

   3. All mixer channels are muted by default. You must use a native

      or OSS mixer program to unmute appropriate channels.

   4. If can not compile the source code, try to rename the /usr/src/linux-2.x -> /usr/src/linux.

   5. The driver added to support the SPDIF functoin.    

   6. Suggest use alsamixer to control mixer function. you can find it in the alsa-utils-0.9.4 (www.alsa-project.org).
<unquote>
« Laatst bewerkt op: 2010/06/08, 10:21:24 door Johnny vdl »

Offline mrGee

  • Lid
  • Steunpunt: Nee
Re: geluid van moederboard ASUS A8N-SLI
« Reactie #8 Gepost op: 2010/06/08, 09:37:17 »
Hallo

In principe uitpakken (rechtsklikken) en dan de Readme.txt door gaan lezen.

Maarrrr, dat zou ik niet doen, dit is een heel oud paketje, driver zou zonder
meer al in het alsa paket moeten zitten. Ook even op gegoogeld, maar niets nuttigs
komt naar voren.

Misschien helpt het om in eerste instantie dit te doen;
Installeer de; linux-backports-modules-alsa-generic
(of linux-backports-modules-alsa-............-generic
.....= juiste versie die bij je nu gebruikte kernel hoort gebruiken)
Machine herstarten en controleren. Tevens ook
daarna checken of alles dan ook op unmute staat.

Dit is een onboard chip, staat hij niet toevallig in het bios uit??

Groeten Gerrit
-- = >  simplify if you can   -- = >

Offline Johnny vdl

  • Lid
  • Steunpunt: Nee
Re: geluid van moederboard ASUS A8N-SLI
« Reactie #9 Gepost op: 2010/06/08, 10:48:23 »
 :|
Heb ff gekeken. Het is gelukkig geen MS produkt waarbij ik gelijk koffie had kunnen zetten...
In het BIOS staat A97 Audio [enabled]
 :)

De leeftijd van die linux driver was ook waarom ik hem eerder niet had gedownload.

Wel vond ik noch op andere (engelse en duitse) fora problemen met dezelfde hardware.
« Laatst bewerkt op: 2010/06/08, 11:13:07 door Johnny vdl »

Offline Johnny vdl

  • Lid
  • Steunpunt: Nee
Re: geluid van moederboard ASUS A8N-SLI
« Reactie #10 Gepost op: 2010/06/08, 10:53:13 »
is het geluid soms gedempt?

De geluidschip zelve wordt niet herkend. Dus dan zal er ook geen geluid uitkomen.

Nee, niet gedempt. Hij ziet gewoon geen hardware.
Wel vreemd overigens dat hij bij die zoekaktie in de terminal wel een nVIDIA audiocontroller ziet.

Offline Johnny vdl

  • Lid
  • Steunpunt: Nee
Re: geluid van moederboard ASUS A8N-SLI
« Reactie #11 Gepost op: 2010/06/08, 11:28:00 »
Op een engels forum kwam ik iemand tegen die dezelfde problemen had met ubuntu 9.
Door het installeren van pulseaudio (apt-get install pulseaudio) was het toen bij hem opgelost.

In het ubuntu softwarecentrum staat een pulseaudio device chooser.
zou het installeren hiervan kwaad kunnen? 

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
Re: geluid van moederboard ASUS A8N-SLI
« Reactie #12 Gepost op: 2010/06/08, 11:31:01 »
Nee, niet gedempt. Hij ziet gewoon geen hardware.
Wel vreemd overigens dat hij bij die zoekaktie in de terminal wel een nVIDIA audiocontroller ziet.

De geluidchip wordt dus wel herkend. En er is dus wel degelijk al een stuurprogramma voor aanwezig. Daar zit het probleem derhalve niet.

Kijk eens of alsamixergui iets voor je kan doen:
http://sites.google.com/site/computertip/geengeluid#TOC-Geluidsniveau-staat-niet-goed-niet-

Offline Johnny vdl

  • Lid
  • Steunpunt: Nee
Re: geluid van moederboard ASUS A8N-SLI
« Reactie #13 Gepost op: 2010/06/08, 17:56:01 »
Wanneer de software aanwezig is, waarom wordt die dan niet gezien????

Denk dat ik toch maar dat stuurprogramma uit 2004 eens probeer... Aan die AC'97 codec zal niet zo veel verandert zijn.

Offline mrGee

  • Lid
  • Steunpunt: Nee
Re: geluid van moederboard ASUS A8N-SLI
« Reactie #14 Gepost op: 2010/06/08, 18:10:41 »
Had je al wel die backports geprobeerd dan??
-- = >  simplify if you can   -- = >

Offline Johnny vdl

  • Lid
  • Steunpunt: Nee
Re: geluid van moederboard ASUS A8N-SLI
« Reactie #15 Gepost op: 2010/06/08, 20:58:34 »
dan moet ik toch eerst mijn kernel versie weten te vinden. Ik was nog aan het uitzoeken hoe daar achter is te komen.

in het softwarecentrum staan;
....alsa-2.6.32-generic en ....alsa-2.6.32-generic-pae
maar ook;
....alsa-2.6.31-generic en ....alsa-2.6.31-generic-pae

verwarrend.
« Laatst bewerkt op: 2010/06/08, 21:17:56 door Johnny vdl »

Offline mrGee

  • Lid
  • Steunpunt: Nee
Re: geluid van moederboard ASUS A8N-SLI
« Reactie #16 Gepost op: 2010/06/08, 21:06:43 »
Ik dacht dat je ten allen tijde wel de generic divers mag installeren.

Als je een terminal opent en daar
uname -a
ingeeft

zie je je kernel versie.

Groeten Gerrit
-- = >  simplify if you can   -- = >

Offline Johnny vdl

  • Lid
  • Steunpunt: Nee
Re: geluid van moederboard ASUS A8N-SLI
« Reactie #17 Gepost op: 2010/06/08, 21:21:05 »
bedankt

2.6.32-22-generic #36-Ubuntu SMP Thu Jun 3 22:02:19 UTC 2010 i686 GNU/Linux

dus...

Offline Johnny vdl

  • Lid
  • Steunpunt: Nee
Re: geluid van moederboard ASUS A8N-SLI
« Reactie #18 Gepost op: 2010/06/11, 20:47:45 »
Sorry dat ik ff stil was. Kwam door de verkiezingen waar ik op een stembureau aanwezig moest zijn van ś morgens vroeg tot s'avonds laat.
Heb ondertussen de backported drivers geïnstalleerd. Ook de generic.

Resultaat is nog steeds geen geluid.  :'(
Ik ben op het punt gekomen waar ik een soundblaster kaart uit een windows pc van de kinderen wil slopen om over te zetten naar dit wonder der techniek dat ik voor ubuntu had gereserveerd.

Offline mrGee

  • Lid
  • Steunpunt: Nee
Re: geluid van moederboard ASUS A8N-SLI
« Reactie #19 Gepost op: 2010/06/11, 21:16:33 »
Volgens wat ik in deze draad tegen kwam;
http://lovinglinux.ubuntuforums.org/showthread.php?t=1306773&page=5

Zou je via synaptic de modemmanager moeten verwijderen en daarna herstarten
sommigen hadden daar icm. ubuntu karmic nl. succes mee

Als je die andere kaart toch al hebt, is dat misschien wel de snelste weg tot een
resultaat, misschien moet je dan wel even de onboard kaart uitzetten in het bios.

Groeten Gerrit
 
-- = >  simplify if you can   -- = >

Offline Johnny vdl

  • Lid
  • Steunpunt: Nee
Re: geluid van moederboard ASUS A8N-SLI
« Reactie #20 Gepost op: 2010/06/14, 08:55:03 »
 ???modemmanager  :|

Offline mrGee

  • Lid
  • Steunpunt: Nee
Re: geluid van moederboard ASUS A8N-SLI
« Reactie #21 Gepost op: 2010/06/14, 10:31:50 »
Uhhm ja,

Volgens dat draadje wel, het schijnt dat de modem software driver
'in de weg' zou kunnen zitten en door dat modemmanager pakketje weg te
halen een evt. oplossing zich aanbiedt

Groeten Gerrit
-- = >  simplify if you can   -- = >

Offline Johnny vdl

  • Lid
  • Steunpunt: Nee
Re: geluid van moederboard ASUS A8N-SLI
« Reactie #22 Gepost op: 2010/06/14, 10:51:09 »
het verwijderen van de modemmanager heeft geen effect.

Bij het opstarten staat in de BIOS "AC97 sound = enabled"

type ik dan in de terminal:
$ lspci

dan:
00:00.0 Memory controller: nVidia Corporation CK804 Memory Controller (rev a3)
00:01.0 ISA bridge: nVidia Corporation CK804 ISA Bridge (rev a3)
00:01.1 SMBus: nVidia Corporation CK804 SMBus (rev a2)
00:02.0 USB Controller: nVidia Corporation CK804 USB Controller (rev a2)
00:02.1 USB Controller: nVidia Corporation CK804 USB Controller (rev a3)
00:06.0 IDE interface: nVidia Corporation CK804 IDE (rev f2)
00:07.0 IDE interface: nVidia Corporation CK804 Serial ATA Controller (rev f3)
00:08.0 IDE interface: nVidia Corporation CK804 Serial ATA Controller (rev f3)
00:09.0 PCI bridge: nVidia Corporation CK804 PCI Bridge (rev a2)
00:0a.0 Bridge: nVidia Corporation CK804 Ethernet Controller (rev a3)
00:0b.0 PCI bridge: nVidia Corporation CK804 PCIE Bridge (rev a3)
00:0c.0 PCI bridge: nVidia Corporation CK804 PCIE Bridge (rev a3)
00:0d.0 PCI bridge: nVidia Corporation CK804 PCIE Bridge (rev a3)
00:0e.0 PCI bridge: nVidia Corporation CK804 PCIE Bridge (rev a3)
00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control
01:00.0 VGA compatible controller: nVidia Corporation G80 [GeForce 8800 GTS] (rev a2)
05:06.0 Ethernet controller: Atheros Communications Inc. Atheros AR5001X+ Wireless Network Adapter (rev 01)
05:0b.0 FireWire (IEEE 1394): Texas Instruments TSB43AB22/A IEEE-1394a-2000 Controller (PHY/Link)
$

maw waar is die verdomde geluidschip gebleven!
eerder was dat ding er wel!

00:04.0 Multimedia audio controller: nVidia Corporation CK804 AC'97 Audio Controller (rev a2)

Offline Johnny vdl

  • Lid
  • Steunpunt: Nee
Re: geluid van moederboard ASUS A8N-SLI
« Reactie #23 Gepost op: 2010/06/14, 11:01:28 »
denk dat ik maar ff koffie gaat drinken en het ding laat afkoelen...

Offline mrGee

  • Lid
  • Steunpunt: Nee
Re: geluid van moederboard ASUS A8N-SLI
« Reactie #24 Gepost op: 2010/06/14, 11:19:23 »
Goed idee en koel zelf ook wat af  ;) dan gooi ik er een espresso tegen aan.

Aangezien hij nu plots niet meer opduikt  ???, is er misschien een ander
hardwarematig probleem. Wellicht is de extra soundkaart bijplaats actie
nu wel de enige juiste keuze.

Groeten Gerrit
-- = >  simplify if you can   -- = >