Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: <Opgelost> Probleem Intel VGA chipset na upgrade van 9.10 naar 10.04  (gelezen 2735 keer)

Offline Sir_Patrick

  • Lid
  • Steunpunt: Nee
Ik heb gisteren de upgrade gemaakt van 9.10 naar 10.04 op mijn HP laptop
Omdat ik in de vorige versie compiz-fusion aan had staan wilde ik deze hier ook weer activeren.
Helaas gaat dit niet meer, 3d spellen spelen gaat ook niet meer, waarschijnlijk is er geen 3d ondersteuning met de huidige driver.

Hier is de output van lspci | grep VGA :

patrick@patrick-laptop:~$ lspci | grep VGA
00:02.0 VGA compatible controller: Intel Corporation Mobile GME965/GLE960 Integrated Graphics Controller (rev 0c)

Als ik in synaptic kijk dan zijn zowel de nvidia drivers als ati geinstalleerd, maar ik weet niet welke drivers ik moet hebben voor de bovenstaande grafische kaart.
« Laatst bewerkt op: 2010/06/02, 21:04:13 door Sir_Patrick »

Offline Vincentlaborant

  • Lid
    • vincentvandenbergh
    • openSUSE tips
  • Steunpunt: Nee
Re: Probleem Intel VGA chipset na upgrade van 9.10 naar 10.04
« Reactie #1 Gepost op: 2010/06/01, 14:35:35 »
Jouw kaart komt van Intel vandaan.

*Link verwijdert want die klopte niet*

*Moet hem even opzoeken want ik heb zelf de juiste driver al op mijn laptop draaien maar die ligt thuis*
« Laatst bewerkt op: 2010/06/01, 14:46:11 door Vincentlaborant »
Toshiba Satellite P500 1C8
openSUSE Leap Xfce

https://sites.google.com/site/guidetoopensuse/home

Offline timosha

  • Lid
  • Steunpunt: Nee
Re: Probleem Intel VGA chipset na upgrade van 9.10 naar 10.04
« Reactie #2 Gepost op: 2010/06/01, 14:41:18 »
Jouw kaart komt van Intel vandaan.

Volgens mij heb je een van deze 2 drivers nodig.
http://downloadcenter.intel.com/SearchResult.aspx?lang=eng&keyword=%22+GME965%22&ProductFamily=Graphics&ProductLine=Laptop+graphics+controllers&ProductProduct=Mobile+Intel%C2%AE+965+Express+Chipset+Family&OSVersion=Linux*

Kies die van 10/23/2009, aangezien je deze waarschijnlijk had draaien in Ubuntu 9.10

Je gaat de TS toch geen IEGD laten installeren? Of wel?
Stabiele OS: Solaris 10 - OS X 10.6.4 - Linux Mint 9 - Windows 7
Project OS: Linux Mint 9 Isadora
Test OS: Ubuntu 10.04 - 10.10
Server: Windows Server 2008 R2 - Exchange 2010

Contra verbosos noli contendere verbis: sermo datur cunctis, animi sapientia paucis.


Offline Vincentlaborant

  • Lid
    • vincentvandenbergh
    • openSUSE tips
  • Steunpunt: Nee
Re: Probleem Intel VGA chipset na upgrade van 9.10 naar 10.04
« Reactie #3 Gepost op: 2010/06/01, 14:47:52 »
Nee ik zie net dat ik de verkeerde link heb gepost. Moet even de juiste opzoeken want ik heb dezelfde laptop met werkende graphics kaart. Helaas ligt mijn laptop thuis dus ik moet even de link opzoeken naar de driver. Ik weet wel dat ik het ergens van de site van intel heb gehaald.
Toshiba Satellite P500 1C8
openSUSE Leap Xfce

https://sites.google.com/site/guidetoopensuse/home

Offline timosha

  • Lid
  • Steunpunt: Nee
Re: Probleem Intel VGA chipset na upgrade van 9.10 naar 10.04
« Reactie #4 Gepost op: 2010/06/01, 14:52:42 »
Nee ik zie net dat ik de verkeerde link heb gepost. Moet even de juiste opzoeken want ik heb dezelfde laptop met werkende graphics kaart. Helaas ligt mijn laptop thuis dus ik moet even de link opzoeken naar de driver. Ik weet wel dat ik het ergens van de site van intel heb gehaald.

Laat die laptop maar waar hij is  :rolleyes:

@Sir_Patrick:

Jij gebruikt de i915 driver. Voeg de volgende (of vervang de bestaande) lijn toe aan /etc/default/grub

GRUB_CMDLINE_LINUX="i915.modeset=1"
Open dan een terminal en geef het volgende commando in:

sudo update-grub
Start de PC opnieuw op.
« Laatst bewerkt op: 2010/06/01, 15:00:50 door timosha »
Stabiele OS: Solaris 10 - OS X 10.6.4 - Linux Mint 9 - Windows 7
Project OS: Linux Mint 9 Isadora
Test OS: Ubuntu 10.04 - 10.10
Server: Windows Server 2008 R2 - Exchange 2010

Contra verbosos noli contendere verbis: sermo datur cunctis, animi sapientia paucis.


Offline Vincentlaborant

  • Lid
    • vincentvandenbergh
    • openSUSE tips
  • Steunpunt: Nee
Re: Probleem Intel VGA chipset na upgrade van 9.10 naar 10.04
« Reactie #5 Gepost op: 2010/06/01, 14:55:05 »
Nee ik zie net dat ik de verkeerde link heb gepost. Moet even de juiste opzoeken want ik heb dezelfde laptop met werkende graphics kaart. Helaas ligt mijn laptop thuis dus ik moet even de link opzoeken naar de driver. Ik weet wel dat ik het ergens van de site van intel heb gehaald.

Laat die laptop maar waar hij is  :rolleyes:


Tja ik had mijn laptop thuis laten liggen  :-X en ben een uitwonende student  :evil: dus kom er deze week sowieso niet aan  :|
Toshiba Satellite P500 1C8
openSUSE Leap Xfce

https://sites.google.com/site/guidetoopensuse/home

Offline Sir_Patrick

  • Lid
  • Steunpunt: Nee
Re: Probleem Intel VGA chipset na upgrade van 9.10 naar 10.04
« Reactie #6 Gepost op: 2010/06/01, 23:38:53 »
 /etc/default/grub kan ik niet vinden in /etc/default is geen grub te bekennen.
Ander mapje misschien?

Offline Thijsg

  • Lid
  • Steunpunt: Nee
Re: Probleem Intel VGA chipset na upgrade van 9.10 naar 10.04
« Reactie #7 Gepost op: 2010/06/02, 07:46:50 »
Het is een bestandje. ;)

Offline Sir_Patrick

  • Lid
  • Steunpunt: Nee
Re: Probleem Intel VGA chipset na upgrade van 9.10 naar 10.04
« Reactie #8 Gepost op: 2010/06/02, 08:11:57 »
Het is een bestandje. ;)

Dan zal ik het anders formuleren :

In het mapje /etc/default staat geen bestand met de naam grub  :rolleyes:

Ik heb, omdat er geen bestand met de naam grub was er een gemaakt met de inhoud welke timosha aangaf.
Daarna sudo update-grub uitgevoerd, hierin zag ik dat hij /ect/default/grub uitlas en daarna de laptop herstart maar tot op heden geen resultaat, geen compiz geen 3d .
Als ik overigens in compiz zoek naar i915 dan zie ik dat xserver-xorg-video-intel geinstalleerd staat.
« Laatst bewerkt op: 2010/06/02, 11:57:24 door Sir_Patrick »

Offline timosha

  • Lid
  • Steunpunt: Nee
Re: Probleem Intel VGA chipset na upgrade van 9.10 naar 10.04
« Reactie #9 Gepost op: 2010/06/02, 09:47:21 »
Er moet een bestand grub in /etc/default staan !

Post de inhoud eens van dat zelfgemaakte grub bestand.
« Laatst bewerkt op: 2010/06/02, 09:49:53 door timosha »
Stabiele OS: Solaris 10 - OS X 10.6.4 - Linux Mint 9 - Windows 7
Project OS: Linux Mint 9 Isadora
Test OS: Ubuntu 10.04 - 10.10
Server: Windows Server 2008 R2 - Exchange 2010

Contra verbosos noli contendere verbis: sermo datur cunctis, animi sapientia paucis.


Offline Sir_Patrick

  • Lid
  • Steunpunt: Nee
Re: Probleem Intel VGA chipset na upgrade van 9.10 naar 10.04
« Reactie #10 Gepost op: 2010/06/02, 11:00:08 »
Echt waar, er stond geen grub bestand in /etc/default...
Ik heb van mijn desktop pc het grub bestand uit /etc/default gekopieerd en jouw lijntje eraan toegevoegd.
Zo ziet mijn huidige grub eruit :

# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.

GRUB_DEFAULT=0
#GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
GRUB_GFXMODE=800x600

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_LINUX_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"

GRUB_CMDLINE_LINUX="i915.modeset=1"

Dus als ik nog wat moet wijzigen ergens dan hoor ik het graag.

Offline Sir_Patrick

  • Lid
  • Steunpunt: Nee
Re: Probleem Intel VGA chipset na upgrade van 9.10 naar 10.04
« Reactie #11 Gepost op: 2010/06/02, 18:16:48 »
Er is mij het een en ander duidelijk geworden en dat is dat mijn grub nog versie 1.5 is en niet grub2.x.
Ik ben begonnen op mijn laptop met ubuntu 9.04 en vandaar uit steeds een upgrade gedaan maar kennelijk word dan de grub versie niet vernieuwd.
Ik heb hier op zich geen probleem mee maar mijn vraag blijft wel hoe ik de intel drivers als voorkeur in kan stellen.

Offline Sir_Patrick

  • Lid
  • Steunpunt: Nee
Re: Probleem Intel VGA chipset na upgrade van 9.10 naar 10.04
« Reactie #12 Gepost op: 2010/06/02, 21:01:07 »
Ik heb nog wat rondgesnuffeld en kwam tot de volgende oplossing :

sudo apt-get --purge remove nvidia*
Schijnbaar gebeurd het nog wel eens dat de nvidia drivers en die van intel elkaar in de weg zitten.
In ieder geval is het na het purgen van de nvidia drivers weer in orde, 3d werkt weer en compiz is ook weer beschikbaar.
Dus alles weer in orde, bedankt voor de hulp... 8)