Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: [Opgelost] Probleem met updates/gpu driver..  (gelezen 1650 keer)

Offline Redfront

  • Lid
  • Steunpunt: Nee
[Opgelost] Probleem met updates/gpu driver..
« Gepost op: 2010/05/27, 12:41:41 »
Heey

Weet eigenlijk niet goed wat het probleem is, maar ik geloof dat ik gisteren in Systeem -> Beheer -> Stuurprogramma's wat heb aangepast. Vanochtend wilde hij niet starten en gaf hij me als optie om het originele bestand (ik geloof iets met xconf) te vervangen. Nu kom ik dus weer in Ubuntu, maar heb ik de volgende problemen:

Als ik update, zegt hij het volgende:
U heeft 1 gebroken pakket op uw systeem.

Gebruik het filter "Gebroken" om deze te vinden.

Als ik FGLRX wil installeren, zegt hij het volgende:

Moet even zeggen dat ik het fglrx_2%3a8.723.1-0ubuntu3_amd64.deb bestand al eens verwijderd heb of hernoemt heb, daarom download hij hem overnieuw. Ik installeer dit omdat hij bij het updaten (van fglrx, nieuwe installatie) een foutmelding geeft, code 1.



redfront@ubuntu:/var/cache/apt/archives$ sudo apt-get install fglrx
Pakketlijsten worden ingelezen... Klaar
Boom van vereisten wordt opgebouwd      
De status informatie wordt gelezen... Klaar
De volgende NIEUWE pakketten zullen geïnstalleerd worden:
  fglrx
0 pakketten opgewaardeerd, 1 pakketten nieuw geïnstalleerd, 0 te verwijderen en 23 niet opgewaardeerd.
1 pakketten niet volledig geïnstalleerd of verwijderd.
Er moeten 0B/29,2MB aan archieven opgehaald worden.
Door deze operatie zal er 100MB extra schijfruimte gebruikt worden.
(Database inlezen ... 152381 bestanden en mappen geïnstalleerd.)
Uitpakken van fglrx (uit .../fglrx_2%3a8.723.1-0ubuntu3_amd64.deb) ...

[Warning] Uninstall : inst_path_default or inst_path_override
 does not exist in /etc/ati.  This suggests that the ATI driver
 is not installed, the ATI driver is only partially installed,
 or the current ATI driver installed is an older version than the
 one this script was designed for.  Both files listed above are
 required for determining where installed files are located.
 To force uninstallation of the driver by guessing where the
 uninstallation files are located, set the FORCE_ATI_UNINSTALL
 environment variable and re-run /usr/share/ati/fglrx-uninstall.sh (this is not recommended).

dpkg: fout bij afhandelen van /var/cache/apt/archives/fglrx_2%3a8.723.1-0ubuntu3_amd64.deb (--unpack):
 subproces nieuw pre-installation script gaf een foutwaarde 1 terug
Fouten gevonden tijdens behandelen van:
 /var/cache/apt/archives/fglrx_2%3a8.723.1-0ubuntu3_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
caspar@Caspar-Linux:/var/cache/apt/archives$ mv fglrx_2%3a8.723.1-0ubuntu3_amd64.deb backup.deb
mv: kan `fglrx_2%3a8.723.1-0ubuntu3_amd64.deb’ niet naar `backup.deb’ verplaatsten: Toegang geweigerd
caspar@Caspar-Linux:/var/cache/apt/archives$ sudo mv fglrx_2%3a8.723.1-0ubuntu3_amd64.deb backup.deb
caspar@Caspar-Linux:/var/cache/apt/archives$ sudo apt-get install fglrxPakketlijsten worden ingelezen... Klaar
Boom van vereisten wordt opgebouwd      
De status informatie wordt gelezen... Klaar
De volgende NIEUWE pakketten zullen geïnstalleerd worden:
  fglrx
0 pakketten opgewaardeerd, 1 pakketten nieuw geïnstalleerd, 0 te verwijderen en 23 niet opgewaardeerd.
1 pakketten niet volledig geïnstalleerd of verwijderd.
Er moeten 29,2MB aan archieven opgehaald worden.
Door deze operatie zal er 100MB extra schijfruimte gebruikt worden.
Ophalen:1 http://nl.archive.ubuntu.com/ubuntu/ lucid/restricted fglrx 2:8.723.1-0ubuntu3 [29,2MB]
29,2MB opgehaald in 23s (1248kB/s)                                            
(Database inlezen ... 152381 bestanden en mappen geïnstalleerd.)
Uitpakken van fglrx (uit .../fglrx_2%3a8.723.1-0ubuntu3_amd64.deb) ...

[Warning] Uninstall : inst_path_default or inst_path_override
 does not exist in /etc/ati.  This suggests that the ATI driver
 is not installed, the ATI driver is only partially installed,
 or the current ATI driver installed is an older version than the
 one this script was designed for.  Both files listed above are
 required for determining where installed files are located.
 To force uninstallation of the driver by guessing where the
 uninstallation files are located, set the FORCE_ATI_UNINSTALL
 environment variable and re-run /usr/share/ati/fglrx-uninstall.sh (this is not recommended).

dpkg: fout bij afhandelen van /var/cache/apt/archives/fglrx_2%3a8.723.1-0ubuntu3_amd64.deb (--unpack):
 subproces nieuw pre-installation script gaf een foutwaarde 1 terug
Fouten gevonden tijdens behandelen van:
 /var/cache/apt/archives/fglrx_2%3a8.723.1-0ubuntu3_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Heeft iemand een idee?

Ben eigenlijk vrij nieuw met Ubuntu.. en dit is best balen.

Tijdens het updaten zegt hij ook wel:
Citaat
U heeft 1 gebroken pakket op uw systeem.

Gebruik het filter "Gebroken" om deze te vinden

Alvast bedankt voor het lezen van mijn onduidelijke post!  :rolleyes:


« Laatst bewerkt op: 2010/05/27, 21:24:08 door Redfront »

Offline Redfront

  • Lid
  • Steunpunt: Nee
Re: Probleem met updates/gpu driver..
« Reactie #1 Gepost op: 2010/05/27, 13:42:57 »
Weet dat het een dubbelpost is, maar ik wil even iets toevoegen en aangezien het al een chaos is, en dit iets is wat ik later heb gevonden en gedaan..

redfront@ubuntu:~$ sudo apt-get install -f
[sudo] password for redfront:
E: Kon vergrendeling /var/lib/dpkg/lock niet verkrijgen - open (11: Hulpbron is tijdelijk onbeschikbaar)
E: Unable to lock the administration directory (/var/lib/dpkg/), is another process using it?
caspar@Caspar-Linux:~$ sudo apt-get install -f
Pakketlijsten worden ingelezen... Klaar
Boom van vereisten wordt opgebouwd       
De status informatie wordt gelezen... Klaar
Vereisten worden gecorrigeerd... Klaar
De volgende extra pakketten zullen geïnstalleerd worden:
  fglrx
De volgende NIEUWE pakketten zullen geïnstalleerd worden:
  fglrx
0 pakketten opgewaardeerd, 1 pakketten nieuw geïnstalleerd, 0 te verwijderen en 0 niet opgewaardeerd.
1 pakketten niet volledig geïnstalleerd of verwijderd.
Er moeten 0B/29,2MB aan archieven opgehaald worden.
Door deze operatie zal er 100MB extra schijfruimte gebruikt worden.
Wilt u doorgaan [J/n]? j
(Database inlezen ... 152381 bestanden en mappen geïnstalleerd.)
Uitpakken van fglrx (uit .../fglrx_2%3a8.723.1-0ubuntu3_amd64.deb) ...

[Warning] Uninstall : inst_path_default or inst_path_override
 does not exist in /etc/ati.  This suggests that the ATI driver
 is not installed, the ATI driver is only partially installed,
 or the current ATI driver installed is an older version than the
 one this script was designed for.  Both files listed above are
 required for determining where installed files are located.
 To force uninstallation of the driver by guessing where the
 uninstallation files are located, set the FORCE_ATI_UNINSTALL
 environment variable and re-run /usr/share/ati/fglrx-uninstall.sh (this is not recommended).

dpkg: fout bij afhandelen van /var/cache/apt/archives/fglrx_2%3a8.723.1-0ubuntu3_amd64.deb (--unpack):
 subproces nieuw pre-installation script gaf een foutwaarde 1 terug
Fouten gevonden tijdens behandelen van:
 /var/cache/apt/archives/fglrx_2%3a8.723.1-0ubuntu3_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
redfront@ubuntu:~$

Maar dit geeft exact dezelfde foutmelding.. dit heb ik gedaan nadat ik dit heb gelezen:

https://lists.ubuntu.com/archives/ubuntu-nl/2008-March/005949.html

Offline heir4c

  • Lid
  • Steunpunt: Nee
Re: Probleem met updates/gpu driver..
« Reactie #2 Gepost op: 2010/05/27, 19:22:27 »
Waarom de fglrx installeren via een .deb dat je waarschijnlijk ergens op internet gehaald hebt?
fglrx kan je via Synaptic installeren.
En die .deb file: normaal kan je daar dubbel op klikken en dan installeert die zich vanzelf met GDebi pakketinstalleerder.

Offline Redfront

  • Lid
  • Steunpunt: Nee
Re: Probleem met updates/gpu driver..
« Reactie #3 Gepost op: 2010/05/27, 19:54:29 »
Ik probeer het niet via de gedownloadde deb, dit is gewoon sudo apt-get install fglrx..

Als ik Synaptic Package Manager opstart krijg ik weer de volgende melding

U heeft 1 gebroken pakket op uw systeem.

Gebruik het filter "Gebroken" om deze te vinden.

Als ik vervolgens filter op fglrx en dit aanvink om te installeren, krijg ik de volgende foutmelding:

E: /var/cache/apt/archives/fglrx_2%3a8.723.1-0ubuntu3_amd64.deb: subproces nieuw pre-installation script gaf een foutwaarde 1 terug


Offline Redfront

  • Lid
  • Steunpunt: Nee
Re: Probleem met updates/gpu driver..
« Reactie #5 Gepost op: 2010/05/27, 20:59:43 »
Citaat
sudo apt-get install lib


Pakketlijsten worden ingelezen... Klaar
Boom van vereisten wordt opgebouwd      
De status informatie wordt gelezen... Klaar
E: Kon pakket lib niet vinden
caspar@Caspar-Linux:/var/cache/apt/archives$ sudo dpkg --configure -a
dpkg: vereistenproblemen verhinderen de configuratie van fglrx-amdcccle:
 fglrx-amdcccle is afhankelijk van fglrx; maar:
  Pakket `fglrx' is niet geïnstalleerd.
dpkg: fout bij afhandelen van fglrx-amdcccle (--configure):
 vereistenproblemen - blijft ongeconfigureerd
Fouten gevonden tijdens behandelen van:
 fglrx-amdcccle


Maar dat wist ik al.. maar hoe ik dat ga oplossen weet ik niet.

sudo apt-get --fix-broken
Werkt bij mij niet, dan krijg ik een uitleg over apt-get, een APT met Super Koe Krachten  O0.

Nu wilde ik hem verwijderen met sudo apt-get remove fglrx-amdcccle, dan zegt hij dat de map /usr/share/ati/ niet leeg is, dus ik met cd er heen navigeren, sudo rm * doen. Daarna weer verwijderen, maar toen zei hij dat het pakket helemaal niet is geinstalleerd.

Daarna weer sudo apt-get install fglrx gedaan, en het werkte! Ik ga even rebooten om te kijken of alles weer normaal werkt!

------------------

Min of meer wel, min of meer niet.

Ik start weer op, docky zegt nog steeds het volgende: docky requires compositing..

Nu staat er in systeem -> voorkeuren -> 2 maal alles van ATi

Daarnaast zegt hij nu wel weer in stuurprogramma's het volgende:
Niet-vrij grafisch stuurpgoramma FGLRX van ATI/AMD
Dit stuurprogramma is ingeschakeld en in gebruik

Nu vraag ik mij af, wat zit docky nu te zeuren?

En nu ik zit te typen, heb ik het antwoord voor je!

Systeem -> Voorkeuren -> Uiterlijk -> Tab [Visuele Effecten] -> Normaal

Merci dames en heren!

« Laatst bewerkt op: 2010/05/27, 21:06:14 door Redfront »

Offline heir4c

  • Lid
  • Steunpunt: Nee
Re: [Opgelost] Probleem met updates/gpu driver..
« Reactie #6 Gepost op: 2010/05/27, 22:32:35 »
Yep, docky heeft blijkbaar Compiz nodig om te kunnen werken.

Blij dat het opgelost is.